On Thu, 27 Oct 2022 05:14:19 GMT, ExE Boss <d...@openjdk.org> wrote: >> src/java.base/share/classes/java/net/JarURLConnection.java line 177: >> >>> 175: @SuppressWarnings("deprecation") >>> 176: var tmp = jarFileURL = new URL(spec.substring(0, separator++)); >>> 177: >> >> I realise that @SuppressWarnings needs a declaration here. I wonder if we >> could agree a better name for the unused variable name though, like >> `unusedSW` or something better? > > Having unnamed local variables[^1] would probably be best for this. > > [^1]: https://openjdk.org/jeps/8294349
How about `_unused` or `_unused1`, `_unused2` then in the meantime? ------------- PR: https://git.openjdk.org/jdk/pull/10874