On Wed, 6 Jul 2022 17:50:54 GMT, Ioi Lam <ik...@openjdk.org> wrote: >> `Forte::register_stub()` should be called only when the JVm is being >> instrumented by Forte (aka "Oracle Developer Studio") >> >> https://www.oracle.com/tools/developerstudio/downloads/developer-studio-jsp.html >> >> We currently always format the name of generated stubs and call >> `Forte::register_stub()`, which usually does nothing. >> >> Example: >> >> https://github.com/openjdk/jdk/blob/master/src/hotspot/share/runtime/sharedRuntime.cpp#L2686-L2697 >> >> To improve start-up, we should check if Forte is enabled before formatting >> the name. >> >> I also renamed some `#ifndef IA64` around the code that I touched. > > Ioi Lam has updated the pull request incrementally with one additional commit > since the last revision: > > Do not remove Forte::register_stub as it is used on Linux as well
src/hotspot/share/prims/forte.hpp line 32: > 30: class Forte : AllStatic { > 31: public: > 32: static bool is_enabled() NOT_JVMTI_RETURN_(false); I don't think the rest of this forte code is disabled by JVMTI. ------------- PR: https://git.openjdk.org/jdk/pull/9386