On Wed, 28 Aug 2024 18:13:26 GMT, Kevin Driver <kdri...@openjdk.org> wrote:

>> src/java.base/share/classes/javax/crypto/KDF.java line 230:
>> 
>>> 228: 
>>> 229:     /**
>>> 230:      * Returns a {@code KDF} instance initialized with the specified 
>>> algorithm from
>> 
>> "initialized with the specified algorithm" is not really accurate. I would 
>> change this text to "that implements the specified algorithm". Applies to 
>> all `getInstance` methods.
>
> This wording was suggested by another reviewer, since the implementation is 
> not truly "returned" at this point (ie - a provider may not have been 
> selected, if the provider is not passed as an argument). Saying that the 
> instance is "initialized" with the algorithm is more accurate, since it 
> returns an instance where the algorithm name is really all we would know at 
> that point in time, unless the provider is specified.

I find Sean's suggestion more accurate than the "initialized" word - even if we 
have not selected the provider, the final choice should "implement" the 
specified algorithm.

-------------

PR Review Comment: https://git.openjdk.org/jdk/pull/20301#discussion_r1735364951

Reply via email to