Hi All,
There is a typo in comments in original commit message. The correct values are
as follows.
with v8:
$ size spl/arch/arm/mach-rmobile/cpu_info.o
text data bss dec hex filename
330 0 0 330 14a
spl/
Hi All,
There is a typo in comments in original commit message. The correct values are
as follows.
with v8:
$ size spl/arch/arm/mach-rmobile/cpu_info.o
text data bss dec hex filename
330 0 0 330 14a
spl/
Hi Lukasz,
On 29/11/20 10:16 pm, Pali Rohár wrote:
> This patch series fix usbtty code (serial console via USB peripheral
> mode), fix underlying musb peripheral code, fix compilation of
> CONFIG_USB_DEVICE (used by usbtty), remove unused Nokia RX-51 code to
> decrease size of U-Boot binary and fi
Hi,
On 06/01/21 9:00 pm, gireesh.hirem...@in.bosch.com wrote:
> From: Gireesh Hiremath
>
> Now that linux/compat.h does not define dev_xxx macros, we need
> to include dm/device_compat.h to use dev_xxx macros
>
> Signed-off-by: Gireesh Hiremath
I did not get the complete intention of this pat
On 06/01/21 9:01 pm, gireesh.hirem...@in.bosch.com wrote:
> From: Moses Christopher
>
> - Add mem-guardian.h derived from am33xx/mem.h
>
> * Add GPMC config values optimized for Bosch Guardian Board
> * NAND Chip used by Bosch Guardian Board is Micron MT29F4G08ABBFA
>
> Signed-off-
On 06/01/21 9:01 pm, gireesh.hirem...@in.bosch.com wrote:
> From: Gireesh Hiremath
>
> Enable lcd controller related clocks, pinmux, config,
> interface and port
>
> Signed-off-by: Gireesh Hiremath
> ---
> arch/arm/dts/am335x-guardian-u-boot.dtsi | 15 +++
> arch/arm/dts/am335x-
On 06/01/21 9:01 pm, gireesh.hirem...@in.bosch.com wrote:
> From: Gireesh Hiremath
>
> - Display splash screen
> - Print "U-Boot" on display when bmp fails to load due to any reason
>
> Signed-off-by: Gireesh Hiremath > ---
> board/bosch/guardian/board.c | 77 +++
On 06/01/21 9:01 pm, gireesh.hirem...@in.bosch.com wrote:
> From: Moses Christopher
>
> pinmux update for guardian board
Please specify what this pinmux update is about.
Thanks and regards,
Lokesh
>
> Signed-off-by: Moses Christopher
> ---
> arch/arm/dts/am335x-guardian.dts | 6 +++---
>
Hi Tom,
Any comment on this ?
On Tue, Dec 22, 2020 at 11:30 AM Pragnesh Patel
wrote:
>
> Add the command "pwm" for controlling the pwm channels. This
> command provides pwm invert/config/enable/disable functionalities
> via PWM uclass drivers
>
> Signed-off-by: Pragnesh Patel
> Reviewed-by: Sim
Add some verbose debug output when crc16 check fails.
Signed-off-by: Bin Meng
Reviewed-by: Jaehoon Chung
---
Changes in v2:
- do the crc_ok assignment at the the same line where it's defined
drivers/mmc/mmc_spi.c | 6 --
1 file changed, 4 insertions(+), 2 deletions(-)
diff --git a/drive
On 12/22/20 7:00 AM, Pragnesh Patel wrote:
Add the command "pwm" for controlling the pwm channels. This
command provides pwm invert/config/enable/disable functionalities
via PWM uclass drivers
Signed-off-by: Pragnesh Patel
Reviewed-by: Simon Glass
Dear Pragnesh,
Users should be pointed to t
Hi Rick
On Tue, Jan 12, 2021 at 7:30 AM Rick Chen wrote:
>
> Hi Pragnesh
>
> > > From: Pragnesh Patel [mailto:pragnesh.pa...@sifive.com]
> > > Sent: Sunday, January 10, 2021 8:43 PM
> > > To: u-boot@lists.denx.de
> > > Cc: atish.pa...@wdc.com; palmerdabb...@google.com; bmeng...@gmail.com;
> > >
When tracing functions is enabled this adds calls to
__cyg_profile_func_enter() and __cyg_profile_func_exit() to the traced
functions.
__cyg_profile_func_enter() and __cyg_profile_func_exit() invoke
timer_get_us() to record the entry and exit time.
initr_dm() will make gd->dm_root = NULL and gd->
Added support for timer_early_get_count() and timer_early_get_rate()
This is mostly useful in tracing.
Signed-off-by: Pragnesh Patel
Reviewed-by: Rick Chen
---
Changes in v4:
- Rebase on master
Changes in v3:
- Add IS_ENABLED(CONFIG_TIMER_EARLY) for timer_early_get_rate()
and timer_early_get
This patch series aims to add CPU identification support for RZ/G2 SoC's
and adding SDHI quirks using SoC identification driver.
This patch series depend on SoC identification driver[1]
[1] https://patchwork.ozlabs.org/project/uboot/list/?series=224764
v9:
* Fixed make file to use default family
RZ/G2 SoC's are identical to R-Car Gen3 SoC's apart from some
automotive peripherals.
RZ/G2H (R8A774E1) = R-Car H3-N (R8A77951).
RZ/G2M (R8A774A1) = R-Car M3-W (R8A77960).
RZ/G2N (R8A774B1) = R-Car M3-N (R8A77965).
RZ/G2E (R8A774C0) = R-Car E3 (R8A77990).
As the devices are the same they also hav
Add SDHI quirks for R-Car M3-W and RZ/G2M SoC.
Signed-off-by: Biju Das
Reviewed-by: Lad Prabhakar
Reviewed-by: Jaehoon chung
---
v9:
* No Change.
v8:
* Added Jaehoon Chung's Rb tag
v7:
* Incorporated Jaehoon Chung's review comments.
* Fixed the build error on Renesas ARM32 platforms.
v6:
*
Add SDHI quirks for R-Car M3-N and RZ/G2N SoC.
Signed-off-by: Biju Das
Reviewed-by: Lad Prabhakar
Reviewed-by: Jaehoon chung
---
v9:
* No Change
v7->v8:
* Added Jaehoon chung's Rb tag
v6->v7:
* No Change. rebased on u-boot-sh/next
v6:
* New patch
---
drivers/mmc/renesas-sdhi.c | 14 ++
Add SDHI quirks for R-Car H3 and RZ/G2H SoC.
Signed-off-by: Biju Das
Reviewed-by: Lad Prabhakar
Reviewed-by: Jaehoon chung
---
v9:
* No Change.
v8:
* Added Jaehoon chung's Rb tag.
v7:
* No Change.
v6:
* New patch. quirks using soc_device_match.
---
drivers/mmc/renesas-sdhi.c | 33 +
DTS files apart from r8a774b1-hihope-rzg2n-u-boot.dts and
r8a774b1-u-boot.dtsi have been imported from linux 5.10
commit 2c85ebc57b3e1817b6c ("Linux 5.10").
Signed-off-by: Biju Das
---
arch/arm/dts/r8a774b1-hihope-rzg2n-ex.dts | 21
arch/arm/dts/r8a774b1-hihope-rzg2n-u-boot.dts | 27
DTS files apart from r8a774a1-hihope-rzg2m-u-boot.dts and
r8a774a1-u-boot.dtsi have been imported from linux 5.10
commit 2c85ebc57b3e1817 ("Linux 5.10").
Signed-off-by: Biju Das
---
arch/arm/dts/hihope-common.dtsi | 377 ++
arch/arm/dts/hihope-rev4.dtsi
DTS files apart from r8a774e1-hihope-rzg2h-u-boot.dts and
r8a774e1-u-boot.dtsi have been imported from linux 5.10
commit 2c85ebc57b3e1817b6 ("Linux 5.10").
Signed-off-by: Biju Das
---
arch/arm/dts/r8a774e1-hihope-rzg2h-ex.dts | 20 +
arch/arm/dts/r8a774e1-hihope-rzg2h-u-boot.dts | 27 +
On 06/01/21 9:02 pm, gireesh.hirem...@in.bosch.com wrote:
> From: Gireesh Hiremath
>
> RTC second scratch register[32-bit]:
> -zero byte hold boot count value
> -first byte hold update available state
> -second byte hold version
> -third byte hold magic number
>
> Signed-off-by: Giree
On 16/01/21 9:51 pm, Tom Rini wrote:
> On Sat, Jan 16, 2021 at 01:04:54AM +0100, Pali Rohár wrote:
>
>> Move twl4030_power_mmc_init() from board_mmc_power_init() to misc_init_r()
>> and disable CONFIG_SYS_MALLOC_F. Otherwise U-Boot cannot initialize MMC.
>> Also disable CONFIG_CMD_SLEEP CONFIG_
The HiHope RZ/G2M board from HopeRun consists of main board
(HopeRun HiHope RZ/G2M main board) and sub board(HopeRun
HiHope RZ/G2M sub board). The HiHope RZ/G2M sub board sits
below the HiHope RZ/G2M main board.
This patch adds the required board support to boot HopeRun HiHope
RZ/G2M board.
Signe
The HiHope RZ/G2N board from HopeRun consists of main board
(HopeRun HiHope RZ/G2N main board) and sub board(HopeRun
HiHope RZ/G2N sub board). The HiHope RZ/G2N sub board sits
below the HiHope RZ/G2N main board.
This patch adds the required board support to boot HopeRun HiHope
RZ/G2N board.
Signe
The HiHope RZ/G2H board from HopeRun consists of main board
(HopeRun HiHope RZ/G2H main board) and sub board(HopeRun
HiHope RZ/G2H sub board). The HiHope RZ/G2H sub board sits
below the HiHope RZ/G2H main board.
This patch adds the required board support to boot HopeRun HiHope
RZ/G2H board.
Signe
Let the sbi command detect the 'System Reset Extension'
(EID #0x53525354 "SRST").
Cf. https://github.com/riscv/riscv-sbi-doc
Signed-off-by: Heinrich Schuchardt
---
cmd/riscv/sbi.c | 1 +
1 file changed, 1 insertion(+)
diff --git a/cmd/riscv/sbi.c b/cmd/riscv/sbi.c
index e66fc8e41d..9897483eb6
Hi Tom,
On 1/16/21 3:11 AM, Tom Rini wrote:
> On Fri, Jan 15, 2021 at 01:46:54PM +0900, Jaehoon Chung wrote:
>
>> Current U-boot doesn't display a message about which architecture is
>> used. So Developer is difficult to know it by intuition.
>> This patch is displaying to CPU information with CO
On 1/17/21 2:26 AM, Heinrich Schuchardt wrote:
On 1/17/21 1:37 AM, Sean Anderson wrote:
On 1/4/21 2:02 AM, Heinrich Schuchardt wrote:
In drivers we use a family of printing functions including pr_err() and
pr_cont(). CONFIG_LOGLEVEL is used to control which of these lead to output
via printf().
On 11/1/20 10:15 PM, Simon Glass wrote:
Add tests to check for buffer overflow using simple replacement as well
as back references. At present these don't fully pass.
Signed-off-by: Simon Glass
---
cmd/setexpr.c | 21 +++
include/command.h | 17 +
test/cmd/setexpr.c |
On 1/17/21 11:27 PM, Sean Anderson wrote:
On 1/17/21 2:26 AM, Heinrich Schuchardt wrote:
On 1/17/21 1:37 AM, Sean Anderson wrote:
On 1/4/21 2:02 AM, Heinrich Schuchardt wrote:
In drivers we use a family of printing functions including pr_err() and
pr_cont(). CONFIG_LOGLEVEL is used to control
Excluding ut bootm in test/cmd_ut.c but compiling test/bootm.c results in
failure of the Python test invoking the C unit tests as observed on
sipeed_riscv_smode_defconfig:
FAILED test/py/tests/test_ut.py::test_ut[ut_bootm_nop]
FAILED test/py/tests/test_ut.py::test_ut[ut_bootm_nospace]
FAILED test/
Excluding ut str in test/cmd_ut.c but compiling test/str_ut.c results in
failure of the Python test invoking the C unit tests as observed on
sipeed_riscv_smode_defconfig:
FAILED test/py/tests/test_ut.py::test_ut[ut_str_upper]
Allow to compile test/str_ut.c on all boards.
Signed-off-by: Heinrich
test_print.c requires CONFIG_CONSOLE_RECORD=y.
Signed-off-by: Heinrich Schuchardt
---
test/lib/Makefile | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/test/lib/Makefile b/test/lib/Makefile
index 98a9abf40e..97c11e35a8 100644
--- a/test/lib/Makefile
+++ b/test/lib/Makefile
@@
There's checks in board/sunxi/board.c if either MACPWR or SATAPWR are
defined and they are defined by default to a empty string which means
on vast majority of AllWinner boards when they're not required the
code is still run and with SATAPWR we even get an unnecessary 500ms
delay booting. So let's
Hi Tom and Lauren,
I failed to build mx6ull with MTD and UBI in OE and meta-freescahe
gatesgarth branch, please be aware that I was able to build it in zeus
branch, it seems something broken in gatesgarth branch.
My apology I am not clear if it is the issue for MTD or u-boot or
meta-freescale or
On Fri, 2021-01-15 at 17:36 +0100, Matthias Brugger wrote:
> On Tue, Jan 12, 2021 at 01:44:02PM +0800, Weijie Gao wrote:
> > The timer being used by this driver may have already been used by first
> > stage bootloader (e.g. ATF/preloader), and it's settings may differ from
> > what this driver is g
On Fri, Jan 15, 2021 at 01:02:51PM +0100, Heinrich Schuchardt wrote:
> On 15.01.21 05:29, AKASHI Takahiro wrote:
> > On Fri, Jan 15, 2021 at 04:12:18AM +0100, Heinrich Schuchardt wrote:
> >> Am 15. Januar 2021 02:56:03 MEZ schrieb AKASHI Takahiro
> >> :
> >>> Heinrich,
> >>>
> >>> On Tue, Jan 12,
> Subject: Re: [NXP-IMX] please pull nxp-imx-2021-1-16
>
> Hi Peng,
>
> On 16.01.21 08:18, Peng Fan wrote:
> > Hi Stefano,
> >
> > Please pull nxp-imx-2021-1-16
> > ---
> > nandbcb update/fix
> > sync i.MX8M dts from Linux kernel
> > add i.MX8MN LPDDR4 evk boar
Heinrich,
On Sun, Jan 17, 2021 at 07:48:18AM +0100, Heinrich Schuchardt wrote:
> Provide an UEFI application to save the initial RAM disk provided by U-Boot
> via the Load File2 protocol.
I don't have any specific comments on this "app," but
as the size of efi selftest grows and even more app's a
On Fri, Jan 15, 2021 at 07:02:49PM +0100, Heinrich Schuchardt wrote:
> Move all load options related functions to a new module. So that they can
> be compiled independently.
>
> Signed-off-by: Heinrich Schuchardt
> ---
> lib/efi_loader/efi_load_options.c | 151 ++
> 1
Heinrich,
On Fri, Jan 15, 2021 at 07:02:48PM +0100, Heinrich Schuchardt wrote:
> Some boards are very tight on the binary size. Booting via UEFI is possible
> without using the boot manager.
>
> Provide a configuration option to make the boot manager available.
>
> Heinrich Schuchardt (2):
> e
On 13/01/21 1:06 pm, Aswath Govindraju wrote:
> AM65x SoC has two USB subsystems and their corresponding device tree nodes
> have the same name but different path. While allocating sequence numbers
> for these device tree nodes using alias, phandles can be used to
> distinguish them.
>
> Enable
On 12/01/21 12:54 am, David Lechner wrote:
> This is a collection of a few updates/cleanups for LEGO MINDSTORMS EV3.
Applied to u-boot-ti/for-next branch.
Thanks and regards,
Lokesh
>
> David Lechner (4):
> ARM: legoev3: set serial# env var
> ARM: legoev3: drop bi_arch_number
> configs
Hi Simon,
On Sat, Jan 16, 2021 at 3:24 PM Peng Fan wrote:
>
> Hi Simon,
>
> > Subject: Re: Invitation: Regular U-Boot video call (Tuesday 19th)
> >
> > Hi Peng,
> >
> > On Thu, 14 Jan 2021 at 18:33, Peng Fan wrote:
> > >
> > > Hi Simon,
> > >
> > > > Subject: Invitation: Regular U-Boot video cal
> Both indices cannot be negative. So it is understandable that u_int was
> chosen.
Yes, u_int is understandable that the length is never be negative, but define
the length parameter as "int" also usable.
Some example in current u-boot source code:
$ grep -rn length common/ | grep "int "
common/
> > You could avoid the subtraction instead of changing the type:
> >
> > -for (i = 0; i < presskey_max - 1; i++)
> > +for (i = 0; i + 1 < presskey_max; i++)
> This style seems not typically way for for loop, how do you think?
I found one similar for loop style in u-boot source code, it seems aim t
> -Original Message-
> From: Lim, Elly Siew Chin
> Sent: Thursday, January 7, 2021 6:04 PM
> To: u-boot@lists.denx.de
> Cc: Marek Vasut ; Tan, Ley Foon
> ; See, Chin Liang ;
> Simon Goldschmidt ; Chee, Tien Fong
> ; Westergreen, Dalon
> ; Simon Glass ; Gan,
> Yau Wai ; Lim, Elly Siew Ch
Hi Tom,
Please pull some riscv updates:
- Update qemu-riscv.rst build instructions.
- Add support for SPI on Kendryte K210.
- Add Microchip PolarFire SoC Icicle Kit support.
- Add support for an early timer.
- select TIMER_EARLY to avoid infinite recursion for Trace.
Thanks
Rick
CI: passed
htt
+Michal from Xilinx
Hi Brandon,
On Sun, Jan 17, 2021 at 4:26 AM Brandon Maier wrote:
>
> On Sat, Jan 16, 2021 at 3:27 AM Bin Meng wrote:
> >
> > Hi Brandon,
> >
> > On Sat, Jan 16, 2021 at 5:54 AM Brandon Maier
> > wrote:
> > >
> > > From: Taylor Burton
> > >
> > > Micron's mt25ql02g is not c
> -Original Message-
> From: Lim, Elly Siew Chin
> Sent: Thursday, January 7, 2021 6:04 PM
> To: u-boot@lists.denx.de
> Cc: Marek Vasut ; Tan, Ley Foon
> ; See, Chin Liang ;
> Simon Goldschmidt ; Chee, Tien Fong
> ; Westergreen, Dalon
> ; Simon Glass ; Gan,
> Yau Wai ; Lim, Elly Siew Ch
> -Original Message-
> From: Lim, Elly Siew Chin
> Sent: Thursday, January 7, 2021 6:04 PM
> To: u-boot@lists.denx.de
> Cc: Marek Vasut ; Tan, Ley Foon
> ; See, Chin Liang ;
> Simon Goldschmidt ; Chee, Tien Fong
> ; Westergreen, Dalon
> ; Simon Glass ; Gan,
> Yau Wai ; Lim, Elly Siew Ch
> -Original Message-
> From: Lim, Elly Siew Chin
> Sent: Thursday, January 7, 2021 6:04 PM
> To: u-boot@lists.denx.de
> Cc: Marek Vasut ; Tan, Ley Foon
> ; See, Chin Liang ;
> Simon Goldschmidt ; Chee, Tien Fong
> ; Westergreen, Dalon
> ; Simon Glass ; Gan,
> Yau Wai ; Lim, Elly Siew Ch
On 1/18/21 6:38 AM, andy...@sony.com wrote:
You could avoid the subtraction instead of changing the type:
-for (i = 0; i < presskey_max - 1; i++)
+for (i = 0; i + 1 < presskey_max; i++)
This style seems not typically way for for loop, how do you think?
I found one similar for loop style in u-b
On 1/18/21 3:17 AM, AKASHI Takahiro wrote:
On Fri, Jan 15, 2021 at 07:02:49PM +0100, Heinrich Schuchardt wrote:
Move all load options related functions to a new module. So that they can
be compiled independently.
Signed-off-by: Heinrich Schuchardt
---
lib/efi_loader/efi_load_options.c | 151
56 matches
Mail list logo