Hi Minkyu,
> Support for a new command (defined at envs) - spl_export generates
> the ATAGS image necessary for fast boot. Afterwards, it is stored
> at ext4 partition.
>
> Generated image format:
> CRC [4B] SIZE [4B] PAYLOAD(ATAGS/DT) [SIZE]
>
> Remarks:
> - CRC is calculated only for PAYLOAD
>
Luca Ceresoli wrote:
Hi,
I'm Cc'ing the linux-mtd list as well as the authors of the Linux
commits cited below.
For these new readers: I reported a problem with U-Boot 2012.04.01 not
being able to attach an UBI partition in NAND, while Linux (2.6.37) can
attach and repair it.
It looks like an
-BEGIN PGP SIGNED MESSAGE-
Hash: SHA1
On 12/25/12 09:15, Javier Martinez Canillas wrote:
> Based on commit cf073e49bc3502be1b48a0e3faf0cde9edbb89db for
> beagleboard
>
> Using the new env import command it is possible to use plain text
> files instead of script-images. Plain text files
-BEGIN PGP SIGNED MESSAGE-
Hash: SHA1
On 12/31/12 11:32, Ilya Yanok wrote:
> This adds necessary config options to enable usb booting and fixes
> board_eth_init() function to take into account that we may have USB
> ether support in SPL now.
[snip]
> +#define CONFIG_USBNET_HOST_ADDR
-BEGIN PGP SIGNED MESSAGE-
Hash: SHA1
On 12/31/12 11:32, Ilya Yanok wrote:
> Currently AM335X hardware has bug in it's ROM code that prevents
> USB booting from working normally. So we have to load SPL via
> serial console instead. But it's feasible to use USB for loading
> the main U-Boot
On Mon, Dec 31, 2012 at 08:32:40PM +0400, Ilya Yanok wrote:
> This patch adds BOOT_DEVICE define for USB booting and fixes
> spl_board_init function to call arch_misc_init (this is the place there
> musb is initialized).
[snip]
> @@ -54,6 +54,9 @@ void spl_board_init(void)
> #ifdef CONFIG_SPL_NAN
2013/1/2 Alexey Brodkin :
> From: Alexey Brodkin
>
> Current implementation works fine for bus width = 16 bits because we
> never get into "if" branch.
>
> If one sets width to 8 bits there will be 2 consequent data accesses
> (read/write):
> 1. Correct data access for 8-bit bus
> 2. Unconditional
2013/1/2 Alexey Brodkin :
> Most architectures don't have symbols "in16"/"out16" defined.
> Only Microblaze/PowerPC/Spark architectures do have them defined.
>
> At the same time there're much more common macros "readw"/"writew" for
> 16-bit data access defined in most of architectures (in
> linux
On Sun, Dec 30, 2012 at 08:24:00AM +0530, Vikram Narayanan wrote:
> On 12/28/2012 7:29 PM, Tom Rini wrote:
> >On Fri, Dec 28, 2012 at 07:17:42AM -0500, Sergey Lapin wrote:
> >
> >>Hi, all!
> >>
> >>As I failed to submit 250KB patch to the list
> >>I will send this pull request
> >>
> >>This patch i
On Mon, Dec 31, 2012 at 03:54:25PM +0100, Wolfgang Denk wrote:
> Dear Lukasz Majewski,
>
> In message <20121231153353.2d9a5dda@amdc308.digital.local> you wrote:
> >
> > > - addr = lcd_setmem(addr);
> > > - gd->fb_base = addr;
> > > + gd->fb_base = lcd_setmem(addr);
> > > #endif
Support for a new command (defined at envs) - spl_export generates
the ATAGS image necessary for fast boot. Afterwards, it is stored
at ext4 partition.
Generated image format:
CRC [4B] SIZE [4B] PAYLOAD(ATAGS/DT) [SIZE]
Remarks:
- CRC is calculated only for PAYLOAD
- SIZE is the size of PAYLOAD
Hi,
2013/1/2 Алексей Бродкин :
> The reason for latter modification is to make code more readable.
> Do you think if I may submit this as a cosmetic change separately?
If you mean create 3rd patch then no.
Thanks,
Michal
--
Michal Simek, Ing. (M.Eng)
w: www.monstr.eu p: +42-0-721842854
Mainta
This commit makes the video subsystem code cache aware.
Memory allocated for decompressed BMP memory is now cache line aligned.
Flushing of the dcache is also performed after copying BMP data to fb
address (it is done for 32 BPP bitmap used on Trats board (Exynos4210)).
Tested-by: Lukasz Majewsk
On clobber, do a cleanup even for SPL build else, we'd have
MLO.byteswap remaining for certain platforms like am33xx SPL builds
Signed-off-by: Nishanth Menon
---
To notice the missing cleanup:
With the cross compile flags set, do:
make am335x_evm_config; make; make clobber; git status
On branch
On Wed, Dec 26, 2012 at 11:51 AM, Robert Nelson wrote:
> On Wed, Dec 26, 2012 at 11:21 AM, Fabio Estevam wrote:
>> On Wed, Dec 26, 2012 at 3:08 PM, Robert Nelson
>> wrote:
>>
>>> I'll keep debugging it here, did reverting this commit, help with the
>>> resets?
>>> http://git.denx.de/?p=u-boot.
On Wed, Jan 2, 2013 at 4:27 PM, Robert Nelson wrote:
> Okay success on another bisect run to find what was causing the Data
> Abort with linaro's gcc toolchain..
> gcc version 4.7.3 20121205 (prerelease) (crosstool-NG
> linaro-1.13.1-4.7-2012.12-20121214 - Linaro GCC 2012.12)
>
> Reverting, Troy'
From: Alexey Brodkin
Current implementation works fine for bus width = 16 bits because we
never get into "if" branch.
If one sets width to 8 bits there will be 2 consequent data accesses
(read/write):
1. Correct data access for 8-bit bus
2. Unconditional (and in this case incorrect) data access
Most architectures don't have symbols "in16"/"out16" defined.
Only Microblaze/PowerPC/Spark architectures do have them defined.
At the same time there're much more common macros "readw"/"writew" for
16-bit data access defined in most of architectures (in
linux kernel header "io.h").
So use of "re
The reason for latter modification is to make code more readable.
Do you think if I may submit this as a cosmetic change separately?
2013/1/2 Michal Simek
> 2013/1/2 Alexey Brodkin :
> > From: Alexey Brodkin
> >
> > Current implementation works fine for bus width = 16 bits because we
> > never
From: Fabio Estevam
Since this structure is not i.MX5x specific, remove the '5x' to make it more
generic.
Signed-off-by: Fabio Estevam
---
tools/imximage.c |2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/tools/imximage.c b/tools/imximage.c
index 63f88b6..80ff66b 100644
-
Actually I meant to respin both patches.
1. Only add "else" thread for "ace_writew", keeping "ace_readw" unchanged
2. Replace "in16"/"out16" with "readw"/"writew"
2013/1/2 Michal Simek
> Hi,
>
> 2013/1/2 Алексей Бродкин :
> > The reason for latter modification is to make code more readable.
> >
On 1/2/2013 11:33 AM, Fabio Estevam wrote:
Thanks for bisecting, Robert. Troy/Stefano, Any suggestions about
this? It would be really nice if we could keep mx53loco functional
when using gcc 4.6.2. Regards, Fabio Estevam
Could you see if this patch makes any difference? It still needs cleaned
On Wed, Jan 2, 2013 at 1:42 PM, Troy Kisky
wrote:
> On 1/2/2013 11:33 AM, Fabio Estevam wrote:
>>
>> Thanks for bisecting, Robert. Troy/Stefano, Any suggestions about this? It
>> would be really nice if we could keep mx53loco functional when using gcc
>> 4.6.2. Regards, Fabio Estevam
>
> Could you
On Wed, Jan 2, 2013 at 5:58 PM, Robert Nelson wrote:
> Sweet! Thanks Troy,
>
> That fixes it on my Dialog based mx53loco with linaro's 4.7.3 gcc toolchain...
Excellent, Troy!
Fixes the issue for me with gcc 4.6.2 as well.
It would be really nice to have this one applied for 2013.01.
Thanks,
Dear Tom,
In message <20130102154854.GC14738@bill-the-cat> you wrote:
>
> > Please see my responses. This is definitely NOT a good idea, it will
> > break most (all?) boards that use CONFIG_FB_ADDR in the way it was
> > intended for.
>
> I think this means we've got people not understanding wha
Dear Alexey Brodkin,
In message <1357139186-9172-1-git-send-email-alexey.brod...@gmail.com> you
wrote:
> Most architectures don't have symbols "in16"/"out16" defined.
> Only Microblaze/PowerPC/Spark architectures do have them defined.
>
> At the same time there're much more common macros "readw"
Dear Alexey Brodkin,
In message <1357137512-8618-1-git-send-email-alexey.brod...@gmail.com> you
wrote:
> From: Alexey Brodkin
>
> Current implementation works fine for bus width = 16 bits because we
> never get into "if" branch.
>
> If one sets width to 8 bits there will be 2 consequent data a
On 12/21/2012 05:16 PM, Tom Warren wrote:
> Add 16-bit divider support (I2C) to periph table, annotate and
> correct some entries, and fix clk_id lookup function.
> diff --git a/arch/arm/cpu/tegra30-common/clock.c
> b/arch/arm/cpu/tegra30-common/clock.c
> - TYPE(PERIPHC_TSENSOR, CLOCK_TYPE
On 12/21/2012 05:16 PM, Tom Warren wrote:
> Note that T30 does not have a separate/different DVC (power I2C)
> controller like T20 - all 5 I2C controllers are identical, but
> DVC_I2C is still used to designate the controller intended for
> power control (PWR_I2C in the schematics). On Cardhu, it's
On 12/21/2012 05:16 PM, Tom Warren wrote:
> Tested all 5 'buses', i2c probe enumerates device addresses on all
> but dev 4 (I2C4) [no devices on that bus on my Cardhu].
>
> Note that this uses the extant tegra_i2c.c driver w/o modification.
Aside from previous comments,
Reviewed-by: Stephen Warre
No, it's now PCST, which is close as I can get to PCTS w/o adding a
whole new clock_type entry for just this one piece of HW, which isn't
used in U-Boot anyway.
PCST is PLLP, PLLC, CLK_S, and CLK_M. PCTS is PLLP, PLLC, CLK_M and CLK_S.
On Wed, Jan 2, 2013 at 1:35 PM, Stephen Warren wrote:
> On
Alrightly. Can you send me a link to the latest-and-greatest
T30/Cardhu kernel DT files so I can use 'em as a reference? Every time
I do a Google search for kernel files I'm never sure if I've got the
latest one or not.
Thanks
On Wed, Jan 2, 2013 at 1:41 PM, Stephen Warren wrote:
> On 12/21/2012
On 01/02/2013 01:58 PM, Tom Warren wrote:
> Alrightly. Can you send me a link to the latest-and-greatest
> T30/Cardhu kernel DT files so I can use 'em as a reference? Every time
> I do a Google search for kernel files I'm never sure if I've got the
> latest one or not.
The easiest way is probably:
From: Fabio Estevam
Add support for the Seiko 4.3'' WVGA panel on mx53loco.
By default, the CLAA WVGA panel is selected.
In order to support the Seiko panel, the enviroment variable 'panel' must be
set to 'seiko'.
Signed-off-by: Fabio Estevam
---
Changes since v1:
- Allow a single binary to s
On Wed, Jan 2, 2013 at 3:39 PM, Tom Rini wrote:
> -BEGIN PGP SIGNED MESSAGE-
> Hash: SHA1
>
> On 12/25/12 09:15, Javier Martinez Canillas wrote:
>> Based on commit cf073e49bc3502be1b48a0e3faf0cde9edbb89db for
>> beagleboard
>>
>> Using the new env import command it is possible to use plain
On Wed, Dec 26, 2012 at 10:42:25AM -0800, Simon Glass wrote:
> Hi Tom,
>
> These are the two that patchwork somehow missed. They are in there
> now, so here is the pull request for those two.
>
>
> The following changes since commit f8cfcf1b1c7543d5dd103359376a3319301143bc:
>
> env: don't ge
On 03/01/13 01:06, Lukasz Majewski wrote:
> Support for a new command (defined at envs) - spl_export generates
> the ATAGS image necessary for fast boot. Afterwards, it is stored
> at ext4 partition.
>
> Generated image format:
> CRC [4B] SIZE [4B] PAYLOAD(ATAGS/DT) [SIZE]
>
> Remarks:
> - CRC is
Subject line should be something like
"mtd: sync NAND and mtdcore with Linux v3.8-rc2".
What is in v3.8-rc2 that you need? I agree with others that we should
sync from stable versions.
On 12/28/2012 05:19:17 AM, Sergey Lapin wrote:
Signed-off-by: Sergey Lapin
---
Warning: no testing, except
On 12/23/2012 05:17:25 PM, Javier Martinez Canillas wrote:
On Sat, Dec 22, 2012 at 4:40 AM, Javier Martinez Canillas
wrote:
>
> But if I'm the only one having this issue maybe is just my hardware
behaving
> badly. I'll ask other OMAP3 users if they can boot with mainline
U-Boot to
> confirm
On 01/02/2013 09:33:33 AM, Tom Rini wrote:
On Sun, Dec 30, 2012 at 08:24:00AM +0530, Vikram Narayanan wrote:
> On 12/28/2012 7:29 PM, Tom Rini wrote:
> >On Fri, Dec 28, 2012 at 07:17:42AM -0500, Sergey Lapin wrote:
> >
> >>Hi, all!
> >>
> >>As I failed to submit 250KB patch to the list
> >>I will
Hi Jaehoon,
Thanks for the comments.
Please find my response below.
Thanks & Regards
Amarendra
On 2 January 2013 10:50, Jaehoon Chung wrote:
> On 12/31/2012 07:58 PM, Amar wrote:
> > This patch adds FDT support for DWMMC, by reading the DWMMC node data
> > from the device tree and initialising
Hi Jaehoon
Thanks for the comments.
Please find my response below.
Than
On 2 January 2013 09:01, Jaehoon Chung wrote:
> Hi Amar,
>
> On 12/31/2012 07:58 PM, Amar wrote:
> > This API computes the divisor value based on MPLL clock and
> > writes it into the FSYS1 register.
> >
> > Changes from V
Hi Amar,
..snip..
>> I didn't understand this function(exynos5_mmc_set_clk_div?).
>> What purpose? I think good that proper to use the "div" as argument.
>> void exynos5_mmc_set_clk(int dev_id, unsigned int div).
>
>
> For fixing dwmmc driver, I referred to working code from
> "chromiumos/src/th
Hi Albert,
2012년 12월 22일 토요일에 Albert ARIBAUD님이 작성:
> Hello Tom,
>
> The following changes since commit
> 095728803eedfce850a2f85828f79500cb09979e:
>
> Merge branch 'master' of git://git.denx.de/u-boot-net (2012-12-17
> 18:39:50 -0700)
>
> are available in the git repository at:
>
>
> git://
Hi Amar,
..snip..
>>> }
>>>
>>> int exynos_dwmci_init(u32 regbase, int bus_width, int index)
>>> {
>>> struct dwmci_host *host = NULL;
>>> + int dev_id = 0;
>>> host = malloc(sizeof(struct dwmci_host));
>>> if (!host) {
>>> printf("dwmci_host malloc fail!\n")
Hi Albert,
> Hi Albert,
>
> 2012년 12월 22일 토요일에 Albert ARIBAUD님이 작성:
>
> > Hello Tom,
> >
> > The following changes since commit
> > 095728803eedfce850a2f85828f79500cb09979e:
> >
> > Merge branch 'master' of git://git.denx.de/u-boot-net (2012-12-17
> > 18:39:50 -0700)
> >
> > are available in
This patch add pinmux settings for Exynos4 for mmc0 and mmc2
The pinmux setting previously added in commit a3eab2ac41
has been deleted in merge 96764df1b4
Piotr Wilczek (1):
arm:exynos4:pinmux: Modify the gpio function for mmc
arch/arm/cpu/armv7/exynos/pinmux.c | 45
This patch add pinmux settings for Exynos4 for mmc0 and mmc2
Signed-off-by: Piotr Wilczek
Signed-off-by: Kyungmin Park
CC: Minkyu Kang
CC: Albert ARIBAUD
---
arch/arm/cpu/armv7/exynos/pinmux.c | 45
1 file changed, 45 insertions(+)
diff --git a/arch/arm
Hi Wolfgang,
2013/1/2 Wolfgang Denk :
> Dear Alexey Brodkin,
>
> In message <1357137512-8618-1-git-send-email-alexey.brod...@gmail.com> you
> wrote:
>> From: Alexey Brodkin
>>
>> Current implementation works fine for bus width = 16 bits because we
>> never get into "if" branch.
>>
>> If one sets
Dear Michal Simek,
In message
you wrote:
>
> > You say, if one sets width to 8 bits, then the code fails when the bus
> > is actually 16 bits wide?
...
> Here is that function with my comment about missing "else".
> In ace_writew function we shouldn't write 16bit value when width is 8.
> (It pr
Hi Jaehoon,
Thanks for the comments.
Please find the response below.
Thanks & Regards
Amarendra Reddy
On 2 January 2013 10:42, Jaehoon Chung wrote:
> On 12/31/2012 07:58 PM, Amar wrote:
> > This patch enumerates dwmci and set auto stop command during
> > dwmci initialisation.
> > EMMC read/wr
51 matches
Mail list logo