On 28/07/2012 15:44, Pavel Herrmann wrote:
> Hi,
>
Hi Pavel,
> While working on the DM project, I found out that there are two
> implementations of AHCI drivers - one in block/ahci.c, one in
> block/dwc_ahsata.c
>
ooopppss !
> what is the difference between them (apart from the obvious, ah
Dear Tomas Hlavacek,
> Hello Marek,
>
> On Sat, Jul 28, 2012 at 10:36 PM, Marek Vasut wrote:
> > I think we should still mark early patches as RFC.
>
> Sure...
>
> > > +#include
> >
> > Do we need early_malloc.h at all? malloc.h won't cut it?
>
> My intention was to keep the early_malloc in
Hello Marek,
On Sat, Jul 28, 2012 at 10:36 PM, Marek Vasut wrote:
> I think we should still mark early patches as RFC.
Sure...
> > +#include
>
> Do we need early_malloc.h at all? malloc.h won't cut it?
My intention was to keep the early_malloc in separate instance from
real malloc. Although t
Hi Marek,
For future reference, please comment against:
Take a look at http://www.denx.de/wiki/U-Boot/ToolsPatchTracking
On 07/29/2012 01:15 PM, Marek Vasut wrote:
> Dear Graeme Russ,
>
> You might want to actually create an mbox of all these stacked patches so
> people
> can download and app
Dear Graeme Russ,
> A revised version of the spec (sorry, I would have used reply-to but
> something went amiss with gmail and I've lost the original)
How does it surprise me ... superawesome google imap just crashed on me like a
week ago, I finished syncing my emails today ...
[...]
> Operati
Dear Benoît Thébaudeau,
> Dear Marek,
>
> On Fri, Jul 27, 2012 at 04:13:45 PM, Benoît Thébaudeau wrote:
> > On Fri, Jul 27, 2012 at 04:01:11 PM, Marek Vasut wrote:
> > > [...]
> > >
> > > > > > + token = (toggle << 31) |
> > > > > > + (xfr_bytes << 16) |
>
Dear Benoît Thébaudeau,
> Dear Marek,
>
> On Fri, Jul 27, 2012 at 07:44:04 PM, Marek Vasut wrote:
> > > I did see a flags field but thought having a new one was
> > > conservative (I
> > > had no real reason to have a new field). As for the typecasts I
> > > was
> > > following the API which te
Dear Otavio Salvador,
> As the register accessing mode is the same for all i.MXS SoCs we ought
> to use 'mxs' prefix intead of 'mx28'.
>
> Signed-off-by: Otavio Salvador
> ---
> arch/arm/cpu/arm926ejs/mxs/clock.c |4 +-
> arch/arm/cpu/arm926ejs/mxs/iomux.c |6 +-
> a
Dear Marek,
On Fri, Jul 27, 2012 at 07:44:04 PM, Marek Vasut wrote:
> > I did see a flags field but thought having a new one was
> > conservative (I
> > had no real reason to have a new field). As for the typecasts I
> > was
> > following the API which tests for device ready (Monkey See Monkey
>
Dear Marek,
On Fri, Jul 27, 2012 at 04:13:45 PM, Benoît Thébaudeau wrote:
> On Fri, Jul 27, 2012 at 04:01:11 PM, Marek Vasut wrote:
> > [...]
> > > > > + token = (toggle << 31) |
> > > > > + (xfr_bytes << 16) |
> > > > > + ((req =
Dear Stefan,
Sorry for the delay. I'm very busy, and there is much to tell on this topic.
On Tue, Jul 24, 2012 at 03:02:00 PM, Stefan Herbrechtsmeier wrote:
> Am 23.07.2012 19:15, schrieb Benoît Thébaudeau:
> > On Monday 23 July 2012 15:35:25 Stefan Herbrechtsmeier wrote:
> >> Am 20.07.2012 17:35
Signed-off-by: Otavio Salvador
---
arch/arm/cpu/arm926ejs/mxs/Makefile |2 +-
arch/arm/cpu/arm926ejs/mxs/{mx28.c => mxs.c} |0
2 files changed, 1 insertion(+), 1 deletion(-)
rename arch/arm/cpu/arm926ejs/mxs/{mx28.c => mxs.c} (100%)
diff --git a/arch/arm/cpu/arm926ejs/mxs/Makef
Signed-off-by: Otavio Salvador
---
arch/arm/cpu/arm926ejs/mxs/mx28.c |8 +-
.../cpu/arm926ejs/mxs/{mx28_init.h => mxs_init.h} | 14 +-
arch/arm/cpu/arm926ejs/mxs/spl_boot.c | 20 +--
arch/arm/cpu/arm926ejs/mxs/spl_lradc_init.c|6 +-
arch/arm/cpu/
Signed-off-by: Otavio Salvador
---
arch/arm/cpu/arm926ejs/mxs/clock.c | 36
arch/arm/cpu/arm926ejs/mxs/mx28.c| 28 +++---
arch/arm/cpu/arm926ejs/mxs/spl_lradc_init.c |4 +-
arch/arm/cpu/arm926ejs/mxs/spl_mem_init.c| 24 +++---
arch/arm/cpu/arm926ejs/m
As the register accessing mode is the same for all i.MXS SoCs we ought
to use 'mxs' prefix intead of 'mx28'.
Signed-off-by: Otavio Salvador
---
arch/arm/cpu/arm926ejs/mxs/clock.c |4 +-
arch/arm/cpu/arm926ejs/mxs/iomux.c |6 +-
arch/arm/cpu/arm926ejs/mxs/mx28.c
Most code can be shared between i.MX23 and i.MX28 as both are from
i.MXS family; this source directory structure makes easy to share code
among them.
Signed-off-by: Otavio Salvador
---
arch/arm/cpu/arm926ejs/{mx28 => mxs}/Makefile |0
arch/arm/cpu/arm926ejs/{mx28 => mxs}/clock.
This patchset is the basis for inclusion of i.MX233 support on U-Boot.
To accomplish it, this patchset moves code around to create the mxs
SoC family support.
The idea of posting it on the mailing list is to receive comments on
ways to improve the patchset and also try to merge it during the merge
This is an improved version of the driver patch original
submitted by Graeme Smecher
The changes are:
- remove hard coded Xilinx BSP defines (XPAR_SPI_*) and
use CONFIG_SYS_SPI_BASE from config.h instead
- add extensive register struct definitions
- remove offset calculation for
Depending on XILINX_SPI_FLASH_BASEADDR enable SPI flash
and environment in SPI flash.
Expected values from xparameters.h are:
- XILINX_SPI_FLASH_BASEADDR
- XILINX_SPI_FLASH_MAX_FREQ
- XILINX_SPI_FLASH_CS
Signed-off-by: Stephan Linz
---
include/configs/microblaze-generic.h | 55 +++
The mx28 prefix has been added to the initialization data and function
so it is clear by which SoC it is used as i.MX233 will have a specific
one. While on that, we also change it to static.
Signed-off-by: Otavio Salvador
---
Changes in v2:
- use static for the allocation of memory initialization
The information now is gathered from HW_DIGCTL_CHIPID register and
includes the chip modem and revision on the output.
Signed-off-by: Otavio Salvador
---
Changes in v2:
- use ?? for unidentified revision and cpu type
- use numeric revisions
Changes in v3:
- drop mx23 data as it will be posted in
Dear Wolfgang Denk,
> Dear Marek Vasut,
>
> In message <201207282139.05998.ma...@denx.de> you wrote:
> > > > include/common.h |7 +++
> > > > 1 file changed, 7 insertions(+)
> > >
> > > We have similar things already, and we don't add dead code - you add a
> > > macro without users here
Dear Wolfgang Denk,
> Dear Marek Vasut,
>
> In message <201207282039.34518.ma...@denx.de> you wrote:
> > > Seems incomplete in several aspects:
> > Below the section:
> >
> > * NOTE * THIS PATCH IS CRAZY
>
> Then what is actually the purpose of such a posting? Just dumping
> unsorted thoughts
Dear Tomas Hlavacek,
I think we should still mark early patches as RFC.
> early_malloc() introduced to ARM architecture (it is a proof of concept).
> GD datastructure extended for holding early-heap.
> mem_malloc_init() in board_init_r() has been put up by few lines.
I take it was sent by the gm
Dear Fabio,
In message
you wrote:
>
> > I understand we put the release on hold until I hear from you / see a
> > patch / pull request ?
>
> Please go ahead with the release. It was an operator error from my
> side. 2012.07-rc3 boots the kernel correctly on mx28evk.
Thanks for the feedback!
Hi Wolfgang,
On Fri, Jul 27, 2012 at 4:43 PM, Wolfgang Denk wrote:
> I understand we put the release on hold until I hear from you / see a
> patch / pull request ?
Please go ahead with the release. It was an operator error from my
side. 2012.07-rc3 boots the kernel correctly on mx28evk.
Thanks
On Fri, Jul 27, 2012 at 3:15 PM, Fabio Estevam wrote:
> On Fri, Jul 27, 2012 at 12:35 PM, Bill wrote:
>> Thanks. I tried that and got the same results. Are there any debug/logging
>> that I can use to see what's going on?
>
> I just tried it here and 2012.07-rc3 does not boot for me too.
I was
On Fri, Jul 27, 2012 at 3:14 PM, Fabio Estevam wrote:
> Bytes transferred = 3343968 (330660 hex)
> ## Booting kernel from Legacy Image at 4200 ...
>Image Name: Linux-3.5.0-next-20120727+
>Created: 2012-07-27 17:27:30 UTC
>Image Type: ARM Linux Kernel Image (uncompressed)
Dear Marek Vasut,
In message <201207282139.05998.ma...@denx.de> you wrote:
>
> > > include/common.h |7 +++
> > > 1 file changed, 7 insertions(+)
> >
> > We have similar things already, and we don't add dead code - you add a
> > macro without users here.
>
> It's used in 2/2 ... what m
Dear Marek Vasut,
In message <201207282039.34518.ma...@denx.de> you wrote:
>
> > Seems incomplete in several aspects:
>
> Below the section:
>
> * NOTE * THIS PATCH IS CRAZY
Then what is actually the purpose of such a posting? Just dumping
unsorted thoughts to community?
You are experienced
Dear Wolfgang Denk,
> Dear Marek Vasut,
>
> In message <1343483279-11572-1-git-send-email-ma...@denx.de> you wrote:
> > This function converts static number to string in preprocessor.
> > This is useful as it allows higher usage of puts() in favour of printf()
> >
> > Signed-off-by: Marek Vasut
Dear Marek Vasut,
In message <1343483279-11572-1-git-send-email-ma...@denx.de> you wrote:
> This function converts static number to string in preprocessor.
> This is useful as it allows higher usage of puts() in favour of printf()
>
> Signed-off-by: Marek Vasut
> Cc: Wolfgang Denk
> Cc: Mike Fr
Hi Michal,
I'll resubmit a new patch which fixes your notes.
br,
Stephan
Am Dienstag, den 24.07.2012, 12:56 +0200 schrieb Michal Simek:
> On 07/14/2012 12:30 AM, Stephan Linz wrote:
> > This is an improved version of the driver patch original
> > submitted by Graeme Smecher
> >
> > The changes
Dear Wolfgang Denk,
> Dear Marek Vasut,
>
> In message <1343483279-11572-2-git-send-email-ma...@denx.de> you wrote:
> > This shall eliminate the need for bubblesorting of commands at runtime.
> > Every command definition structure is now put into it's own subsection
> > of section .u_boot_cmd, th
Dear Marek Vasut,
In message <1343483279-11572-2-git-send-email-ma...@denx.de> you wrote:
> This shall eliminate the need for bubblesorting of commands at runtime.
> Every command definition structure is now put into it's own subsection
> of section .u_boot_cmd, that is .u_boot_cmd. . These are th
Hello!
I am working on early_malloc() for U-Boot Driver Model (this malloc is
going to serve for internal DM structures during early init and it has it's
minimalistic heap in global data).
My question is how to correctly switch from early allocator to full-scale
malloc and when to enable caches.
This shall eliminate the need for bubblesorting of commands at runtime.
Every command definition structure is now put into it's own subsection
of section .u_boot_cmd, that is .u_boot_cmd. . These are then put
into .u_boot_cmd by linker and lastly, linker uses SORT() over these
subsections to make p
This function converts static number to string in preprocessor.
This is useful as it allows higher usage of puts() in favour of printf()
Signed-off-by: Marek Vasut
Cc: Wolfgang Denk
Cc: Mike Frysinger
---
include/common.h |7 +++
1 file changed, 7 insertions(+)
diff --git a/include/co
Hi,
While working on the DM project, I found out that there are two
implementations of AHCI drivers - one in block/ahci.c, one in
block/dwc_ahsata.c
what is the difference between them (apart from the obvious, ahci.c exposes
SCSI API, dwc_ahsata exposes SATA API)? are there any problems that w
Signed-off-by: Javier Martinez Canillas
---
arch/arm/include/asm/arch-omap3/mem.h | 29 +
1 files changed, 29 insertions(+), 0 deletions(-)
diff --git a/arch/arm/include/asm/arch-omap3/mem.h
b/arch/arm/include/asm/arch-omap3/mem.h
index 9f6992a..12dcf4e 100644
---
This patch adds SPL support for IGEP-based boards.
Tested on an IGEPv2 Rev.C board with Micron NAND Flash memory.
Signed-off-by: Javier Martinez Canillas
---
board/isee/igep0020/config.mk | 33
board/isee/igep0020/igep0020.c | 42 +-
board/isee/i
IGEP-based boards can have two different flash memories, a OneNAND or a
NAND device. Add a configuration option for to choose which memory to use.
Signed-off-by: Javier Martinez Canillas
Acked-by: Enric Balletbo i Serra
---
board/isee/igep0020/igep0020.h |4
board/isee/igep0030/igep003
IGEP-based boards can have two different flash memories, a OneNAND or a
NAND device.
Since u-boot still lacks of a device model to be the able to look at
run-time which memory type is available on a the board, a built time
config option is needed to choose which memory to use.
This is a resend of
From: Zhong Hongbo
Signed-off-by: Zhong Hongbo
---
Change for V3:
- None.
Change for V2:
- None.
---
include/configs/smdk6400.h | 15 ---
1 files changed, 0 insertions(+), 15 deletions(-)
diff --git a/include/configs/smdk6400.h b/include/configs/smdk6400.h
index f
From: Zhong Hongbo
Signed-off-by: Zhong Hongbo
---
Change for V3:
- Replace ELFIN with S3C64XX for all the variable of cpu.h
- Change __S3C6400_H__ into __CPU__H__
Change for V2:
- New.
---
arch/arm/cpu/arm1176/s3c64xx/pwm.c |2 +-
arch/arm/cpu/arm1176/s3c64
From: Zhong Hongbo
Signed-off-by: Zhong Hongbo
---
Change for V3:
- Replace the magic numbers with variable name.
- Use C language to implement memory initialization.
Change for V2:
- None.
---
arch/arm/include/asm/arch-s3c64xx/dmc.h | 62 +
arch/arm/includ
From: Zhong Hongbo
Signed-off-by: Zhong Hongbo
---
Change for V3:
- Replace the magic numbers with the variable name.
Change for V2:
- None.
---
arch/arm/include/asm/arch-s3c64xx/gpio.h | 38
arch/arm/include/asm/arch-s3c64xx/interrupt.h | 31 +++
arch/arm/include/
From: Zhong Hongbo
Switch to use read/writel function and clear the relevant variable.
Signed-off-by: Zhong Hongbo
---
Change for V3:
- Use C language to re-write reset function.
- Replace the magic numbers witch variale name.
Change for V2:
- merge clock patch.
From: Zhong Hongbo
Signed-off-by: Zhong Hongbo
---
Change for V3:
- None.
Change for V2:
- Change the type of return for s3c64xx_get_base_sromc function.
---
arch/arm/cpu/arm1176/s3c64xx/Makefile |2 +-
arch/arm/cpu/arm1176/s3c64xx/srom.c | 51 +++
From: Zhong Hongbo
When It do not need to relocat for u-boot,
the offset(r9) of relocation should be set zero.
Signed-off-by: Zhong Hongbo
---
Change for V3:
- Replace mov with moveq.
Change for V2:
- Seprate some code.
---
arch/arm/cpu/arm1176/start.S |1 +
1 files changed
From: Zhong Hongbo
The old spl use nand_spl directory file to support
nand flash boot. We will adopt the new SPL framework
to implement it.
Signed-off-by: Zhong Hongbo
---
Change for V3:
- Delete u-boot-nand.lds.
Change for V2:
- None.
---
board/samsung/smdk6400/config.mk
From: Zhong Hongbo
Adopt the new SPL framework to implement the SPL booting of
the nand flash for S3C6400.
Signed-off-by: Zhong Hongbo
---
Change for V3:
- None.
Change for V2:
- seprate some code.
---
arch/arm/cpu/arm1176/start.S| 16 +---
board/samsung/s
From: Zhong Hongbo
It just only do the memory init. The memory depend on the
design of board.
Signed-off-by: Zhong Hongbo
---
Change for V3:
- None.
Change for V2:
- None.
---
arch/arm/cpu/arm1176/s3c64xx/Makefile |2 +-
arch/arm/cpu/arm1176/s3c64xx/cpu_init.S | 135
From: Zhong Hongbo
The old s3c64xx timer is not work normal, Adopt s5p time design,
It work perfect.
Signed-off-by: Zhong Hongbo
---
Change for V3:
- None.
Change for V2:
- Delete const key word for the variable of struct s3c_timer
---
arch/arm/cpu/arm1176/s3c64xx/timer.c | 19
From: Zhong Hongbo
Signed-off-by: Zhong Hongbo
---
Change for V3:
- None.
Change for V2:
- Change the type of the return value from unsinged int
to unsinged long for s3c64xx_get_base_nand function.
---
arch/arm/cpu/arm1176/s3c64xx/Makefile |1 +
arch/arm/cpu/
From: Zhong Hongbo
Signed-off-by: Zhong Hongbo
---
Change for v3:
- None.
Change for V2:
- Change the type of the return value from unsinged int
to unsinged long for s3c64xx_get_base_uart function.
- Delete const for the local variable.
---
arch/arm/include/as
From: Zhong Hongbo
Signed-off-by: Zhong Hongbo
---
Change for V3:
- Replace the magic numbers with variable name.
Change for V2:
- Change the type of the return value from unsinged int
to unsinged long for s3c64xx_get_base_uart function.
- Delete const for the l
From: Zhong Hongbo
Signed-off-by: Zhong Hongbo
---
Change for V3:
- None
Change for V2:
- None
---
Makefile | 20
board/samsung/smdk6400/config.mk |4 +---
boards.cfg |2 ++
include/configs/smdk6400.h
V3:
1. Replace ELFIN with S3C64XX for all the variable of cpu.h.
2. Change __S3C6400_H__ into __CPU__H__.
3. Use C language to implement memory initialization.
4. Use C language to re-write reset function.
5. Delete u-boot-nand.lds.
V2:
1. Modify the type of return for s3c64xx_get_base_nand
2. Add
From: Jagannadha Sutradharudu Teki <402ja...@gmail.com>
This patch adds support to include Load, Entry address and OS tag
of ramdisk on to FIT image through mkimage tool.
Signed-off-by: Jagannadha Sutradharudu Teki <402ja...@gmail.com>
---
common/image.c |7 ---
1 files changed, 4 insert
From: Jagannadha Sutradharudu Teki <402ja...@gmail.com>
The current code in image.c doesn't include the Load, Entry address and OS tag
to FIT image through mkimage tool.
Due to this while extracting the ramdisk from FIT blob, bootm showing an
error like...
Can't get ramdisk subimage load addres
Hi Laurence,
Thanks for the patch. I have tested this patch, below are few comments.
On Fri, Jul 27, 2012 at 4:19 PM, Laurence Withers wrote:
> For the DA8xx family of SoCs, the set_cpu_clk_info() function was not
> initialising the DSP frequency, leading to 'bdinfo' command output such as:
>
>
62 matches
Mail list logo