Hi Heiko,
On Thu, Feb 24, 2011 at 3:33 PM, Heiko Schocher wrote:
> Albert ARIBAUD wrote:
> The bin length is calculated in arch/arm/lib/board.c, but it seems
> to me not correct ... :-(
>
> in board_init_f():
>
> gd->mon_len = _bss_end_ofs;
>
> that seems correct to me, but later in board_init_r(
Hello Albert,
Albert ARIBAUD wrote:
> Le 24/02/2011 07:06, Po-Yu Chuang a écrit :
>> Hi all,
>>
>> I am using relocation fixed a320evb (arm) u-boot.
>>
>> I noticed something weird about the output of
>> command flinfo.
>>
>> The size of u-boot.bin is 129156 (0x1F884), but the
>> protected range i
Hi Albert,
On Thu, Feb 24, 2011 at 2:52 PM, Albert ARIBAUD wrote:
> Hi Po-Yu Chuang,
>
> Le 24/02/2011 07:06, Po-Yu Chuang a écrit :
>> That is quite strange.
>> According to arch/arm/cpu/arm920t/u-boot.lds,
>> .rel.dyn and .dynsym sections should be placed before __bss_start.
>> However, objdump
Dear Albert ARIBAUD,
In message <4d660030@free.fr> you wrote:
>
> You're right that U-Boot protection should cover the whole of U-Boot,
> including the relocation tables...
True. This was overlooked during all thie relocation rework.
> ... I *think* protectio
Hi Po-Yu Chuang,
Le 24/02/2011 07:06, Po-Yu Chuang a écrit :
> Hi all,
>
> I am using relocation fixed a320evb (arm) u-boot.
>
> I noticed something weird about the output of
> command flinfo.
>
> The size of u-boot.bin is 129156 (0x1F884), but the
> protected range is only 0 ~ 0x1bfff.
>
> I gues
Hi all,
I am using relocation fixed a320evb (arm) u-boot.
I noticed something weird about the output of
command flinfo.
The size of u-boot.bin is 129156 (0x1F884), but the
protected range is only 0 ~ 0x1bfff.
I guess that it is because u-boot protects _start ~ __bss_start,
but there are some ot
Hi Pratik,
ST provided In Application Programming via USART.
Search for application node AN2557, it is used to boot uClinux.
But you may take a look to
https://github.com/leaflabs/maple-bootloader
if you intent to create your board-support in u-boot :)
On Wed, Feb 23, 2011 at 7:53 PM, pratik puja
Hi,
I wrote:
> The omap3_spi driver was one of those affected by the bug fixed in
> commit 495df3b "ARM: fix write*() I/O accessors", see
> http://patchwork.ozlabs.org/patch/82841/
Sorry, I mixed this up. That was the davinci_spi driver, not the
omap3_spi one.
Best regards,
Wolfgang Denk
--
Dear Anatolij Gustschin,
In message <20110223233201.09aee7e4@wker> you wrote:
>
> No, please do not remove them. Fix the register access
> problem instead.
>
> > Anyway all read and write to enc fails.
> > Could that be related to omap3_spi implementation?
>
> Yes. If you use the omap3_spi drive
On Wednesday, February 23, 2011 17:17:39 Alper YILDIRIM wrote:
> I am using u-boot 2010.12 release. On previous releases auto completion was
> working for environment variables (bootargs, bootcmd, etc...) but with this
> release it is not.
it will be re-enabled in the next release
> When i search
Hello
I am using u-boot 2010.12 release. On previous releases auto completion was
working for environment variables (bootargs, bootcmd, etc...) but with this
release it is not.
When i searched the mailing list for a clue i found this patch [1], which i
think
disables autocompletion for enviro
Hi,
On Tue, 22 Feb 2011 17:34:30 +0100
jacopo mondi wrote:
...
> Second issue is related to enc identification.
> The following code section:
>
> phid1 = phy_read(enc, PHY_REG_PHID1);
> phid2 = phy_read(enc, PHY_REG_PHID2) & ENC_PHID2_MASK;
> if (phid1 != ENC_PHID1_VALUE || phi
Le 23/02/2011 21:03, Tom Warren a écrit :
> OK, I'm an idiot. I see now that I needed to add -n to format-patch to
> add the numbering to the [PATCH] header.
>
> Sorry for the noise - resending now with the corrected patchset.
>
> Tom
Actually, for a single patch, you don't need to generate number
Signed-off-by: Tom Warren
---
include/configs/seaboard.h |2 +-
1 files changed, 1 insertions(+), 1 deletions(-)
diff --git a/include/configs/seaboard.h b/include/configs/seaboard.h
index fd87560..59eef56 100644
--- a/include/configs/seaboard.h
+++ b/include/configs/seaboard.h
@@ -37,7 +37,7
Seaboard build stopped working due to Sandeep's recent mach-types.h update
to match the Linux kernel. Change Seaboard to use MACH_TYPE_SEABOARD.
Tom Warren (1):
arm: Tegra2: Change mach-type to MACH_TYPE_SEABOARD due to
mach-types.h update
include/configs/seaboard.h |2 +-
1 files chan
Signed-off-by: Tom Warren
---
include/configs/seaboard.h |2 +-
1 files changed, 1 insertions(+), 1 deletions(-)
diff --git a/include/configs/seaboard.h b/include/configs/seaboard.h
index fd87560..59eef56 100644
--- a/include/configs/seaboard.h
+++ b/include/configs/seaboard.h
@@ -37,7 +37,7
OK, I'm an idiot. I see now that I needed to add -n to format-patch to
add the numbering to the [PATCH] header.
Sorry for the noise - resending now with the corrected patchset.
Tom
On Wed, Feb 23, 2011 at 12:54 PM, Tom Warren wrote:
> Signed-off-by: Tom Warren
> ---
> include/configs/seaboard
Seaboard build stopped working due to Sandeep's recent mach-types.h update
to match the Linux kernel. Change Seaboard to use MACH_TYPE_SEABOARD.
Tom Warren (1):
arm: Tegra2: Change mach-type to MACH_TYPE_SEABOARD due to
mach-types.h update
include/configs/seaboard.h |2 +-
1 files chan
On Wednesday, February 23, 2011 14:28:44 Kyle Moffett wrote:
> +__attribute__((__weak__)) int arch_reset(void)
> +{
> + return 0;
> +}
is there any cpu which wouldnt provide arch_reset() ? i dont think it was
possible in the past to do this, so i dont see any value in supporting this.
> +in
The existing do_reset() shell command function is defined and redefined
all over the place.
Most CPU types have their own default internal reset mechanism, even if
it is just to force a triple-fault. In addition, some board designs
require the ability to override the native CPU reset due to hardw
The eXMeritus HWW-1U-1A unit is a DO-160-certified 13lb 1U chassis
with 3 independent TEMPEST zones. Two independent P2020 computers may
be found inside each zone. Complete hardware support is included.
High-level hardware overview:
* DO-160 certified for passenger aircraft (noncritical)
* T
The numeric constants in the switch statements are replaced by #defines
added to the common ddr_spd.h header. This dramatically improves the
readability of the switch statments.
In addition, a few of the longer lines were cleaned up, and the DDR2
type for an SO-RDIMM module was added to the DDR2
To ease the implementation of other MPC85xx board ports, several common
GPIO helpers are added to .
Since each of these compiles to no more than 4-5 instructions it would
be very inefficient to call them out of line, therefore we put them
entirely in the header file.
The HWW-1U-1A board port whic
Dear Albert:
Let me try. U-Boot is a "board oriented" bootloader. So, with that said, can
you tell us what "boards" might use an M3 or armv7-M?
When I say boards, I mean those boards one can buy from Freescale, Intel,
TI, Digikey or others.
Given a "board" name, it gets easier to answer your qu
Le 23/02/2011 18:36, Thorsten Mühlfelder a écrit :
> Am Wednesday 23 February 2011 13:53:53 schrieb pratik pujar:
>> Hello,
>>
>> Does U-boot have support for Cortex-M3?
>
> Cortex M3 is a CPU architecture, not a specific CPU or board type.
Not exactly. M3 is a core; the architecture in ARM parlan
Am Wednesday 23 February 2011 13:53:53 schrieb pratik pujar:
> Hello,
>
> Does U-boot have support for Cortex-M3?
Cortex M3 is a CPU architecture, not a specific CPU or board type.
___
U-Boot mailing list
U-Boot@lists.denx.de
http://lists.denx.de/mailman
Signed-off-by: Tom Warren
---
include/configs/seaboard.h |2 +-
1 files changed, 1 insertions(+), 1 deletions(-)
diff --git a/include/configs/seaboard.h b/include/configs/seaboard.h
index fd87560..59eef56 100644
--- a/include/configs/seaboard.h
+++ b/include/configs/seaboard.h
@@ -37,7 +37,7
Seaboard build stopped working due to Sandeep's recent mach-types.h update
to match the Linux kernel. Change Seaboard to use MACH_TYPE_SEABOARD.
Tom Warren (1):
arm: Tegra2: Change mach-type to MACH_TYPE_SEABOARD due to
mach-types.h update
include/configs/seaboard.h |2 +-
1 files chan
Standard Debian powerpc and powerpcspe systems only include hard-float
libgcc in their native compilers, which causes scary build warnings when
building U-Boot.
Debian and other PowerPC-supporting distributions used to provide libgcc
and other libraries in a "nof" (soft-float) form in the "multili
The current FreeScale MPC-8xxx DDR SPD interpreter is using full 64-bit
integer divide operations to convert between nanoseconds and DDR clock
cycles given arbitrary DDR clock frequencies.
Since all of the inputs to this are 32-bit (nanoseconds, clock cycles,
and DDR frequencies), we can easily re
On Wed, 23 Feb 2011 12:28:34 +0100
Michael Trimarchi wrote:
> Change since V1:
>
>- add a better description
This part does not go in the changelog -- it should be below the --- line.
> Signed-off-by: Michael Trimarchi
> Cc: Scott Wood
> ---
> drivers/mtd/nand/atmel_nand.c | 10 ++
When fdt_fixup_memory_banks is called with 2-cell address and size
fields in the device-tree (IE: 64-bit address and size), then it will
overflow its on-stack "tmp" buffer.
This fixes the buffer size and adds a comment explaining how many bytes
need to be allocated per record.
Signed-off-by: Kyle
To make it possible to use the "sspi" command with the e1000 firmware
EEPROM we add a small "generic SPI" driver wrapper around the existing
e1000 SPI backend.
Signed-off-by: Kyle Moffett
Cc: Ben Warren
---
No changes since v1
drivers/net/e1000.c | 92
For our new board ports, we are programming the EEPROMs attached to our
Intel 82571EB controllers from software (using U-Boot and Linux).
This code provides a helpful set of "e1000" subcommands for performing
EEPROM manipulation on e1000 devices, including displaying a hex-dump,
copying to and fro
By allocating the e1000 device structures much earlier, we can easily
generate better error messages and siginficantly clean things up.
The only user-visable change (aside from reworded error messages) is
that a detected e1000 device which fails to initialize due to software
or hardware error will
As an aide to debugging, we should print out the expected value of the
EEPROM checksum in addition to just saying that it is wrong.
Signed-off-by: Kyle Moffett
Cc: Ben Warren
---
No changes since v1
drivers/net/e1000.c | 48 ++--
1 files changed, 3
Consolidate the test for a dual-port NIC to one location for easy
modification, then fix support for the dual-port 82571.
Signed-off-by: Kyle Moffett
Cc: Ben Warren
---
No changes since v1
drivers/net/e1000.c | 66 +-
drivers/net/e1000.h |6
Albert,
On Tue, Feb 22, 2011 at 4:57 PM, Albert ARIBAUD wrote:
> Hi Tom,
>
> Le 23/02/2011 00:41, Tom Warren a écrit :
>>
>> Anyone willing to review this? I'd like to get it pulled in to
>> Albert's arm repo ASAP.
>
> I should be able to review it during the week-end--not before, sorry.
>
Thank
Hi,
Hope you are the right person to deal with on email list acquisition/ email
campaigns. I'm sure you have a strong in-house database that you maintain, but
do you have the accurate and updated information?
Our latest verified index of lead that has been compiled is of Specific target
audi
The default IGEP configuration doesn't do anything useful; using some
boot.scr search logic like BeagleBoard is much more useful.
Signed-off-by: Loïc Minier
---
include/configs/igep0020.h | 55 ---
1 files changed, 51 insertions(+), 4 deletions(-)
diff
Hello,
Does U-boot have support for Cortex-M3?
Or is it available in terms of patch, if yes how can I get it?
It will be very helpful to me.
Thanks,
Pratik.
___
U-Boot mailing list
U-Boot@lists.denx.de
http://lists.denx.de/mailman/listinfo/u-boot
Dear Michael Trimarchi,
In message <4d64f927.1000...@gandalf.sssup.it> you wrote:
>
> I will edit the text and resend with mutt. do I need to change again revision?
Yes, please, as it's a new commit (commit message has changed).
Best regards,
Wolfgang Denk
--
DENX Software Engineering GmbH,
Hi,
On 02/23/2011 12:42 PM, Albert ARIBAUD wrote:
> Hi Michael,
>
> Le 23/02/2011 12:28, Michael Trimarchi a écrit :
>> Change since V1:
>>
>> - add a better description
>
> History should not be put above the '---' cut line; it should be below.
>
>> Signed-off-by: Michael Trimarchi
>> Cc:
Hi Michael,
Le 23/02/2011 12:28, Michael Trimarchi a écrit :
> Change since V1:
>
> - add a better description
History should not be put above the '---' cut line; it should be below.
> Signed-off-by: Michael Trimarchi
> Cc: Scott Wood
> ---
> drivers/mtd/nand/atmel_nand.c | 10 ++
Change since V1:
- add a better description
Signed-off-by: Michael Trimarchi
Cc: Scott Wood
---
drivers/mtd/nand/atmel_nand.c | 10 ++
1 files changed, 10 insertions(+), 0 deletions(-)
diff --git a/drivers/mtd/nand/atmel_nand.c b/drivers/mtd/nand/atmel_nand.c
index ab8bbb3..c167f
45 matches
Mail list logo