Author: luigi
Date: Thu Apr 12 08:38:56 2012
New Revision: 234168
URL: http://svn.freebsd.org/changeset/base/234168
Log:
use getopt to parse options, add one option to set
the wait time for link-up events
Modified:
head/tools/tools/netmap/bridge.c
Modified: head/tools/tools/netmap/bridge.c
Author: luigi
Date: Thu Apr 12 08:54:01 2012
New Revision: 234169
URL: http://svn.freebsd.org/changeset/base/234169
Log:
use correct selinfo pointer for the generic interrupt handler
(it is never used in current FreeBSD drivers).
Modified:
head/sys/dev/netmap/netmap.c
Modified: head/sys/de
On 12 April 2012 05:53, Doug Barton wrote:
> Author: dougb
> Date: Thu Apr 12 01:53:33 2012
> New Revision: 234165
> URL: http://svn.freebsd.org/changeset/base/234165
>
> Log:
> The BIND 9.8.2 tarball was re-rolled to remove 9.8.1 release notes.
> This change was noticed by ISC at:
>
> https://
Author: kib
Date: Thu Apr 12 10:32:22 2012
New Revision: 234170
URL: http://svn.freebsd.org/changeset/base/234170
Log:
Propagate the current state of rtld_bind_lock to dlopen_object() calls
through the filter loading call chain. This fixes attempts to
write-lock the already locked rtld_bind_
Author: luigi
Date: Thu Apr 12 10:32:34 2012
New Revision: 234171
URL: http://svn.freebsd.org/changeset/base/234171
Log:
remove an unnecessary #define
Modified:
head/sys/net/netmap.h
Modified: head/sys/net/netmap.h
=
Author: kib
Date: Thu Apr 12 10:48:43 2012
New Revision: 234172
URL: http://svn.freebsd.org/changeset/base/234172
Log:
Add thread-private flag to indicate that error value is already placed
in td_errno. Flag is supposed to be used by syscalls returning
EJUSTRETURN because errno was already p
Author: des
Date: Thu Apr 12 11:23:24 2012
New Revision: 234173
URL: http://svn.freebsd.org/changeset/base/234173
Log:
Keep a copy of the original pointer returned by openpam_readline() so
we can free it later, instead of trying to free a pointer that points
to the end of the buffer.
Co
Author: luigi
Date: Thu Apr 12 11:27:09 2012
New Revision: 234174
URL: http://svn.freebsd.org/changeset/base/234174
Log:
Some code restructuring to bring the memory allocator out of netmap.c
and make it easier to replace it with a different implementation.
On passing, also fix indentation.
Author: ae
Date: Thu Apr 12 12:37:53 2012
New Revision: 234176
URL: http://svn.freebsd.org/changeset/base/234176
Log:
Read backup GPT header from the last LBA only when primary GPT header and
table aren't valid. If they are ok, use hdr_lba_alt value to read backup
header. This will make gptb
Author: trasz
Date: Thu Apr 12 12:58:14 2012
New Revision: 234177
URL: http://svn.freebsd.org/changeset/base/234177
Log:
Refactor da(4) to remove one of two code paths used to query capacity
data.
Reviewed by: ken, mav (earlier version)
Sponsored by: The FreeBSD Foundation
Modified:
Author: trasz
Date: Thu Apr 12 13:43:43 2012
New Revision: 234178
URL: http://svn.freebsd.org/changeset/base/234178
Log:
Remove block reallocation used to make room for the cylinder group
summary structure. From now on, when there is no room for it,
we simply allocate new one in a newly add
Author: jhb
Date: Thu Apr 12 13:46:56 2012
New Revision: 234179
URL: http://svn.freebsd.org/changeset/base/234179
Log:
MFC 233670,233671:
- Use VM_MEMATTR_UNCACHEABLE for the constant for UC memory rather than
VM_MEMATTR_UNCACHED on mips.
- Rename VM_MEMATTR_UNCACHED to VM_MEMATTR_WEAK_U
Author: jhb
Date: Thu Apr 12 13:47:23 2012
New Revision: 234180
URL: http://svn.freebsd.org/changeset/base/234180
Log:
MFC 233670,233671:
- Use VM_MEMATTR_UNCACHEABLE for the constant for UC memory rather than
VM_MEMATTR_UNCACHED on mips.
- Rename VM_MEMATTR_UNCACHED to VM_MEMATTR_WEAK_U
Author: jhb
Date: Thu Apr 12 13:53:10 2012
New Revision: 234181
URL: http://svn.freebsd.org/changeset/base/234181
Log:
MFC 233547:
Use VM_MEMATTR_UNCACHEABLE instead of VM_MEMATTR_UNCACHED for UC mappings.
VM_MEMATTR_UNCACHED is actually the x86-specific UC- mode (where a WC
MTRR can overr
Author: jhb
Date: Thu Apr 12 13:53:49 2012
New Revision: 234182
URL: http://svn.freebsd.org/changeset/base/234182
Log:
Don't update if_obytes when transmitting packets. That is already done
in IFQ_HANDOFF() when the packet is passed to the start routine, so doing
it here resulted in double
Author: jhb
Date: Thu Apr 12 14:01:06 2012
New Revision: 234183
URL: http://svn.freebsd.org/changeset/base/234183
Log:
Add OFED and the associated options and drivers to x86 LINT builds:
- Mark 'sdp' as requiring 'inet'.
- Always include "opt_inet.h" and "opt_inet6.h" and modify the IB
d
Author: dumbbell
Date: Thu Apr 12 14:02:59 2012
New Revision: 234184
URL: http://svn.freebsd.org/changeset/base/234184
Log:
Fix error messages containing the executed command name
Before, we took the first argument to pam_exec(8). With the addition of
options in front of the command, this
Author: luigi
Date: Thu Apr 12 14:06:05 2012
New Revision: 234185
URL: http://svn.freebsd.org/changeset/base/234185
Log:
Apparently the length field in advanced descriptors
does not include the CRC irrespective of the setting
of CRCSTRIP. The 82599 data sheets (sec. 7.1.6) say differently.
Author: jhb
Date: Thu Apr 12 14:49:25 2012
New Revision: 234186
URL: http://svn.freebsd.org/changeset/base/234186
Log:
If a linker file contains at least one module, but all of the modules
fail to load (the MOD_LOAD event fails) during a kldload(2), unload the
linker file and fail the kldloa
On 12 April 2012 18:49, John Baldwin wrote:
> Author: jhb
> Date: Thu Apr 12 14:49:25 2012
> New Revision: 234186
> URL: http://svn.freebsd.org/changeset/base/234186
>
> Log:
> If a linker file contains at least one module, but all of the modules
> fail to load (the MOD_LOAD event fails) during
On 12 April 2012 19:06, Sergey Kandaurov wrote:
> On 12 April 2012 18:49, John Baldwin wrote:
>> Author: jhb
>> Date: Thu Apr 12 14:49:25 2012
>> New Revision: 234186
>> URL: http://svn.freebsd.org/changeset/base/234186
>>
>> Log:
>> If a linker file contains at least one module, but all of the
Author: pluknet
Date: Thu Apr 12 16:02:45 2012
New Revision: 234188
URL: http://svn.freebsd.org/changeset/base/234188
Log:
Update the swi_add prototype after struct ithd was split up into
struct intr_event and struct intr_thread.
PR: docs/166864
Reviewed by: jhb (older versio
Author: trasz
Date: Thu Apr 12 16:55:48 2012
New Revision: 234189
URL: http://svn.freebsd.org/changeset/base/234189
Log:
Style.
Modified:
head/sbin/growfs/growfs.c
Modified: head/sbin/growfs/growfs.c
==
--- head/sbin
Author: jhb
Date: Thu Apr 12 17:43:59 2012
New Revision: 234190
URL: http://svn.freebsd.org/changeset/base/234190
Log:
- Extend the KDB interface to add a per-debugger callback to print a
backtrace for an arbitrary thread (rather than the calling thread).
A kdb_backtrace_thread() wrapper
Author: melifaro
Date: Thu Apr 12 17:49:53 2012
New Revision: 234191
URL: http://svn.freebsd.org/changeset/base/234191
Log:
MFC: r228730
Add binding support to libradius(3).
Submitted by:Sergey Matveychuk
Approved by: kib(mentor)
Modified:
stable/9/lib/libradius/Makefile
Author: melifaro
Date: Thu Apr 12 17:59:17 2012
New Revision: 234192
URL: http://svn.freebsd.org/changeset/base/234192
Log:
MFC: r214018
Add links for libradius(3) functions.
Approved by: pjd
Approved by: kib(mentor)
Modified:
stable/8/lib/libradius/Makefile
Directory Prop
Author: hselasky
Date: Thu Apr 12 18:06:30 2012
New Revision: 234193
URL: http://svn.freebsd.org/changeset/base/234193
Log:
Add missing LibUSB 1.0 API function.
Reported by: lme @
MFC after:1 week
Modified:
head/lib/libusb/Makefile
head/lib/libusb/libusb.3
head/lib/libusb/libu
Author: grehan
Date: Thu Apr 12 18:46:48 2012
New Revision: 234194
URL: http://svn.freebsd.org/changeset/base/234194
Log:
Complete polled-mode operation by using a callout if the device will be
used in polled-mode. The callout invokes uart_intr, which rearms the timeout.
Implemented for bhyv
Author: madpilot (ports committer)
Date: Thu Apr 12 20:22:17 2012
New Revision: 234195
URL: http://svn.freebsd.org/changeset/base/234195
Log:
Add myself and my relation to my mentors.
Approved by: crees
Modified:
head/share/misc/committers-ports.dot
Modified: head/share/misc/committers
Author: jhb
Date: Thu Apr 12 21:34:58 2012
New Revision: 234196
URL: http://svn.freebsd.org/changeset/base/234196
Log:
Update the ddb and gdb backends for the new 'trace_thread' hook.
It is implemented via db_trace_thread() for DDB and not implemented
for GDB. This should have been part of
Author: jkim
Date: Thu Apr 12 23:06:07 2012
New Revision: 234197
URL: http://svn.freebsd.org/changeset/base/234197
Log:
MFC: r233704
Re-initialize more model-specific registers when we resume CPUs.
Modified:
stable/9/sys/amd64/acpica/acpi_wakeup.c
stable/9/sys/amd64/amd64/mp_machdep.c
Author: ae
Date: Fri Apr 13 04:17:43 2012
New Revision: 234198
URL: http://svn.freebsd.org/changeset/base/234198
Log:
MFC r233000:
Add MODULE_DEPEND() to geom_part modules.
MFC r233342:
Check that scheme is not already registered. This may happens when a
KLD is preloaded with lo
Author: ae
Date: Fri Apr 13 04:18:12 2012
New Revision: 234199
URL: http://svn.freebsd.org/changeset/base/234199
Log:
MFC r233000:
Add MODULE_DEPEND() to geom_part modules.
MFC r233342:
Check that scheme is not already registered. This may happens when a
KLD is preloaded with lo
Author: adrian
Date: Fri Apr 13 04:22:42 2012
New Revision: 234201
URL: http://svn.freebsd.org/changeset/base/234201
Log:
Use strdup() on the name (and free it when it's done) so non-static names
can be used in firmware_register().
Modified:
head/sys/kern/subr_firmware.c
Modified: head/sys
Author: jh
Date: Fri Apr 13 05:40:26 2012
New Revision: 234202
URL: http://svn.freebsd.org/changeset/base/234202
Log:
Additional manual page updates for r234103.
Submitted by: bde
Modified:
head/lib/libc/sys/chflags.2
Modified: head/lib/libc/sys/chflags.2
===
Author: jh
Date: Fri Apr 13 05:48:31 2012
New Revision: 234203
URL: http://svn.freebsd.org/changeset/base/234203
Log:
Apply changes from r234103 to ext2fs:
Return EPERM from ext2_setattr() when an user without PRIV_VFS_SYSFLAGS
privilege attempts to toggle SF_SETTABLE flags.
Flags ar
Author: adrian
Date: Fri Apr 13 06:11:24 2012
New Revision: 234204
URL: http://svn.freebsd.org/changeset/base/234204
Log:
Sync this code against what's in OpenWRT trunk.
* the openwrt code doesn't treat 0/0/0 any differently
from other bus/slot/func combinations.
* A "local write" fun
On 2012-01-23, Mikolaj Golub wrote:
> I see two issues with this patch:
What do you think about this patch?
%%%
Index: sys/fs/tmpfs/tmpfs.h
===
--- sys/fs/tmpfs/tmpfs.h(revision 234201)
+++ sys/fs/tmpfs/tmpfs.h(workin
Author: adrian
Date: Fri Apr 13 06:13:37 2012
New Revision: 234205
URL: http://svn.freebsd.org/changeset/base/234205
Log:
Remove an unused variable. Grr.
Modified:
head/sys/mips/atheros/ar71xx_pci.c
Modified: head/sys/mips/atheros/ar71xx_pci.c
Author: kevlo
Date: Fri Apr 13 06:15:51 2012
New Revision: 234206
URL: http://svn.freebsd.org/changeset/base/234206
Log:
Partially implement zipinfo (-Z) support.
This fixes some test failures seen with perl 5.12 and 5.14.
PR: bin/166895
Submitted by: swills
MFC after:3 days
Mo
40 matches
Mail list logo