On Tue, 2 May 2023 16:35:18 GMT, Jiangli Zhou wrote:
> This PR was requested by awar...@google.com. The updates were provided by
> awar...@google.com.
This pull request has now been integrated.
Changeset: 03030d47
Author:Jiangli Zhou
URL:
https://git.openjdk.org/jdk/
On Wed, 3 May 2023 17:42:14 GMT, Rajan Halade wrote:
> Looks good to me. Please don't forget to update the release note and backport
> to JDK 20u.
Thanks @rhalade. Will do.
-
PR Comment: https://git.openjdk.org/jdk/pull/13754#issuecomment-1533751038
On Tue, 2 May 2023 18:42:36 GMT, Rajan Halade wrote:
>> This PR was requested by awar...@google.com. The updates were provided by
>> awar...@google.com.
>
>> > >
>> >
>> >
>> > I have infra tests for interop implemented. @jianglizhou, please check
>> > https://github.com/openjdk/jdk/compare/
On Tue, 2 May 2023 21:11:09 GMT, Jiangli Zhou wrote:
>> Thanks for the explanation. Please file a different issue for this change,
>> since it is outside the scope of this issue, which is to specifically add
>> new roots that have been approved by the Java SE CA Root
> This PR was requested by awar...@google.com. The updates were provided by
> awar...@google.com.
Jiangli Zhou has updated the pull request incrementally with one additional
commit since the last revision:
Update test/jdk/sun/security/lib/cacerts/VerifyCACerts.java after revertin
On Tue, 2 May 2023 20:36:57 GMT, Sean Mullan wrote:
>> The original R4 did not have the digitalSignature keyUsage set. This root
>> signs OCSP responses, so it needed to be reissued to comply with section
>> 7.1.2.1 of the CA/B Forum baseline requirements. The only change between the
>> two ve
> This PR was requested by awar...@google.com. The updates were provided by
> awar...@google.com.
Jiangli Zhou has updated the pull request incrementally with one additional
commit since the last revision:
Revert the src/java.base/share/data/cacerts/globalsigneccrootcar4
> This PR was requested by awar...@google.com. The updates were provided by
> awar...@google.com.
Jiangli Zhou has updated the pull request incrementally with one additional
commit since the last revision:
Add GoogleCA.java test from @rhalade.
-
Changes:
- all:
On Tue, 2 May 2023 18:42:36 GMT, Rajan Halade wrote:
> You can include this contribution in your PR. Then it will be easier to
> backport to JDK 20u as one changeset. I updated bug id in the changeset.
Done. Please double check.
I ran the GoogleCA.java test with a test JDK binary built with th
On Tue, 2 May 2023 17:29:07 GMT, Rajan Halade wrote:
> >
>
> I have infra tests for interop implemented. @jianglizhou, please check
> https://github.com/openjdk/jdk/compare/master...rhalade:jdk:googletrust-certify?expand=1
@rhalade, thanks! I have a minor comment below for your
test/jdk/secu
On Tue, 2 May 2023 17:29:07 GMT, Rajan Halade wrote:
>> This PR was requested by awar...@google.com. The updates were provided by
>> awar...@google.com.
>
>>
>
> I have infra tests for interop implemented. @jianglizhou, please check
> https://github.com/openjdk/jdk/compare/master...rhalade:jd
This PR was requested by awar...@google.com. The updates are provided by
awar...@google.com.
-
Commit messages:
- Merge branch 'master' into JDK-8307134
- 8307134: Add GTS root CAs
Changes: https://git.openjdk.org/jdk/pull/13754/files
Webrev: https://webrevs.openjdk.org/?repo=jdk
On Thu, 27 Apr 2023 00:12:58 GMT, Jiangli Zhou wrote:
> Resolve misc symbol issues observed when statically linking JDK/VM natives
> with the standard Java launcher executable. Use the same approaches adopted
> by earlier fixes for static linking related symbol problems (e.g.
>
On Thu, 27 Apr 2023 00:12:58 GMT, Jiangli Zhou wrote:
> Resolve misc symbol issues observed when statically linking JDK/VM natives
> with the standard Java launcher executable. Use the same approaches adopted
> by earlier fixes for static linking related symbol problems (e.g.
>
Resolve misc symbol issues observed when statically linking JDK/VM natives with
the standard Java launcher executable. Use the same approaches adopted by
earlier fixes for static linking related symbol problems (e.g. JDK-8306033):
- Change findFunction() to be a static function in
src/java.smar
On Mon, 17 Apr 2023 16:56:31 GMT, Jiangli Zhou wrote:
> - Make functions 'static' when feasible:
> - throwByName() in
> src/java.security.jgss/share/native/libj2gss/NativeUtil.c.
> - throwByName(), throwIOException() and throwNullPointerException() in
> src/jav
On Tue, 25 Apr 2023 00:47:17 GMT, Jiangli Zhou wrote:
>> - Make functions 'static' when feasible:
>> - throwByName() in
>> src/java.security.jgss/share/native/libj2gss/NativeUtil.c.
>> - throwByName(), throwIOException() and throwNullPointerException(
On Mon, 24 Apr 2023 22:41:53 GMT, Mark Powers wrote:
> Update copyrights to 2023.
Done, thanks.
> src/java.security.jgss/share/native/libj2gss/GSSLibStub.c line 201:
>
>> 199: cb = malloc(sizeof(struct gss_channel_bindings_struct));
>> 200: if (cb == NULL) {
>> 201: gssThrowOutOfMemory
other throw functions.
>
> - Remove throw_internal_error() from
> src/java.management/share/native/libmanagement/management.h and
> src/java.management/share/native/libmanagement/management.c. It's not used.
> - Remove throw_internal_error() from
> src/jdk.management/share/n
On Mon, 17 Apr 2023 16:56:31 GMT, Jiangli Zhou wrote:
> - Make functions 'static' when feasible:
> - throwByName() in
> src/java.security.jgss/share/native/libj2gss/NativeUtil.c.
> - throwByName(), throwIOException() and throwNullPointerException() in
> src/jav
On Wed, 19 Apr 2023 11:01:07 GMT, Jaikiran Pai wrote:
> Even if it doesn't get enrolled in the pre-submit testing, I think the fact
> that there will be a build within the JDK which can catch these issues is a
> good thing. It might catch the issue(s) after the integration, but I think
> it's
On Mon, 17 Apr 2023 16:56:31 GMT, Jiangli Zhou wrote:
> - Make functions 'static' when feasible:
> - throwByName() in
> src/java.security.jgss/share/native/libj2gss/NativeUtil.c.
> - throwByName(), throwIOException() and throwNullPointerException() in
> src/jav
- Make functions 'static' when feasible:
- throwByName() in src/java.security.jgss/share/native/libj2gss/NativeUtil.c.
- throwByName(), throwIOException() and throwNullPointerException() in
src/java.smartcardio/unix/native/libj2pcsc/pcsc_md.c.
- throwByName() in
src/jdk.crypto.cryptoki/shar
On Wed, 12 Apr 2023 03:20:47 GMT, Jiangli Zhou wrote:
> Rename 'handleSocketError' to 'sctpHandleSocketError' in libsctp. This
> resolves the related duplicate symbol failures when both libnio and libsctp
> are statically linked with the launcher.
>
>
On Wed, 12 Apr 2023 03:26:10 GMT, Jiangli Zhou wrote:
> I noticed there is a presubmit test failure:
> https://github.com/jianglizhou/jdk/actions/runs/4672962155#user-content-java_lang_thread_virtual_tracevirtualthreadlocals
> for linux-x86. It appears to be unrelated. Will file a bug
On Wed, 12 Apr 2023 17:18:25 GMT, Jiangli Zhou wrote:
>> Rename 'handleSocketError' to 'sctpHandleSocketError' in libsctp. This
>> resolves the related duplicate symbol failures when both libnio and libsctp
>> are statically linked with the launcher.
&g
On Wed, 12 Apr 2023 06:29:16 GMT, Alan Bateman wrote:
> This looks okay but it makes me wonder about loadSocketExtensionFuncs. Maybe
> we should remove that from Sctp.h and change loadSocketExtensionFuncs in
> SctpNet.c to be static.
Changed loadSocketExtensionFuncs to be static as suggested.
pl.c and SctpNet.c. Looks like
> that's only needed for handleSocketError() declaration. Declare
> sctpHandleSocketError() in Sctp.h.
>
> (Sorry about the earlier RFR/Withdrawn noise.)
Jiangli Zhou has updated the pull request incrementally with one additional
commit since t
On Wed, 12 Apr 2023 03:20:47 GMT, Jiangli Zhou wrote:
> Rename 'handleSocketError' to 'sctpHandleSocketError' in libsctp. This
> resolves the related duplicate symbol failures when both libnio and libsctp
> are statically linked with the launcher.
>
>
Rename 'handleSocketError' to 'sctpHandleSocketError' in libsctp. This resolves
the related duplicate symbol failures when both libnio and libsctp are
statically linked with the launcher.
Remove #include "nio_util.h" from SctpChannelImpl.c and SctpNet.c. Looks like
that's only needed for handle
On Tue, 11 Apr 2023 19:19:07 GMT, Jiangli Zhou wrote:
> Rename 'handleSocketError' to 'sctpHandleSocketError' in libsctp. This
> resolves related duplicate symbol failure when both libnio and libsctp are
> statically linked with.
This pull request has been cl
Rename 'handleSocketError' to 'sctpHandleSocketError' in libsctp. This resolves
related duplicate symbol failure when both libnio and libsctp are statically
linked with.
-
Commit messages:
- 8305858: Resolve multiple definition of 'handleSocketError' when statically
linking with J
On Sat, 8 Apr 2023 01:11:08 GMT, Jiangli Zhou wrote:
> Rename various 'jvm' variables to 'jvm_' to avoid duplicate symbol
> problems when statically linking the launcher executable with JDK native
> libraries.
This pull request has now been integrated.
Changeset
On Mon, 10 Apr 2023 19:38:18 GMT, Jiangli Zhou wrote:
>> Rename various 'jvm' variables to 'jvm_' to avoid duplicate symbol
>> problems when statically linking the launcher executable with JDK native
>> libraries.
>
> Jiangli Zhou has updated the pu
> Rename various 'jvm' variables to 'jvm_' to avoid duplicate symbol
> problems when statically linking the launcher executable with JDK native
> libraries.
Jiangli Zhou has updated the pull request incrementally with one additional
commit since the last revisio
On Mon, 10 Apr 2023 13:52:39 GMT, Alan Bateman wrote:
>> Rename various 'jvm' variables to 'jvm_' to avoid duplicate symbol
>> problems when statically linking the launcher executable with JDK native
>> libraries.
>
> src/java.management/share/native/libmanagement/management.c line 36:
>
>> 34
… with JDK native libraries
-
Commit messages:
- 8305761: Resolve multiple definition of 'jvm' when statically linking with
JDK native libraries
Changes: https://git.openjdk.org/jdk/pull/13397/files
Webrev: https://webrevs.openjdk.org/?repo=jdk&pr=13397&range=00
Issue: https://b
On Fri, 7 Apr 2023 23:32:46 GMT, Jiangli Zhou wrote:
> Rename various 'jvm' variables to 'jvm_' to avoid duplicate symbol
> problems when statically linking the launcher executable with JDK native
> libraries.
>
> 8305761: Resolve multiple definition of
Rename various 'jvm' variables to 'jvm_' to avoid duplicate symbol
problems when statically linking the launcher executable with JDK native
libraries.
8305761: Resolve multiple definition of 'jvm' when statically linking with JDK
native libraries
-
Commit messages:
- Resolve link
39 matches
Mail list logo