Rename 'handleSocketError' to 'sctpHandleSocketError' in libsctp. This resolves the related duplicate symbol failures when both libnio and libsctp are statically linked with the launcher.
Remove #include "nio_util.h" from SctpChannelImpl.c and SctpNet.c. Looks like that's only needed for handleSocketError() declaration. Declare sctpHandleSocketError() in Sctp.h. (Sorry about the earlier RFR/Withdrawn noise.) ------------- Commit messages: - 8305858: Resolve multiple definition of 'handleSocketError' when statically linking with JDK native libraries Changes: https://git.openjdk.org/jdk/pull/13438/files Webrev: https://webrevs.openjdk.org/?repo=jdk&pr=13438&range=00 Issue: https://bugs.openjdk.org/browse/JDK-8305858 Stats: 20 lines in 3 files changed: 2 ins; 4 del; 14 mod Patch: https://git.openjdk.org/jdk/pull/13438.diff Fetch: git fetch https://git.openjdk.org/jdk.git pull/13438/head:pull/13438 PR: https://git.openjdk.org/jdk/pull/13438