Re: RFR: 8339280: jarsigner -verify performs cross-checking between CEN and LOC [v2]

2025-03-12 Thread Hai-May Chao
> The jarsigner -verify command currently performs verification by reading from > JarFile to navigate the central directory (CEN) headers. It is now enhanced > to include cross-validation of entries between JarFile (CEN-based) and > JarInputStream (stream-based) representations of the JAR. It em

Re: RFR: 8298420: PEM API: Implementation (Preview) [v13]

2025-03-12 Thread Anthony Scarpino
> Hi all, > > I need a code review of the PEM API. Privacy-Enhanced Mail (PEM) is a format > for encoding and decoding cryptographic keys and certificates. It will be > integrated into JDK24 as a Preview Feature. Preview features does not > permanently define the API and it is subject to cha

SSLContext instances

2025-03-12 Thread Scott Lewis
Greets, I'm not a regular participant on this mailing list, so please forgive the newby and point me in the right direction if this has already been discussed. I am a regular configurer [1] and consumer of SSLContext [2] instances...e.g. for jdk httpsclient config, apache httpsclient config,

Re: RFR: 8350964: Add an ArtifactResolver.fetch(clazz) method [v4]

2025-03-12 Thread Weijun Wang
On Wed, 12 Mar 2025 20:28:31 GMT, Matthew Donovan wrote: >> In this PR, I created a new method, `ArtifactResolver.fetchOne()`, to >> consolidate duplicate code across tests. > > Matthew Donovan has updated the pull request incrementally with one > additional commit since the last revision: > >

Re: RFR: 8350964: Add an ArtifactResolver.fetch(clazz) method [v3]

2025-03-12 Thread Matthew Donovan
On Wed, 12 Mar 2025 16:39:41 GMT, Weijun Wang wrote: >> Matthew Donovan has updated the pull request incrementally with one >> additional commit since the last revision: >> >> Changed ArtifactResolver.fetchOne() to throw a skipped exception > > test/jdk/sun/security/pkcs11/PKCS11Test.java lin

Re: RFR: 8350964: Add an ArtifactResolver.fetch(clazz) method [v4]

2025-03-12 Thread Matthew Donovan
> In this PR, I created a new method, `ArtifactResolver.fetchOne()`, to > consolidate duplicate code across tests. Matthew Donovan has updated the pull request incrementally with one additional commit since the last revision: updated code to remove extraneous null checks - Chang

Re: RFR: 8351034: Add AVX-512 intrinsics for ML-DSA [v7]

2025-03-12 Thread Ferenc Rakoczi
> By using the AVX-512 vector registers the speed of the computation of the > ML-DSA algorithms (key generation, document signing, signature verification) > can be approximately doubled. Ferenc Rakoczi has updated the pull request incrementally with one additional commit since the last revision

Re: RFR: 8349583: Add mechanism to disable signature schemes based on their TLS scope [v18]

2025-03-12 Thread Artur Barashev
> Currently when a signature scheme constraint is specified with > "jdk.tls.disabledAlgorithms" property we don't differentiate between > signatures used to sign a TLS handshake exchange and the signatures used in > TLS certificates: > https://datatracker.ietf.org/doc/html/rfc8446#section-4.2.3

Integrated: 8303770: Remove Baltimore root certificate expiring in May 2025

2025-03-12 Thread Rajan Halade
On Tue, 11 Mar 2025 17:28:17 GMT, Rajan Halade wrote: > Removed "_CN=Baltimore CyberTrust Root, OU=CyberTrust, O=Baltimore, C=IE_" > root certificate expiring in May 2025 from cacerts truststore. No code > signing certificates were issued from CA. > > The release-note is at > [JDK-8351686](ht

Re: RFR: 8303770: Remove Baltimore root certificate expiring in May 2025

2025-03-12 Thread Sean Mullan
On Tue, 11 Mar 2025 17:28:17 GMT, Rajan Halade wrote: > Removed "_CN=Baltimore CyberTrust Root, OU=CyberTrust, O=Baltimore, C=IE_" > root certificate expiring in May 2025 from cacerts truststore. No code > signing certificates were issued from CA. > > The release-note is at > [JDK-8351686](ht

Re: RFR: 8341775: Duplicate manifest files are removed by jarsigner after signing [v8]

2025-03-12 Thread Sean Mullan
On Tue, 11 Mar 2025 17:30:54 GMT, Kevin Driver wrote: >> JDK-8341775: In the case where there is a *single* META-INF directory but >> potentially *multiple* manifest files of different cases, print a warning >> before selecting the first one and ignoring the rest (the current behavior >> shoul

Re: RFR: 8350964: Add an ArtifactResolver.fetch(clazz) method [v2]

2025-03-12 Thread Matthew Donovan
On Wed, 12 Mar 2025 16:05:12 GMT, Weijun Wang wrote: >> Do you mean to just assume `artifact` is never null and let the NPE be >> thrown if it is? > > Yes. I updated the code to reflect that. - PR Review Comment: https://git.openjdk.org/jdk/pull/23989#discussion_r1991893033

Re: RFR: 8350964: Add an ArtifactResolver.fetch(clazz) method [v2]

2025-03-12 Thread Matthew Donovan
On Wed, 12 Mar 2025 13:27:49 GMT, Weijun Wang wrote: >> Matthew Donovan has updated the pull request incrementally with one >> additional commit since the last revision: >> >> Changed exception message in Artifact resolver and fixed logic in keytool >> test > > test/jdk/sun/security/pkcs11/P

Re: RFR: 8349583: Add mechanism to disable signature schemes based on their TLS scope [v17]

2025-03-12 Thread Artur Barashev
> Currently when a signature scheme constraint is specified with > "jdk.tls.disabledAlgorithms" property we don't differentiate between > signatures used to sign a TLS handshake exchange and the signatures used in > TLS certificates: > https://datatracker.ietf.org/doc/html/rfc8446#section-4.2.3

Re: RFR: 8350964: Add an ArtifactResolver.fetch(clazz) method [v2]

2025-03-12 Thread Weijun Wang
On Wed, 12 Mar 2025 13:50:06 GMT, Matthew Donovan wrote: >> test/lib/jdk/test/lib/artifacts/ArtifactResolver.java line 103: >> >>> 101: message = "Cannot find the artifact " + >>> artifact.name(); >>> 102: } else { >>> 103: message = "Class " + klass.

Re: RFR: 8351034: Add AVX-512 intrinsics for ML-DSA [v6]

2025-03-12 Thread Leonid Mesnik
On Wed, 12 Mar 2025 13:42:33 GMT, Ferenc Rakoczi wrote: >> By using the AVX-512 vector registers the speed of the computation of the >> ML-DSA algorithms (key generation, document signing, signature verification) >> can be approximately doubled. > > Ferenc Rakoczi has updated the pull request i

Re: RFR: 8350964: Add an ArtifactResolver.fetch(clazz) method [v3]

2025-03-12 Thread Matthew Donovan
On Wed, 12 Mar 2025 13:29:08 GMT, Weijun Wang wrote: >> It encapsulates all of the logic involved in getting the tests. >> Specifically, what to do if the tests can't be fetched. It could be done in >> `main()` but this is a little cleaner. > > I'd rather just let `ArtifactResolver.fetchOne` th

Re: RFR: 8350964: Add an ArtifactResolver.fetch(clazz) method [v2]

2025-03-12 Thread Matthew Donovan
On Wed, 12 Mar 2025 13:31:56 GMT, Weijun Wang wrote: >> Matthew Donovan has updated the pull request incrementally with one >> additional commit since the last revision: >> >> Changed exception message in Artifact resolver and fixed logic in keytool >> test > > test/lib/jdk/test/lib/artifact

Re: RFR: 8350964: Add an ArtifactResolver.fetch(clazz) method [v3]

2025-03-12 Thread Matthew Donovan
> In this PR, I created a new method, `ArtifactResolver.fetchOne()`, to > consolidate duplicate code across tests. Matthew Donovan has updated the pull request incrementally with one additional commit since the last revision: Changed ArtifactResolver.fetchOne() to throw a skipped exception -

Re: RFR: 8350964: Add an ArtifactResolver.fetch(clazz) method [v2]

2025-03-12 Thread Weijun Wang
On Tue, 11 Mar 2025 16:24:23 GMT, Matthew Donovan wrote: >> test/jdk/sun/security/provider/acvp/Launcher.java line 181: >> >>> 179: } >>> 180: >>> 181: private static Path fetchACVPServerTests(Class clazz) { >> >> Is there a point in this method? It's used in 1 spot only it seems and y

Re: RFR: 8351034: Add AVX-512 intrinsics for ML-DSA [v4]

2025-03-12 Thread Ferenc Rakoczi
On Thu, 6 Mar 2025 14:30:35 GMT, Jatin Bhateja wrote: >> Ferenc Rakoczi has updated the pull request incrementally with one >> additional commit since the last revision: >> >> Added alignment to loop entries. > > src/hotspot/cpu/x86/stubGenerator_x86_64_dilithium.cpp line 2: > >> 1: /* >> 2:

Re: RFR: 8351034: Add AVX-512 intrinsics for ML-DSA [v3]

2025-03-12 Thread Ferenc Rakoczi
On Thu, 6 Mar 2025 09:32:19 GMT, Jatin Bhateja wrote: >> I think the easiest is to put a for (int i = 0; i < 1000; i++) loop around >> the switch statement in the run() method of the ML_DSA_Test class >> (test/jdk/sun/security/provider/acvp/ML_DSA_Test.java). (This is because the >> intrinsi

Re: RFR: 8351034: Add AVX-512 intrinsics for ML-DSA [v5]

2025-03-12 Thread Ferenc Rakoczi
On Mon, 10 Mar 2025 03:00:09 GMT, Leonid Mesnik wrote: > There are no any new tests in the PR. How fix has been tested by openjdk > tests? I have just added one. - PR Comment: https://git.openjdk.org/jdk/pull/23860#issuecomment-2717950685

Re: RFR: 8351034: Add AVX-512 intrinsics for ML-DSA [v6]

2025-03-12 Thread Ferenc Rakoczi
> By using the AVX-512 vector registers the speed of the computation of the > ML-DSA algorithms (key generation, document signing, signature verification) > can be approximately doubled. Ferenc Rakoczi has updated the pull request incrementally with one additional commit since the last revision

Re: RFR: 8350964: Add an ArtifactResolver.fetch(clazz) method [v2]

2025-03-12 Thread Weijun Wang
On Tue, 11 Mar 2025 16:53:17 GMT, Matthew Donovan wrote: >> In this PR, I created a new method, `ArtifactResolver.fetchOne()`, to >> consolidate duplicate code across tests. > > Matthew Donovan has updated the pull request incrementally with one > additional commit since the last revision: > >

Re: RFR: 8350964: Add an ArtifactResolver.fetch(clazz) method [v2]

2025-03-12 Thread Fernando Guallini
On Tue, 11 Mar 2025 16:48:03 GMT, Matthew Donovan wrote: >> test/jdk/sun/security/pkcs12/KeytoolOpensslInteropTest.java line 90: >> >>> 88: generateInitialKeystores(opensslPath); >>> 89: testWithJavaCommands(); >>> 90: testWithOpensslCommands(opens

Re: RFR: 8325448: Hybrid Public Key Encryption [v10]

2025-03-12 Thread Weijun Wang
> Implement HPKE as defined in https://datatracker.ietf.org/doc/rfc9180/. > ![HPKEParameterSpec](https://github.com/user-attachments/assets/4a7e6609-fd64-444a-978f-bde1634caa70) Weijun Wang has updated the pull request incrementally with one additional commit since the last revision: switch to

Re: RFR: 8350964: Add an ArtifactResolver.fetch(clazz) method [v2]

2025-03-12 Thread Mikhail Yankelevich
On Tue, 11 Mar 2025 16:53:17 GMT, Matthew Donovan wrote: >> In this PR, I created a new method, `ArtifactResolver.fetchOne()`, to >> consolidate duplicate code across tests. > > Matthew Donovan has updated the pull request incrementally with one > additional commit since the last revision: > >