(Forgot the subject)
> >* On 25 Mar 2017, at 15:51, Gerald Britton ><https://mail.python.org/mailman/listinfo/python-ideas>> wrote:
> *> >* On 25 March 2017 at 11:24, Pavel Velikhov <http://gmail.com> <http://gmail.com/ <http://gmail.com/>>> wrot
on, which is implemented in .NET, has no GIL
and doesn't need it since ir runs on the CLR. That means that, for some
things, IronPython can be more performant.
No word yet if the IronPython project intends to port to .NET core or
enable to run it on OS's other than Windows.
Also, it&
>
> As you guys might know, .NET Core is up and running, promising a
> "cross-platform, unified, fast, lightweight, modern and open source
> experience" (source: .NET Core official site). What do you guys think about
> it? Do you think it will be able to compete with and overcome Python in the
> op
I was rereading the 2.7 docs about abstract base classes the other day. I
found this line in the usage section of the abc.abstractproperty function:
"This defines a read-only property; you can also define a read-write
abstract property using the ‘long’ form of property declaration:"
along with
ng write property
implementation (otherwise, what's the point of the example?)
Is this a doc bug, an ABC bug or just me? (I've been known to be buggy
from time to time!)
--
Gerald Britton
--
https://mail.python.org/mailman/listinfo/python-list
ppy=50, sleepy=60, sneezy=70):
> # the usual assign arguments to attributes dance...
> self.bashful = bashful
> self.doc = doc
> # etc.
This looks like a situation where the GoF Builder pattern might help
--
Gerald Britton, MCSE-DP, MVP
LinkedIn Profile: http://ca.linkedin.com/in/g
type. (Or at least, updated every thirty seconds or so.) Anybody know
> anything like that?
Visual Studio Code does an OK job with the
reStructuredText Language Support for Visual Studio Code
Extension
--
Gerald Britton, MCSE-DP, MVP
LinkedIn Profile: http://ca.linkedin.com/in/geraldbritton
--
just me? (I've been known to be buggy
from time to time!)
--
Gerald Britton, MCSE-DP, MVP
LinkedIn Profile: http://ca.linkedin.com/in/geraldbritton
--
https://mail.python.org/mailman/listinfo/python-list
>On Sun, Jul 31, 2016 at 6:33 AM, Gerald Britton
> wrote:
>> Today, I was reading RH's Descriptor HowTo Guide at
>>
>> https://docs.python.org/3/howto/descriptor.html?highlight=descriptors
>>
>> I just really want to fully "get" this.
>>
>
Today, I was reading RH's Descriptor HowTo Guide at
https://docs.python.org/3/howto/descriptor.html?highlight=descriptors
I just really want to fully "get" this.
So I put together a little test from scratch. Looks like this:
class The:
class Answer:
def __get__(self, obj, type=None
<https://mail.python.org/pipermail/python-list/2016-July/thread.html#711777>
[ subject ]
<https://mail.python.org/pipermail/python-list/2016-July/subject.html#711777>
[ author ]
<https://mail.python.org/pipermail/python-list/2016-July/author.html#711777>
---
that would indicate to prefer method
1 or method 2? Are there methods 3, 4, 5, ... that I should consider that
are even better?
--
Gerald Britton, MCSE-DP, MVP
LinkedIn Profile: http://ca.linkedin.com/in/geraldbritton
--
https://mail.python.org/mailman/listinfo/python-list
On Wed, 25 May 2016 10:00 am, Steven D'Aprano wrote:
>On Wed, 25 May 2016 09:35 am, Gerald Britton wrote:
>
>For brevity, here's your package setup:
>
>
>testpkg/
>+-- __init__.py
>+-- testimport.py which runs "from testpkg.testimported import A"
>
t call last):
File "testimport.py", line 1, in
from testpkg.testimported import A
ImportError: No module named testpkg.testimported
However, I thought I was doing what the doc describes for intra package
imports. What am I missing?
Or is the problem simply that I do not have subpackages?
el + '\n' +
"description *** local outbound dialpeer ***" + '\n' +
destpatt + '\n' +
"port " + p + '\n'
"forward-digits 7" if line[0:3] == y and q == "y" else "&
>Gerald Britton wrote:
>> I now understand the Python does
>> not consider a class definition as a separate namespace as it does for
>> function definitions. That is a helpful understanding.
>That is not correct. Classes are separate namespaces -- they just
>aren
ses the global
definition of "meat". The class attribute "meat" is not seen by the
serve method unless it is qualified. I now understand the Python does
not consider a class definition as a separate namespace as it does for
function definitions. That is a helpful understanding.
Anyway, thanks for jumping in to the discussion.
--
Gerald Britton
--
http://mail.python.org/mailman/listinfo/python-list
quot; to my use of "foo"
>>> class a():
... foo = 'foo'
... def g(x):
... return a.foo
...
>>> x = a()
>>> x.g()
'foo'
So, this works and I can use it. However, I would like a deeper
understanding of why I cannot use "foo" as an unqualified variable
inside the method in the class. If Python allowed such a thing, what
problems would that cause?
--
Gerald Britton
--
http://mail.python.org/mailman/listinfo/python-list
horsepower and the size of sys.maxint on your
machine, this may take a few *days* to run.
Note: The sum in the Python expression above runs in reverse to
minimize rounding errors.
--
Gerald Britton
--
http://mail.python.org/mailman/listinfo/python-list
d
obviate any such concern.
>3/ it would make the implementation more complex (i.e. more work for our
>beloved active community) for no gain
See my reply to 1/ above.
>4/ you can write C code to speed up things:
>http://docs.python.org/extending/extending.html, when really needed.
How do you spell red herring?
--
Gerald Britton
--
http://mail.python.org/mailman/listinfo/python-list
19 STORE_MAP
20 BINARY_MODULO
21 POP_TOP
22 LOAD_CONST 5 (None)
25 RETURN_VALUE
>>>
Any idea why Python works this way? I see that, in 3.2, an
optimization was done for sets (See "Optimizations" at
http://docs.python.org/py3k/whatsnew/3.2.html) though I do not see
anything similar for dictionaries.
--
Gerald Britton
--
Gerald Britton
--
http://mail.python.org/mailman/listinfo/python-list
&& x < 7')
'x > 2 && x < 7'
--
Gerald Britton
--
http://mail.python.org/mailman/listinfo/python-list
I see that Python 3.2 includes a new module -- html -- with a single
function -- escape. I would like to know how this function differs
from xml.sax.saxutils.escape and, if there is no difference (or only a
minor one), what the need is for this new module and its lone function
--
Gerald Britton
gt; Timer('map(g, s)', 'from __main__ import s, g').timeit()
1.8645310401916504
>>> Timer('[x.__class__ for x in s]', 'from __main__ import s').timeit()
1.7232599258422852
>>> Timer('map(a, s)', 'from __main__ import s, a').timeit()
2.4131419658660889
>>>
So, what's the feeling out there? Go with map and the operators or
stick with the list comps?
--
Gerald Britton
--
http://mail.python.org/mailman/listinfo/python-list
0 loops, best of 3: 879 usec per loop
granted, but not on topic here. we're talking about map vs list comps
when you want to use a function.
>map is only likely to be faster if you wanted to call a function in both cases.
Which is exactly the point.
>f you have an expression that can be inlined you save the function call
>overhead with the list comprehension.
Of course, but that's not the point.
--
Gerald Britton
--
http://mail.python.org/mailman/listinfo/python-list
ter. BTW, if you like:
[item for item in iterable if predicate(item)]
you can use:
filter(predicate, item)
I find the latter neater for the same reasons as above
--
Gerald Britton
--
http://mail.python.org/mailman/listinfo/python-list
ack (most recent call last):
File "", line 1, in
File "", line 2, in f
File "", line 2, in g
File "", line 2, in h
Exception
>>>
--
Gerald Britton
--
http://mail.python.org/mailman/listinfo/python-list
ss of how
it was created. Whatever the test, it needs to return False in the
first case and True in the second case, without modifying the class
definition.
Gerald Britton
--
http://mail.python.org/mailman/listinfo/python-list
On Dienstag 01 Februar 2011, Gerald Britton wrote:
> I'd like to know how (perhaps with the inspect module) I can
> tell if I am running in a context manager.
>>class f(object):
>> def __init__(self):
>> self.inContext = False
>>def __enter__(sel
ot in a context
manager on f:
with h as f():
# insert code here to return True, since I am in a context manager on f:
--
Gerald Britton
--
http://mail.python.org/mailman/listinfo/python-list
roach 2 sets
up loop machinery which you don't really need in this case.
I have a couple of questions:
1. If you had to choose between approaches 1 and 2, which one would
you go for, and why?
2. What other techniques have you used in such a situation?
--
Gerald Britton
--
http://mail.python.org/mailman/listinfo/python-list
ld do this:
>>> l = [1,2,3,4,5]
>>> l[0:1, 3:4]
Traceback (most recent call last):
File "", line 1, in
TypeError: list indices must be integers, not tuple
but that clearly doesn't work! So, when and how can one use slice lists?
--
Gerald Britton
--
http://mail.python.org/mailman/listinfo/python-list
;s the general feeling about this? Adhere to the PEP 8
binary operators style, or modify it for string formatting?
--
Gerald Britton
--
http://mail.python.org/mailman/listinfo/python-list
ng (the trailing comma suppresses the new
line) and you'll never have to count the number of items in lst.
You also have some statements like:
sqlchk = "select * from employees where id = \"%s\"" % (arg)
Since a Python list can be enclosed in apostrophes as well as
quotations, you can get the same thing without the escapes:
sqlchk = 'select * from employees where id = "%s"' % (arg)
Anyway -- just some food for thought.
--
Gerald Britton
--
http://mail.python.org/mailman/listinfo/python-list
e 3, in
Exception: Long exception text
Then, you can indent the individual lines any way you like.
--
Gerald Britton
--
http://mail.python.org/mailman/listinfo/python-list
Have you used the second approach and, if so, what was your motivation?
Is there a good/bad reason to choose one over the other?
--
Gerald Britton
--
http://mail.python.org/mailman/listinfo/python-list
> http://mail.python.org/mailman/listinfo/python-list
>
Something similar in a for-loop:
for x in y:
if not should_process(x): continue
# process x
--
Gerald Britton
--
http://mail.python.org/mailman/listinfo/python-list
tandards
>
> --
> Pablo Recio Quijano
>
> Estudiante de Ingeniería Informática (UCA)
> Alumno colaborador del Departamento de Lenguajes y Sistemas Informáticos
> Participante del IV Concurso Universitario de Software Libre
>
> --
> http://mail.python.org/mailman/listin
If you browse the Python source tree, you should be able to find it.
http://svn.python.org/view/python/trunk/Objects/exceptions.c?revision=77045&view=markup
On Fri, Feb 5, 2010 at 7:27 PM, Charles Yeomans wrote:
>
> On Feb 5, 2010, at 2:13 PM, Gerald Britton wrote:
>
>> On
; return ret
> --
> http://mail.python.org/mailman/listinfo/python-list
>
http://docs.python.org/3.1/library/decimal.html#decimal.Context.power
--
Gerald Britton
--
http://mail.python.org/mailman/listinfo/python-list
names should be lowercase, with words separated by underscores
as necessary to improve readability.
mixedCase is allowed only in contexts where that's already the
prevailing style (e.g. threading.py), to retain backwards compatibility.
--
Gerald Britton
--
http://mail.python.org/mailman/listinfo/python-list
'd','e')
Exception('a', 'b', 'c', 'd', 'e')
>>> Exception(Exception(1))
Exception(Exception(1,),)
--
Gerald Britton
--
http://mail.python.org/mailman/listinfo/python-list
ecker or pylint though I believe that
its not too difficult. Who knows? Perhaps someone already has such a
plugin that you can use.
--
Gerald Britton
--
http://mail.python.org/mailman/listinfo/python-list
if-then-else machinery, making it easier (for me)
> to read. But there was considerable resistance to spending so much vertical
> space in the source code.
Weird! It's three lines and the original was four lines was it not>?
--
Gerald Britton
--
http://mail.python.org/mailman/listinfo/python-list
t in ['a'], not None.
>
> http://www.python.org/doc/faq/general/#why-doesn-t-list-sort-return-the-sorted-list
> --
> Aahz (a...@pythoncraft.com) <*> http://www.pythoncraft.com/
>
> import antigravity
> --
> http://mail.python.org/mailman/listinfo/python-list
>
--
Gerald Britton
--
http://mail.python.org/mailman/listinfo/python-list
hough I might consider removing
the outer parentheses.
--
Gerald Britton
--
http://mail.python.org/mailman/listinfo/python-list
tracebacks** when asking a
> question like this. (The only exception would be if it is v e r y long, as
> with hitting the recursion depth limit of 1000.)
>
> --
> http://mail.python.org/mailman/listinfo/python-list
>
--
Gerald Britton
--
http://mail.python.org/mailman/listinfo/python-list
,re,os
> files2create = sys.argv[1:]
> os.system('mkdir tmp')
>
> # Some code to create the .tex
>
> # Compile tex files
> os.system('for file in tmp/*; do pdflatex "$file"; done')
>
> Pretty simple, alas.
>
> --
> Cpa
>
>
> O
cted some kind of escaping issue, but it won't even work with
> files such as : foo.txt, bar.txt.
>
> Any idea ?
> Thanks,
> Cpa
> --
> http://mail.python.org/mailman/listinfo/python-list
>
--
Gerald Britton
--
http://mail.python.org/mailman/listinfo/python-list
d
> many factors affecting it, including patterns of use. I just wanted to
> demonstrate the basics for a situation that I just encountered. In
> particular, if the array was sparse, rather than completely full, the
> two-level dictionary implementation would be the natural representation.
> --
> http://mail.python.org/mailman/listinfo/python-list
>
--
Gerald Britton
--
http://mail.python.org/mailman/listinfo/python-list
it
> buggy.
Quite so. I just like to eliminate the possibility up front. If
'value' is never bound, the the bug will show up sooner.
--
Gerald Britton
--
http://mail.python.org/mailman/listinfo/python-list
med by the string in the variable
> `name`.
> You want setattr(): http://docs.python.org/library/functions.html#setattr
> Assuming the rest of your code chunk is correct:
>
> setattr(tee, name, new.instancemethod(func,None,tee))
>
> Cheers,
> Chris
> --
> http://blog.rebertia.com
> --
> http://mail.python.org/mailman/listinfo/python-list
>
--
Gerald Britton
--
http://mail.python.org/mailman/listinfo/python-list
st calls deque anyway when you want to
eat up the rest of the iterable. It also solves the iterator-variable
leakage problem and is only a wee bit slower than a conventional
for-loop.
>
> --
> Arnaud
> --
> http://mail.python.org/mailman/listinfo/python-list
>
--
Gerald Bri
any interest in an apply() built-in
function that would work like map() does in 2.x (calls the function
with each value returned by the iterator) but return nothing. Maybe
"apply" isn't the best name; it's just the first one that occurred to
me.
Or is this just silly and should
n Tue, Jan 19, 2010 at 4:01 PM, Arnaud Delobelle
wrote:
> Gerald Britton writes:
>
>> [snip]
>>
>>>
>>> Yes, list building from a generator expression *is* expensive. And
>>> join has to do it, because it has to iterate twice over the iterable
>>&
s as you say then join would have to copy the
iterable on the first pass, effectively turning it into a list.
Though I didn't read through it, I would suppose that join could use a
dynamic-table approach to hold the result, starting with some
guesstimate then expanding the result buffer
_name": "action_1", "val": "asdf", "val2":
> "asdf"}]
>
> And have this create a list/dict. I'm aware of pickle, but it won't
> work as far as I can tell.
>
> Thanks.
> --
> http://mail.python.org/mailman/listinfo/python-list
>
--
Gerald Britton
--
http://mail.python.org/mailman/listinfo/python-list
em
in the generator expression. That in itself probably accounts for the
differences since function calls are somewhat expensive IIRC.
On Tue, Jan 19, 2010 at 11:18 AM, Stephen Hansen wrote:
> On Tue, Jan 19, 2010 at 7:30 AM, Gerald Britton
> wrote:
> [snip]
>>
>> mystring = &
Thanks! Good explanation.
On Tue, Jan 19, 2010 at 10:57 AM, Alf P. Steinbach wrote:
> * Gerald Britton:
>>
>> Yesterday I stumbled across some old code in a project I was working
>> on. It does something like this:
>>
>> mystring = '\n'.join( [ li
on
would prove more efficient. There doesn't appear to be one. I scaled
the length of the input list up to 1 million items and got more or
less the same relative performance.
Now I'm really curious and I'd like to know:
1. Can anyone else confirm this observation?
2. Why should the "pure" list comprehension be slower than the same
comprehension enclosed in '[...]' ?
--
Gerald Britton
--
http://mail.python.org/mailman/listinfo/python-list
Hi -- Some time ago I ran across a comment recommending using is
None instead of == None (also is not None, etc.) My own
testing indicates that the former beats the latter by about 30% on
average. Not a log for a single instruction but it can add up in
large projects.
I'm looking for a (semi)
For those interested in the Sieve of Eratosthenes, have a look at:
http://www.cs.hmc.edu/~oneill/papers/Sieve-JFP.pdf
The examples in the paper are in Haskell, but I have been
corresponding with the author who provided this Python version:
def sieve():
innersieve = sieve()
prevsquare = 1
62 matches
Mail list logo