On Fri, 24 Jul 2015, John Crispin wrote:
On 16/07/2015 22:20, Matthias Schiffer wrote:
-BOARDS:= \
- sun4i-a10-cubieboard \
- sun4i-a10-olinuxino-lime \
- sun4i-a10-pcduino \
- sun5i-a13-olinuxino \
- sun6i-a31-colombus \
- sun6i-a31-m9 \
- sun7i-a20-ba
Hi Karl,
On Sun, Jul 26, 2015 at 4:41 AM, Karl Palsson wrote:
> -BEGIN PGP SIGNED MESSAGE-
> Hash: SHA1
>
> Let me just preface this with...
>
> I am _not_ any sort of authority on code style, or any sort of
> "approved" openwrt commit police. I'm just some person subscribed to the
> ma
Signed-off-by: Piotr Dymacz
---
target/linux/ramips/base-files/lib/ramips.sh | 288 +--
1 file changed, 144 insertions(+), 144 deletions(-)
diff --git a/target/linux/ramips/base-files/lib/ramips.sh
b/target/linux/ramips/base-files/lib/ramips.sh
index 7db6d37..8b9d731 100
The following changes fix different mistakes in ramips target and
try to make the code more clean and consistent.
The patches affect:
* dts{,i} files
* base-files/* scripts
* image Makefile
Piotr Dymacz (13):
ramips: fix indentation and other mistakes in .dts{,i} files
ramips: remove leadi
The following patch fixes:
* wrong indentations
* doubled gpio-keys-polled nodes (DIR-300-B7, DIR-320-B1, DIR-610-A1)
* duplicate spacings
* empty lines at end
* trailing whitespace
in .dts{,i} files, for ramips target.
Signed-off-by: Piotr Dymacz
---
target/linux/ramips/dts/AWAPN2403.dts
The following patch:
* fixes wrong indentation
* combines together boards with same configuration
* removes unnecessary spaces
* removes empty lines after ;; (for consistency)
* removes indentation for case...esac body (for consistency)
in base-files/etc/board.d/* scripts.
Signed-off-by: Pio
Signed-off-by: Piotr Dymacz
---
target/linux/ramips/base-files/lib/ramips.sh | 4 ++--
target/linux/ramips/dts/UR-326N4G.dts| 2 +-
target/linux/ramips/dts/UR-336UN.dts | 2 +-
3 files changed, 4 insertions(+), 4 deletions(-)
diff --git a/target/linux/ramips/base-files/lib/ramips
There is another Zbtlink board (ZBT-WA05) supported in ramips target,
so use the same naming scheme for WR8305RT board and its DTS file.
Signed-off-by: Piotr Dymacz
---
target/linux/ramips/base-files/etc/board.d/01_leds | 2 +-
.../linux/ramips/base-files/etc/board.d/02_network | 2 +-
targe
The following patch:
* combines together boards with same configuration
* removes unnecessary spaces
in base-files/etc/diag.sh script and:
* sorts boards alphabetically
in base-files/etc/board.d/* scripts.
Signed-off-by: Piotr Dymacz
---
target/linux/ramips/base-files/etc/board.d/01_leds |
This device doesn't have any LEDs in dts file.
Signed-off-by: Piotr Dymacz
---
target/linux/ramips/base-files/etc/diag.sh | 3 ---
1 file changed, 3 deletions(-)
diff --git a/target/linux/ramips/base-files/etc/diag.sh
b/target/linux/ramips/base-files/etc/diag.sh
index 8c96b3b..29ee2da 100644
-
There are other Asus boards supported in ramips target, so use
the same naming scheme for WL-330N{,3G} boards and their DTS files.
Signed-off-by: Piotr Dymacz
---
target/linux/ramips/dts/WL-330N.dts | 95 +++
target/linux/ramips/dts/WL-330N3G.dts | 103
For some boards in ramips (and other targets) naming scheme for LEDs is:
"manufacturer:color:led-name", but there are many other boards which don't
follow this approach.
This patch switches ramips boards from the following manufacturers:
* Airlink101
* Asus
* Belkin
* Buffalo
* Huawei
* Omni
Signed-off-by: Piotr Dymacz
---
target/linux/ramips/base-files/etc/board.d/01_leds | 52 +++---
target/linux/ramips/base-files/etc/diag.sh | 42 -
target/linux/ramips/dts/ALL0239-3G.dts | 8 ++--
target/linux/ramips/dts/ALL0256N-4M.dts
Always use "|\" (without spaces) and keep boards in alphabetical order.
Signed-off-by: Piotr Dymacz
---
.../ramips/base-files/lib/upgrade/platform.sh | 232 ++---
1 file changed, 116 insertions(+), 116 deletions(-)
diff --git a/target/linux/ramips/base-files/lib/upgrade/pla
Other Asus RT-N dts files are named "RT-N..." (not "RTN..."), so use the same
for RT-N56U.
Signed-off-by: Piotr Dymacz
---
target/linux/ramips/dts/RT-N56U.dts | 146
target/linux/ramips/dts/RTN56U.dts | 146
target/linux
For other Belkin devices we use only their model names in image names,
so make the same for Belkin F7C027 (instead of "belkinf7c027").
Signed-off-by: Piotr Dymacz
---
target/linux/ramips/image/Makefile | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/target/linux/ramips/image/
Hi All!
I want to obtain openwrt linux kernel sources for ar71xx in the form of git
repo.
So I want to convert the patches from
openwrt.git/target/linux/ar71xx/patches-3.18/
into git commits.
I'm trying to 'git am' patches from openwrt repo:
$ cd linux.git
$ git checkout v3.18
$ git am ../open
On Sun, 26 Jul 2015 18:24:30 +0200, Piotr Dymacz wrote:
For some boards in ramips (and other targets) naming scheme for LEDs is:
"manufacturer:color:led-name", but there are many other boards which
don't
follow this approach.
The upstream convention is "device:color:led-name". So actually,
2015-07-26 21:16 GMT+02:00 Imre Kaloz :
>
> On Sun, 26 Jul 2015 18:24:30 +0200, Piotr Dymacz wrote:
>
>> For some boards in ramips (and other targets) naming scheme for LEDs is:
>> "manufacturer:color:led-name", but there are many other boards which don't
>> follow this approach.
>
>
> The upstrea
On Sun, Jul 26, 2015 at 9:34 PM, Piotr Dymacz wrote:
> 2015-07-26 21:16 GMT+02:00 Imre Kaloz :
>>
>> On Sun, 26 Jul 2015 18:24:30 +0200, Piotr Dymacz wrote:
>>
>>> For some boards in ramips (and other targets) naming scheme for LEDs is:
>>> "manufacturer:color:led-name", but there are many other
-BEGIN PGP SIGNED MESSAGE-
Hash: SHA1
Just one more, I promise :)
Drasko DRASKOVIC wrote:
> +
> +static void __init weio_common_setup(void)
> +{
> + u8 *art = (u8 *) KSEG1ADDR(0x1fff);
> +
> + ath79_register_m25p80(NULL);
> + ath79_register_wmac(art + WEIO_CALDATA_OFFSET,
I have replaced eth0 with lan, but still getting same error
/etc/radvd.conf:1 error: syntax error, unexpected STRING, expecting
T_INTERFACE
[Jul 24 10:51:59] radvd (950): exiting, failed to read config file
What this 950 denotes in above error ?
Do I need to change something in /etc/config/netwo
22 matches
Mail list logo