I have replaced eth0 with lan, but still getting same error

/etc/radvd.conf:1 error: syntax error, unexpected STRING, expecting
T_INTERFACE
[Jul 24 10:51:59] radvd (950): exiting, failed to read config file

What this 950 denotes in above error ?

Do I need to change something in /etc/config/network ?

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config interface 'lan'
        option ifname 'eth0'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config globals 'globals'
        option ula_prefix 'fdf4:7b51:d11d::/48'

On Fri, Jul 24, 2015 at 9:26 PM, Luiz Angelo Daros de Luca <
luizl...@gmail.com> wrote:

> This is a question for openwrt-users.
>
> Anyway, interface is the logical openwrt interface (lan, wan), not Linux
> devices.
> http://wiki.openwrt.org/doc/uci/radvd
>
> Regards,
>
> Em sex, 24 de jul de 2015 09:36, Pratik Prajapati <
> pratik.prajapat...@gmail.com> escreveu:
>
>> Hi,
>>
>> I want to run radvd on OpenWrt but its giving me syntax error in
>> radvd.conf
>>
>> radvd.conf:
>>
>> config 'interface'
>>         option 'interface'          'eth0'
>>         option 'AdvSendAdvert'      '1'
>>         option 'AdvManagedFlag'     '0'
>>         option 'AdvOtherConfigFlag' '0'
>>
>> config 'prefix'
>>         option 'interface'     'eth0'
>>         option 'AdvOnLink'     '1'
>>         option 'AdvAutonomous' '1'
>>         option 'AdvRouterAddr' '0'
>>
>> config 'route'
>>         option 'interface'        'eth0'
>>         option 'prefix'           '2001:0DB8:1234:5677::/64'
>>         option 'AdvRouteLifetime' 'infinity'
>>
>>
>> Error on running: radvd start
>>
>> /etc/radvd.conf:1 error: syntax error, unexpected STRING, expecting
>> T_INTERFACE
>> [Jul 24 12:28:09] radvd (1202): exiting, failed to read config file
>>
>> What needs to be corrected in radvd.conf ?
>>
>> Thanks,
>> Pratik
>> _______________________________________________
>> openwrt-devel mailing list
>> openwrt-devel@lists.openwrt.org
>> https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel
>>
>
_______________________________________________
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel

Reply via email to