[OpenWrt-Devel] [PATCH 4/4] oxnas: sata_oxnas: make irq handler more readable

2014-12-17 Thread Daniel Golle
safed one level of indention by using 'continue' instead of a lengthy if-clause. Signed-off-by: Daniel Golle --- target/linux/oxnas/files/drivers/ata/sata_oxnas.c | 26 --- 1 file changed, 14 insertions(+), 12 deletions(-) diff --git a/target/linux/oxnas/files/drivers/ata/sa

[OpenWrt-Devel] [PATCH 3/4] oxnas: sata_oxnas: refactoring phase 2

2014-12-17 Thread Daniel Golle
- replaced // comments by /* comments */ - added line-breaks where needed - fixed white-space according to kernel style - fixed some obvious spelling mistakes in comments and printks - removed some unneeded left-overs imported from vendor code-base - replaced printk(...) by libata macros wher

[OpenWrt-Devel] [PATCH 2/4] oxnas: sata_oxnas: refactoring phase 1

2014-12-17 Thread Daniel Golle
locking for 2nd port and hwraid was added from vendor's GPL code which doesn't comply with current kernel coding style. - moved all global variables into host_priv - renamed locks - sanetized acquire() and release() parameter list Signed-off-by: Daniel Golle --- target/linux/oxnas/files/driv

[OpenWrt-Devel] [PATCH 1/4] oxnas: refresh kernel config-3.1[48]

2014-12-17 Thread Daniel Golle
and no longer compile-in ext4 filesystem now that sata_oxnas is also built as a module. Signed-off-by: Daniel Golle --- target/linux/oxnas/config-3.14 | 16 +++- target/linux/oxnas/config-3.18 | 25 +++-- 2 files changed, 10 insertions(+), 31 deletions(-) diff --

Re: [OpenWrt-Devel] [PATCH] dnsmasq: allow de-selecting features from -full variant.

2014-12-17 Thread Yousong Zhou
Hi, Frank. On 18 December 2014 at 01:49, Frank Schäfer wrote: > Hi yousong, > > thanks for the patch. > A few issues/comments: > > Am 17.12.2014 um 02:21 schrieb Yousong Zhou: >> Signed-off-by: Yousong Zhou >> --- >> package/network/services/dnsmasq/Makefile | 27 >>

[OpenWrt-Devel] [PATCH v2 15/16] delta: fix outputing of delta entries occupying multiple lines.

2014-12-17 Thread Yousong Zhou
Signed-off-by: Yousong Zhou --- delta.c | 85 ++- 1 file changed, 46 insertions(+), 39 deletions(-) diff --git a/delta.c b/delta.c index 556250d..cdd46bc 100644 --- a/delta.c +++ b/delta.c @@ -66,6 +66,35 @@ uci_free_delta(struct uci

[OpenWrt-Devel] [PATCH v2 16/16] uci_internal: use comma expression for UCI_INTERNAL() call.

2014-12-17 Thread Yousong Zhou
Signed-off-by: Yousong Zhou --- uci_internal.h |8 1 file changed, 4 insertions(+), 4 deletions(-) diff --git a/uci_internal.h b/uci_internal.h index 89863f1..cb8f86c 100644 --- a/uci_internal.h +++ b/uci_internal.h @@ -227,10 +227,10 @@ struct uci_backend _var = { \

[OpenWrt-Devel] [PATCH v2 11/16] cli: fix printing option values occupying multiple lines.

2014-12-17 Thread Yousong Zhou
Signed-off-by: Yousong Zhou --- cli.c | 45 +++-- 1 file changed, 35 insertions(+), 10 deletions(-) diff --git a/cli.c b/cli.c index 554..2ee1e36 100644 --- a/cli.c +++ b/cli.c @@ -168,18 +168,41 @@ static void cli_perror(void) uci_perror(ct

[OpenWrt-Devel] [PATCH v2 14/16] delta: use a table for converting between UCI_CMD_XXX and prefixes.

2014-12-17 Thread Yousong Zhou
Signed-off-by: Yousong Zhou --- delta.c | 64 +++ uci.h |6 ++ 2 files changed, 25 insertions(+), 45 deletions(-) diff --git a/delta.c b/delta.c index 2eb2ae7..556250d 100644 --- a/delta.c +++ b/delta.c @@ -95,34 +95,29 @@

[OpenWrt-Devel] [PATCH v2 12/16] delta: add a simple duplication check when adding delta path.

2014-12-17 Thread Yousong Zhou
Signed-off-by: Yousong Zhou --- delta.c |2 ++ uci.h |2 ++ 2 files changed, 4 insertions(+) diff --git a/delta.c b/delta.c index 082633b..b56df5b 100644 --- a/delta.c +++ b/delta.c @@ -87,6 +87,8 @@ int uci_add_delta_path(struct uci_context *ctx, const char *dir) UCI_HANDL

[OpenWrt-Devel] [PATCH v2 13/16] delta: preprocess delta line with uci_parse_argument().

2014-12-17 Thread Yousong Zhou
Signed-off-by: Yousong Zhou --- delta.c | 25 ++--- file.c |7 +-- 2 files changed, 15 insertions(+), 17 deletions(-) diff --git a/delta.c b/delta.c index b56df5b..2eb2ae7 100644 --- a/delta.c +++ b/delta.c @@ -95,11 +95,14 @@ int uci_add_delta_path(struct uci_con

[OpenWrt-Devel] [PATCH v2 09/16] tests: add test coverage for `uci revert' command.

2014-12-17 Thread Yousong Zhou
Signed-off-by: Yousong Zhou --- test/references/revert_option.result |3 +++ test/references/revert_option_multiline.result |2 ++ test/tests.d/070_revert| 28 3 files changed, 33 insertions(+) create mode 100644 test/referenc

[OpenWrt-Devel] [PATCH v2 10/16] tests: add test coverage for uci list related commands.

2014-12-17 Thread Yousong Zhou
Signed-off-by: Yousong Zhou --- test/references/add_list_changes.result |4 ++ test/references/add_list_config.result |6 +++ test/references/add_list_show.result |3 ++ test/references/del_list_config.result |5 +++ test/references/del_li

[OpenWrt-Devel] [PATCH v2 08/16] tests: add test coverage for `uci batch' command.

2014-12-17 Thread Yousong Zhou
Signed-off-by: Yousong Zhou --- test/references/batch_set.result |9 + test/tests.d/060_batch | 17 + 2 files changed, 26 insertions(+) create mode 100644 test/references/batch_set.result create mode 100644 test/tests.d/060_batch diff --git a/test/refer

[OpenWrt-Devel] [PATCH v2 07/16] tests: add more test coverage for `uci show' command.

2014-12-17 Thread Yousong Zhou
Signed-off-by: Yousong Zhou --- test/references/show_parsing_multiline.data| 20 + .../show_parsing_multiline_option.result | 12 .../show_parsing_multiline_package.result | 18 .../show_parsing_multiline_section.result

[OpenWrt-Devel] [PATCH v2 06/16] tests: remove straying echo in 020_get.

2014-12-17 Thread Yousong Zhou
Signed-off-by: Yousong Zhou --- test/tests.d/020_get |1 - 1 file changed, 1 deletion(-) diff --git a/test/tests.d/020_get b/test/tests.d/020_get index 7fd30ba..630d84d 100644 --- a/test/tests.d/020_get +++ b/test/tests.d/020_get @@ -35,7 +35,6 @@ test_get_option_multiline() { cp $

[OpenWrt-Devel] [PATCH v2 05/16] file: fix error string about "unterminated XXX".

2014-12-17 Thread Yousong Zhou
- Remove unreachable call to uci_parse_error(). - Fix false claim of unterminated double quote to single quote. Signed-off-by: Yousong Zhou --- file.c |4 +--- 1 file changed, 1 insertion(+), 3 deletions(-) diff --git a/file.c b/file.c index 3f02c11..0fc68a6 100644 --- a/file.c +++ b/file

[OpenWrt-Devel] [PATCH v2 03/16] file: fix use-after-free bug.

2014-12-17 Thread Yousong Zhou
Currently, it's possible that pointers returned by next_arg() could be invalidated by another call to next_arg() due to uci_realloc(). Signed-off-by: Yousong Zhou --- file.c | 41 + 1 file changed, 29 insertions(+), 12 deletions(-) diff --git a/file.c b

[OpenWrt-Devel] [PATCH v2 04/16] file: fix EOF check.

2014-12-17 Thread Yousong Zhou
Signed-off-by: Yousong Zhou --- file.c |4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/file.c b/file.c index 1d2718a..3f02c11 100644 --- a/file.c +++ b/file.c @@ -48,8 +48,8 @@ __private void uci_getln(struct uci_context *ctx, int offset) pctx->buf = uc

[OpenWrt-Devel] [PATCH v2 02/16] Fix memory leaks found by using valgrind on test cases.

2014-12-17 Thread Yousong Zhou
Signed-off-by: Yousong Zhou --- cli.c |8 ++-- list.c |2 +- 2 files changed, 7 insertions(+), 3 deletions(-) diff --git a/cli.c b/cli.c index 6fbbfe9..554 100644 --- a/cli.c +++ b/cli.c @@ -360,6 +360,7 @@ static int uci_do_package_cmd(int cmd, int argc, char **argv) {

[OpenWrt-Devel] [PATCH v2 01/16] Fix a few style issues.

2014-12-17 Thread Yousong Zhou
- Remove deprecated uci-static and ucimap-example from .gitignore. - Minor code formatting fix. Signed-off-by: Yousong Zhou --- .gitignore |2 -- file.c |2 +- 2 files changed, 1 insertion(+), 3 deletions(-) diff --git a/.gitignore b/.gitignore index c3e50e0..0407feb 100644 --- a/

[OpenWrt-Devel] [PATCH v2 00/16] uci: fix issues caused by newly-added multiline option value support.

2014-12-17 Thread Yousong Zhou
This patch set mainly tries to - Fix heap memory management issues. - Add test more cases with multiline option value and quotes in mind. - Fix issues of uci show, revert, add_list, del_list, batch commands. My previous patch set for adding support for multiline option value support to UCI par

[OpenWrt-Devel] [PATCH fstools] block: make sure /etc/ exists on the extroot

2014-12-17 Thread Rafał Miłecki
Otherwise opening .extroot-uuid could fail. Signed-off-by: Rafał Miłecki --- block.c | 4 1 file changed, 4 insertions(+) diff --git a/block.c b/block.c index 107ba64..c29017d 100644 --- a/block.c +++ b/block.c @@ -911,6 +911,10 @@ static int check_extroot(char *path)

[OpenWrt-Devel] [PATCH fstools] block: allow mounting UBIFS partition as extroot

2014-12-17 Thread Rafał Miłecki
Signed-off-by: Rafał Miłecki --- block.c | 7 ++- 1 file changed, 6 insertions(+), 1 deletion(-) diff --git a/block.c b/block.c index 68cfd5a..107ba64 100644 --- a/block.c +++ b/block.c @@ -598,6 +598,10 @@ static void check_filesystem(struct blkid_struct_probe *pr) struct stat statb

Re: [OpenWrt-Devel] ar8216: phy_init and bug report 18415

2014-12-17 Thread Heiner Kallweit
Am 17.12.2014 um 08:47 schrieb Weedy: > > On Nov 28, 2014 3:24 PM, "Weedy" > wrote: >> >> >> On Nov 28, 2014 5:23 AM, "Heiner Kallweit" > > wrote: >> > Anybody with a 8216-based device who can test this? >> >> Me me me, me me. >> 4300 curre

[OpenWrt-Devel] [PATCH uqmi] Add mandatory field to Initiate Network Register

2014-12-17 Thread Sławomir Demeszko
According to json data Action field in Initiate Network Register is mandatory. I get "Missing argument" from qmi without it. Signed-off-by: Sławomir Demeszko --- commands-nas.c | 5 - 1 file changed, 4 insertions(+), 1 deletion(-) diff --git a/commands-nas.c b/commands-nas.c index ccc58ab..

Re: [OpenWrt-Devel] [PATCH] dnsmasq: allow de-selecting features from -full variant.

2014-12-17 Thread Frank Schäfer
Hi yousong, thanks for the patch. A few issues/comments: Am 17.12.2014 um 02:21 schrieb Yousong Zhou: > Signed-off-by: Yousong Zhou > --- > package/network/services/dnsmasq/Makefile | 27 > ++-- > .../network/services/dnsmasq/files/dnsmasq.init|5 > 2 fi

[OpenWrt-Devel] [PATCH fstools] support UBI blocks (volumes)

2014-12-17 Thread Rafał Miłecki
We already had ubifs idinfo, so only /dev/ubiN_M support was missing. Signed-off-by: Rafał Miłecki --- block.c | 1 + libblkid-tiny/libblkid-tiny.c | 2 +- 2 files changed, 2 insertions(+), 1 deletion(-) diff --git a/block.c b/block.c index bba68c2..68cfd5a 100644 --- a/bl

Re: [OpenWrt-Devel] dnsmasq packages

2014-12-17 Thread Frank Schäfer
Am 16.12.2014 um 19:02 schrieb Christian Schoenebeck: > Hi, > > I would prefer to make it configurable like libcurl, busybox and others so > select the option you need during compile. Well, the idea of providing multiple package variants is to allow users to upgrade/downgrade their system at runt

[OpenWrt-Devel] [PATCH uqmi] Fix improper characters after reading Escape code for switching extension table in SMS

2014-12-17 Thread Sławomir Demeszko
Escape code 0x1b is a prefix indicating that next character should be represented from extension table, but it only applies to one character, so switching it off is needed to read further characters correctly. Signed-off-by: Sławomir Demeszko --- commands-wms.c | 1 + 1 file changed, 1 insertion

[OpenWrt-Devel] [PATCH uqmi 3/3] v2 Added commands to change PIN code

2014-12-17 Thread Sławomir Demeszko
Signed-off-by: Sławomir Demeszko --- Sorry, somehow old version was in commit. I removed static from struct. commands-dms.c | 36 commands-dms.h | 8 2 files changed, 44 insertions(+) diff --git a/commands-dms.c b/commands-dms.c index 76144cf..435c

[OpenWrt-Devel] [PATCH] binutils: break-out libbfd, libopcodes and ar

2014-12-17 Thread Daniel Golle
Package libbfd, libopcodes and ar seperately. Signed-off-by: Daniel Golle --- package/devel/binutils/Makefile | 50 - 1 file changed, 44 insertions(+), 6 deletions(-) diff --git a/package/devel/binutils/Makefile b/package/devel/binutils/Makefile index ff9

[OpenWrt-Devel] [PATCH uqmi] Add support for 16-bit reference number in concatenated SMS.

2014-12-17 Thread Sławomir Demeszko
Signed-off-by: Sławomir Demeszko --- commands-wms.c | 7 ++- 1 file changed, 6 insertions(+), 1 deletion(-) diff --git a/commands-wms.c b/commands-wms.c index 47d4d76..6ac52eb 100644 --- a/commands-wms.c +++ b/commands-wms.c @@ -179,11 +179,16 @@ static int decode_udh(const unsigned char *da

[OpenWrt-Devel] [PATCH fstools] document mount_root and block (extroot) a bit

2014-12-17 Thread Rafał Miłecki
Also s/fs_data/blkdev_path/ which should make more sense. Signed-off-by: Rafał Miłecki --- block.c | 40 +++- libfstools/extroot.c | 4 mount_root.c | 18 ++ 3 files changed, 53 insertions(+), 9 deletions(-) diff --g

[OpenWrt-Devel] [PATCH uqmi 2/3] Added shared struct to allow the same option names for different functions

2014-12-17 Thread Sławomir Demeszko
For example we can use one option --new-pin with commands unblock-pin and with change-pin, without that we need to invent new name for every new command. Signed-off-by: Sławomir Demeszko --- commands-dms.c | 64 +++--- 1 file changed, 39 insert

[OpenWrt-Devel] [PATCH uqmi 3/3] Added commands to change PIN code

2014-12-17 Thread Sławomir Demeszko
Signed-off-by: Sławomir Demeszko --- commands-dms.c | 36 commands-dms.h | 8 2 files changed, 44 insertions(+) diff --git a/commands-dms.c b/commands-dms.c index 76144cf..277223d 100644 --- a/commands-dms.c +++ b/commands-dms.c @@ -136,6 +136,42 @@

[OpenWrt-Devel] [PATCH uqmi 1/3] Added option for enabling and disabling protection of simcard by PIN

2014-12-17 Thread Sławomir Demeszko
Signed-off-by: Sławomir Demeszko --- commands-dms.c | 53 + commands-dms.h | 7 +++ 2 files changed, 60 insertions(+) diff --git a/commands-dms.c b/commands-dms.c index ad5c89d..360e926 100644 --- a/commands-dms.c +++ b/commands-dms.c @@ -

Re: [OpenWrt-Devel] Linksys WRT54G / 16mb / wifi / lowmem / concurrency

2014-12-17 Thread Felix Fietkau
On 2014-12-17 09:41, Bastian Bittorf wrote: > I did some experiments to get our "good old" Linksys WRT54G > running with recent trunk r43602 / kernel 3.14.26. We are only > using it in adhoc-mode (with olsrd) and it is working OK. > > But there is still an issue, but i think it has to do with the

Re: [OpenWrt-Devel] [PATCH 1/1] KIRKWOOD : add sheevaplug and derivatives

2014-12-17 Thread Luka Perkov
On Wed, Dec 17, 2014 at 07:11:34AM +0100, Gérald Kerma wrote: > ADD some kirkwood FDT > - SheevaPlug > - SheevaPlug with eSATA > - GuruplugServerPlus > - Topkick1281P2 > > Signed-off-by: Gérald Kerma > --- > target/linux/kirkwood/image/Makefile | 12 + > target/linux/kirkwood/profiles/

[OpenWrt-Devel] Linksys WRT54G / 16mb / wifi / lowmem / concurrency

2014-12-17 Thread Bastian Bittorf
I did some experiments to get our "good old" Linksys WRT54G running with recent trunk r43602 / kernel 3.14.26. We are only using it in adhoc-mode (with olsrd) and it is working OK. But there is still an issue, but i think it has to do with the design of the bootup-process: if wifi is enabled, the