This patch changes the output values to be lowercase and replaces
"True"/"False" by "yes"/"no" so the output from the IGC driver is
consistent with other Intel drivers.
Signed-off-by: Andre Guedes
---
igc.c | 36 ++
Hi Michal,
Quoting Michal Kubecek (2020-07-19 17:10:46)
> On Tue, Jul 07, 2020 at 04:47:56PM -0700, Andre Guedes wrote:
> > Hi all,
> >
> > This patch series adds support for parsing registers dumped by the IGC
> > driver.
> > For now, t
This patch adds support for parsing the Receive Control (RCTL) register
fields.
Signed-off-by: Andre Guedes
---
igc.c | 91 ++-
1 file changed, 90 insertions(+), 1 deletion(-)
diff --git a/igc.c b/igc.c
index 91ab64d..df3916c 100644
--- a
This patch adds the initial support for parsing registers dumped by the
IGC driver. At this moment, only the Receive Address Low (RAL) and the
Receive Address High (RAH) registers are parsed. More registers will be
added on demand.
Signed-off-by: Andre Guedes
---
Makefile.am | 3 ++-
ethtool.c
This patch adds support for parsing the EType Queue Filter (ETQF)
registers fields.
Signed-off-by: Andre Guedes
---
igc.c | 34 ++
1 file changed, 34 insertions(+)
diff --git a/igc.c b/igc.c
index 6a2e06d..9c0a750 100644
--- a/igc.c
+++ b/igc.c
@@ -59,6 +59,14
This patch adds support for parsing the VLAN Priority Queue Filter
(VLANPQF) register fields.
Signed-off-by: Andre Guedes
---
igc.c | 98 +++
1 file changed, 98 insertions(+)
diff --git a/igc.c b/igc.c
index df3916c..6a2e06d 100644
--- a
)
* EType Queue Filter (ETQF)
More registers should be parsed as we need/enable them.
Cheers,
Andre
Andre Guedes (4):
Add IGC driver support
igc: Parse RCTL register fields
igc: Parse VLANPQF register fields
igc: Parse ETQF registers
Makefile.am | 3 +-
ethtool.c | 1 +
igc.c
Quoting Jakub Kicinski (2020-06-29 15:11:17)
> On Mon, 29 Jun 2020 13:51:32 -0700 Andre Guedes wrote:
> > > > @@ -435,6 +432,9 @@ static void igc_ptp_tx_hwtstamp(struct igc_adapter
> > > > *adapter)
> > > > struct igc_hw *hw =
Hi Jakub,
Quoting Jakub Kicinski (2020-06-26 21:30:35)
> On Fri, 26 Jun 2020 18:54:23 -0700 Jeff Kirsher wrote:
> > From: Andre Guedes
> >
> > The __IGC_PTP_TX_IN_PROGRESS flag indicates we have a pending Tx
> > timestamp. In some places, instead of checking that
Hi,
Quoting Jakub Kicinski (2020-05-18 16:09:06)
> On Mon, 18 May 2020 16:05:08 -0700 Vinicius Costa Gomes wrote:
> > Jakub Kicinski writes:
> > >> That was the (only?) strong argument in favor of having frame preemption
> > >> in the TC side when this was last discussed.
> > >>
> > >> We can ha
Hi Jakub,
Quoting Jakub Kicinski (2020-05-19 19:00:26)
> On Tue, 19 May 2020 17:04:05 -0700 Jeff Kirsher wrote:
> > This series contains updates to igc only.
> >
> > Sasha cleans up the igc driver code that is not used or needed.
> >
> > Vitaly cleans up driver code that was used to support Virt
Hi,
Quoting Vinicius Costa Gomes (2020-05-18 12:34:22)
> Hi,
>
> Michal Kubecek writes:
>
> > On Fri, May 15, 2020 at 06:29:44PM -0700, Vinicius Costa Gomes wrote:
> >> Hi,
> >>
> >> This series adds support for configuring frame preemption, as defined
> >> by IEEE 802.1Q-2018 (previously IEEE
Hi,
Quoting Vinicius Costa Gomes (2020-05-15 18:29:44)
> One example, for retrieving and setting the configuration:
>
> $ ethtool $ sudo ./ethtool --show-frame-preemption enp3s0
> Frame preemption settings for enp3s0:
> support: supported
> active: active
IIUC the code in patch 2
Hi Jeff,
Quoting Jeff Kirsher (2020-05-14 21:21:34)
> From: Andre Guedes
>
> In igc_ethtool.c we print log messages using dev_* helpers, generating
> inconsistent output with the rest of the driver. Since this is a network
> device driver, we should preferably use netdev_* helpe
Hi Heiner,
Quoting Heiner Kallweit (2020-05-14 15:07:42)
> On 14.05.2020 23:31, Jeff Kirsher wrote:
> > @@ -4877,8 +4870,7 @@ static int igc_probe(struct pci_dev *pdev,
> >
> > if (igc_get_flash_presence_i225(hw)) {
> > if (hw->nvm.ops.validate(hw) < 0) {
> > -
t
and call list_is_last() within advance_sched() instead.
Signed-off-by: Andre Guedes
---
net/sched/sch_taprio.c | 10 +-
1 file changed, 1 insertion(+), 9 deletions(-)
diff --git a/net/sched/sch_taprio.c b/net/sched/sch_taprio.c
index d0aae7b5e608..77cca993710a 100644
--- a/net/sched/sch_taprio.c
This patch removes a pointless variable assigment in taprio_change().
The 'err' variable is not used from this assignment to the next one so
this patch removes it.
Signed-off-by: Andre Guedes
---
net/sched/sch_taprio.c | 1 -
1 file changed, 1 deletion(-)
diff --git a/net/sched/sch_
_OPEN macro instead of the magic number '-1'.
Fixes: 5a781ccbd19e (“tc: Add support for configuring the taprio scheduler”)
Signed-off-by: Andre Guedes
---
net/sched/sch_taprio.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/net/sched/sch_taprio.c b/net/sched/sch
e
that code to the beginning of the function. Also, if 'cycle' calculation
is zero, something went really wrong with taprio and we should log that
internal error properly.
Signed-off-by: Andre Guedes
---
net/sched/sch_taprio.c | 37 +++--
1 file changed,
de effect, that function becomes a dummy
wrapper on list_is_last() so we simply remove it and call list_is_last()
instead.
Best regards,
Andre
Andre Guedes (5):
net: sched: taprio: Remove pointless variable assigment
net: sched: taprio: Refactor taprio_get_start_time()
net: sched:
scheduler”)
Signed-off-by: Andre Guedes
---
net/sched/sch_taprio.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/net/sched/sch_taprio.c b/net/sched/sch_taprio.c
index 0df924f87f3e..df848a36b222 100644
--- a/net/sched/sch_taprio.c
+++ b/net/sched/sch_taprio.c
@@ -188,12
This patch removes a pointless variable assigment in taprio_change().
The 'err' variable is not used from this assignment to the next one so
this patch removes it.
Signed-off-by: Andre Guedes
---
net/sched/sch_taprio.c | 1 -
1 file changed, 1 deletion(-)
diff --git a/net/sched/sch_
_OPEN macro instead of the magic number '-1'.
Fixes: 5a781ccbd19e (“tc: Add support for configuring the taprio scheduler”)
Signed-off-by: Andre Guedes
---
net/sched/sch_taprio.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/net/sched/sch_taprio.c b/net/sched/sch
e
that code to the beginning of the function. Also, if 'cycle' calculation
is zero, something went really wrong with taprio and we should log that
internal error properly.
Signed-off-by: Andre Guedes
---
net/sched/sch_taprio.c | 37 +++--
1 file changed,
scheduler”)
Signed-off-by: Andre Guedes
---
net/sched/sch_taprio.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/net/sched/sch_taprio.c b/net/sched/sch_taprio.c
index 110436d11f86..9f361f2b7510 100644
--- a/net/sched/sch_taprio.c
+++ b/net/sched/sch_taprio.c
@@ -180,12
Hi all,
This series contains some minor improvements (patches 1 and 2) and fixes
(patches 3-5) to taprio qdisc.
Best regards,
Andre
Andre Guedes (5):
net: sched: taprio: Remove pointless variable assigment
net: sched: taprio: Refactor taprio_get_start_time()
net: sched: taprio: Fix null
If 'entry' is NULL we WARN_ON() but dereference the pointer anyway,
generating a null pointer dereference bug. This patch fixes should_
restart_cycle() so we return if the pointer is NULL.
Fixes: 5a781ccbd19e (“tc: Add support for configuring the taprio scheduler”)
Signed-off-by: An
27 matches
Mail list logo