On 8/9/20 7:38 PM, Xu Wang wrote:
A multiplication for the size determination of a memory allocation
indicated that an array data structure should be processed.
Thus use the corresponding function "devm_kcalloc".
Signed-off-by: Xu Wang
Acked-by: Shannon Nelson
---
drivers/net/ethernet/pe
On Sun, 2020-08-09 at 20:50 -0700, Shannon Nelson wrote:
> On 8/9/20 8:20 PM, Joe Perches wrote:
> > On Mon, 2020-08-10 at 02:38 +, Xu Wang wrote:
> > > A multiplication for the size determination of a memory allocation
> > > indicated that an array data structure should be processed.
> > > Thu
On 8/9/20 8:20 PM, Joe Perches wrote:
On Mon, 2020-08-10 at 02:38 +, Xu Wang wrote:
A multiplication for the size determination of a memory allocation
indicated that an array data structure should be processed.
Thus use the corresponding function "devm_kcalloc".
[]
diff --git a/drivers/net
Fixes problematic commit f166f890c8f026a931e1bb80f51561a1d2f41b27
Commit broke Ethernet functionality on i.MX53 with 1 GHz clock due to a
race condition which may not be observed in the unknown CPU(s) implied
by comments to depart from FEC behavior documented by Motorola,
Freescale and NXP.
Durin
On Mon, 2020-08-10 at 02:38 +, Xu Wang wrote:
> A multiplication for the size determination of a memory allocation
> indicated that an array data structure should be processed.
> Thus use the corresponding function "devm_kcalloc".
[]
> diff --git a/drivers/net/ethernet/pensando/ionic/ionic_lif.
在 2020/8/7 21:38, Timur Tabi 写道:
On 8/6/20 8:54 PM, wanghai (M) wrote:
Thanks for your suggestion. May I fix it like this?
Yes, this is what I had in mind. Thanks.
Acked-by: Timur Tabi
.
Thanks for your ack. I just sent a new patch.
"[PATCH net] net: qcom/emac: add missed clk_disable_
Fix the missing clk_disable_unprepare() before return
from emac_clks_phase1_init() in the error handling case.
Fixes: b9b17debc69d ("net: emac: emac gigabit ethernet controller driver")
Reported-by: Hulk Robot
Signed-off-by: Wang Hai
Acked-by: Timur Tabi
---
drivers/net/ethernet/qualcomm/emac/
A multiplication for the size determination of a memory allocation
indicated that an array data structure should be processed.
Thus use the corresponding function "devm_kcalloc".
Signed-off-by: Xu Wang
---
drivers/net/ethernet/pensando/ionic/ionic_lif.c | 4 ++--
1 file changed, 2 insertions(+),
When creating a raw AF_NFC socket, CAP_NET_RAW needs to be checked first.
Signed-off-by: Qingyu Li
---
net/nfc/rawsock.c | 7 +--
1 file changed, 5 insertions(+), 2 deletions(-)
diff --git a/net/nfc/rawsock.c b/net/nfc/rawsock.c
index ba5ffd3badd3..b5c867fe3232 100644
--- a/net/nfc/rawsock.
On 8/7/20 10:30 AM, Jiri Olsa wrote:
hi,
we have a customer facing some odd verifier fails on following
sk_skb program:
0. r2 = *(u32 *)(r1 + data_end)
1. r4 = *(u32 *)(r1 + data)
2. r3 = r4
3. r3 += 42
4. r1 = 0
5. if r3 > r2 goto 8
6. r4 += 14
7. r1 = r4
On 2020-08-09 2:15 p.m., Cong Wang wrote:
On Fri, Aug 7, 2020 at 3:28 PM Jamal Hadi Salim wrote:
From: Jamal Hadi Salim
his classifier, in the same spirit as the tc skb mark classifier,
provides a generic (fast lookup) approach to filter on the hash value
and optional mask.
like skb->mark,
On Sun, Aug 09, 2020 at 07:33:03PM +0200, Willy Tarreau wrote:
> Not that low in fact because they don't know precisely when the call is
> made. I mean, let's say we're in the worst case, with two VMs running on
> two siblings of the same core, with the same TSC, on a 3 GHz machine. The
> attacker
On Sun, Aug 9, 2020 at 2:10 PM Marc Plumb wrote:
>
> However, I think I'm starting to see your underlying assumptions.
> You're thinking that raw noise data are the only truly unpredictable
> thing so you think that adding it is a defense against attacks like
> foreshadow/spectre/meltdown. You are
Two compiler warnings still appear when compiling current source:
comparison between signed and unsigned values and missing struct member
initializations.
The former are mostly handled by declaring variables (loop iterators,
mostly) as unsigned, only few required an explicit cast. The latter are
h
In do_geeprom(), do_seprom() and do_getmodule(), check if user used
"length" command line argument is done by setting the value to -1 before
parsing and checking if it changed. This is quite ugly and also causes
compiler warnings as the variable is u32.
Use proper "seen" flag to let parser tell us
Use macro helpers to make link_mode_info[] initializers easier to read and
less prone to mistakes. As a bonus, this gets rid of "missing field
initializer" warnings in netlink/settings.c
This commit should have no effect on resulting code (checked with gcc-11
and -O2).
Signed-off-by: Michal Kubec
All of these are avoided by declaring a variable (mostly loop iterators)
holding only unsigned values as unsigned.
Signed-off-by: Michal Kubecek
---
dsa.c | 2 +-
fec.c | 2 +-
ibm_emac.c | 2 +-
marvell.c | 2 +-
natsemi.c | 2 +-
rxclass.c | 8 +---
sfpdiag.c | 2 +-
tg3.c
As a result of previous commits, ethtool source now builds with gcc
versions 7-11 without any compiler warning with "-Wall -Wextra". Add
"-Wextra" to default cflags to make sure that any new warnings are
caught as early as possible.
Suggested-by: Andrew Lunn
Signed-off-by: Michal Kubecek
---
Ma
Comparison between signed and unsigned values is fragile and causes
compiler warnings with recent compilers and stricter CFLAGS. Prevent such
comparisons either by properly declaring variables (mostly loop iterators)
as unsigned or by explicitly casting one side of the comparison.
Signed-off-by: M
Get rid of compiler warnings about comparison between signed and
unsigned integer values in netlink code.
Signed-off-by: Michal Kubecek
---
netlink/features.c | 4 ++--
netlink/netlink.c | 4 ++--
netlink/netlink.h | 2 +-
netlink/nlsock.c | 2 +-
netlink/parser.c | 2 +-
netlink/settings.
To get rid of remaining "missing field initializer" compiler warnings,
convert arrays of struct cmdline_info used for command line parser to
named initializers. This also makes the initializers easier to read.
This commit should have no effect on resulting code (checked with gcc-11
and -O2).
Sign
+ CC:netdev
( Just FYI: Build and boot on bare metal. )
- Sedat -
On Sun, Aug 9, 2020 at 11:01 PM Sedat Dilek wrote:
>
> Hi George,
>
> I have tried your patch on top of Linux v5.8 with...
>
> commit f227e3ec3b5c ("random32: update the net random state on
> interrupt and activity")
>
> ...rever
(Reseending since I accidentally sent it as HTML which the netdev
mailing list doesn't like)
On 2020-08-09 2:05 p.m., Marc Plumb wrote:
Willy,
On 2020-08-07 3:19 p.m., Willy Tarreau wrote:
If I can figure the state out once,
Yes but how do you take that as granted ? This state doesn't appe
On Sun, Aug 09, 2020 at 11:38:05AM +0200, Willy Tarreau wrote:
> So I gave it a quick test under Qemu and it didn't show any obvious
> performance difference compared to Tausworthe, which is a good thing,
> even though there's a significant amount of measurement noise in each
> case.
Thank you ver
On Sun, Aug 09, 2020 at 11:26:31AM +0300, Amit Klein wrote:
> BITS_PER_LONG==23 ???
> Should be ==32, I guess.
Of course. I've been testing on a 64-bit system so hadn't
exercised that branch yet, and it's a case of "seeing what
I expect to see".
On Sun, Aug 09, 2020 at 06:30:17PM +, George Spelvin wrote:
> I'm trying to understand your attack scenario. I'm assuming that an
> attacker can call prandom_u32() locally.
Well, first, I'm mostly focusing on remote attacks, because if the
attacker has a permanent local access, he can as well
On Fri, Aug 7, 2020 at 3:28 PM Jamal Hadi Salim wrote:
>
> From: Jamal Hadi Salim
>
> his classifier, in the same spirit as the tc skb mark classifier,
> provides a generic (fast lookup) approach to filter on the hash value
> and optional mask.
>
> like skb->mark, skb->hash could be set by multip
On Sun, Aug 9, 2020 at 2:13 AM Willem de Bruijn
wrote:
>
> The patch is analogous to commit c7ca03c216ac
> ("drivers/net/wan/lapbether: Added needed_headroom and a skb->len
> check").
>
> Seems to make sense based on call stack
>
> x25_asy_xmit // skb_pull(skb, 1)
> lapb_data_req
On Sun, Aug 09, 2020 at 05:06:39PM +, George Spelvin wrote:
> On Sun, Aug 09, 2020 at 11:38:05AM +0200, Willy Tarreau wrote:
> > So I gave it a quick test under Qemu and it didn't show any obvious
> > performance difference compared to Tausworthe, which is a good thing,
> > even though there's
On Sun, Aug 9, 2020 at 1:48 AM Willem de Bruijn
wrote:
>
> Does this solve an actual observed bug?
>
> In many ways lapbeth is similar to tunnel devices. This is not common.
Thank you for your comment!
This doesn't solve a bug observed by me. But I think this should be
necessary considering the
Hello,
syzbot found the following issue on:
HEAD commit:ce8056d1 wip: changed copy_from_user where instrumented
git tree: https://github.com/google/kmsan.git master
console output: https://syzkaller.appspot.com/x/log.txt?x=130c562c90
kernel config: https://syzkaller.appspot.com/x/.
Hello,
syzbot found the following issue on:
HEAD commit:ce8056d1 wip: changed copy_from_user where instrumented
git tree: https://github.com/google/kmsan.git master
console output: https://syzkaller.appspot.com/x/log.txt?x=1195d1aa90
kernel config: https://syzkaller.appspot.com/x/.
Hello,
syzbot found the following issue on:
HEAD commit:ce8056d1 wip: changed copy_from_user where instrumented
git tree: https://github.com/google/kmsan.git master
console output: https://syzkaller.appspot.com/x/log.txt?x=106e4c3c90
kernel config: https://syzkaller.appspot.com/x/.
On Sun, 9 Aug 2020 21:49:24 +0800
Hillf Danton wrote:
> +
> +static void br_workfn(struct work_struct *w)
> +{
> + struct br_work *brw = container_of(w, struct br_work, work);
> +
> + rtnl_lock();
> + brw->err = brw->set(brw->br, brw->val);
> + if (!brw->err)
> + netd
Adding verifier test for attaching tracing program and
calling d_path helper from within and testing that it's
allowed for dentry_open function and denied for 'd_path'
function with appropriate error.
Acked-by: Andrii Nakryiko
Signed-off-by: Jiri Olsa
---
tools/testing/selftests/bpf/test_verifi
If the resolved type is array, make btf_resolve_size return also
ID of the elem type. It will be needed in following changes.
Acked-by: Andrii Nakryiko
Signed-off-by: Jiri Olsa
---
kernel/bpf/btf.c | 10 +++---
1 file changed, 7 insertions(+), 3 deletions(-)
diff --git a/kernel/bpf/btf.c b
Adding btf_struct_ids_match function to check if given address provided
by BTF object + offset is also address of another nested BTF object.
This allows to pass an argument to helper, which is defined via parent
BTF object + offset, like for bpf_d_path (added in following changes):
SEC("fentry/
Adding test for d_path helper which is pretty much
copied from Wenbo Zhang's test for bpf_get_fd_path,
which never made it in.
The test is doing fstat/close on several fd types,
and verifies we got the d_path helper working on
kernel probes for vfs_getattr/filp_close functions.
Original-patch-by:
Adding d_path helper function that returns full path for
given 'struct path' object, which needs to be the kernel
BTF 'path' object. The path is returned in buffer provided
'buf' of size 'sz' and is zero terminated.
bpf_d_path(&file->f_path, buf, size);
The helper calls directly d_path function
Moving btf_resolve_size into __btf_resolve_size and
keeping btf_resolve_size public with just first 3
arguments, because the rest of the arguments are not
used by outside callers.
Following changes are adding more arguments, which
are not useful to outside callers. They will be added
to the __btf_
Adding test to for sets resolve_btfids. We're checking that
testing set gets properly resolved and sorted.
Acked-by: Andrii Nakryiko
Signed-off-by: Jiri Olsa
---
.../selftests/bpf/prog_tests/resolve_btfids.c | 39 ++-
1 file changed, 38 insertions(+), 1 deletion(-)
diff --git a
Adding support to define sorted set of BTF ID values.
Following defines sorted set of BTF ID values:
BTF_SET_START(btf_allowlist_d_path)
BTF_ID(func, vfs_truncate)
BTF_ID(func, vfs_fallocate)
BTF_ID(func, dentry_open)
BTF_ID(func, vfs_getattr)
BTF_ID(func, filp_close)
BTF_SET_END(bt
Adding type_id pointer as argument to __btf_resolve_size
to return also BTF ID of the resolved type. It will be
used in following changes.
Acked-by: Andrii Nakryiko
Signed-off-by: Jiri Olsa
---
kernel/bpf/btf.c | 13 +
1 file changed, 9 insertions(+), 4 deletions(-)
diff --git a/ke
Updating btf.rst doc with info about BTF_SET_START/END macros.
Acked-by: Andrii Nakryiko
Signed-off-by: Jiri Olsa
---
Documentation/bpf/btf.rst | 25 +
1 file changed, 25 insertions(+)
diff --git a/Documentation/bpf/btf.rst b/Documentation/bpf/btf.rst
index b5361b8621c9
Andrii suggested we can simply jump to again label
instead of making recursion call.
Suggested-by: Andrii Nakryiko
Acked-by: Andrii Nakryiko
Signed-off-by: Jiri Olsa
---
kernel/bpf/btf.c | 11 +--
1 file changed, 5 insertions(+), 6 deletions(-)
diff --git a/kernel/bpf/btf.c b/kernel/b
hi,
adding d_path helper function that returns full path for
given 'struct path' object, which needs to be the kernel
BTF 'path' object. The path is returned in buffer provided
'buf' of size 'sz' and is zero terminated.
long bpf_d_path(struct path *path, char *buf, u32 sz);
The helper calls dir
The set symbol does not have the unique number suffix,
so we need to give it a special parsing function.
This was omitted in the first batch, because there was
no set support yet, so it slipped in the testing.
Acked-by: Andrii Nakryiko
Signed-off-by: Jiri Olsa
---
tools/bpf/resolve_btfids/main
Adding btf_struct_walk function that walks through the
struct type + given offset and returns following values:
enum bpf_struct_walk_result {
/* < 0 error */
WALK_SCALAR = 0,
WALK_PTR,
WALK_STRUCT,
};
WALK_SCALAR - when SCALAR_VALUE is found
WALK_PTR- when poin
To make sure we don't crash on malformed symbols.
Acked-by: Andrii Nakryiko
Signed-off-by: Jiri Olsa
---
tools/bpf/resolve_btfids/main.c | 9 -
1 file changed, 8 insertions(+), 1 deletion(-)
diff --git a/tools/bpf/resolve_btfids/main.c b/tools/bpf/resolve_btfids/main.c
index 52d883325a
On Fri, Aug 07, 2020 at 01:04:26PM -0700, Andrii Nakryiko wrote:
SNIP
> > + }
> > }
> > } else if (!fn->check_btf_id(reg->btf_id, arg)) {
>
> Put this on a wishlist for now. I don't think we should expect
> fb->check_btf_id()
On 09/08/2020 17:12, Nikolay Aleksandrov wrote:
> On 09/08/2020 16:49, Hillf Danton wrote:
>>
>> On Fri, 7 Aug 2020 08:03:32 -0700 Stephen Hemminger wrote:
>>> On Fri, 7 Aug 2020 10:03:59 +0200
>>> Rasmus Villemoes wrote:
>>>
On 07/08/2020 05.39, Stephen Hemminger wrote:
> On Thu, 6 Aug 2
On 09/08/2020 16:49, Hillf Danton wrote:
>
> On Fri, 7 Aug 2020 08:03:32 -0700 Stephen Hemminger wrote:
>> On Fri, 7 Aug 2020 10:03:59 +0200
>> Rasmus Villemoes wrote:
>>
>>> On 07/08/2020 05.39, Stephen Hemminger wrote:
On Thu, 6 Aug 2020 12:46:43 +0300
Nikolay Aleksandrov wrote:
On 8/8/20 11:57 PM, George Spelvin wrote:
+#elif BITS_PER_LONG == 23
s/23/32/ ???
--
~Randy
On 8/6/2020 9:25 PM, Jakub Kicinski wrote:
On Wed, 5 Aug 2020 13:02:58 +0200 Jiri Pirko wrote:
Tue, Aug 04, 2020 at 10:39:46PM CEST, k...@kernel.org wrote:
AFAIU the per-driver default is needed because we went too low
level with what the action constitutes. We need maintain the higher
level
Non-cryptographic PRNGs may have great statistical proprties, but
are usually trivially predictable to someone who knows the algorithm,
given a small sample of their output. An LFSR like prandom_u32() is
particularly simple, even if the sample is widely scattered bits.
It turns out the network st
On Fri, Aug 7, 2020 at 5:26 PM Hideaki Yoshifuji
wrote:
>
> Hi,
>
> 2020年8月6日(木) 23:03 David Ahern :
> >
> > On 8/6/20 2:55 AM, Xin Long wrote:
> > > On Thu, Aug 6, 2020 at 10:50 AM Hideaki Yoshifuji
> > > wrote:
> > >>
> > >> Hi,
> > >>
> > >> 2020年8月4日(火) 0:35 Xin Long :
> > >>>
> > >>> This is
Hi George,
On Sun, Aug 09, 2020 at 06:57:44AM +, George Spelvin wrote:
> +/*
> + * This is the core CPRNG function. As "pseudorandom", this is not used
> + * for truly valuable things, just intended to be a PITA to guess.
> + * For maximum speed, we do just two SipHash rounds per word. This
A possible call chain is as follow:
mwifiex_sdio_interrupt(sdio.c)
--> mwifiex_main_process(main.c)
--> mwifiex_process_cmdresp (cmdevt.c)
--> mwifiex_process_sta_cmdresp (sta_cmdresp.c)
On Sun, Aug 9, 2020 at 4:36 AM Xie He wrote:
>
> 1. Added a skb->len check
>
> This driver expects upper layers to include a pseudo header of 1 byte
> when passing down a skb for transmission. This driver will read this
> 1-byte header. This patch added a skb->len check before reading the
> header
On Sat, Aug 8, 2020 at 7:53 PM Xie He wrote:
>
> The underlying Ethernet device may request necessary tailroom to be
> allocated by setting needed_tailroom. This driver should also set
> needed_tailroom to request the tailroom needed by the underlying
> Ethernet device to be allocated.
>
> Cc: Wil
On Sat, Aug 08, 2020 at 03:57:33PM -0700, Jack Leadford wrote:
> Hello!
>
> Thanks to Jason for getting this conversation back on track.
>
> Yes: in general, {} or a partial initializer /will/ zero padding bits.
>
> However, there is a bug in some versions of GCC where {} will /not/ zero
> padding
61 matches
Mail list logo