On 2015-12-11 13:23:58, Kenneth Graunke wrote:
> The compact VUE map only works when varying packing is in use.
> Unfortunately, varying packing is disabled for TCS inputs.
>
> This is needed to fix Piglit's tcs-input-read-array-interface test.
>
> Signed-off-by: Kenneth Graunke
> ---
> src/mes
On 2015-12-11 13:23:57, Kenneth Graunke wrote:
> TCS outputs and TES inputs both refer to a common "patch URB entry"
> shared across all invocations. First, there are some number of
> per-patch entries. Then, there are per-vertex entries accessed via
> an offset for the variable and a stride time
On 2015-12-13 16:25, Timothy Arceri wrote:
This makes the code easier to follow, should be more efficient
and will makes it easier to add matching via explicit locations
in the following patch.
This patch also replaces the hash table with the newer
resizable hash table this should be more suitab
---
docs/GL3.txt | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/docs/GL3.txt b/docs/GL3.txt
index 84b5a17..5ec3613 100644
--- a/docs/GL3.txt
+++ b/docs/GL3.txt
@@ -184,7 +184,7 @@ GL 4.4, GLSL 4.40:
- forced alignment within blocks in progress
- speci
This change also adds explicit location supoort for structs and interfaces which
is currently missing in Mesa but is allowed with SSO and GLSL 1.50+.
---
src/glsl/ast.h | 1 +
src/glsl/ast_to_hir.cpp| 79 +++---
src/glsl/glsl_parser.
This makes the code easier to follow, should be more efficient
and will makes it easier to add matching via explicit locations
in the following patch.
This patch also replaces the hash table with the newer
resizable hash table this should be more suitable as the table
is likely to only contain a s
Our hardware requires an LOD for all texelFetch commands even if they are
on buffer textures. GLSL IR gives us an LOD of 0 in that case, but the LOD
is really rather meaningless. This commit allows other NIR producers to be
more lazy and not provide one at all.
---
src/mesa/drivers/dri/i965/brw_
On 2015-12-11 13:23:50, Kenneth Graunke wrote:
> My tessellation branch has two additional remap functions. I don't want
> to replicate this logic there.
>
> v2: Handle inputs/outputs separately (suggested by Jason Ekstrand).
>
> Signed-off-by: Kenneth Graunke
> ---
> src/mesa/drivers/dri/i965
On Sat, Dec 12, 2015 at 2:04 PM, Kenneth Graunke wrote:
> On Saturday, December 12, 2015 02:01:49 PM Jason Ekstrand wrote:
>> On Sat, Dec 12, 2015 at 2:00 PM, Jason Ekstrand wrote:
>> > On Sat, Dec 12, 2015 at 12:22 PM, Kenneth Graunke
>> > wrote:
>> >> On Saturday, December 12, 2015 08:29:37 A
On Saturday, December 12, 2015 02:01:49 PM Jason Ekstrand wrote:
> On Sat, Dec 12, 2015 at 2:00 PM, Jason Ekstrand wrote:
> > On Sat, Dec 12, 2015 at 12:22 PM, Kenneth Graunke
> > wrote:
> >> On Saturday, December 12, 2015 08:29:37 AM Jason Ekstrand wrote:
> >>> On Dec 11, 2015 1:24 PM, "Kenneth
On Sat, Dec 12, 2015 at 2:00 PM, Jason Ekstrand wrote:
> On Sat, Dec 12, 2015 at 12:22 PM, Kenneth Graunke
> wrote:
>> On Saturday, December 12, 2015 08:29:37 AM Jason Ekstrand wrote:
>>> On Dec 11, 2015 1:24 PM, "Kenneth Graunke" wrote:
>> [snip]
>>> > @@ -302,12 +302,12 @@ LOAD(shared, 1, 1,
On Sat, Dec 12, 2015 at 12:22 PM, Kenneth Graunke wrote:
> On Saturday, December 12, 2015 08:29:37 AM Jason Ekstrand wrote:
>> On Dec 11, 2015 1:24 PM, "Kenneth Graunke" wrote:
> [snip]
>> > @@ -302,12 +302,12 @@ LOAD(shared, 1, 1, NIR_INTRINSIC_CAN_ELIMINATE)
>> > #define STORE(name, srcs, indi
On Friday, December 11, 2015 12:32:18 PM Neil Roberts wrote:
> Previously if the visual didn't have an alpha channel then it would
> pick a format that is not sRGB-capable. I don't think there's any
> reason not to always have an sRGB-capable visual. Since 28090b30 there
> are now visuals advertise
On Saturday, December 12, 2015 08:29:37 AM Jason Ekstrand wrote:
> On Dec 11, 2015 1:24 PM, "Kenneth Graunke" wrote:
[snip]
> > @@ -302,12 +302,12 @@ LOAD(shared, 1, 1, NIR_INTRINSIC_CAN_ELIMINATE)
> > #define STORE(name, srcs, indices, flags) \
> > INTRINSIC(store_##name, srcs, ARR(0, 1, 1,
On 2015-12-11 13:23:55, Kenneth Graunke wrote:
> Based on a patch by Chris Forbes, but largely rewritten by Ken.
>
> Signed-off-by: Kenneth Graunke
> ---
> src/mesa/drivers/dri/i965/brw_compiler.h | 20 ++-
> src/mesa/drivers/dri/i965/brw_vue_map.c | 98
> ++--
>
On 3 December 2015 at 23:52, Anuj Phogat wrote:
> On Thu, Dec 3, 2015 at 2:43 PM, Ian Romanick wrote:
>> From: Ian Romanick
>>
>> GL_DRAW_FRAMEBUFFER does not exist in OpenGL ES 1.x, and since
>> _mesa_meta_begin hasn't been called yet, we have to work-around API
>> difficulties. The whole reas
On 10 December 2015 at 08:42, Oded Gabbay wrote:
> On Wed, Dec 9, 2015 at 8:30 PM, Matt Turner wrote:
>> On Tue, Dec 8, 2015 at 9:37 PM, Jonathan Gray wrote:
>>> Change the __m128i variables to be volatile so gcc 4.9 won't optimise
>>> all of them out with -O1 or greater. The _mm_set1_epi32/pin
On 2015-12-11 13:23:54, Kenneth Graunke wrote:
> From: Chris Forbes
>
> v2: Rewrite the push constant allocation code to be clearer.
> Only apply the minimum VS entries workaround on Gen 8.
>
> Signed-off-by: Chris Forbes
> Signed-off-by: Kenneth Graunke
> ---
> src/mesa/drivers/dri/i965/
I had some very minor comments but, with those addressed 1-4 are
Reviewed-by: Jason Ekstrand
On Dec 11, 2015 1:24 PM, "Kenneth Graunke" wrote:
> Instead of performing the read-modify-write cycle in glsl->nir, we can
> simply emit a partial writemask. For locals, nir_lower_vars_to_ssa will
> do
On Dec 11, 2015 1:24 PM, "Kenneth Graunke" wrote:
>
> Tessellation control shaders need to be careful when writing outputs.
> Because multiple threads can concurrently write the same output
> variables, we need to only write the exact components we were told.
>
> Traditionally, for sub-vector writ
On Dec 11, 2015 1:24 PM, "Kenneth Graunke" wrote:
>
> My tessellation branch has two additional remap functions. I don't want
> to replicate this logic there.
>
> v2: Handle inputs/outputs separately (suggested by Jason Ekstrand).
>
> Signed-off-by: Kenneth Graunke
> ---
> src/mesa/drivers/dri/
21 matches
Mail list logo