Re: [Mesa-dev] [PATCH] driconf: Added german translation

2011-08-28 Thread Carl-Philip Haensch
Lauri Kasanen : Hi Carl It looks to me you wrote the translations in the result file; the Makefile says you should be editing the .po file, and options.h would autogenerate from that. - Lauri Whats the proper tool to auto generate the new entries in the .po file from t_options.h?

[Mesa-dev] [PATCH 6/6] i965/vs: Avoid the emit(), remove(), insert_before() for array instructions.

2011-08-28 Thread Eric Anholt
--- src/mesa/drivers/dri/i965/brw_vec4_visitor.cpp | 26 +-- 1 files changed, 10 insertions(+), 16 deletions(-) diff --git a/src/mesa/drivers/dri/i965/brw_vec4_visitor.cpp b/src/mesa/drivers/dri/i965/brw_vec4_visitor.cpp index c15db83..2f899db 100644 --- a/src/mesa/drivers/

[Mesa-dev] [PATCH 5/6] i965/vs: Move logic for weird CMP type handling to CMP generators.

2011-08-28 Thread Eric Anholt
--- src/mesa/drivers/dri/i965/brw_vec4.h |9 +-- src/mesa/drivers/dri/i965/brw_vec4_visitor.cpp | 93 ++-- 2 files changed, 54 insertions(+), 48 deletions(-) diff --git a/src/mesa/drivers/dri/i965/brw_vec4.h b/src/mesa/drivers/dri/i965/brw_vec4.h index 7bd59ad

[Mesa-dev] [PATCH 3/6] i965/vs: Convert gen6 userclip handling to new generators.

2011-08-28 Thread Eric Anholt
This DP4 had one of its operands missing, so we were generating garbage clip distances. Using the per-opcode instruction generators made it obvious. --- src/mesa/drivers/dri/i965/brw_vec4_visitor.cpp |6 +++--- 1 files changed, 3 insertions(+), 3 deletions(-) diff --git a/src/mesa/drivers/dr

[Mesa-dev] [PATCH 1/6] i965/vs: Restructure emit() functions around a vec4_instruction constructor.

2011-08-28 Thread Eric Anholt
We sometimes want to put an instruction somewhere besides the end of the instruction stream, and we also want per-opcode instruction generation to enable compile-time checking of operands. --- src/mesa/drivers/dri/i965/brw_vec4.h |8 + src/mesa/drivers/dri/i965/brw_vec4_visitor.c

[Mesa-dev] [PATCH 4/6] i965/vs: Convert emit() calls to the new instruction generators.

2011-08-28 Thread Eric Anholt
--- src/mesa/drivers/dri/i965/brw_vec4_visitor.cpp | 293 ++- 1 files changed, 127 insertions(+), 166 deletions(-) diff --git a/src/mesa/drivers/dri/i965/brw_vec4_visitor.cpp b/src/mesa/drivers/dri/i965/brw_vec4_visitor.cpp index 7334a38..3c005f1 100644 --- a/src/mesa/driver

[Mesa-dev] i965: emit() functions again

2011-08-28 Thread Eric Anholt
Ken didn't like how I was handling new instruction generation for the array stuff, and it convinced me to try a cleanup I had been thinking about. I think this ended up nicer than before. I don't like the extra set of parens per emit() line (back to how the FS used to be, where I mis-balanced par

[Mesa-dev] [PATCH 2/6] i965/vs: Create instruction generators outside of the emit() functions.

2011-08-28 Thread Eric Anholt
--- src/mesa/drivers/dri/i965/brw_vec4.h | 20 +++ src/mesa/drivers/dri/i965/brw_vec4_visitor.cpp | 73 2 files changed, 93 insertions(+), 0 deletions(-) diff --git a/src/mesa/drivers/dri/i965/brw_vec4.h b/src/mesa/drivers/dri/i965/brw_vec4.h index 6e67

Re: [Mesa-dev] [PATCH 2/3] xorg/xvmc: Only set decode buffer when available

2011-08-28 Thread Younes Manton
On Sun, Aug 28, 2011 at 12:56 PM, Maarten Lankhorst wrote: > On 08/28/2011 06:23 PM, Younes Manton wrote: >> On Sun, Aug 28, 2011 at 12:13 PM, Younes Manton wrote: >>> On Sat, Aug 27, 2011 at 7:58 PM, Maarten Lankhorst >>> wrote: The nouveau xvmc decoder doesn't need it. Signed-of

[Mesa-dev] [Bug 38970] [bisected]piglit glx/glx-pixmap-multi failed

2011-08-28 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=38970 Gordon Jin changed: What|Removed |Added CC||mesa-dev@lists.freedesktop.

[Mesa-dev] [Bug 40401] Cogs is slow

2011-08-28 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=40401 --- Comment #10 from imamdxl8...@gmail.com 2011-08-28 20:11:52 PDT --- (In reply to comment #9) > (In reply to comment #4) > > Same here on Intel GMA 4500 and Mesa 7.12-devel > BTW I'm not a developer, but I think only gallium drivers are using >

Re: [Mesa-dev] [PATCH 0/4] Miscelaneous buildsystem patches

2011-08-28 Thread Christopher James Halse Rogers
On Sat, 2011-08-27 at 14:02 +0800, Chia-I Wu wrote: > On Fri, Aug 26, 2011 at 4:03 PM, Christopher James Halse Rogers > wrote: > > Eric was wondering why the --enable-shared-dricore option also built > > libglsl.so. > > This provided the activation energy to fix it, and also extend dricore to >

[Mesa-dev] egl_glx [PATCH] Added eglSwapInterval support via GLX_EXT_swap_control

2011-08-28 Thread Joseph Bates
I've been playing around with egl_glx lately and noticed it was missing something I wanted. A quick look at source revealed it'd be an easy addition. This is my first time contributing to Mesa. Honestly, I tried setting up a Mesa dev environment, but I never quite got it working. That shouldn't ma

Re: [Mesa-dev] [PATCH] glsl: Use a separate div_to_mul_rcp lowering flag for integers.

2011-08-28 Thread Bryan Cain
On 08/28/2011 07:38 PM, Eric Anholt wrote: > On Sat, 27 Aug 2011 20:18:55 -0700, Kenneth Graunke > wrote: >> From: Bryan Cain >> >> Using multiply and reciprocal for integer division involves potentially >> lossy floating point conversions. This is okay for older GPUs that >> represent integers

Re: [Mesa-dev] [PATCH] glsl: Use a separate div_to_mul_rcp lowering flag for integers.

2011-08-28 Thread Eric Anholt
On Sat, 27 Aug 2011 20:18:55 -0700, Kenneth Graunke wrote: > From: Bryan Cain > > Using multiply and reciprocal for integer division involves potentially > lossy floating point conversions. This is okay for older GPUs that > represent integers as floating point, but undesirable for GPUs with >

Re: [Mesa-dev] [PATCH 01/21] intel: Enable extensions by just setting the flags

2011-08-28 Thread Eric Anholt
On Sat, 27 Aug 2011 00:56:51 -0700, "Ian Romanick" wrote: > From: Ian Romanick > > Core Mesa already does the dispatch offset remapping for every > function that could possibly ever be supported. There's no need to > continue using that cruft in the driver. This is a dream come true! Those #d

Re: [Mesa-dev] [PATCH 2/2] i965: Avoid generating MOVs for most ir_assignment handling.

2011-08-28 Thread Eric Anholt
On Sat, 27 Aug 2011 03:23:28 -0700, Kenneth Graunke wrote: > This is a port of vec4_visitor::try_rewrite_rhs_to_dst to fs_visitor. > > Not only is this technique less invasive and more robust, it also > generates better code. Over and above the previous technique, this > reduced instruction cou

Re: [Mesa-dev] [PATCH] mesa, glsl_to_tgsi: fixes for native integers

2011-08-28 Thread Bryan Cain
On 08/26/2011 09:58 PM, Bryan Cain wrote: > This fixes all of the piglit regressions in softpipe when native integers are > enabled. > --- > src/mesa/main/uniforms.c |8 + > src/mesa/state_tracker/st_glsl_to_tgsi.cpp | 45 > ++-- > 2 files chang

[Mesa-dev] [Bug 40437] libGL should give some indication when DRI2 fails

2011-08-28 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=40437 --- Comment #1 from Andrew Deason 2011-08-28 11:33:36 PDT --- Created an attachment (id=50635) View: https://bugs.freedesktop.org/attachment.cgi?id=50635 Review: https://bugs.freedesktop.org/review?bug=40437&attachment=50635 Add some debug ab

[Mesa-dev] [Bug 40437] New: libGL should give some indication when DRI2 fails

2011-08-28 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=40437 Summary: libGL should give some indication when DRI2 fails Product: Mesa Version: 7.11 Platform: All URL: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=63961 7

Re: [Mesa-dev] [PATCH 7/7] g3dvl: Rewrite the mpeg 1&2 bitstream parser

2011-08-28 Thread Andy Furniss
Andy Furniss wrote: deathsim...@vodafone.de wrote: From: Christian König Based on work of Maarten Lankhorst this time. I am getting new artifacts on r600 and softpipe Forgot to say - I don't get them if I reset git to 6/7 so it does seem to be specifically Rewrite the mpeg 1&2 bitstream p

Re: [Mesa-dev] [PATCH 7/7] g3dvl: Rewrite the mpeg 1&2 bitstream parser

2011-08-28 Thread Andy Furniss
deathsim...@vodafone.de wrote: From: Christian König Based on work of Maarten Lankhorst this time. I am getting new artifacts on r600 and softpipe (ignoring all the other issues it has) when using -vc ffmpeg12vdpau, -vo vdpau alone or xvmc are unaffected. Some streams don't show it at all

Re: [Mesa-dev] [PATCH 3/3] xorg/xvmc: Add missing call to set_picture_parameters

2011-08-28 Thread Maarten Lankhorst
Hey, On 08/28/2011 05:04 PM, Christian König wrote: > Hi Maarten, > > could you put this into SetDecoderStatus instead? This makes the picture > structure also available in end_frame. Erm it doesn't make sense there. It might make sense to move it to after the begin_frame though, but with interlac

Re: [Mesa-dev] VDPAU scaling rather than cropping 1088 -> 1080

2011-08-28 Thread Andy Furniss
Christian König wrote: Hey Andy, the attached patch should fix your issue. Please test it. Yes, it looks OK with that, thanks. Andy. ___ mesa-dev mailing list mesa-dev@lists.freedesktop.org http://lists.freedesktop.org/mailman/listinfo/mesa-dev

Re: [Mesa-dev] [PATCH 2/3] xorg/xvmc: Only set decode buffer when available

2011-08-28 Thread Maarten Lankhorst
On 08/28/2011 06:23 PM, Younes Manton wrote: > On Sun, Aug 28, 2011 at 12:13 PM, Younes Manton wrote: >> On Sat, Aug 27, 2011 at 7:58 PM, Maarten Lankhorst >> wrote: >>> The nouveau xvmc decoder doesn't need it. >>> >>> Signed-off-by: Maarten Lankhorst >>> --- >>> src/gallium/state_trackers/xor

Re: [Mesa-dev] [PATCH 2/3] xorg/xvmc: Only set decode buffer when available

2011-08-28 Thread Younes Manton
On Sun, Aug 28, 2011 at 12:13 PM, Younes Manton wrote: > On Sat, Aug 27, 2011 at 7:58 PM, Maarten Lankhorst > wrote: >> The nouveau xvmc decoder doesn't need it. >> >> Signed-off-by: Maarten Lankhorst >> --- >>  src/gallium/state_trackers/xorg/xvmc/surface.c |    9 ++--- >>  1 files changed,

Re: [Mesa-dev] [PATCH 7/8] i965: Fix Android build by removing relative includes

2011-08-28 Thread Chad Versace
-BEGIN PGP SIGNED MESSAGE- Hash: SHA1 Spurious whitespace is fixed in v2. On 08/27/2011 12:19 AM, Ian Romanick wrote: > On 08/26/2011 06:54 PM, Chad Versace wrote: >> Add $(TOP)/src/mesa to include paths and replace each occurence of >> #include "../glsl/*.h" >> with >> #include "glsl

Re: [Mesa-dev] [PATCH 1/3] xvmc tests: Clean up test_rendering slightly

2011-08-28 Thread Younes Manton
On Sat, Aug 27, 2011 at 7:56 PM, Maarten Lankhorst wrote: > Signed-off-by: Maarten Lankhorst > --- >  .../xorg/xvmc/tests/test_rendering.c               |   38 --- >  1 files changed, 24 insertions(+), 14 deletions(-) > > diff --git a/src/gallium/state_trackers/xorg/xvmc/tests/tes

Re: [Mesa-dev] [PATCH 2/3] xorg/xvmc: Only set decode buffer when available

2011-08-28 Thread Younes Manton
On Sat, Aug 27, 2011 at 7:58 PM, Maarten Lankhorst wrote: > The nouveau xvmc decoder doesn't need it. > > Signed-off-by: Maarten Lankhorst > --- >  src/gallium/state_trackers/xorg/xvmc/surface.c |    9 ++--- >  1 files changed, 6 insertions(+), 3 deletions(-) > > diff --git a/src/gallium/stat

Re: [Mesa-dev] [PATCH 8/8] i965: Build i965_dri.so for Android

2011-08-28 Thread Chad Versace
-BEGIN PGP SIGNED MESSAGE- Hash: SHA1 On 08/26/2011 10:51 PM, Chia-I Wu wrote: > On Sat, Aug 27, 2011 at 9:54 AM, Chad Versace wrote: >> This just gets the driver to build. I have not yet tested if the driver >> actually works. >> >> Signed-off-by: Chad Versace >> --- >> Android.mk

Re: [Mesa-dev] [PATCH 6/8] dri: Build libmesa_dri_common for Android

2011-08-28 Thread Chad Versace
-BEGIN PGP SIGNED MESSAGE- Hash: SHA1 On 08/26/2011 10:43 PM, Chia-I Wu wrote: > On Sat, Aug 27, 2011 at 9:54 AM, Chad Versace wrote: >> libmesa_dri_common is a static library that contains the sources in >> src/mesa/drivers/dri/common. Each DRI driver should link to it. >> >> Signed-off-

Re: [Mesa-dev] [PATCH 4/8] make: Remove duplicate occurence of driverfuncs.c

2011-08-28 Thread Chad Versace
-BEGIN PGP SIGNED MESSAGE- Hash: SHA1 On 08/27/2011 12:16 AM, Ian Romanick wrote: > On 08/26/2011 06:53 PM, Chad Versace wrote: >> Stop building driverfuncs.c twice for each DRI driver. driverfuncs.c is >> included in both libmesa.a and in >> src/mesa/drivers/dri/Makefiles.defines:COMMON_S

Re: [Mesa-dev] [PATCH 5/8] make: Factor out source lists from drivers/dri/common into Makefile.sources

2011-08-28 Thread Chad Versace
-BEGIN PGP SIGNED MESSAGE- Hash: SHA1 On 08/26/2011 10:56 PM, Chia-I Wu wrote: > On Sat, Aug 27, 2011 at 9:53 AM, Chad Versace wrote: >> In order that the autoconf and Android build can share the same source >> lists, move the lists from >> src/mesa/drivers/dri/Makefile.defines >> into >

[Mesa-dev] [PATCH 3/3] egl_dri2: add pbuffer support to platform_android

2011-08-28 Thread Chia-I Wu
From: Chia-I Wu This is a simple change thanks to allocateBuffer. --- src/egl/drivers/dri2/platform_android.c | 12 1 files changed, 8 insertions(+), 4 deletions(-) diff --git a/src/egl/drivers/dri2/platform_android.c b/src/egl/drivers/dri2/platform_android.c index 7b6730a..759f

[Mesa-dev] [PATCH 2/3] egl_dri2: check the surface type in platform_android

2011-08-28 Thread Chia-I Wu
From: Chia-I Wu Check the surface type is EGL_WINDOW_BIT before doing anything, in preparation for pbuffer support. --- src/egl/drivers/dri2/platform_android.c | 104 +-- 1 files changed, 58 insertions(+), 46 deletions(-) diff --git a/src/egl/drivers/dri2/platform_a

[Mesa-dev] [PATCH 1/3] egl_dri2: refactor droid_get_buffers_with_format

2011-08-28 Thread Chia-I Wu
From: Chia-I Wu Move the loop to parse attachments to its own function. --- src/egl/drivers/dri2/platform_android.c | 66 ++- 1 files changed, 39 insertions(+), 27 deletions(-) diff --git a/src/egl/drivers/dri2/platform_android.c b/src/egl/drivers/dri2/platform_an

[Mesa-dev] [PATCH] egl_dri2: set ctx->WindowRenderBuffer

2011-08-28 Thread Chia-I Wu
From: Chia-I Wu Set ctx->WindowRenderBuffer to EGL_BACK_BUFFER. As EGL_WINDOW_BIT of a config is set only when there is dri_double_buffer, that makes sure window surfaces are always double-buffered and contexts will render to the back buffer. --- src/egl/drivers/dri2/egl_dri2.c |6 ++ 1

Re: [Mesa-dev] [PATCH] glsl: Use a separate div_to_mul_rcp lowering flag for integers.

2011-08-28 Thread Bryan Cain
On 08/27/2011 10:18 PM, Kenneth Graunke wrote: > From: Bryan Cain > > Using multiply and reciprocal for integer division involves potentially > lossy floating point conversions. This is okay for older GPUs that > represent integers as floating point, but undesirable for GPUs with > native integer

Re: [Mesa-dev] [PATCH 3/3] xorg/xvmc: Add missing call to set_picture_parameters

2011-08-28 Thread Christian König
Hi Maarten, could you put this into SetDecoderStatus instead? This makes the picture structure also available in end_frame. Also named initializers shouldn't be used according to the coding rules. Christian. Am Sonntag, den 28.08.2011, 01:59 +0200 schrieb Maarten Lankhorst: > picture_structure

Re: [Mesa-dev] [PATCH 3/8] make: Document imported variables

2011-08-28 Thread Chad Versace
-BEGIN PGP SIGNED MESSAGE- Hash: SHA1 On 08/26/2011 10:29 PM, Chia-I Wu wrote: > On Sat, Aug 27, 2011 at 9:53 AM, Chad Versace wrote: >> In src/mesa/Android.mk, it is non-trivial to determine which variables are >> imported by `include sources.mak`. So document them. >> >> Signed-off-by:

Re: [Mesa-dev] llvm-config on a biarch machine

2011-08-28 Thread Maarten Lankhorst
Hey Kevin, On 08/28/2011 02:36 PM, Kevin DeKorte wrote: > -BEGIN PGP SIGNED MESSAGE- > Hash: SHA1 > > On 08/27/2011 08:17 PM, Maarten Lankhorst wrote: >> Hey Kevin, >> >> On 08/24/2011 05:34 PM, Kevin DeKorte wrote: >>> -BEGIN PGP SIGNED MESSAGE- Hash: SHA1 >>> >>> On a biarch mach

Re: [Mesa-dev] llvm-config on a biarch machine

2011-08-28 Thread Kevin DeKorte
-BEGIN PGP SIGNED MESSAGE- Hash: SHA1 On 08/27/2011 08:17 PM, Maarten Lankhorst wrote: > Hey Kevin, > > On 08/24/2011 05:34 PM, Kevin DeKorte wrote: >> -BEGIN PGP SIGNED MESSAGE- Hash: SHA1 >> >> On a biarch machine like Fedora llvm-config defaults to >> outputting the values for

Re: [Mesa-dev] VDPAU scaling rather than cropping 1088 -> 1080

2011-08-28 Thread Christian König
Hey Andy, the attached patch should fix your issue. Please test it. Christian. Am Mittwoch, den 17.08.2011, 12:52 +0100 schrieb Andy Furniss: > Maybe this is already known/just not complete yet, but as I've > previously written that r600 -vo vdpau without decode looked OK I ought > to mention