Martin Vermeer wrote:
> 350 #warning CHECK! Are we comparing last_paste to the wrong list
> here? (Lgb)
> 351 if (boost::next(last_paste) != pars.end() &&
> 352 paste_the_end) {
>
> This remark looks valid to me...wrong comparison.
Not to me.
> What is doubleplusunnice a
On Fri, Sep 12, 2003 at 07:14:08PM +0200, Andre Poenitz spake thusly:
...
> 'Final' patch attached for the curious.
>
> Note that most of the infrastructure for 'living' itemize bullets is
> also there
>
> Andre'
This is what I envisaged (more or less; not the template idea, great!)
but
Martin Vermeer wrote:
> Which Juergen? Vigna?
Sure. You don't consider seriously that I know anything about the core.
Juergen.
On Fri, Sep 12, 2003 at 06:42:30PM +0200, Andre Poenitz spake thusly:
> On Fri, Sep 12, 2003 at 07:43:44PM +0300, Martin Vermeer wrote:
> > Commented it out... no effect. Everything just works... (That's why I
> > asked if anybody knew this code, so I could test more directedly.)
> > Yes, and I d
I have the same problem I had in 1.4CVS.
lyx2lyx takes forever converting a 220 to 221 file.
Lars fixed it in 1.4 by writing a tmp file instead of converting in
place.
Any chance of porting that patch to 1.3.x?
Thanks,
Garst
On Fri, Sep 12, 2003 at 06:40:57PM +0200, Jean-Marc Lasgouttes wrote:
> Andre> What else do you want?
>
> Nothing. It's friday.
Fine.
'Final' patch attached for the curious.
Note that most of the infrastructure for 'living' itemize bullets is
also there
Andre'
Index: lib/layouts/article.l
> "Andre" == Andre Poenitz <[EMAIL PROTECTED]> writes:
Andre> What else do you want?
Nothing. It's friday.
I have to go now, but I'll answer in a saner manner monday.
JMarc
On Fri, Sep 12, 2003 at 07:43:44PM +0300, Martin Vermeer wrote:
> Commented it out... no effect. Everything just works... (That's why I
> asked if anybody knew this code, so I could test more directedly.)
> Yes, and I did test insets in insets in insets.
I'd guess Juergen is the only one who compl
On Fri, Sep 12, 2003 at 06:28:33PM +0200, Jean-Marc Lasgouttes wrote:
> > "Andre" == Andre Poenitz <[EMAIL PROTECTED]> writes:
>
> Andre> In this case, the section label string should be defined as
>
> Andre> Chapter: "Chapter \arabic{chapter}"
> Andre> Section: "\arabic{chapter}.\arabic{s
> "Andre" == Andre Poenitz <[EMAIL PROTECTED]> writes:
Andre> In this case, the section label string should be defined as
Andre> Chapter: "Chapter \arabic{chapter}"
Andre> Section: "\arabic{chapter}.\arabic{section}"
Andre> Subsection: "@[EMAIL PROTECTED]"
Andre> Subsubsection: "@[EMAIL
On Fri, Sep 12, 2003 at 07:04:43PM +0300, Martin Vermeer spake thusly:
>
> On Fri, Sep 12, 2003 at 05:32:00PM +0200, Andre Poenitz spake thusly:
> > >
> > > Eh... there is similar code in BufferView::lockInset(). So what to
> > > think about that...?
> >
> > Depends on what happens if you remove
On Fri, Sep 12, 2003 at 05:31:06PM +0200, Jean-Marc Lasgouttes wrote:
> > "Andre" == Andre Poenitz <[EMAIL PROTECTED]> writes:
>
> Andre> Not my invention.
>
> Andre> But \Alpha is fine with me.
>
> Unfortunately, LaTeX uses \alph and \Alph because \alpha means
> something else...
So what
350 #warning CHECK! Are we comparing last_paste to the wrong list
here? (Lgb)
351 if (boost::next(last_paste) != pars.end() &&
352 paste_the_end) {
This remark looks valid to me...wrong comparison.
What is doubleplusunnice about this, it that *usually*, by pure
chance, the
On Fri, Sep 12, 2003 at 05:32:00PM +0200, Andre Poenitz spake thusly:
> >
> > Eh... there is similar code in BufferView::lockInset(). So what to
> > think about that...?
>
> Depends on what happens if you remove that...
>
> Andre'
Bloody empiricist. No I have to do some work.
- Martin
pgp00
> "Andre" == Andre Poenitz <[EMAIL PROTECTED]> writes:
Andre> Not my invention.
Andre> But \Alpha is fine with me.
Unfortunately, LaTeX uses \alph and \Alph because \alpha means
something else...
>> Also what does the @Section@ thing do? Return the whole
>> Labelstring?
Andre> Of the 'Sec
On Fri, Sep 12, 2003 at 06:47:07PM +0300, Martin Vermeer wrote:
> On Fri, Sep 12, 2003 at 03:22:11PM +0200, Andre Poenitz spake thusly:
>
> > > So, shall I just check it in and wait for others to notice possible
> > > problems? It works for me as far as I can tell.
> >
> > Yes.
> >
> > [Actual
On Fri, Sep 12, 2003 at 03:22:11PM +0200, Andre Poenitz spake thusly:
> > So, shall I just check it in and wait for others to notice possible
> > problems? It works for me as far as I can tell.
>
> Yes.
>
> [Actually I think it is some kind of leftover of my doings, so in case
> somebody compl
On Fri, Sep 12, 2003 at 05:01:25PM +0200, Jean-Marc Lasgouttes wrote:
> > "Andre" == Andre Poenitz <[EMAIL PROTECTED]> writes:
>
> Andre> This seems to work except for \itemize.
>
> Andre> I don't see how this worked before and I don't see how I broke
> Andre> this.
>
> What is this \Latin t
> "Andre" == Andre Poenitz <[EMAIL PROTECTED]> writes:
Andre> This seems to work except for \itemize.
Andre> I don't see how this worked before and I don't see how I broke
Andre> this.
What is this \Latin thing? Shouldn't it be \Alph? If you use latex
syntax, you might as well keep the macro
This seems to work except for \itemize.
I don't see how this worked before and I don't see how I broke this.
Any ideas?
Andre'
--
Those who desire to give up Freedom in order to gain Security, will not have,
nor do they deserve, either one. (T. Jefferson or B. Franklin or both...)
? 1.dif
On Fri, Sep 12, 2003 at 04:21:54PM +0200, Lars Gullik Bjønnes wrote:
> Andre Poenitz <[EMAIL PROTECTED]> writes:
>
> >> Here $$the(foo) is the String output of counter foo.
> >
> >> Of course, this is a bit ugly because I followed closely the latex
> >> spec. We could also define in the counter wh
Andre Poenitz <[EMAIL PROTECTED]> writes:
>> Here $$the(foo) is the String output of counter foo.
>
>> Of course, this is a bit ugly because I followed closely the latex
>> spec. We could also define in the counter whether it should use
>> arabic, latin, etc. We will though have a problem with app
On Fri, Sep 12, 2003 at 03:57:17PM +0200, Jean-Marc Lasgouttes wrote:
> > "Jean-Marc" == Jean-Marc Lasgouttes <[EMAIL PROTECTED]> writes:
>
> Jean-Marc> A typical latex example is
>
> Jean-Marc> \def\thechapter{\arabic{chapter}}
> Jean-Marc> \def\thesection{\thechapter.\arabic{section}}
> Jea
> "Jean-Marc" == Jean-Marc Lasgouttes <[EMAIL PROTECTED]> writes:
Jean-Marc> A typical latex example is
Jean-Marc> \def\thechapter{\arabic{chapter}}
Jean-Marc> \def\thesection{\thechapter.\arabic{section}}
Jean-Marc> \def\subsection{\thesection.\arabic{subsection}}
To follow up on my proposa
On Fri, Sep 12, 2003 at 03:48:14PM +0200, Lars Gullik Bjønnes wrote:
> John Levon <[EMAIL PROTECTED]> writes:
>
> | My eyes hurt.
> >
> | if (n < 1 || n > 26)
> | return '?';
> | return 'a' + n - 1;
>
> In this case I agree... there are too many short tokes to parse
> easily.
On Fri, Sep 12, 2003 at 03:41:52PM +0200, Jean-Marc Lasgouttes wrote:
> A typical latex example is
>
> \def\thechapter{\arabic{chapter}}
> \def\thesection{\thechapter.\arabic{section}}
> \def\subsection{\thesection.\arabic{subsection}}
We need a simpler syntax until we have the tex parser in the
John Levon <[EMAIL PROTECTED]> writes:
| My eyes hurt.
>
| if (n < 1 || n > 26)
| return '?';
| return 'a' + n - 1;
In this case I agree... there are too many short tokes to parse
easily.
--
Lgb
> "Andre" == Andre Poenitz <[EMAIL PROTECTED]> writes:
Andre> This is a preliminary patch to finish the counter work.
Andre> I am not that happy about the .layout syntax and there must be
Andre> away to have shorter LabelString definitions but apart from
Andre> that it seems to work rather we
On Fri, Sep 12, 2003 at 03:27:42PM +0200, Andre Poenitz wrote:
> Not to mention that the new version saves more than 100 lines...
What, by making things less readable ?
> char loweralphaCounter(int n)
> {
> - if (n < 1 || n > 26)
> - return '?';
> - else
> - ret
On Friday 12 September 2003 14:27, Andre Poenitz wrote:
> This is a preliminary patch to finish the counter work.
>
> I am not that happy about the .layout syntax and there must be away to
> have shorter LabelString definitions but apart from that it seems to
> work rather well.
>
> Not to mention
This is a preliminary patch to finish the counter work.
I am not that happy about the .layout syntax and there must be away to
have shorter LabelString definitions but apart from that it seems to
work rather well.
Not to mention that the new version saves more than 100 lines...
Comments?
Andre
On Fri, Sep 12, 2003 at 04:13:27PM +0300, Martin Vermeer wrote:
> ...or rather, it's bad code, but its removal good...
>
> So, shall I just check it in and wait for others to notice possible
> problems? It works for me as far as I can tell.
Yes.
[Actually I think it is some kind of leftover of
On Fri, Sep 12, 2003 at 02:05:40PM +0200, Andre Poenitz spake thusly:
>
> On Fri, Sep 12, 2003 at 02:47:18PM +0300, Martin Vermeer wrote:
> > I remember once repairing some piece of equipment (an alarm clock
> > IIRC) and being left with several little pieces. Still the thing
> > worked fine after
On Fri, Sep 12, 2003 at 02:47:18PM +0300, Martin Vermeer wrote:
> I remember once repairing some piece of equipment (an alarm clock
> IIRC) and being left with several little pieces. Still the thing
> worked fine after that.
>
> Does anybody recognize this little piece?
No.
But if it does not ma
On Mon, Sep 08, 2003 at 04:08:21PM +0200, [EMAIL PROTECTED] spake thusly:
> --- Additional Comments From [EMAIL PROTECTED] 2003-09-08 16:08 ---
...
> 2) A probably related bug occurs if you
> a) create an inset, e.g. Note;
> b) create a second inset inside it, e.g. footnote;
> c
On Fri, Sep 12, 2003 at 07:02:28PM +0930, Pierre Dumuid wrote:
> So, is it is possible to change the color in the font editor, when
> character's become bold?
Ok, I've just implemented some 'poor man's boldsymbol' by simply drawing the
contents of some new 'boldsymbol inset' twice (1 pixel apart)
On Fri, Sep 12, 2003 at 07:02:28PM +0930, Pierre Dumuid wrote:
> Hi,
> A friend in our department who has been fairly used to using latex in
> for writing in his documents, is deciding about using lyx in the future..
>
> In testing out lyx, he found that the fact that bold greek letters
> didn't
Hi,
A friend in our department who has been fairly used to using latex in
for writing in his documents, is deciding about using lyx in the future..
In testing out lyx, he found that the fact that bold greek letters
didn't work was really annoying.
I ended up placing \renewcommand{\mathbf}{\bold
> "John" == John Levon <[EMAIL PROTECTED]> writes:
John> On Wed, Sep 10, 2003 at 06:30:35PM +0200, Jean-Marc Lasgouttes
John> wrote:
>> Ronald Florence). The patch mathed.patch fixes this, but I have no
>> idea of the side effects on linux (I do not use xft).
>>
>> Could you have a look? Coul
> "Lars" == Lars Gullik Bjønnes <[EMAIL PROTECTED]> writes:
Lars> My vote is to ditch lyx::string now.
I cannot compile anymore on the system where I need that and we are
going to get rid of it... So go for it!
JMarc
[EMAIL PROTECTED] (Juergen Spitzmueller) writes:
| shall I apply the fix?
| (including to aspell.C)
| Juergen.
yes please
--
Lgb
On Thu, Sep 11, 2003 at 07:29:52PM +0200, Lars Gullik Bjønnes wrote:
> This patch does something _very_ similar to this.
>
> Please comment.
Looks good.
Andre'
--
Those who desire to give up Freedom in order to gain Security, will not have,
nor do they deserve, either one. (T. Jefferson o
42 matches
Mail list logo