Changes in directory llvm/test/AdaFrontend:
switch.adb added (r1.1)
---
Log message:
Test handling of switches with wide case ranges.
---
Diffs of the changes: (+12 -0)
switch.adb | 12
1 files changed, 12 insertions(+)
Index: llvm/test/AdaFrontend/switch.adb
diff -c /dev/
Changes in directory llvm-test/External/SPEC/CINT2006/462.libquantum:
Makefile updated: 1.2 -> 1.3
---
Log message:
Get 462.libquantum compiling on Linux.
---
Diffs of the changes: (+4 -0)
Makefile |4
1 files changed, 4 insertions(+)
Index: llvm-test/External/SPEC/CINT2006/462.
Changes in directory llvm/lib/VMCore:
ConstantFold.cpp updated: 1.147 -> 1.148
---
Log message:
Fix constant fold of div by zero and rem by zero to match IEEE 754
requirements. We must return NaN in some cases and correctly signed
infinity in other cases. Passes CFP2006 (not that that says muc
Changes in directory llvm/lib/Transforms/Scalar:
InstructionCombining.cpp updated: 1.676 -> 1.677
---
Log message:
Make the "KnownZero ^ TypeMask" computation just once.
---
Diffs of the changes: (+4 -3)
InstructionCombining.cpp |7 ---
1 files changed, 4 insertions(+), 3 deletions
Chris / Jeff,
No need to file a bug. Here's a patch that I think solves this. Could
you (preferably both) review this to make sure I've interpreted the IEEE
754 standard correctly?
Thanks,
Reid.
On Thu, 2007-03-22 at 18:42 -0800, Chris Lattner wrote:
> On Thu, 22 Mar 2007, Jeff Cohen wrote:
> >
Changes in directory llvm/lib/Transforms/Scalar:
InstructionCombining.cpp updated: 1.675 -> 1.676
---
Log message:
Simplify the code.
---
Diffs of the changes: (+1 -1)
InstructionCombining.cpp |2 +-
1 files changed, 1 insertion(+), 1 deletion(-)
Index: llvm/lib/Transforms/Scalar/Ins
Changes in directory llvm/lib/CodeGen/SelectionDAG:
DAGCombiner.cpp updated: 1.277 -> 1.278
---
Log message:
A couple of bug fixes for reducing load width xform:
1. Address offset is in bytes.
2. Make sure truncate node uses are replaced with new load.
---
Diffs of the changes: (+16 -7)
DAG
Revision: 125252
Author: dpatel
Date: 2007-03-22 16:02:12 -0700 (Thu, 22 Mar 2007)
Log Message:
---
Emit switch cases with a wide range as a conditional branch.
Patch by Duncan Sands.
Modified Paths:
--
apple-local/branches/llvm/gcc/llvm-convert.cpp
Modified: apple-
Changes in directory llvm/lib/Transforms/Scalar:
InstructionCombining.cpp updated: 1.674 -> 1.675
---
Log message:
For PR1205: http://llvm.org/PR1205 :
APInt support for logical operators in visitAnd, visitOr, and visitXor.
Patch by Zhou Sheng.
---
Diffs of the changes: (+25 -21)
Instruct
Changes in directory llvm/utils:
findoptdiff updated: 1.2 -> 1.3
---
Log message:
The -funcresolve and -raise options no longer exist.
---
Diffs of the changes: (+1 -1)
findoptdiff |2 +-
1 files changed, 1 insertion(+), 1 deletion(-)
Index: llvm/utils/findoptdiff
diff -u llvm/utils/
Changes in directory llvm/lib/Transforms/Scalar:
InstructionCombining.cpp updated: 1.673 -> 1.674
---
Log message:
For PR1205: http://llvm.org/PR1205 :
* APIntify commonIntCastTransforms
* APIntify visitTrunc
* APIntify visitZExt
Patch by Zhou Sheng.
---
Diffs of the changes: (+17 -16)
In
Changes in directory llvm/lib/Transforms/Scalar:
InstructionCombining.cpp updated: 1.672 -> 1.673
---
Log message:
For PR1205: http://llvm.org/PR1205 :
* Re-enable the APInt version of MaskedValueIsZero.
* APIntify the Comput{Un}SignedMinMaxValuesFromKnownBits functions
* APIntify visitICmpInst
Changes in directory llvm/lib/Target/X86:
X86InstrMMX.td updated: 1.22 -> 1.23
---
Log message:
We generate a shufflevector instruction, so we don't need the builtin
intrinsic.
---
Diffs of the changes: (+13 -6)
X86InstrMMX.td | 19 +--
1 files changed, 13 insertions(+),
Changes in directory llvm/include/llvm:
IntrinsicsX86.td updated: 1.36 -> 1.37
---
Log message:
We generate a shufflevector instruction, so we don't need the builtin
intrinsic.
---
Diffs of the changes: (+0 -7)
IntrinsicsX86.td |7 ---
1 files changed, 7 deletions(-)
Index: llvm/
On Thu, 2007-03-22 at 12:35 -0700, Jeff Cohen wrote:
> How is it any worse than checking for GCC?
I don't like that either :)
>
> It's treated as an intrinsic when optimizations are enable. It directly
> generates a bswap instruction. Same as the conditional code for GCC.
Okay, sounds like i
Reid Spencer wrote:
>
>> -for (uint64_t Shift = 64 >> 1; Shift; Shift >>= 1) {
>> +for (unsigned Shift = 64 >> 1; Shift; Shift >>= 1) {
>>
>
> Why not uint32_t? For conformity with the rest of your changes?
The size of a shift amount is unrelated to the size of the function's
argumen
How is it any worse than checking for GCC?
It's treated as an intrinsic when optimizations are enable. It directly
generates a bswap instruction. Same as the conditional code for GCC.
Reid Spencer wrote:
> Jeff,
>
> On Thu, 2007-03-22 at 14:12 -0500, Jeff Cohen wrote:
>
>> Changes in direct
Jeff,
On Thu, 2007-03-22 at 14:12 -0500, Jeff Cohen wrote:
>
> Changes in directory llvm/include/llvm/Support:
>
> MathExtras.h updated: 1.43 -> 1.44
> ---
> Log message:
>
> Be more explicit concerning argument sizes.
> Use VC++ byteswap intrinsics.
... snip ...
> @@ -93,22 +93,30 @@
>
>
Changes in directory llvm/win32:
.cvsignore updated: 1.1 -> 1.2
README.txt (r1.1) removed
---
Log message:
Cleanup obsolete stuff.
---
Diffs of the changes: (+0 -2)
.cvsignore |2 --
1 files changed, 2 deletions(-)
Index: llvm/win32/.cvsignore
diff -u llvm/win32/.cvsignore:1.1 llvm/wi
Changes in directory llvm/include/llvm/Support:
MathExtras.h updated: 1.43 -> 1.44
---
Log message:
Be more explicit concerning argument sizes.
Use VC++ byteswap intrinsics.
---
Diffs of the changes: (+41 -31)
MathExtras.h | 72 +--
Changes in directory llvm/include/llvm:
IntrinsicsX86.td updated: 1.35 -> 1.36
---
Log message:
Support added for shifts and unpacking MMX instructions.
---
Diffs of the changes: (+38 -0)
IntrinsicsX86.td | 38 ++
1 files changed, 38 insertions(+)
In
Changes in directory llvm/lib/Target/X86:
README-MMX.txt added (r1.1)
README-SSE.txt updated: 1.15 -> 1.16
X86ISelLowering.cpp updated: 1.374 -> 1.375
X86InstrMMX.td updated: 1.21 -> 1.22
---
Log message:
Support added for shifts and unpacking MMX instructions.
---
Diffs of the changes: (+21
Revision: 125247
Author: bwendlin
Date: 2007-03-22 11:41:21 -0700 (Thu, 22 Mar 2007)
Log Message:
---
Add build vector shuffles for MMX instructions.
Modified Paths:
--
apple-local/branches/llvm/gcc/config/i386/llvm-i386.cpp
Modified: apple-local/branches/llvm/gcc/c
Revision: 125246
Author: dpatel
Date: 2007-03-22 11:31:30 -0700 (Thu, 22 Mar 2007)
Log Message:
---
Do not map 80 bit and 96 bit float point types to
64 bit LLVM type.
Patch by Duncan Sands.
Modified Paths:
--
apple-local/branches/llvm/gcc/llvm-types.cpp
Modified:
Changes in directory llvm/lib/CodeGen/SelectionDAG:
SelectionDAGISel.cpp updated: 1.390 -> 1.391
---
Log message:
Change uses of Function::front to Function::getEntryBlock for readability.
---
Diffs of the changes: (+1 -1)
SelectionDAGISel.cpp |2 +-
1 files changed, 1 insertion(+), 1
Changes in directory llvm/lib/Transforms/Utils:
CloneFunction.cpp updated: 1.43 -> 1.44
CodeExtractor.cpp updated: 1.50 -> 1.51
InlineFunction.cpp updated: 1.54 -> 1.55
SimplifyCFG.cpp updated: 1.118 -> 1.119
---
Log message:
Change uses of Function::front to Function::getEntryBlock for readabi
Changes in directory llvm/lib/Analysis:
ProfileInfo.cpp updated: 1.10 -> 1.11
ProfileInfoLoader.cpp updated: 1.11 -> 1.12
---
Log message:
Change uses of Function::front to Function::getEntryBlock for readability.
---
Diffs of the changes: (+3 -2)
ProfileInfo.cpp |2 +-
ProfileIn
Changes in directory llvm/lib/Transforms/Scalar:
InstructionCombining.cpp updated: 1.671 -> 1.672
LICM.cpp updated: 1.88 -> 1.89
ScalarReplAggregates.cpp updated: 1.80 -> 1.81
TailRecursionElimination.cpp updated: 1.29 -> 1.30
---
Log message:
Change uses of Function::front to Function::getEntr
Changes in directory llvm/lib/VMCore:
AsmWriter.cpp updated: 1.264 -> 1.265
Instructions.cpp updated: 1.80 -> 1.81
---
Log message:
Change uses of Function::front to Function::getEntryBlock for readability.
---
Diffs of the changes: (+2 -2)
AsmWriter.cpp|2 +-
Instructions.cpp |
29 matches
Mail list logo