Reid Spencer wrote: > >> - for (uint64_t Shift = 64 >> 1; Shift; Shift >>= 1) { >> + for (unsigned Shift = 64 >> 1; Shift; Shift >>= 1) { >> > > Why not uint32_t? For conformity with the rest of your changes?
The size of a shift amount is unrelated to the size of the function's argument, so there's no reason not to use the "natural" integer size. _______________________________________________ llvm-commits mailing list llvm-commits@cs.uiuc.edu http://lists.cs.uiuc.edu/mailman/listinfo/llvm-commits