Changes in directory llvm/lib/CodeGen/SelectionDAG:
SelectionDAGISel.cpp updated: 1.390 -> 1.391 --- Log message: Change uses of Function::front to Function::getEntryBlock for readability. --- Diffs of the changes: (+1 -1) SelectionDAGISel.cpp | 2 +- 1 files changed, 1 insertion(+), 1 deletion(-) Index: llvm/lib/CodeGen/SelectionDAG/SelectionDAGISel.cpp diff -u llvm/lib/CodeGen/SelectionDAG/SelectionDAGISel.cpp:1.390 llvm/lib/CodeGen/SelectionDAG/SelectionDAGISel.cpp:1.391 --- llvm/lib/CodeGen/SelectionDAG/SelectionDAGISel.cpp:1.390 Tue Mar 20 14:32:11 2007 +++ llvm/lib/CodeGen/SelectionDAG/SelectionDAGISel.cpp Thu Mar 22 11:38:57 2007 @@ -4328,7 +4328,7 @@ std::vector<SDOperand> UnorderedChains; // Lower any arguments needed in this block if this is the entry block. - if (LLVMBB == &LLVMBB->getParent()->front()) + if (LLVMBB == &LLVMBB->getParent()->getEntryBlock()) LowerArguments(LLVMBB, SDL, UnorderedChains); BB = FuncInfo.MBBMap[LLVMBB]; _______________________________________________ llvm-commits mailing list llvm-commits@cs.uiuc.edu http://lists.cs.uiuc.edu/mailman/listinfo/llvm-commits