On Thu, Sep 5, 2024, at 21:15, Charlie Jenkins wrote:
> Create a personality flag ADDR_LIMIT_47BIT to support applications
> that wish to transition from running in environments that support at
> most 47-bit VAs to environments that support larger VAs. This
> personality can be set to cause all all
On 2024/9/4 16:40, Qi Zheng wrote:
Currently, the usage of pte_offset_map_nolock() can be divided into the
following two cases:
1) After acquiring PTL, only read-only operations are performed on the PTE
page. In this case, the RCU lock in pte_offset_map_nolock() will ensure
that the P
On Fri, Sep 06, 2024 at 07:17:44AM GMT, Arnd Bergmann wrote:
> On Thu, Sep 5, 2024, at 21:15, Charlie Jenkins wrote:
> > Create a personality flag ADDR_LIMIT_47BIT to support applications
> > that wish to transition from running in environments that support at
> > most 47-bit VAs to environments th
On Fri, Sep 06, 2024 at 07:17:44AM GMT, Arnd Bergmann wrote:
> On Thu, Sep 5, 2024, at 21:15, Charlie Jenkins wrote:
> > Create a personality flag ADDR_LIMIT_47BIT to support applications
> > that wish to transition from running in environments that support at
> > most 47-bit VAs to environments th
When running in a non-root time namespace, the global VDSO data page
is replaced by a dedicated namespace data page and the global data
page is mapped next to it. Detailed explanations can be found at
commit 660fd04f9317 ("lib/vdso: Prepare for time namespace support").
When it happens, __kernel_g
Use the new get_realdatapage macro instead of get_datapage
Signed-off-by: Christophe Leroy
---
arch/powerpc/kernel/vdso/getrandom.S | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/arch/powerpc/kernel/vdso/getrandom.S
b/arch/powerpc/kernel/vdso/getrandom.S
index a957cd2b2b03.
On 2024/9/6 15:06, Morten Rasmussen wrote:
> Hi Yicong,
>
> On Thu, Sep 05, 2024 at 08:02:20PM +0800, Yicong Yang wrote:
>> On 2024/9/5 16:34, Pierre Gondois wrote:
>>> Hello Yicong,
>>>
>>> If a platform has CPUs with:
>>> - 1 thread
>>> - X (!= 1) threads
>>> Then I think that the asymmetry is n
On Fri, Sep 6, 2024, at 08:14, Lorenzo Stoakes wrote:
> On Fri, Sep 06, 2024 at 07:17:44AM GMT, Arnd Bergmann wrote:
>> On Thu, Sep 5, 2024, at 21:15, Charlie Jenkins wrote:
>> > Create a personality flag ADDR_LIMIT_47BIT to support applications
>> > that wish to transition from running in environm
On Fri, Sep 6, 2024 at 3:18 PM Arnd Bergmann wrote:
>
> On Thu, Sep 5, 2024, at 21:15, Charlie Jenkins wrote:
> > Create a personality flag ADDR_LIMIT_47BIT to support applications
> > that wish to transition from running in environments that support at
> > most 47-bit VAs to environments that sup
Le 26/08/2024 à 08:55, Mike Rapoport a écrit :
From: "Mike Rapoport (Microsoft)"
Using large pages to map text areas reduces iTLB pressure and improves
performance.
Extend execmem_alloc() with an ability to use PMD_SIZE'ed pages with ROX
permissions as a cache for smaller allocations.
Why
(Sorry having issues with my IPv6 setup that duplicated the original email...
On Fri, Sep 06, 2024 at 09:14:08AM GMT, Arnd Bergmann wrote:
> On Fri, Sep 6, 2024, at 08:14, Lorenzo Stoakes wrote:
> > On Fri, Sep 06, 2024 at 07:17:44AM GMT, Arnd Bergmann wrote:
> >> On Thu, Sep 5, 2024, at 21:15, Ch
On Fri, Sep 6, 2024, at 09:14, Guo Ren wrote:
> On Fri, Sep 6, 2024 at 3:18 PM Arnd Bergmann wrote:
>>
>> It's also unclear to me how we want this flag to interact with
>> the existing logic in arch_get_mmap_end(), which attempts to
>> limit the default mapping to a 47-bit address space already.
>
This function is base on the accelerator implementation
for compress API:
https://patchwork.kernel.org/project/alsa-devel/patch/20240731083843.59911-1-pe...@perex.cz/
Audio signal processing also has the requirement for memory to
memory similar as Video.
This asrc memory to memory (memory ->asrc-
Add 'pcm_format' for struct snd_codec, add 'pcm_formats' for
struct snd_codec_desc, these are used for accelerator usage.
Current accelerator example is sample rate converter (SRC).
Define struct snd_codec_desc_src for descript minmum and maxmum
sample rates. And add 'src_d' in union snd_codec_opt
ASRC can be used on memory to memory case, define several
functions for m2m usage.
m2m_prepare: prepare for the start step
m2m_start: the start step
m2m_unprepare: unprepare for stop step, optional
m2m_stop: stop step
m2m_check_format: check format is supported or not
m2m_calc_out_len: calculate o
ASRC can be used on memory to memory case, define several
functions for m2m usage and export them as function pointer.
Signed-off-by: Shengjiu Wang
---
sound/soc/fsl/fsl_easrc.c | 228 ++
sound/soc/fsl/fsl_easrc.h | 4 +
2 files changed, 232 insertions(+)
d
Implement the ASRC memory to memory function using
the compress framework, user can use this function with
compress ioctl interface.
This feature can be shared by ASRC and EASRC drivers
Signed-off-by: Shengjiu Wang
---
sound/soc/fsl/Kconfig | 1 +
sound/soc/fsl/Makefile |
Register m2m platform device, that user can
use M2M feature.
Signed-off-by: Shengjiu Wang
---
sound/soc/fsl/fsl_asrc.c | 37 +
1 file changed, 33 insertions(+), 4 deletions(-)
diff --git a/sound/soc/fsl/fsl_asrc.c b/sound/soc/fsl/fsl_asrc.c
index b1b35954f7ac
Register m2m platform device,that user can
use M2M feature.
Signed-off-by: Shengjiu Wang
---
sound/soc/fsl/fsl_easrc.c | 33 +++--
1 file changed, 31 insertions(+), 2 deletions(-)
diff --git a/sound/soc/fsl/fsl_easrc.c b/sound/soc/fsl/fsl_easrc.c
index a1a7a90ff5ef..
Solar Designer writes:
> Hi,
>
> This bug report is misaddressed. Per upstream's preference and common
> sense (given how many issue reports there are against the Linux kernel),
> most Linux kernel (maybe-)issues should first be reported to Linux
> kernel maintainers/lists or (if you're reasonabl
Hi Yicong,
On Thu, Sep 05, 2024 at 08:02:20PM +0800, Yicong Yang wrote:
> On 2024/9/5 16:34, Pierre Gondois wrote:
> > Hello Yicong,
> >
> > If a platform has CPUs with:
> > - 1 thread
> > - X (!= 1) threads
> > Then I think that the asymmetry is not detected
>
> Ah ok, I only handle the case wh
On Fri, Sep 06, 2024 at 09:55:42AM +, Arnd Bergmann wrote:
> On Fri, Sep 6, 2024, at 09:14, Guo Ren wrote:
> > On Fri, Sep 6, 2024 at 3:18 PM Arnd Bergmann wrote:
> >> It's also unclear to me how we want this flag to interact with
> >> the existing logic in arch_get_mmap_end(), which attempts
On Thu, 29 Aug 2024 07:58:27 +0530, Nysal Jan K.A. wrote:
> If an interrupt occurs in queued_spin_lock_slowpath() after we increment
> qnodesp->count and before node->lock is initialized, another CPU might
> see stale lock values in get_tail_qnode(). If the stale lock value happens
> to match the l
On Fri, 30 Aug 2024 07:31:31 -0400, Abhishek Dubey wrote:
> This is an adaptation of commit f3a112c0c40d ("x86,rethook,kprobes:
> Replace kretprobe with rethook on x86") to powerpc.
>
> Rethook follows the existing kretprobe implementation, but separates
> it from kprobes so that it can be used by
On Tue, 20 Aug 2024 14:26:54 +0200, Christophe Leroy wrote:
> VMAP stack added an emergency stack on powerpc/32 for when there is
> a stack overflow, but failed to add stack validation for that
> emergency stack. That validation is required for show stack.
>
> Implement it.
>
>
> [...]
Applied
On Thu, 22 Aug 2024 10:00:29 +0200, Christophe Leroy wrote:
> During merge of commit 4e991e3c16a3 ("powerpc: add CFUNC assembly
> label annotation") a fallback version of CFUNC macro was added at
> the last minute, so it can be used inconditionally.
>
>
Applied to powerpc/next.
[1/1] powerpc/vd
On Tue, 20 Aug 2024 19:23:44 +0200, Christophe Leroy wrote:
> This series does mainly two things:
> - Remove the 8M alignment constraint on STRICT_KERNEL_RWX on 8xx to
> avoid wasting memory.
> - Speed-up TLB misses by duplicating kernel PGD entries into each
> task's PGDIRs to avoid the address co
On Thu, 22 Aug 2024 21:06:05 +0800, Gaosheng Cui wrote:
> Remove obsoleted declaration for powerpc, thanks!
>
> Gaosheng Cui (4):
> powerpc: Remove obsoleted declaration for _get_SP
> powerpc: Remove obsoleted declaration for maple_calibrate_decr
> powerpc: Remove obsoleted declaration for p
On Thu, 22 Aug 2024 21:00:43 +0800, Gaosheng Cui wrote:
> The pnv_pci_init_ioda_hub() have been removed since
> commit 5ac129cdb50b ("powerpc/powernv/pci: Remove ioda1 support"),
> and now it is useless, so remove it.
>
>
Applied to powerpc/next.
[1/1] powerpc/powernv/pci: Remove obsoleted decl
On Wed, 21 Aug 2024 19:50:26 -0700, Haren Myneni wrote:
> _be32 type is defined for some elements in pseries_hp_errorlog
> struct but also used them u32 after be32_to_cpu() conversion.
>
> Example: In handle_dlpar_errorlog()
> hp_elog->_drc_u.drc_index = be32_to_cpu(hp_elog->_drc_u.drc_index);
>
On Mon, 26 Aug 2024 23:09:55 +0800, Huang Xiaojia wrote:
> 'struct kobj_type' is not modified. It is only used in
> kobject_init_and_add()/kobject_init() which takes
> a 'const struct kobj_type *ktype' parameter.
>
> Constifying this structure moves some data to a read-only section,
> so increase
On Mon, 26 Aug 2024 12:12:17 +0530, Madhavan Srinivasan wrote:
> If a function name is greater than 63 char long, xmon command
> may not find them. For example, here is a test that
> executed an illegal instruction in a kernel function and one of
> call stack function has name >63 char long,
>
> c
On Fri, 23 Aug 2024 13:29:10 +1000, Michael Ellerman wrote:
> Move the Kconfig symbols related to transparent hugepages (THP) under a
> separate config symbol, separate from CONFIG_PPC_BOOK3S_64.
>
> The new symbol is automatically enabled if CONFIG_PPC_BOOK3S_64 is
> enabled, so there is no behav
On Wed, 21 Aug 2024 18:21:01 +1000, Michael Ellerman wrote:
> register_pmu_pm_ops() is only called at init time, via
> device_initcall(), so can be marked __init. The driver can't be built as
> a module.
>
>
Applied to powerpc/next.
[1/1] macintosh/via-pmu: register_pmu_pm_ops() can be __init
On Wed, 21 Aug 2024 18:07:45 +1000, Michael Ellerman wrote:
> The mmu_hash_ops are only assigned to during boot, so mark them
> __ro_after_init to prevent any further modification.
>
>
Applied to powerpc/next.
[1/1] powerpc/64s: Make mmu_hash_ops __ro_after_init
https://git.kernel.org/pow
On Fri, 23 Aug 2024 17:08:30 +1000, Michael Ellerman wrote:
> The non-standard "fast endian switch" syscall was added in 2008[1],
> but was never widely used. It was disabled by default in 2017[2], and
> there's no evidence it's ever been used since.
>
> Remove it entirely.
>
> A normal endian sw
On Tue, 03 Sep 2024 21:19:51 +1000, Michael Ellerman wrote:
> Since commit 868941b14441 ("fs: remove no_llseek"), no_llseek() is
> simply defined to be NULL, and a NULL llseek means seeking is
> unsupported.
>
> So for statically defined file_operations, such as all these, there's no
> need or ben
On Thu, 22 Aug 2024 16:54:28 +0800, Zhang Zekun wrote:
> Use for_each_child_of_node() to iterate through the device_node, this
> can make code more simple.
>
> Zhang Zekun (2):
> powerpc/powermac/pfunc_base: Use helper function
> for_each_child_of_node()
> powerpc/pseries/dlpar: Use helper
On Wed, 21 Aug 2024 18:07:29 +1000, Michael Ellerman wrote:
> The stub versions of __real_pte() etc are only used with HPT & 4K pages,
> so move them into the hash-4k.h header.
>
>
Applied to powerpc/next.
[1/1] powerpc/64s/mm: Move __real_pte stubs into hash-4k.h
https://git.kernel.org/p
On Tue, 20 Aug 2024 16:57:05 +1000, Michael Ellerman wrote:
> It can speed up initialisation of page structs at boot on large
> machines.
>
>
Applied to powerpc/next.
[1/1] powerpc/configs/64s: Enable DEFERRED_STRUCT_PAGE_INIT
https://git.kernel.org/powerpc/c/d6b34416b08895a7457c53630595c
On Fri, 16 Aug 2024 17:33:12 +0800, al...@kernel.org wrote:
> During build testing, we found a error:
> /arch/powerpc/kvm/book3s_hv.c:4052:17: error: variable 'loops' set but not
> used [-Werror,-Wunused-but-set-variable]
> unsigned long loops = 0;
> 1 error generated.
>
> Remove
-BEGIN PGP SIGNED MESSAGE-
Hash: SHA512
Hi Linus,
Please pull some more powerpc fixes for 6.11:
The following changes since commit 227bbaabe64b6f9cd98aa051454c1d4a194a8c6a:
powerpc/topology: Check if a core is online (2024-08-13 10:32:17 +1000)
are available in the git repository at:
Christophe Leroy writes:
> When running in a non-root time namespace, the global VDSO data page
> is replaced by a dedicated namespace data page and the global data
> page is mapped next to it. Detailed explanations can be found at
> commit 660fd04f9317 ("lib/vdso: Prepare for time namespace suppo
Le 06/09/2024 à 14:23, Michael Ellerman a écrit :
Christophe Leroy writes:
When running in a non-root time namespace, the global VDSO data page
is replaced by a dedicated namespace data page and the global data
page is mapped next to it. Detailed explanations can be found at
commit 660fd04f9
On Fri, Sep 06, 2024 at 10:23:08PM +1000, Michael Ellerman wrote:
> Christophe Leroy writes:
> > When running in a non-root time namespace, the global VDSO data page
> > is replaced by a dedicated namespace data page and the global data
> > page is mapped next to it. Detailed explanations can be f
On Fri, Sep 06, 2024 at 03:43:17PM +0200, Jason A. Donenfeld wrote:
> On Fri, Sep 06, 2024 at 10:23:08PM +1000, Michael Ellerman wrote:
> > Christophe Leroy writes:
> > > When running in a non-root time namespace, the global VDSO data page
> > > is replaced by a dedicated namespace data page and t
On Fri, Sep 06, 2024 at 10:33:44AM +0200, Christophe Leroy wrote:
> Use the new get_realdatapage macro instead of get_datapage
>
> Signed-off-by: Christophe Leroy
> ---
> arch/powerpc/kernel/vdso/getrandom.S | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/arch/powerpc/k
Le 06/09/2024 à 16:07, Jason A. Donenfeld a écrit :
On Fri, Sep 06, 2024 at 10:33:44AM +0200, Christophe Leroy wrote:
Use the new get_realdatapage macro instead of get_datapage
Signed-off-by: Christophe Leroy
---
arch/powerpc/kernel/vdso/getrandom.S | 2 +-
1 file changed, 1 insertion(+)
On Fri, Aug 30 2024 at 22:21, Ma Ke wrote:
> Zero and negative number is not a valid IRQ for in-kernel code and the
> irq_of_parse_and_map() function returns zero on error. So this check for
> valid IRQs should only accept values > 0.
The subsystem prefix is wrong. This changes drivers/i2c/busses
On Fri, Sep 06, 2024 at 04:26:32PM +0200, Christophe Leroy wrote:
> And thanks for playing up with it while I was sleeping and getting ideas
> too.
>
> Did you learn powerpc assembly during the night or did you know it already ?
I don't really know ppc assembly. I had perused the tree over the l
On Wed, 2024-08-28 at 09:24:27 UTC, Charles Han wrote:
> devm_kasprintf() can return a NULL pointer on failure but this
> returned value is not checked.
>
> Fixes: acfe63ec1c59 ("mtd: Convert to using %pOFn instead of
> device_node.name")
> Signed-off-by: Charles Han
Applied to https://git.kern
Le 06/09/2024 à 16:46, Jason A. Donenfeld a écrit :
On Fri, Sep 06, 2024 at 04:26:32PM +0200, Christophe Leroy wrote:
On the long run I wonder if we should try to find a more generic
solution for getrandom instead of requiring each architecture to handle
it. On gettimeofday the selection of
On Fri Sep 6, 2024 at 8:02 PM EEST, Stefan Berger wrote:
>
>
> On 9/5/24 10:26 AM, Jarkko Sakkinen wrote:
> > On Thu Sep 5, 2024 at 11:52 AM EEST, Kexy Biscuit wrote:
> >> Commit 08d08e2e9f0a ("tpm: ibmvtpm: Call tpm2_sessions_init() to
> >> initialize session support") adds call to tpm2_sessions_i
On Fri, Sep 06, 2024 at 05:14:43PM +0200, Christophe Leroy wrote:
>
>
> Le 06/09/2024 à 16:46, Jason A. Donenfeld a écrit :
> > On Fri, Sep 06, 2024 at 04:26:32PM +0200, Christophe Leroy wrote:
> >
> >> On the long run I wonder if we should try to find a more generic
> >> solution for getrandom
On Fri, 6 Sept 2024 at 05:08, Michael Ellerman wrote:
>
> Please pull some more powerpc fixes for 6.11:
>
> https://git.kernel.org/pub/scm/linux/kernel/git/powerpc/linux.git
> tags/powerpc-6.11-3
Hmm. New pgp key? Please don't take me by surprise like this.
The key looks fine, I see the signa
The pull request you sent on Fri, 06 Sep 2024 22:07:54 +1000:
> https://git.kernel.org/pub/scm/linux/kernel/git/powerpc/linux.git
> tags/powerpc-6.11-3
has been merged into torvalds/linux.git:
https://git.kernel.org/torvalds/c/a78d7dce1e71231cef671ccf5ab48b31606fe352
Thank you!
--
Deet-doot-d
On 9/5/24 10:26 AM, Jarkko Sakkinen wrote:
On Thu Sep 5, 2024 at 11:52 AM EEST, Kexy Biscuit wrote:
Commit 08d08e2e9f0a ("tpm: ibmvtpm: Call tpm2_sessions_init() to
initialize session support") adds call to tpm2_sessions_init() in ibmvtpm,
which could be built as a module. However, tpm2_sessi
Replace `cpumask_any_and(a, b) >= nr_cpu_ids`
with the more readable `!cpumask_intersects(a, b)`.
Signed-off-by: Costa Shulyupin
---
arch/powerpc/sysdev/xive/common.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/arch/powerpc/sysdev/xive/common.c
b/arch/powerpc/sysdev/xive
Linus Torvalds writes:
> On Fri, 6 Sept 2024 at 05:08, Michael Ellerman wrote:
>>
>> Please pull some more powerpc fixes for 6.11:
>>
>> https://git.kernel.org/pub/scm/linux/kernel/git/powerpc/linux.git
>> tags/powerpc-6.11-3
>
> Hmm. New pgp key? Please don't take me by surprise like this.
Y
On Sat, Sep 7, 2024 at 1:50 AM Costa Shulyupin wrote:
>
> Replace `cpumask_any_and(a, b) >= nr_cpu_ids`
> with the more readable `!cpumask_intersects(a, b)`.
>
> Signed-off-by: Costa Shulyupin
> ---
> arch/powerpc/sysdev/xive/common.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> d
Hello Baoquan,
Do you think this patch would help reduce lock contention when
CPU/Memory resources are removed in bulk from a system?
Thanks,
Sourabh Jain
On 23/08/24 17:22, Sourabh Jain wrote:
On a CPU/Memory hotplug event, the kexec lock is taken to update the
kdump image. At the same time
61 matches
Mail list logo