Ian Campbell writes:
> On Sat, 2010-03-13 at 00:29 +, Eric W. Biederman wrote:
>> [...]
>> > after that xen could use
>> > irq_to_desc_alloc_node_f(irq, node, xen_init_chip_data);
>> >
>> > as need...
>> >
>> > at last we don't need to call x86_init_chip_data everywhere.
>
> This was one of
On Sat, 2010-03-13 at 00:29 +, Eric W. Biederman wrote:
> [...]
> > after that xen could use
> > irq_to_desc_alloc_node_f(irq, node, xen_init_chip_data);
> >
> > as need...
> >
> > at last we don't need to call x86_init_chip_data everywhere.
This was one of the things I was considering. It se
Yinghai Lu writes:
> On 03/12/2010 01:45 AM, Ian Campbell wrote:
>> Move arch_init_copy_chip_data and arch_free_chip_data into function
>> pointers in struct irq_chip since they operate on irq_desc->chip_data.
>>
>> arch_init_chip_data cannot be moved into struct irq_chip at this time
>> because
On 03/12/2010 01:45 AM, Ian Campbell wrote:
> Move arch_init_copy_chip_data and arch_free_chip_data into function
> pointers in struct irq_chip since they operate on irq_desc->chip_data.
>
> arch_init_chip_data cannot be moved into struct irq_chip at this time
> because irq_desc->chip is not known
Move arch_init_copy_chip_data and arch_free_chip_data into function
pointers in struct irq_chip since they operate on irq_desc->chip_data.
arch_init_chip_data cannot be moved into struct irq_chip at this time
because irq_desc->chip is not known at the time the irq_desc is
setup. For now rename arc
On Wed, 2010-03-10 at 10:55 +, i...@hellion.org.uk wrote:
> From: Ian Campbell
>
> Move arch_init_copy_chip_data and arch_free_chip_data into function
> pointers in struct irq_chip since they operate on irq_desc->chip_data.
>
> arch_init_chip_data cannot be moved into struct irq_chip at this
Yinghai Lu writes:
> On 03/10/2010 04:51 AM, Ian Campbell wrote:
>> On Wed, 2010-03-10 at 12:06 +, Yinghai Lu wrote:
>>> On Wed, Mar 10, 2010 at 2:55 AM, wrote:
From: Ian Campbell
Move arch_init_copy_chip_data and arch_free_chip_data into function
pointers in struct irq
Ian Campbell writes:
> On Wed, 2010-03-10 at 10:55 +, i...@hellion.org.uk wrote:
>>
>> arch_init_chip_data cannot be moved into struct irq_chip at this time
>> because irq_desc->chip is not known at the time the irq_desc is
>> setup. For now rename arch_init_chip_data to arch_init_irq_desc (
On 03/10/2010 04:51 AM, Ian Campbell wrote:
> On Wed, 2010-03-10 at 12:06 +, Yinghai Lu wrote:
>> On Wed, Mar 10, 2010 at 2:55 AM, wrote:
>>> From: Ian Campbell
>>>
>>> Move arch_init_copy_chip_data and arch_free_chip_data into function
>>> pointers in struct irq_chip since they operate on i
On 03/10/2010 09:42 AM, Eric W. Biederman wrote:
All we need between the Xen and the rest of x86 is a convention
so that we never manage the same irqs. At least for domU we are
in an either/or situation so I don't see even that being a problem.
Dom0 too. This is part of the work implemen
On Wed, 2010-03-10 at 18:15 +, Eric W. Biederman wrote:
> Ian Campbell writes:
>
> > On Wed, 2010-03-10 at 17:42 +, Eric W. Biederman wrote:
> >>
> >>
> >> Ian Xen in this sense is simply not x86. irq_cfg is not acpi or
> >> ioapic or anything but x86 specific. It has everything to d
Ian Campbell writes:
> On Wed, 2010-03-10 at 17:42 +, Eric W. Biederman wrote:
>>
>>
>> Ian Xen in this sense is simply not x86. irq_cfg is not acpi or
>> ioapic or anything but x86 specific. It has everything to do with
>> having a per cpu vector table of 256 entries and architecturally
Ian Campbell writes:
> On Wed, 2010-03-10 at 17:18 +, Eric W. Biederman wrote:
>> Ian Campbell writes:
>>
>> > On Wed, 2010-03-10 at 10:55 +, i...@hellion.org.uk wrote:
>> >>
>> >> arch_init_chip_data cannot be moved into struct irq_chip at this time
>> >> because irq_desc->chip is not
On Wed, 2010-03-10 at 17:42 +, Eric W. Biederman wrote:
>
>
> Ian Xen in this sense is simply not x86. irq_cfg is not acpi or
> ioapic or anything but x86 specific. It has everything to do with
> having a per cpu vector table of 256 entries and architecturally
> receiving a vector number wh
Ian Campbell writes:
> On Wed, 2010-03-10 at 12:06 +, Yinghai Lu wrote:
>> On Wed, Mar 10, 2010 at 2:55 AM, wrote:
>> > From: Ian Campbell
>> >
>> > Move arch_init_copy_chip_data and arch_free_chip_data into function
>> > pointers in struct irq_chip since they operate on irq_desc->chip_dat
On Wed, 2010-03-10 at 17:18 +, Eric W. Biederman wrote:
> Ian Campbell writes:
>
> > On Wed, 2010-03-10 at 10:55 +, i...@hellion.org.uk wrote:
> >>
> >> arch_init_chip_data cannot be moved into struct irq_chip at this time
> >> because irq_desc->chip is not known at the time the irq_desc
On Wed, 2010-03-10 at 12:06 +, Yinghai Lu wrote:
> On Wed, Mar 10, 2010 at 2:55 AM, wrote:
> > From: Ian Campbell
> >
> > Move arch_init_copy_chip_data and arch_free_chip_data into function
> > pointers in struct irq_chip since they operate on irq_desc->chip_data.
> >
> > arch_init_chip_data
From: Ian Campbell
Move arch_init_copy_chip_data and arch_free_chip_data into function
pointers in struct irq_chip since they operate on irq_desc->chip_data.
arch_init_chip_data cannot be moved into struct irq_chip at this time
because irq_desc->chip is not known at the time the irq_desc is
setu
On Wed, Mar 10, 2010 at 2:55 AM, wrote:
> From: Ian Campbell
>
> Move arch_init_copy_chip_data and arch_free_chip_data into function
> pointers in struct irq_chip since they operate on irq_desc->chip_data.
>
> arch_init_chip_data cannot be moved into struct irq_chip at this time
> because irq_de
On Wed, 2010-03-10 at 10:55 +, i...@hellion.org.uk wrote:
>
> arch_init_chip_data cannot be moved into struct irq_chip at this time
> because irq_desc->chip is not known at the time the irq_desc is
> setup. For now rename arch_init_chip_data to arch_init_irq_desc (for
> PowerPC, the only other
20 matches
Mail list logo