On Wed, Nov 30, 2011 at 05:20:22PM +1100, Benjamin Herrenschmidt wrote:
> On Wed, 2011-11-30 at 16:24 +1100, Tony Breeds wrote:
>
> > + cpu@1 {
> > + device_type = "cpu";
> > + model = "PowerPC,476";
> > + reg = <1>;
> > +
On Wed, 2011-11-30 at 16:24 +1100, Tony Breeds wrote:
> + cpu@1 {
> + device_type = "cpu";
> + model = "PowerPC,476";
> + reg = <1>;
> + clock-frequency = <16>; // 1.6 GHz
> + ti
It's only used inside the same file where it's defined. There's
also no point exporting it anymore.
Signed-off-by: Benjamin Herrenschmidt
---
arch/powerpc/include/asm/pci.h |2 --
arch/powerpc/kernel/pci-common.c |3 +--
2 files changed, 1 insertions(+), 4 deletions(-)
diff --git a/ar
On Wed, 2011-11-30 at 16:23 +1100, Tony Breeds wrote:
> Code copied from arch/powerpc/kernel/misc_32.S
>
> Signed-off-by: Tony Breeds
> ---
> arch/powerpc/boot/div64.S | 52
> +
> 1 files changed, 52 insertions(+), 0 deletions(-)
Should we just lin
On Wed, 2011-11-30 at 16:23 +1100, Tony Breeds wrote:
> Signed-off-by: Tony Breeds
> ---
> arch/powerpc/sysdev/ppc4xx_pci.c |6 +++---
> 1 files changed, 3 insertions(+), 3 deletions(-)
>
> diff --git a/arch/powerpc/sysdev/ppc4xx_pci.c
> b/arch/powerpc/sysdev/ppc4xx_pci.c
> index 16f5eba..d
Hi,
Does anyone know of any kernel support for the Freescale P2020-MSC8156 AMC
board?-
http://freescale.com.hk/webapp/sps/site/prod_summary.jsp?code=P2020-MSC8156AMCRD
I am looking for platform-specific files ie. the ones that go in
arch/powerpc/platforms/85xx and DTS files if possible...
Chee
Based on original work by David 'Shaggy' Kliekamp.
Signed-off-by: Tony Breeds
---
arch/powerpc/boot/Makefile |5 +-
arch/powerpc/boot/dts/currituck.dts | 240 ++
arch/powerpc/boot/treeboot-currituck.c | 129 ++
arch/power
Signed-off-by: Tony Breeds
---
arch/powerpc/boot/dcr.h |6 ++
1 files changed, 6 insertions(+), 0 deletions(-)
diff --git a/arch/powerpc/boot/dcr.h b/arch/powerpc/boot/dcr.h
index 645a7c9..51b5893 100644
--- a/arch/powerpc/boot/dcr.h
+++ b/arch/powerpc/boot/dcr.h
@@ -9,6 +9,12 @@
Code copied from arch/powerpc/kernel/misc_32.S
Signed-off-by: Tony Breeds
---
arch/powerpc/boot/div64.S | 52 +
1 files changed, 52 insertions(+), 0 deletions(-)
diff --git a/arch/powerpc/boot/div64.S b/arch/powerpc/boot/div64.S
index d271ab5..bbcb8
From: Christoph Egger
CONFIG_PPC47x doesn't exist in Kconfig, therefore removing all
references for it from the source code.
Signed-off-by: Christoph Egger
---
arch/powerpc/mm/44x_mmu.c |4
1 files changed, 0 insertions(+), 4 deletions(-)
diff --git a/arch/powerpc/mm/44x_mmu.c b/arch
Needed if you want to use swiotlb, harmless otherwise.
Signed-off-by: Tony Breeds
---
arch/powerpc/sysdev/ppc4xx_pci.c |6 ++
1 files changed, 6 insertions(+), 0 deletions(-)
diff --git a/arch/powerpc/sysdev/ppc4xx_pci.c b/arch/powerpc/sysdev/ppc4xx_pci.c
index d3fa380..d766068 100644
-
Signed-off-by: Tony Breeds
---
arch/powerpc/sysdev/ppc4xx_pci.c |6 +++---
1 files changed, 3 insertions(+), 3 deletions(-)
diff --git a/arch/powerpc/sysdev/ppc4xx_pci.c b/arch/powerpc/sysdev/ppc4xx_pci.c
index 16f5eba..d3fa380 100644
--- a/arch/powerpc/sysdev/ppc4xx_pci.c
+++ b/arch/powerpc
Patches 1 and 2
Modify the 44x PCI code to work with currituck.
Patch 3
Is an old patch by Christoph Egger that fell through the cracks somehow.
Patches 4 and 5
Modify the bootwrapper to handle currituck
Patch 6
The platform itself.
arch/powerpc/boot/Makefile
On Wed, 2011-11-30 at 06:55 +0530, Deepthi Dharwar wrote:
> I was trying to add a return value for power_save for all arch/powepc
> idle functions but a few of them directly call *.S routines, as they
> are asm.
>
> What would be a good way to change the return value for asm
> routines ?
> Do we
On Tue, 2011-11-29 at 13:58 -0500, Kyle Moffett wrote:
> Hello,
>
> As BenH requested, this is the version-2 repost of the PowerPC MPIC
> cleanup patch series.
>
> All of the review comments have been addressed, and I have performed
> build and boot testing on our HWW-1U-1A hardware with these pa
Open Firmware on OPAL machines seems to have issues if we close
stdin and/or we try to print things after calling "quiesce" so
we avoid doing both.
Signed-off-by: Benjamin Herrenschmidt
---
arch/powerpc/kernel/prom_init.c | 14 ++
1 files changed, 10 insertions(+), 4 deletions(-)
Signed-off-by: Benjamin Herrenschmidt
---
arch/powerpc/platforms/powernv/pci-ioda.c | 25 ---
arch/powerpc/platforms/powernv/pci-p5ioc2.c |1 +
arch/powerpc/platforms/powernv/pci.c| 117 --
arch/powerpc/platforms/powernv/pci.h| 16
4 fil
This adds some more interfaces for OPAL v2
Signed-off-by: Benjamin Herrenschmidt
---
arch/powerpc/include/asm/opal.h| 131 +++-
arch/powerpc/platforms/powernv/opal-wrappers.S |8 ++
arch/powerpc/platforms/powernv/pci-ioda.c |4 +-
3 files changed
On Fri, 2011-07-01 at 18:03 +0800, tiejun.chen wrote:
>
> Here emulate_step() is called to emulate 'stwu'. Actually this is equivalent
> to
> 1> update pr_regs->gpr[1] = mem(old r1 + (-A))
> 2> 'stw , mem<(old r1 + (-A)) >
>
> You should notice the stack based on new r1 would be covered with mem
Hi Dave,
Unfortunately, your address got cut off for this patch.
I think Ben can merge this one through his powerpc tree since it is just
a trivial change to the ps3 gelic net driver.
Please consider.
-Geoff
On Wed, 2011-11-30 at 01:38 +, Geoff Levand wrote:
> The lv1_net_stop_tx_dma and
On Nov 29, 2011, at 3:48 PM, Scott Wood wrote:
> On 11/29/2011 03:40 PM, Artem Bityutskiy wrote:
>> On Thu, 2011-11-24 at 08:24 -0600, Kumar Gala wrote:
>>> On Nov 22, 2011, at 9:41 PM, Kumar Gala wrote:
>>>
On Oct 31, 2011, at 4:38 AM,
wrote:
> From: Liu Shuo
>
Add an __init annotation to the ps3_smp_probe() routine.
Fixes build warnings like these when
CONFIG_DEBUG_SECTION_MISMATCH=y:
WARNING: Section mismatch in reference from the function .ps3_smp_probe()
Signed-off-by: Geoff Levand
---
arch/powerpc/platforms/ps3/smp.c |2 +-
1 files changed,
Fix some PS3 build warnings when DEBUG is defined.
Fixes warnings like these:
format '%lx' expects type 'long unsigned int', but argument 7 has type 'u64'
Signed-off-by: Geoff Levand
---
arch/powerpc/platforms/ps3/repository.c | 14 --
1 files changed, 8 insertions(+), 6 deleti
The lv1_get_version_info hcall takes 2, not 1 output
arguments. Adjust the lv1 hcall table and all calls.
Usage:
int lv1_get_version_info(u64 *version_number, u64 *vendor_id)
Signed-off-by: Geoff Levand
---
arch/powerpc/include/asm/lv1call.h |2 +-
arch/powerpc/kernel/irq.c |
Refresh ps3_defconfig to latest kernel sources and
change the options:
CONFIG_PPP=m to CONFIG_PPP=n.
CONFIG_NAMESPACES=y to CONFIG_NAMESPACES=n
CONFIG_NUMA=y to CONFIG_NUMA=n
Signed-off-by: Geoff Levand
---
arch/powerpc/configs/ps3_defconfig | 39 ++-
1 f
General code cleanup for PS3 interrupt.c:
o Fill out comments for structure members.
o Move variables ipi_debug_brk_mask and lock from struct ps3_bmp to
struct ps3_private.
o Fix pr_debug build errors when DEBUG is defined.
o Convert bit operation to set_bit().
o Convert DBG macro from pr_
The lv1_net_stop_tx_dma and net_stop_rx_dma hcalls take 2, not 3 input
arguments. Adjust the lv1 hcall table and all calls.
Signed-off-by: Geoff Levand
---
arch/powerpc/include/asm/lv1call.h |4 ++--
drivers/net/ethernet/toshiba/ps3_gelic_net.c |4 ++--
2 files changed, 4 inse
The lv1_get_virtual_address_space_id_of_ppe hcall takes 0, not 1 input
arguments. Adjust the lv1 hcall table and all calls.
Signed-off-by: Geoff Levand
---
arch/powerpc/include/asm/lv1call.h |2 +-
arch/powerpc/platforms/ps3/spu.c |2 +-
2 files changed, 2 insertions(+), 2 deletions(-
The lv1 hcall #91 should be named lv1_read_repository_node, and
not lv1_get_repository_node_value. Adjust the lv1 hcall table
and all calls.
Signed-off-by: Geoff Levand
---
arch/powerpc/include/asm/lv1call.h |2 +-
arch/powerpc/platforms/ps3/repository.c |4 ++--
2 files changed, 3
Hi Ben,
Here are the PS3 updates for 3.3.
The patch 'powerpc/ps3: Fix hcall lv1_net_stop_rx_dma' includes a trivial
change to the ps3_gelic_net driver in drivers/net.
-Geoff
The following changes since commit caca6a03d365883564885f2c1da3e88dcf65d139:
Linus Torvalds (1):
Linux 3.2-rc3
On Tue, Nov 29, 2011 at 10:36:42AM -0600, Becky Bruce wrote:
>
> On Nov 28, 2011, at 11:25 PM, Benjamin Herrenschmidt wrote:
>
> > On Mon, 2011-10-10 at 15:50 -0500, Becky Bruce wrote:
> >> From: Becky Bruce
> >>
> >> This updates the hugetlb page table code to handle 64-bit FSL_BOOKE.
> >> The
On 11/29/2011 12:14 PM, Deepthi Dharwar wrote:
> On 11/29/2011 02:09 AM, Benjamin Herrenschmidt wrote:
>
>> On Mon, 2011-11-28 at 16:33 +0530, Deepthi Dharwar wrote:
>>
>>> On an LPAR if cpuidle is disabled, ppc_md.power_save is still set to
>>> cpuidle_idle_call by default here. This would resul
From: Becky Bruce
Define HUGETLB_NEED_PRELOAD in mmu-book3e.h for CONFIG_PPC64 instead
of having a much more complicated #if block. This is easier to read
and maintain.
Signed-off-by: Becky Bruce
---
arch/powerpc/include/asm/hugetlb.h|3 +--
arch/powerpc/include/asm/mmu-book3e.h |
On Tue, Nov 29, 2011 at 11:25 AM, Ira W. Snyder wrote:
> I believe that you are correct, for powerpc. However, anything outside
> of arch/powerpc shouldn't assume it only runs on powerpc. I wouldn't be
> surprised to see fsldma running on an iMX someday (ARM processor).
I certainly would. The i
Kumar Gala wrote:
>> > The only fix I can think of is to move "fsl,eloplus-dma" into
>> > mpc85xx_common_ids[]. I'll post a patch that does that, and we can
>> > discuss it.
> what if you make the p1022_ds_ids call first? Maybe we need to add 'soc' to
> p1022_ds_ids list
Reversing the calls
On 11/29/2011 03:40 PM, Artem Bityutskiy wrote:
> On Thu, 2011-11-24 at 08:24 -0600, Kumar Gala wrote:
>> On Nov 22, 2011, at 9:41 PM, Kumar Gala wrote:
>>
>>>
>>> On Oct 31, 2011, at 4:38 AM,
>>> wrote:
>>>
From: Liu Shuo
Integrated Flash Controller supports various flashes like
On Thu, 2011-11-24 at 08:24 -0600, Kumar Gala wrote:
> On Nov 22, 2011, at 9:41 PM, Kumar Gala wrote:
>
> >
> > On Oct 31, 2011, at 4:38 AM,
> > wrote:
> >
> >> From: Liu Shuo
> >>
> >> Integrated Flash Controller supports various flashes like NOR, NAND
> >> and other devices using NOR, NAN
On Mon, 2011-10-31 at 17:38 +0800, b35...@freescale.com wrote:
> +/*
> + * fsl_ifc_ctrl_probe
> + *
> + * called by device layer when it finds a device matching
> + * one our driver can handled. This code allocates all of
> + * the resources needed for the controller only. The
> + * resources for
On Nov 29, 2011, at 12:52 PM, Timur Tabi wrote:
> Kumar Gala wrote:
>> Ben would probably have to answer that. I can't remember why he wanted it.
>> I'm sure he has a good reason.
>
> Well, I'm not sure what's going on with the code. I *think* what's happening
> is that the first call of_pl
On 11/28/2011 09:19 PM, Li Yang-R58472 wrote:
>> Subject: Re: [PATCH][RFC] fsldma: fix performance degradation by optimizing
>> spinlock use.
>>
>> On Thu, Nov 24, 2011 at 08:12:25AM +, Shi Xuelin-B29237 wrote:
>>> Hi Ira,
>>>
>>> Thanks for your review.
>>>
>>> After second thought, I think yo
On 11/29/2011 10:20 AM, Timur Tabi wrote:
> Timur Tabi wrote:
>
>> If I move the "fsl,eloplus-dma" into mpc85xx_common_ids[], then everything
>> works.
>>
>> I suspect there's some kind of state machine in of_platform_bus_probe() that
>> allows it to find the DMA channel nodes if it's scanned ev
On 11/29/2011 02:36 AM, Arshad, Farrukh wrote:
> I am loading the kernel from Uboot as following way
>
>
>
> Setenv bootm_low 0x1000
>
> Setenv bootm_size 0x1000
>
> Setenv bootm boot=/dev/mmcblk0p3 ro debug rootdelay=5
>
> Interrupts off
>
> Bootm start $load1addr - $fdt1addr
>
>
The Cell and PowerMac platforms use virtually identical cascaded-IRQ
setup code, so just merge it into the core. Ideally this code would
trigger automatically when an MPIC device-node specifies an "interrupts"
property, perhaps even enabling MPIC_SECONDARY along the way.
Unfortunately, Benjamin H
It turns out that there are only 2 in-tree platforms which use MPICs
which are not "primary": IBM Cell and PowerMac. To reduce the
complexity of the typical board setup code, invert the MPIC_PRIMARY bit
into MPIC_SECONDARY.
Signed-off-by: Kyle Moffett
---
arch/powerpc/include/asm/mpic.h
Don't open-code the OpenFirmware "dcr-reg" property lookup trying to map
DCR resources. This makes the code a bit easier to read.
Signed-off-by: Kyle Moffett
---
arch/powerpc/sysdev/mpic.c |7 ++-
1 files changed, 2 insertions(+), 5 deletions(-)
diff --git a/arch/powerpc/sysdev/mpic.c
There's not really any reason to have this one-liner in a separate
static inline function, given that all the other similar tests are
already in the alloc_mpic() code.
Signed-off-by: Kyle Moffett
---
arch/powerpc/sysdev/mpic.c |7 +--
1 files changed, 1 insertions(+), 6 deletions(-)
dif
Almost all PowerPC platforms use a standard "open-pic" device node so
the mpic_alloc() function now accepts NULL for the device-node. This
will cause it to perform a default search with of_find_matching_node().
Signed-off-by: Kyle Moffett
---
arch/powerpc/platforms/85xx/corenet_ds.c |
Store the node pointer in the MPIC during initialization so that all of
the later operational code can just reuse the cached pointer.
Signed-off-by: Kyle Moffett
---
arch/powerpc/include/asm/mpic.h |3 +++
arch/powerpc/sysdev/mpic.c | 33 -
2 files chan
This removes a bunch of "extern" declarations and CONFIG_SMP ifdefs.
Signed-off-by: Kyle Moffett
Cc: Benjamin Herrenschmidt
Cc: Paul Mackerras
Cc: Kumar Gala
---
arch/powerpc/platforms/85xx/corenet_ds.c |7 +--
arch/powerpc/platforms/85xx/mpc85xx_ds.c |6 +-
arch/powerpc/pla
The MPIC code can already perform an automatic OF address translation
step as part of mpic_alloc(), but several boards need to use that base
address when they perform mpic_assign_isu().
The easiest solution is to save the computed physical address into the
"struct mpic" for later use by the board
Instead of using the open-coded "reg" property lookup and address
translation in mpic_alloc(), directly call of_address_to_resource().
This includes various workarounds for special cases which the naive
of_address_translate() does not.
Afterwards it is possible to remove the copiously copy-pasted
All of the existing callers of mpic_alloc() pass in a non-NULL
device-node pointer, so the checks for a NULL device-node may be
removed.
Signed-off-by: Kyle Moffett
---
arch/powerpc/sysdev/mpic.c | 50 ++-
1 files changed, 21 insertions(+), 29 deletions(
Hello,
As BenH requested, this is the version-2 repost of the PowerPC MPIC
cleanup patch series.
All of the review comments have been addressed, and I have performed
build and boot testing on our HWW-1U-1A hardware with these patches
applied (plus a few independent board-support patches).
Unfort
Kumar Gala wrote:
> Ben would probably have to answer that. I can't remember why he wanted it.
> I'm sure he has a good reason.
Well, I'm not sure what's going on with the code. I *think* what's happening
is that the first call of_platform_bus_probe() is scanning most, but not all,
of the tr
Good grief! Sorry for the spacing mess-up! Here's a resend with reformatting.
Amit,
We aren't using either QEMU or kvmtool, but we are using KVM. All
the issues we are seeing happen when we try to establish multiple
virtioconsoles at boot time. The command line isn't relevant, but I
can tell y
On Tue, Nov 29, 2011 at 03:19:05AM +, Li Yang-R58472 wrote:
> > Subject: Re: [PATCH][RFC] fsldma: fix performance degradation by optimizing
> > spinlock use.
> >
> > On Thu, Nov 24, 2011 at 08:12:25AM +, Shi Xuelin-B29237 wrote:
> > > Hi Ira,
> > >
> > > Thanks for your review.
> > >
> > >
Amit,
We aren't using either QEMU or kvmtool, but we are using KVM. All
theissues we are seeing happen when we try to establish multiple
virtioconsoles at boot time. The command line isn't relevant, but I
cantell you the protocol that's passing between the host (kvm) and
theguest (see the end of
On Nov 28, 2011, at 9:58 PM, Benjamin Herrenschmidt wrote:
> On Mon, 2011-10-10 at 15:50 -0500, Becky Bruce wrote:
>
>> diff --git a/arch/powerpc/include/asm/hugetlb.h
>> b/arch/powerpc/include/asm/hugetlb.h
>> index 8600493..70f9885 100644
>> --- a/arch/powerpc/include/asm/hugetlb.h
>> +++ b/a
On Nov 29, 2011, at 10:20 AM, Timur Tabi wrote:
> Timur Tabi wrote:
>
>> If I move the "fsl,eloplus-dma" into mpc85xx_common_ids[], then everything
>> works.
>>
>> I suspect there's some kind of state machine in of_platform_bus_probe() that
>> allows it to find the DMA channel nodes if it's s
On Nov 28, 2011, at 11:25 PM, Benjamin Herrenschmidt wrote:
> On Mon, 2011-10-10 at 15:50 -0500, Becky Bruce wrote:
>> From: Becky Bruce
>>
>> This updates the hugetlb page table code to handle 64-bit FSL_BOOKE.
>> The previous 32-bit work counted on the inner levels of the page table
>> collap
Timur Tabi wrote:
> If I move the "fsl,eloplus-dma" into mpc85xx_common_ids[], then everything
> works.
>
> I suspect there's some kind of state machine in of_platform_bus_probe() that
> allows it to find the DMA channel nodes if it's scanned everything else
> first. I'm trying to debug it no
Kumar Gala wrote:
>> I don't think this is working. I need to investigate some more to be
>> sure, but it looks like this is not picking up "fsl,eloplus-dma".
>> None of the DMA channels are being probed in the audio driver
>> (sound/soc/fsl_dma.c).
>
> Hmm, that's odd. Should see if the issues
On Nov 28, 2011, at 5:42 PM, Tabi Timur-B04825 wrote:
> On Thu, Nov 17, 2011 at 11:56 AM, Dmitry Eremin-Solenikov
> wrote:
>
>> diff --git a/arch/powerpc/platforms/85xx/p1022_ds.c
>> b/arch/powerpc/platforms/85xx/p1022_ds.c
>> index 00d93a4..cacb4d4 100644
>> --- a/arch/powerpc/platforms/85xx/
Hi,
On (Mon) 28 Nov 2011 [15:40:41], Miche Baker-Harvey wrote:
> Amit,
>
> You said that the work would be serialized "due to port additions
> being on work items on the same workqueue". I'm not seeing that.
You leave a lot of questions unanswered. What's your environment?
Are you hot-plugging
Hi,
I am using custom 460ex board with kernel version 2.6.30.
I noticed that page_alloc() is returning a page whose memory
is already allocated by lmb_alloc() while unflattening the device
tree. As per my knowledge the memory allocated by lmb_alloc()
should be reserved till the end, right?
Some mo
Greetings All,
I am working on P1022RDK (P1022 Processor). I am trying to bring up LTIB Linux
only on Core1 of the processor. I have configured the "cpus" node in the device
tree file as following way
Cpus {
#address-cells = <1>;
#size-cells = <0>;
PowerPC,P1022@1 {
De
This driver works with both, static platform data and device tree
bindings. It has been tested on a TQM855L board with two AN82527
CAN controllers on the local bus.
CC: devicetree-disc...@lists.ozlabs.org
CC: linuxppc-...@ozlabs.org
CC: Kumar Gala
Signed-off-by: Wolfgang Grandegger
Acked-by: Mar
This patch enables or updates support for the CC770 and AN82527
CAN controller on the TQM8548 and TQM8xx boards.
CC: devicetree-disc...@lists.ozlabs.org
CC: linuxppc-...@ozlabs.org
CC: Kumar Gala
Signed-off-by: Wolfgang Grandegger
---
arch/powerpc/boot/dts/tqm8548-bigflash.dts | 19 ++
68 matches
Mail list logo