[PATCH 7/8] fsldma: rename fsl_chan to fchan

2009-12-31 Thread Ira W. Snyder
The name fsl_chan seems too long, so it has been shortened to fchan. Signed-off-by: Ira W. Snyder --- drivers/dma/fsldma.c | 446 +- 1 files changed, 223 insertions(+), 223 deletions(-) diff --git a/drivers/dma/fsldma.c b/drivers/dma/fsldma.c ind

[PATCH 8/8] fsldma: major cleanups and fixes

2009-12-31 Thread Ira W. Snyder
Fix locking. Use two queues in the driver, one for pending transacions, and one for transactions which are actually running on the hardware. Call dma_run_dependencies() on descriptor cleanup so that the async_tx API works correctly. There are a number of places throughout the code where lists of d

[PATCH 5/8] fsldma: clean up the OF subsystem routines

2009-12-31 Thread Ira W. Snyder
This fixes some errors in the cleanup paths of the OF subsystem, including missing checks for ioremap failing. Also, some variables were renamed for brevity. Signed-off-by: Ira W. Snyder --- drivers/dma/fsldma.c | 259 + drivers/dma/fsldma.h |

[PATCH 6/8] fsldma: simplify IRQ probing and handling

2009-12-31 Thread Ira W. Snyder
The IRQ probing is needlessly complex. All off the 83xx device trees in arch/powerpc/boot/dts/ specify 5 interrupts per DMA controller: one for the controller, and one for each channel. These interrupts are all attached to the same IRQ line. This causes an interesting situation if two channels int

[PATCH 3/8] fsldma: rename struct fsl_dma_chan to struct fsldma_chan

2009-12-31 Thread Ira W. Snyder
This is the beginning of a cleanup which will change all instances of "fsl_dma" to "fsldma" to match the name of the driver itself. Signed-off-by: Ira W. Snyder --- drivers/dma/fsldma.c | 128 ++--- drivers/dma/fsldma.h | 26 +- 2 files chan

[PATCH 4/8] fsldma: rename dest to dst for uniformity

2009-12-31 Thread Ira W. Snyder
Most functions in the standard library use "dst" as a parameter, rather than "dest". This renames all use of "dest" to "dst" to match the usual convention. Signed-off-by: Ira W. Snyder --- drivers/dma/fsldma.c | 32 drivers/dma/fsldma.h |2 +- 2 files chang

[PATCH 1/8] fsldma: reduce kernel text size

2009-12-31 Thread Ira W. Snyder
Some of the functions are written in a way where they use multiple reads and writes where a single read/write pair could suffice. This shrinks the kernel text size measurably, while making the functions easier to understand. add/remove: 0/0 grow/shrink: 1/4 up/down: 4/-196 (-192) function

[PATCH 2/8] fsldma: remove unused structure members

2009-12-31 Thread Ira W. Snyder
Remove some unused members from the fsldma data structures. A few trivial uses of struct resource were converted to use the stack rather than keeping the memory allocated for the lifetime of the driver. Signed-off-by: Ira W. Snyder --- drivers/dma/fsldma.c | 17 - drivers/dma/f

fsldma: cleanup driver and fix async_tx compatibility

2009-12-31 Thread Ira W. Snyder
This patch series cleans up the Freescale DMAEngine driver, including verifying the locking and making sure that all code paths are correct. There were a few places that seemed suspicious, and they have been fixed. I have written a quick memory->memory DMAEngine test driver, and the performance is

RE: How to access PPC460EX SDRAM space from PCI/PCIe.

2009-12-31 Thread Tirumala Reddy Marri
It should be able to access any region in 32bit mode as long as it is smaller than 4GB size. Usually whole SDRAM is mapped to inbound PCI memory region. -Original Message- From: linuxppc-dev-bounces+tmarri=amcc@lists.ozlabs.org [mailto:linuxppc-dev-bounces+tmarri=amcc@lists.ozlabs.

Re: [PATCH v2 3/3] powerpc: Add support for ram filesystems in FIT uImages

2009-12-31 Thread Peter Tyser
Hi Wolfgang, > > IIRC, uImage.fit.initrd.% should appear before uImage.fit.% in the > > Makefile so that make behaves more consistently. Speaking of which, > > the number of '.' in the name is getting rather large. Would you > > consider using 'fitImage' instead of 'uImage.fit'? > > Why chose a

Re: [PATCH v2 3/3] powerpc: Add support for ram filesystems in FIT uImages

2009-12-31 Thread Wolfgang Denk
Dear Grant Likely, In message you wrote: > > IIRC, uImage.fit.initrd.% should appear before uImage.fit.% in the > Makefile so that make behaves more consistently. Speaking of which, > the number of '.' in the name is getting rather large. Would you > consider using 'fitImage' instead of 'uImag

[PATCH] POWERPC: Simplify param.h by including

2009-12-31 Thread Robert P. J. Day
Signed-off-by: Robert P. J. Day --- diff --git a/arch/powerpc/include/asm/param.h b/arch/powerpc/include/asm/param.h index 094f63d..965d454 100644 --- a/arch/powerpc/include/asm/param.h +++ b/arch/powerpc/include/asm/param.h @@ -1,22 +1 @@ -#ifndef _ASM_POWERPC_PARAM_H -#define _ASM_POWERPC_PAR

Re: Trouble specifying dts gpio-leds with GPIO expander chip

2009-12-31 Thread Bill Gatliff
Anton Vorontsov wrote: > Though, soon there will be an easier way to register I2C/SPI chips > with the OF GPIO infrastructure. > Should this make me hesitate to update the pca953x driver, or clone it? b.g. -- Bill Gatliff Embedded systems training and consulting http://billgatliff.com b...@

Re: Question on MPC52xx IRQ[123] pins

2009-12-31 Thread Bill Gatliff
Grant Likely wrote: > Correct. IRQ2 can only be used as IRQ2. It cannot be used a GPIO. > (Well, I suppose you *could* try to hack into the interrupt controller > driver and fetch the pin state that way; but I don't know if you can > read the state of masked out IRQ pins, and it sure would be ugl

RE: [PATCH] arch/powerpc/boot/devtree.c: use %pM to show MAC address

2009-12-31 Thread H Hartley Sweeten
On Wednesday, December 30, 2009 9:49 PM, Paul Mackerras wrote: > On Wed, Dec 30, 2009 at 02:30:39PM -0500, H Hartley Sweeten wrote: > >> Use the %pM kernel extension to display the MAC address. >> >> Signed-off-by: H Hartley Sweeten >> >> --- > > Nak - this isn't the kernel, this is a separate p

How to access PPC460EX SDRAM space from PCI/PCIe.

2009-12-31 Thread Lonsn
Hi: I'm now using canyonlands board with latest u-boot and linux kernel from DENX git. A PCIe card is plugged in the PCIeX4 slot. The PCIe card is a PCIe-pci bridge(PI7C9X130) plus an Altera fpga. The PCIe card act as a PCI master and send data to SDRAM of 460EX space (total sdram 512MB, reserve 8M

Re: [HELP] BAD interrupts

2009-12-31 Thread Régis Odeyé
Hi, We experimented something similar with a 8641D board. This seems to come from the gianfar and: - when we are binding the three interruptions enet_tx, enet_rx and enet_err of each interfaces on the same processor, the BAD interruptions do not increase any more. - when we are compiling the d

Re: [PATCH v2 3/3] powerpc: Add support for ram filesystems in FIT uImages

2009-12-31 Thread Peter Korsgaard
> "Grant" == Grant Likely writes: Hi, Grant> Personally, I don't get any benefit out of the new image format, Grant> so I haven't spent any time looking at it. However, I'm Grant> concerned about the drift back towards a different image per Grant> target when the move over the last 4 ye