On Mon, 17 Sep 2007 16:28:31 +1000 Stephen Rothwell <[EMAIL PROTECTED]> wrote:
>
> the topology (on my POWERPC5+ box) is not correct:
>
> cpu0/topology/thread_siblings:000f
> cpu1/topology/thread_siblings:000f
> cpu2/topology/thread_siblings:000f
> cpu3/topology/thread_siblings:0
On Tue, 11 Sep 2007 18:56:53 -0700 [EMAIL PROTECTED] wrote:
>
> Convert cpu_sibling_map to a per_cpu cpumask_t array for the ppc64
> architecture. This fixes build errors in block/blktrace.c and
> kernel/sched.c when CONFIG_SCHED_SMT is defined.
>
> Note: these changes have not been built nor tes
On Mon, Sep 17, 2007 at 07:34:08AM +0200, Stefan Roese wrote:
>
> My understanding was, that adding many #ifdef's into the code was not the
> preferred way.
But just making a copy seems to be a proffered one? Wow.
OCP and/or OF part is quite small part of the driver; another approach
would be
msic_dcr_read() doesn't really do anything useful, just replace it with
direct calls to dcr_read().
Use dcr_map_reg() in the axon_msi setup code, rather than essentially doing
it by hand.
Signed-off-by: Michael Ellerman <[EMAIL PROTECTED]>
---
arch/powerpc/platforms/cell/axon_msi.c | 22 +++---
Add a helper routine to map dcr's based on the "dcr-reg" property of
a device node.
Signed-off-by: Michael Ellerman <[EMAIL PROTECTED]>
---
arch/powerpc/sysdev/dcr.c | 17 +
include/asm-powerpc/dcr.h |1 +
2 files changed, 18 insertions(+), 0 deletions(-)
diff --git a/arch/
Now that all users of dcr_read()/dcr_write() add the dcr_host_t.base, we can
save them the trouble and do it in dcr_read()/dcr_write().
Signed-off-by: Michael Ellerman <[EMAIL PROTECTED]>
---
arch/powerpc/platforms/cell/axon_msi.c |4 ++--
arch/powerpc/sysdev/mpic.c |4 ++--
d
Now that dcr_host_t contains the base address, we can use that in the
axon_msi code, rather than storing it separately.
Signed-off-by: Michael Ellerman <[EMAIL PROTECTED]>
---
arch/powerpc/platforms/cell/axon_msi.c | 13 ++---
1 files changed, 6 insertions(+), 7 deletions(-)
diff --git
This requires us to do a sort-of fake dcr_map(), so that base is set
properly. This will be fixed/removed when the device-tree-aware emac driver
is merged.
Signed-off-by: Michael Ellerman <[EMAIL PROTECTED]>
---
drivers/net/ibm_emac/ibm_emac_mal.c |5 -
drivers/net/ibm_emac/ibm_emac_mal.h
Now that dcr_host_t contains the base address, we can use that in the mpic
code, rather than storing it separately.
Signed-off-by: Michael Ellerman <[EMAIL PROTECTED]>
---
arch/powerpc/sysdev/mpic.c | 28 +++-
include/asm-powerpc/mpic.h |6 --
2 files changed, 11
In its current form, dcr_map() doesn't remember the base address you passed
it, which means you need to store it somewhere else. Rather than adding the
base to another struct it seems simpler to store it in the dcr_host_t.
Signed-off-by: Michael Ellerman <[EMAIL PROTECTED]>
---
arch/powerpc/sysde
pci_device_to_OF_node() returns the device node attached to a PCI device,
but doesn't actually grab a reference - we need to do it ourselves.
Signed-off-by: Michael Ellerman <[EMAIL PROTECTED]>
---
arch/powerpc/platforms/cell/axon_msi.c |4 ++--
1 files changed, 2 insertions(+), 2 deletions(-
On Mon, Sep 17, 2007 at 07:34:08AM +0200, Stefan Roese wrote:
> On Sunday 16 September 2007, Eugene Surovegin wrote:
> > Hmm, I just noticed that you basically added a copy of existing
> > driver with small changes to support OF while keeping OCP one.
> >
> > Why not just add OF support to the exis
Flat device trees always have integers in their structure stored as
big-endian. From this point of view, property values are
bags-of-bytes and any endianness is up to users of the device tree to
determine.
The libfdt testcases which use properties with integer values,
currently use native endian
On Sunday 16 September 2007, Eugene Surovegin wrote:
> Hmm, I just noticed that you basically added a copy of existing
> driver with small changes to support OF while keeping OCP one.
>
> Why not just add OF support to the existing code (under some ifdef),
> and then remove OCP support as soon as p
It is just a C char array, so declare it thusly.
Signed-off-by: Stephen Rothwell <[EMAIL PROTECTED]>
---
arch/powerpc/kernel/head_32.S|8
arch/powerpc/kernel/head_40x.S |7 ---
arch/powerpc/kernel/head_44x.S |8
arch/powerpc/kernel/head_64.S
run_tests.sh from the dtc testsuite currently has a facility ro run
just "functional" or just "stress" tests. This distinction is carried
over from libhugetlbfs where the test framework originated, and where
it made sense.
In dtc, we have no stress tests, so running these subsections isn't
partic
This patch adds a function to libfdt to locate nodes containing a
property with a specific value.
Signed-off-by: David Gibson <[EMAIL PROTECTED]>
Index: dtc/libfdt/fdt_ro.c
===
--- dtc.orig/libfdt/fdt_ro.c2007-09-17 14:00:22.
On Sun, 2007-09-16 at 22:39 -0500, Olof Johansson wrote:
> On Sun, Sep 16, 2007 at 10:26:37PM -0500, Josh Boyer wrote:
> > On Mon, 2007-09-17 at 12:52 +1000, David Gibson wrote:
> > > On Fri, Sep 14, 2007 at 03:44:47PM -0500, Hollis Blanchard wrote:
> > > > Implement udbg_getc() for 440, which fixe
Create a helper function (alloc_maybe_bootmem) that is marked __init_refok
to limit the chances of mistakenly refferring to other __init routines.
WARNING: vmlinux.o(.text+0x2a9c4): Section mismatch: reference to
.init.text:.__alloc_bootmem (between '.update_dn_pci_info' and
'.pci_dn_reconfig_no
Removes these warnings:
/home/sfr/kernels/linus/drivers/ide/ppc/pmac.c: In function
'pmac_ide_dma_check':
/home/sfr/kernels/linus/drivers/ide/ppc/pmac.c:1807: warning: unused variable
'map'
/home/sfr/kernels/linus/drivers/ide/ppc/pmac.c:1805: warning: unused variable
'pmif'
Signed-off-by: Step
On Sun, Sep 16, 2007 at 10:26:37PM -0500, Josh Boyer wrote:
> On Mon, 2007-09-17 at 12:52 +1000, David Gibson wrote:
> > On Fri, Sep 14, 2007 at 03:44:47PM -0500, Hollis Blanchard wrote:
> > > Implement udbg_getc() for 440, which fixes xmon input.
> > > Signed-off-by: Hollis Blanchard <[EMAIL PROTE
On Mon, 2007-09-17 at 12:52 +1000, David Gibson wrote:
> On Fri, Sep 14, 2007 at 03:44:47PM -0500, Hollis Blanchard wrote:
> > Implement udbg_getc() for 440, which fixes xmon input.
> > Signed-off-by: Hollis Blanchard <[EMAIL PROTECTED]>
> Acked-by: David Gibson <[EMAIL PROTECTED]>
>
I fixed up t
On Fri, Sep 14, 2007 at 01:11:07PM -0500, Kumar Gala wrote:
>
> On Sep 14, 2007, at 11:28 AM, Jon Loeliger wrote:
>
> > Kumar Gala wrote:
> >
> >> Someone really needs to add some macro/preprocessor magic into DTC
> >> so this is made a lot simpler.
> >> - k
> >
> > Kumar,
> >
> > I am serious
On Fri, Sep 14, 2007 at 03:44:47PM -0500, Hollis Blanchard wrote:
> Implement udbg_getc() for 440, which fixes xmon input.
> Signed-off-by: Hollis Blanchard <[EMAIL PROTECTED]>
Acked-by: David Gibson <[EMAIL PROTECTED]>
--
David Gibson| I'll have my music baroque, and my code
On Sat, Sep 15, 2007 at 09:20:10PM +0200, Segher Boessenkool wrote:
> >> Maybe we can have U-Boot add the partition information if it's
> >> missing in the device tree, and extend the mtdparts command in U-Boot
> >> to add / adjust settings so they match what is defined in U-Boot.
> >
> > Th
On Sat, Sep 15, 2007 at 05:09:01PM +0200, Wolfgang Denk wrote:
> In message <[EMAIL PROTECTED]> Josh Boyer wrote:
> > On Sat, 2007-09-15 at 05:23 +0200, Stefan Roese wrote:
> ...
> > > There are not only Bamboo board running PIBS, but running U-Boot too. How
> > > should we handle this different F
On Sun, Sep 16, 2007 at 06:27:47PM +0200, Robert Schwebel wrote:
> On Sun, Sep 16, 2007 at 01:52:02PM +0200, Stefan Roese wrote:
> > diff --git a/drivers/i2c/busses/Kconfig b/drivers/i2c/busses/Kconfig
> > index 9f3a4cd..12453e2 100644
> > --- a/drivers/i2c/busses/Kconfig
> > +++ b/drivers/i2c/buss
On Sun, Sep 16, 2007 at 11:53:30AM -0700, Eugene Surovegin wrote:
> On Sun, Sep 16, 2007 at 01:52:02PM +0200, Stefan Roese wrote:
> > This patch reworks existing ibm-iic driver to an of_platform_device
> > and enables it to talk to device tree directly. The ocp quirks are
> > completely removed by
Hi,
I made EDK tcl script for generation DTS test scructure for FDT. Script
support Microblaze and PowerPC 405.
Script was primary built for generation U-BOOT configs files for Microblaze.
For Microblaze can you generate both files (FDT and U-BOOT).
For PowerPC can you generate only DTS file. Gene
On Sun, Sep 16, 2007 at 11:07:23AM +0200, Stefan Roese wrote:
> On Saturday 15 September 2007, Vitaly Bordug wrote:
> > > Where is dev->clkdiv initialized?
> > >
> > > My original version used iic_clkdiv() to calculate correct devider
> > > based on OPB frequency. Did you even test this code?
>
>
On Sun, Sep 16, 2007 at 01:52:02PM +0200, Stefan Roese wrote:
> This patch reworks existing ibm-iic driver to an of_platform_device
> and enables it to talk to device tree directly. The ocp quirks are
> completely removed by this patch.
>
> This is done to enable I2C support for the PPC4xx platfor
On Sun, Sep 16, 2007 at 01:52:02PM +0200, Stefan Roese wrote:
> diff --git a/drivers/i2c/busses/Kconfig b/drivers/i2c/busses/Kconfig
> index 9f3a4cd..12453e2 100644
> --- a/drivers/i2c/busses/Kconfig
> +++ b/drivers/i2c/busses/Kconfig
> @@ -220,7 +220,17 @@ config I2C_PIIX4
>
> config I2C_IBM_II
On Sun, 16 Sep 2007 18:27:47 +0200
Robert Schwebel <[EMAIL PROTECTED]> wrote:
> On Sun, Sep 16, 2007 at 01:52:02PM +0200, Stefan Roese wrote:
> > diff --git a/drivers/i2c/busses/Kconfig b/drivers/i2c/busses/Kconfig
> > index 9f3a4cd..12453e2 100644
> > --- a/drivers/i2c/busses/Kconfig
> > +++ b/dr
On Sep 16, 2007, at 5:53 AM, Sylvain Munaut wrote:
> This patch adds support for the core of the BestComm API
> for the Freescale MPC5200(b). The BestComm engine is a
> microcode-controlled / tasks-based DMA used by several
> of the onchip devices.
>
> Setting up the tasks / memory allocation and
On Sep 16, 2007, at 5:53 AM, Sylvain Munaut wrote:
> Instead of having in the makefile all the option that
> requires rheap, we define a configuration symbol
> and when needed we make sure it's selected.
>
> Signed-off-by: Sylvain Munaut <[EMAIL PROTECTED]>
> ---
> arch/powerpc/Kconfig
On Sun, 16 Sep 2007 12:53:27 +0200 Sylvain Munaut <[EMAIL PROTECTED]> wrote:
>
> +++ b/arch/powerpc/sysdev/bestcomm/Makefile
> @@ -0,0 +1,8 @@
> +#
> +# Makefile for BestComm & co
> +#
> +
> +bestcomm-core-objs := bestcomm.o sram.o
> +
> +obj-$(CONFIG_PPC_BESTCOMM) += bestcomm-core.o
O
This patch reworks existing ibm-iic driver to an of_platform_device
and enables it to talk to device tree directly. The ocp quirks are
completely removed by this patch.
This is done to enable I2C support for the PPC4xx platforms now
being moved from arch/ppc (OCP) to arch/powerpc (of). The first b
This is the microcode for the GenBD task and the associated
support code. This is a generic task that copy data to/from
a hardware FIFO. This is currently locked to 32bits wide
access but could be extended as needed.
The microcode itself comes directly from the offical
API (v2.2)
Signed-off-by: S
This is the microcode for the FEC task and the associated
support code.
The microcode itself comes directly from the offical
API (v2.2)
Signed-off-by: Sylvain Munaut <[EMAIL PROTECTED]>
---
arch/powerpc/sysdev/bestcomm/Kconfig|7 +
arch/powerpc/sysdev/bestcomm/Makefile
This patch adds support for the core of the BestComm API
for the Freescale MPC5200(b). The BestComm engine is a
microcode-controlled / tasks-based DMA used by several
of the onchip devices.
Setting up the tasks / memory allocation and all common
low level functions are handled by this patch.
The s
This is the microcode for the ATA task and the associated
support code.
The microcode itself comes directly from the offical
API (v2.2)
Signed-off-by: Sylvain Munaut <[EMAIL PROTECTED]>
---
arch/powerpc/sysdev/bestcomm/Kconfig |7 +
arch/powerpc/sysdev/bestcomm/Makefile|2
On the mpc5200b the ccr register is 32 bits wide while on the
mpc5200 it's only 16 bits. It's up to the driver to use the
correct format depending on the chip it's running on.
The 5200b also offers some more registers & status in AC97
mode. Again, if not running on a 5200b the driver should not
us
Instead of having in the makefile all the option that
requires rheap, we define a configuration symbol
and when needed we make sure it's selected.
Signed-off-by: Sylvain Munaut <[EMAIL PROTECTED]>
---
arch/powerpc/Kconfig |2 ++
arch/powerpc/lib/Kconfig |3
Theses can be useful in modules too. So we export them.
Signed-off-by: Sylvain Munaut <[EMAIL PROTECTED]>
---
arch/powerpc/lib/rheap.c | 15 +++
1 files changed, 15 insertions(+), 0 deletions(-)
diff --git a/arch/powerpc/lib/rheap.c b/arch/powerpc/lib/rheap.c
index ada5b42..22c3b4f
Hello Paul, Hi everyone,
This series of patch is mainly the bestcomm support for
the mpc5200. It was posted a while ago and received some
comments. Theses are all addressed here (afaik).
The first few patch are more a preparation for what
follows. (rheap module support & extended fields in psc
st
On Saturday 15 September 2007, Stephen Rothwell wrote:
> [Just some trivial things]
Thanks for the feedback. I'll change those things and resubmit.
Best regads,
Stefan
___
Linuxppc-dev mailing list
Linuxppc-dev@ozlabs.org
https://ozlabs.org/mailman/list
On Saturday 15 September 2007, Vitaly Bordug wrote:
> > Where is dev->clkdiv initialized?
> >
> > My original version used iic_clkdiv() to calculate correct devider
> > based on OPB frequency. Did you even test this code?
Yes, I tested it successfully on the Sequoia eval board.
> heh, just my $0.
47 matches
Mail list logo