On Thu, Jul 3, 2014 at 1:18 AM, Christoph Hellwig wrote:
> On Mon, Jun 30, 2014 at 05:19:57PM -0700, Adam Radford wrote:
>> James/linux-scsi,
>>
>> The following patch for megaraid_sas fixes the LD/VF affiliation policy
>> parsing code to account for LD targetId's and Hidden LD's (not yet
>> aff
2014-07-03 19:45 GMT+02:00 Joe Lawrence :
> On Wed, 28 May 2014, Christoph Hellwig wrote:
>
>> > - ioc_status = le16_to_cpu(mpi_reply->IOCStatus) & MPI2_IOCSTATUS_MASK;
>> > + if (mpi_reply) {
>> > + ioc_status = le16_to_cpu(mpi_reply->IOCStatus) &
>> > MPI2_IOCSTATUS_MASK;
>> > +
On Wed, 28 May 2014, Christoph Hellwig wrote:
> > - ioc_status = le16_to_cpu(mpi_reply->IOCStatus) & MPI2_IOCSTATUS_MASK;
> > + if (mpi_reply) {
> > + ioc_status = le16_to_cpu(mpi_reply->IOCStatus) &
> > MPI2_IOCSTATUS_MASK;
> > + }
> >
> > if (ioc_status != MPI2_IOCSTATUS_S
On Thu, 2014-07-03 at 09:33 -0700, Christoph Hellwig wrote:
> On Thu, Jul 03, 2014 at 09:27:48AM -0700, Greg Kroah-Hartman wrote:
> > I copy everyone on the patch. You were not on that patch as it doesn't
> > look like it went through your tree at all.
>
> It went through the target tree despite
ALIGN is certainly more readable to me.
Reviewed-by: Joe Lawrence
-- Joe
On Tue, 1 Jul 2014, Rasmus Villemoes wrote:
> Rounding up to a multiple of 4 should be done using the ALIGN
> macro. As a bonus, this also makes the generated code smaller.
>
> In GetIocFacts(), sz is assigned to a few l
Thanks Vikas,
I've applied this to my drivers queue for 3.17, which I will push out
publically as soon the current set of 3.16 updates has hit Linus' tree.
--
To unsubscribe from this list: send the line "unsubscribe linux-scsi" in
the body of a message to majord...@vger.kernel.org
More majordomo
Thanks Stephen,
applied to the for 3.17 queue.
--
To unsubscribe from this list: send the line "unsubscribe linux-scsi" in
the body of a message to majord...@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
On 07/03/2014 12:11 PM, Christoph Hellwig wrote:
> On Thu, Jul 03, 2014 at 10:05:57AM -0500, Stephen M. Cameron wrote:
>> From: Stephen M. Cameron
>>
>> Don't loop through all the devices even after
>> finding the one we're looking for
>
> The comments in the code seem to indicate that we want to
On Thu, Jul 03, 2014 at 09:57:32AM -0700, Steven Haber wrote:
> Both patches work fine -- zero uncommitted writes over several hundred
> power cycles.
Thanks for the testing.
Below is James' patch with a trivial comment fix and a proper changelog.
James, can I get your signoff for this one? I'll
On Thu, Jul 03, 2014 at 10:05:57AM -0500, Stephen M. Cameron wrote:
> From: Stephen M. Cameron
>
> Don't loop through all the devices even after
> finding the one we're looking for
The comments in the code seem to indicate that we want to modify
the queue depth for all LUNs on a given target.
C
Both patches work fine -- zero uncommitted writes over several hundred
power cycles.
On Tue, Jul 1, 2014 at 1:15 AM, Christoph Hellwig wrote:
> On Mon, Jun 30, 2014 at 11:45:31AM -0700, Steven Haber wrote:
>> Our qual rig is having some woes. I'll let you know how the test works
>> out after I fi
On Thu, Jul 03, 2014 at 09:27:48AM -0700, Greg Kroah-Hartman wrote:
> I copy everyone on the patch. You were not on that patch as it doesn't
> look like it went through your tree at all.
It went through the target tree despite exclusive touching scsi
initiator side code. I'm still not sure how t
On Thu, Jul 03, 2014 at 06:54:05AM -0700, James Bottomley wrote:
> Well it did:
>
> https://git.kernel.org/cgit/linux/kernel/git/stable/linux-stable.git/commit/drivers/scsi?h=linux-3.15.y&id=04423ddea30a7fb7232636eda8aed55ea5b972fe
>
> The stable process is a bit broken from my point of view sinc
On Thu, Jul 03, 2014 at 06:54:05AM -0700, James Bottomley wrote:
> On Wed, 2014-07-02 at 23:05 -0700, Christoph Hellwig wrote:
> > On Wed, Jul 02, 2014 at 03:52:35PM -0700, James Bottomley wrote:
> > > In which case it's not marked for stable backport ... I assume it should
> > > be?
> >
> > Only
On Thu, 26 Jun 2014 20:14:15 -0700
James Bottomley wrote:
> On Thu, 2014-06-26 at 21:06 -0400, Steven Rostedt wrote:
> > As this patch is in my 3.17 queue and it touches the kvm and scsi
> > tracepoint code, I figured I should at least do the courtesy of
> > notifying the maintainers of those sub
On 14-07-03 11:05 AM, Stephen M. Cameron wrote:
From: Stephen M. Cameron
Don't loop through all the devices even after
finding the one we're looking for
Signed-off-by: Stephen M. Cameron
Reviewed-by: Robert Elliott
With my scsi_debug testing on Christoph's core-for-3.17
tree I can simulate
From: Stephen M. Cameron
Signed-off-by: Stephen M. Cameron
Reviewed-by: Joe Handzik
---
drivers/scsi/hpsa.c |4 +++-
1 files changed, 3 insertions(+), 1 deletions(-)
diff --git a/drivers/scsi/hpsa.c b/drivers/scsi/hpsa.c
index 08b34e9..794d726 100644
--- a/drivers/scsi/hpsa.c
+++ b/driver
From: Stephen M. Cameron
a 6-byte READ/WRITE CDB with a 0 block data transfer really
means a 256 block data transfer. The RAID mapping code failed
to handle this case. For 10/12/16 byte READ/WRITEs, 0 just means
no data should be transferred, and should not trigger BUG_ON.
Signed-off-by: Steph
From: Robert Elliott
Signed-off-by: Robert Elliott
Signed-off-by: Stephen M. Cameron
Reviewed-by: Stephen M. Cameron
---
drivers/scsi/hpsa.c | 16
1 files changed, 8 insertions(+), 8 deletions(-)
diff --git a/drivers/scsi/hpsa.c b/drivers/scsi/hpsa.c
index a97a7ff..f937ea9
From: Stephen M. Cameron
When copy_from_user fails, return -EFAULT, not -ENOMEM
Signed-off-by: Stephen M. Cameron
Reported-by: Robert Elliott
Reviewed-by: Joe Handzik
Reviewed-by: Scott Teel
Cc:
---
drivers/scsi/hpsa.c |2 +-
1 files changed, 1 insertions(+), 1 deletions(-)
diff --git
Nothing very big here, just a few small updates for now.
I still have a giant ball of patches waiting in the wings, but it
is unfortunately not quite ready yet.
---
Robert Elliott (1):
hpsa: do not unconditionally copy sense data
Stephen M. Cameron (4):
hpsa: remove online devices f
From: Stephen M. Cameron
When devices come on line, they should be removed from the list of
offline devices that are monitored.
Signed-off-by: Stephen M. Cameron
Reviewed-by: Scott Teel
Reviewed-by: Joe Handzik
---
drivers/scsi/hpsa.c |6 +-
1 files changed, 5 insertions(+), 1 deleti
From: Stephen M. Cameron
Don't loop through all the devices even after
finding the one we're looking for
Signed-off-by: Stephen M. Cameron
Reviewed-by: Robert Elliott
---
drivers/scsi/scsi_error.c |2 ++
1 files changed, 2 insertions(+), 0 deletions(-)
diff --git a/drivers/scsi/scsi_erro
On 7/3/2014 5:17 PM, Bart Van Assche wrote:
This patch series consists of the following five patches, of which three
are bug fixes and two are performance optimizations:
0001-scsi_transport_srp-Fix-fast_io_fail_tmo-dev_loss_tmo.patch
0002-IB-srp-Fix-deadlock-between-host-removal-and-multipa.patc
(CC'ing linux-scsi)
On 07/03/14 15:45, Bart Van Assche wrote:> If scsi_remove_host() is called
while an rport is in the blocked
> state then scsi_remove_host() will only finish if the rport is
> unblocked from inside a timer function. Make sure that an rport
> only enters the blocked state if a t
(CC-ing linux-scsi)
On 07/03/14 15:44, Bart Van Assche wrote:
> This patch series consists of the following five patches, of which three
> are bug fixes and two are performance optimizations:
>
> 0001-scsi_transport_srp-Fix-fast_io_fail_tmo-dev_loss_tmo.patch
> 0002-IB-srp-Fix-deadlock-between-ho
Hello,
On Wed, Jul 02, 2014 at 03:45:07PM +0530, Suman Tripathi wrote:
> +int ahci_restart_engine(struct ata_port *ap)
> +{
> + struct ahci_host_priv *hpriv = ap->host->private_data;
> +
> + ahci_stop_engine(ap);
> + ahci_start_fis_rx(ap);
> + hpriv->start_engine(ap);
> +
> + r
On Wed, 2014-07-02 at 23:05 -0700, Christoph Hellwig wrote:
> On Wed, Jul 02, 2014 at 03:52:35PM -0700, James Bottomley wrote:
> > In which case it's not marked for stable backport ... I assume it should
> > be?
>
> Only if the patch that regression went to stable, which it shouldn't,
Well it did
On Thu, Jul 03, 2014 at 01:43:48AM -0700, Christoph Hellwig wrote:
> On Thu, Jun 26, 2014 at 09:34:45AM -0500, scame...@beardog.cce.hp.com wrote:
> > Thanks.
>
> Do you plan to include this with the next hpsa update, or should I take
> this as an ACK and apply it?
Take it as an ACK. I should hav
From: Vikas Chaudhary
Signed-off-by: Vikas Chaudhary
Acked-by: Eddie Wai
---
MAINTAINERS | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/MAINTAINERS b/MAINTAINERS
index 2482eee..dec99fb 100644
--- a/MAINTAINERS
+++ b/MAINTAINERS
@@ -1943,13 +1943,13 @@ S: Supported
From: Vikas Chaudhary
QLogic has acquired the NetXtremeII products and drivers from Broadcom.
This patch re-brands bnx2i driver as a QLogic driver
Signed-off-by: Vikas Chaudhary
Acked-by: Eddie Wai
---
drivers/scsi/bnx2i/57xx_iscsi_constants.h | 6 --
drivers/scsi/bnx2i/57xx_iscsi_hsi.h
From: Vikas Chaudhary
The following set of patches are for rebranding Broadcom bnx2i and bnx2fc
driver as QLogic drivers.
Please apply the following patches to the scsi tree at your earliest
convenience.
Saurav Kashyap (1):
bnx2fc: Rebranding bnx2fc driver
Vikas Chaudhary (2):
bnx
From: Saurav Kashyap
QLogic has acquired the NetXtremeII products and drivers from Broadcom.
This patch re-brands bnx2fc driver as a QLogic driver
Signed-off-by: Saurav Kashyap
Signed-off-by: Vikas Chaudhary
Acked-by: Eddie Wai
---
drivers/scsi/bnx2fc/57xx_hsi_bnx2fc.h | 13 +
d
On 7/3/2014 12:35 PM, Sagi Grimberg wrote:
On 5/29/2014 6:28 AM, Martin K. Petersen wrote:
The protection interval is not necessarily tied to the logical block
size of a block device. Stop using the terms sector and sectors.
Signed-off-by: Martin K. Petersen
---
block/bio-integrity.c | 46
On 6/11/2014 7:35 PM, Christoph Hellwig wrote:
On Wed, May 28, 2014 at 11:28:38PM -0400, Martin K. Petersen wrote:
bip_buf is not really needed so we can remove it.
Signed-off-by: Martin K. Petersen
Looks good,
Reviewed-by: Christoph Hellwig
Reviewed-by: Sagi Grimberg
--
To unsubscribe
On 5/29/2014 6:28 AM, Martin K. Petersen wrote:
We'd occasionally merge requests with conflicting integrity flags.
Introduce a merge helper which checks that the requests have compatible
integrity payloads.
Signed-off-by: Martin K. Petersen
---
block/blk-integrity.c | 36
On 5/29/2014 6:28 AM, Martin K. Petersen wrote:
Move flags affecting the integrity code out of the bio bi_flags and into
the block integrity payload.
Signed-off-by: Martin K. Petersen
---
block/bio-integrity.c | 4 ++--
drivers/scsi/sd_dif.c | 4 ++--
include/linux/bio.h | 2
On 6/25/2014 2:49 PM, Martin K. Petersen wrote:
"Christoph" == Christoph Hellwig writes:
Christoph> On Wed, Jun 11, 2014 at 09:30:34PM -0400, Martin K. Petersen wrote:
/sys/block/foo/integrity/disk_is_formatted_with_pi
/sys/block/foo/integrity/disk_is_integrity_capable
/sys/block/foo/integrity
On 5/29/2014 6:28 AM, Martin K. Petersen wrote:
Add a BLK_ prefix to the integrity profile flags. Also rename the flags
to be more consistent with the generate/verify terminology in the rest
of the integrity code.
Signed-off-by: Martin K. Petersen
---
block/bio-integrity.c | 4 ++--
block/
On 5/29/2014 6:28 AM, Martin K. Petersen wrote:
Instead of the "operate" parameter we pass in a seed value and a pointer
to a function that can be used to process the integrity metadata. The
generation function is changed to have a return value to fit into this
scheme.
Signed-off-by: Martin K. P
On 5/29/2014 6:28 AM, Martin K. Petersen wrote:
The protection interval is not necessarily tied to the logical block
size of a block device. Stop using the terms sector and sectors.
Signed-off-by: Martin K. Petersen
---
block/bio-integrity.c | 46 +
On 6/12/2014 3:18 AM, Martin K. Petersen wrote:
"Christoph" == Christoph Hellwig writes:
Christoph> Instead of having a union of pointer just make it a void
Christoph> pointer. I also think special is a terribly generic name, but
Christoph> I don't really have a better idea at hand.
I needed s
On 6/11/2014 7:31 PM, Christoph Hellwig wrote:
On Wed, May 28, 2014 at 11:28:35PM -0400, Martin K. Petersen wrote:
bdev_integrity_enabled() is only used by bio_integrity_enabled().
Combine these two functions.
Signed-off-by: Martin K. Petersen
Looks good,
Reviewed-by: Christoph Hellwig
Re
On Thu, Jun 26, 2014 at 09:34:45AM -0500, scame...@beardog.cce.hp.com wrote:
> Thanks.
Do you plan to include this with the next hpsa update, or should I take
this as an ACK and apply it?
--
To unsubscribe from this list: send the line "unsubscribe linux-scsi" in
the body of a message to majord..
On Sat, Jun 28, 2014 at 09:54:02AM -0700, Joe Perches wrote:
> These haven't had a single ack by the listed maintainer
> in all git history and the email addresses don't work.
>
> And entry for Michael Neuffer is already in CREDITS.
Looks fine to me..
--
To unsubscribe from this list: send the l
Suresh,
do you maintain pm8001 for pmcs now? There have been lots of pm8001
patches on the list, many of them with reviews from various people
including Jack. I'd be really greatful if someone could collect them
and resend them as a single coherent series.
Also it the MAINTAINERS information fo
On Wed, Jun 25, 2014 at 08:38:47PM +, Elliott, Robert (Server Storage)
wrote:
> Since the ACTION_FAIL case always prints the sense key
> and additional sense code:
> perhaps the description string should be removed altogether?
> For the "Unhandled error code" (for which you are proposing
> r
Looks good,
Reviewed-by: Christoph Hellwig
--
To unsubscribe from this list: send the line "unsubscribe linux-scsi" in
the body of a message to majord...@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
On Mon, Jun 30, 2014 at 05:19:57PM -0700, Adam Radford wrote:
> James/linux-scsi,
>
> The following patch for megaraid_sas fixes the LD/VF affiliation policy
> parsing code to account for LD targetId's and Hidden LD's (not yet affiliated
> with any Virtual Functions).
Hi Adam,
this doesn't add
On 7/2/2014 9:36 PM, Christoph Hellwig wrote:
On Wed, Jul 02, 2014 at 02:29:05PM -0400, Mikulas Patocka wrote:
And what about protection information for commands that transfer partial
sectors? (for example, UMAP transfers 24 bytes). Should
scsi_transfer_length return 24 or 32 in this case?
As f
50 matches
Mail list logo