jiffies_64 is always defined in file kernel/time/timer.c. Thus, we
can unify definition of jiffies and make it less confusing. This
only affects 64-bit platforms.
Signed-off-by: Zhihui Zhang
---
arch/x86/kernel/time.c| 4
arch/x86/kernel/vmlinux.lds.S | 4 ++--
2 files changed, 2
Ah, I see your point. Thanks for the detail explanation.
-Zhihui
On Mon, Jan 23, 2017 at 6:10 AM, Thomas Gleixner wrote:
> On Sat, 21 Jan 2017, Zhihui Zhang wrote:
>
>> Sure, I believe that comments should always match the code. In this
>
> That's fine.
>
>> ca
, John Stultz wrote:
> On Mon, Jan 2, 2017 at 1:14 PM, Zhihui Zhang wrote:
>> Adjust the time start of each level to match the comments. Note that
>> LVL_START(n) is never used for n = 0 case. Also, each level (except
>> level 0) has more than enough room to accommodate a
Adjust the time start of each level to match the comments. Note that
LVL_START(n) is never used for n = 0 case. Also, each level (except
level 0) has more than enough room to accommodate all its timers.
Signed-off-by: Zhihui Zhang
---
kernel/time/timer.c | 4 ++--
1 file changed, 2 insertions
-off-by: Zhihui Zhang
---
kernel/sched/fair.c | 36 +++-
1 file changed, 19 insertions(+), 17 deletions(-)
diff --git a/kernel/sched/fair.c b/kernel/sched/fair.c
index 6e2e348..5e8e17b 100644
--- a/kernel/sched/fair.c
+++ b/kernel/sched/fair.c
@@ -1203,7 +1203,7
RECLAIM_SWAP behind. commit <2e2e42598908> reintroduced .may_swap
for memory controller.
Signed-off-by: Zhihui Zhang
---
mm/vmscan.c | 12 ++--
1 file changed, 6 insertions(+), 6 deletions(-)
diff --git a/mm/vmscan.c b/mm/vmscan.c
index 5e8eadd..15328de 100644
--- a/mm/vmscan.c
++
11:36:02PM -0400, Zhihui Zhang wrote:
>> If kernelcore is not set, then we are working with a very large kernelcore
>> for nothing - no movable zone will be created. If kernelcore is set,
>> then it is not respected at all.
>>
>> Signed-off-by: Zhihui Zhang
>
> I
If kernelcore is not set, then we are working with a very large kernelcore
for nothing - no movable zone will be created. If kernelcore is set,
then it is not respected at all.
Signed-off-by: Zhihui Zhang
---
mm/page_alloc.c | 6 +-
1 file changed, 5 insertions(+), 1 deletion(-)
diff --git
), we can use a separate field to track
how
much time the current period has elapsed instead of overloading
runnable_avg_period.
This patch achieves this.
Signed-off-by: Zhihui Zhang
---
include/linux/sched.h | 2 +-
kernel/sched/fair.c | 5 -
2 files changed, 5 insertions(+), 2 deletions
*nodes, nsc->mask1);
so mask2 is based on mask1. mask2 is only used when nodes is not NULL
later. so we don't care the
case of (pol->mode == MPOL_PREFERRED && nodes_empty(*nodes)).
-Zhihui
On Mon, Nov 17, 2014 at 6:08 PM, Andrew Morton
wrote:
> On Sat, 15 Nov 2014 21:49:57 -050
When nodes is true, nsc->mask2 has already been filtered by nsc->mask1, which
has
already factored in node_states[N_MEMORY].
Signed-off-by: Zhihui Zhang
---
mm/mempolicy.c | 10 ++
1 file changed, 2 insertions(+), 8 deletions(-)
diff --git a/mm/mempolicy.c b/mm/mempolicy.c
I see your point. Thanks.
-Zhihui
On Wed, Oct 29, 2014 at 12:18 AM, Tejun Heo wrote:
> Plesae restore lkml cc when replying.
>
> On Tue, Oct 28, 2014 at 08:12:30PM -0400, Zhihui Zhang wrote:
>> My patch just increases the dynamic area in the first chunk slightly
>> to cover
ee_fn(ptr + size_sum, ai->unit_size - size_sum);
I am trying to make each CPU to have a full unit size in the first
chunk, same as in all other chunks. Does this make sense?
-Zhihui
On Mon, Oct 27, 2014 at 10:08 AM, Tejun Heo wrote:
> On Sat, Oct 25, 2014 at 11:05:58AM -0400, Zhihui Zhang
Since we have already allocated the full unit size for the first chunk, we
might as well use
it so that the unit size are the same for all chunks. The page first chunk
allocator already
has this effect because it allocates one page at a time.
Signed-off-by: Zhihui Zhang
---
mm/percpu.c | 6
Commit-ID: 9c58c79a8a76c510cd3a5012c536d4fe3c81ec3b
Gitweb: http://git.kernel.org/tip/9c58c79a8a76c510cd3a5012c536d4fe3c81ec3b
Author: Zhihui Zhang
AuthorDate: Sat, 20 Sep 2014 21:24:36 -0400
Committer: Ingo Molnar
CommitDate: Sun, 21 Sep 2014 09:00:02 +0200
sched: Clean up some typos
Well, the subject line says it all.
Signed-off-by: Zhihui Zhang
---
kernel/sched/core.c | 4 ++--
kernel/sched/fair.c | 6 +++---
kernel/sched/sched.h | 2 +-
3 files changed, 6 insertions(+), 6 deletions(-)
diff --git a/kernel/sched/core.c b/kernel/sched/core.c
index ec1a286..eb5505f 100644
Commit-ID: aaecac4ad46b35ad308245384d019633fb9bc21b
Gitweb: http://git.kernel.org/tip/aaecac4ad46b35ad308245384d019633fb9bc21b
Author: Zhihui Zhang
AuthorDate: Fri, 1 Aug 2014 21:18:03 -0400
Committer: Ingo Molnar
CommitDate: Tue, 12 Aug 2014 12:48:21 +0200
sched: Rename a misleading
The child variable in build_overlap_sched_groups() actually refers to the
peer or sibling domain of the given CPU. Rename it to sibling to be consistent
with the naming in build_group_mask().
Signed-off-by: Zhihui Zhang
---
kernel/sched/core.c | 13 ++---
1 file changed, 6 insertions
e example (perhaps
with numbers)?
thanks,
-Zhihui
On Thu, Jul 3, 2014 at 5:50 AM, Juri Lelli wrote:
> On Wed, 2 Jul 2014 19:44:04 -0400
> Zhihui Zhang wrote:
>
>> My point is that rq_clock(rq) - dl_se->deadline is already part of
>> dl_se->runtime, which is decremente
Unless we want to double-penalize an overrun task, the time after the deadline
and before the current time is already accounted in the negative dl_se->runtime
value. So we can leave it as is in the case of dmiss && rorun.
Signed-off-by: Zhihui Zhang
---
kernel/sched/deadline.c |
This unifies the way to specify start VMA on both 32 and 64-bit platforms.
I would like to remove __PHYSICAL_START as well, but that appears to be harder.
Signed-off-by: Zhihui Zhang
---
arch/x86/kernel/vmlinux.lds.S | 3 +--
1 file changed, 1 insertion(+), 2 deletions(-)
diff --git a/arch/x86
Signed-off-by: Zhihui Zhang
---
fs/f2fs/node.h |2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/fs/f2fs/node.h b/fs/f2fs/node.h
index afdb130..2be47b2 100644
--- a/fs/f2fs/node.h
+++ b/fs/f2fs/node.h
@@ -239,7 +239,7 @@ static inline bool IS_DNODE(struct page *node_page
22 matches
Mail list logo