On Wed, Oct 11, 2023 at 8:53 PM Masahiro Yamada wrote:
>
> On Wed, Oct 11, 2023 at 11:24 AM Guo Ren wrote:
> >
> > On Mon, Oct 9, 2023 at 8:42 PM Masahiro Yamada wrote:
>
> > > --- a/arch/riscv/Makefile
> > > +++ b/arch/riscv/Makefile
> > > @@ -131,12 +131,6 @@ endif
> > > libs-y += arch/riscv/
On Mon, 2023-10-09 at 17:04 +0200, David Hildenbrand wrote:
> On 07.10.23 10:55, Huang, Ying wrote:
> > Vishal Verma writes:
> >
> > > @@ -2167,47 +2221,28 @@ static int __ref try_remove_memory(u64 start, u64
> > > size)
> > > if (rc)
> > > return rc;
> > >
> > > +
To facilitate syzkaller test, it's essential for the module to retain the
same address across reboots. In userspace, the execution of modprobe
commands must occur sequentially. In the kernel, selecting the
CONFIG_MODULE_DISABLE_INIT_FREE option disables the asynchronous freeing
of init sections.
S
On Wed, Aug 23, 2023 at 02:13:30PM +0100, Alexandru Elisei wrote:
> Reserving the tag storage associated with a tagged page requires the
> ability to migrate existing data if the tag storage is in use for data.
>
> The kernel allocates pages, which are now tagged because of HW KASAN, in
> non-pree
To facilitate syzkaller test, it's essential for the module to retain the same
address across reboots. In userspace, the execution of modprobe commands must
occur sequentially. In the kernel, selecting the CONFIG_MODULE_DISABLE_INIT_FREE
option disables the asynchronous freeing of init sections.
S
On Wed, Aug 23, 2023 at 02:13:17PM +0100, Alexandru Elisei wrote:
> Some architectures implement hardware memory coloring to catch incorrect
> usage of memory allocation. One such architecture is arm64, which calls its
> hardware implementation Memory Tagging Extension.
>
> So far, the memory whic
On Wed, Aug 23, 2023 at 02:13:19PM +0100, Alexandru Elisei wrote:
> pcp lists keep MIGRATE_METADATA pages on the MIGRATE_MOVABLE list. Make
> sure pages from the movable list are allocated only when the
> ALLOC_FROM_METADATA alloc flag is set, as otherwise the page allocator
> could end up allocati
On Wed, Oct 11, 2023 at 06:33:13PM +0200, Luca Weiss wrote:
> From: Matti Lehtimäki
>
> Add compatibles for the MSM8226 and MSM8974 platforms to the Qualcomm
> watchdog binding.
>
> Signed-off-by: Matti Lehtimäki
> Signed-off-by: Luca Weiss
Reviewed-by: Guenter Roeck
> ---
> Documentation/
On Mon 09 Oct 2023 21:42:09 GMT, Masahiro Yamada wrote:
> Currently, there is no standard implementation for vdso_install,
> leading to various issues:
>
> 1. Code duplication
>
> Many architectures duplicate similar code just for copying files
> to the install destination.
>
> Some
On Wed, Oct 11, 2023 at 01:14:38PM +0530, Joey Jiao wrote:
> When modprobe cmds are executed one by one, the final loaded modules
> are not in fixed sequence as expected.
>
> Add the option to make sure modules are in fixed sequence across reboot.
>
> Signed-off-by: Joey Jiao
> ---
> kernel/mod
On 10/11/23 18:33, Luca Weiss wrote:
From: Matti Lehtimäki
Add watchdog for MSM8974 platform.
Signed-off-by: Matti Lehtimäki
Signed-off-by: Luca Weiss
---
Reviewed-by: Konrad Dybcio
Konrad
On 10/11/23 18:33, Luca Weiss wrote:
From: Matti Lehtimäki
Add watchdog for MSM8226 platform.
Signed-off-by: Matti Lehtimäki
Signed-off-by: Luca Weiss
---
Reviewed-by: Konrad Dybcio
Konrad
On 11/10/2023 18:33, Luca Weiss wrote:
> From: Matti Lehtimäki
>
> Add compatibles for the MSM8226 and MSM8974 platforms to the Qualcomm
> watchdog binding.
>
> Signed-off-by: Matti Lehtimäki
Reviewed-by: Krzysztof Kozlowski
Best regards,
Krzysztof
On 10/11/23 20:24, Krzysztof Kozlowski wrote:
On 11/10/2023 19:02, Luca Weiss wrote:
Add the vendor prefix for HTC (https://www.htc.com/).
Signed-off-by: Luca Weiss
---
So it is the first HTC device in upstream? That's a surprise...
Same feeling, this was very unexpected!
Konrad
On 10/11/23 19:02, Luca Weiss wrote:
Add support for this smartphone based on the MSM8926 SoC, codenamed
"memul".
Supported functionality:
* Power & volume buttons
* ADSP
* Magnetometer
* Accelerometer
* Touchscreen
* Vibrator
* Internal storage
* SD card
* Charger
* USB
Signed-off-by: Luca
On 11/10/2023 19:02, Luca Weiss wrote:
> Add the vendor prefix for HTC (https://www.htc.com/).
>
> Signed-off-by: Luca Weiss
> ---
So it is the first HTC device in upstream? That's a surprise...
Acked-by: Krzysztof Kozlowski
Best regards,
Krzysztof
On 11/10/2023 19:02, Luca Weiss wrote:
> Document the compatible for the MSM8926-based HTC One Mini 2 smartphone.
>
> Signed-off-by: Luca Weiss
Acked-by: Krzysztof Kozlowski
Best regards,
Krzysztof
On Tue, Oct 10, 2023 at 12:03:56AM +0900, Masami Hiramatsu wrote:
> On Mon, 9 Oct 2023 09:51:03 -0400
> Steven Rostedt wrote:
>
> > On Sat, 7 Oct 2023 21:09:00 +0530
> > Atul Kumar Pant wrote:
> >
> > > On Sat, Sep 23, 2023 at 11:00:46PM +0530, Atul Kumar Pant wrote:
> > > > On Thu, Aug 17, 202
On Mon, Oct 09, 2023 at 09:51:03AM -0400, Steven Rostedt wrote:
> On Sat, 7 Oct 2023 21:09:00 +0530
> Atul Kumar Pant wrote:
>
> > On Sat, Sep 23, 2023 at 11:00:46PM +0530, Atul Kumar Pant wrote:
> > > On Thu, Aug 17, 2023 at 10:38:19PM +0530, Atul Kumar Pant wrote:
> > > > Fixes typo in a func
(struct device *dev)
---
base-commit: 2933a1156742d8c47550493a77af8e2d81cf3c84
change-id: 20231011-msm8953-iommu-restore-fabc2e31fee7
Best regards,
--
Luca Weiss
On Mon, Oct 09, 2023 at 04:13:40PM -0500, Rob Herring wrote:
> Use preferred device_get_match_data() instead of of_match_device() to
> get the driver match data. With this, adjust the includes to explicitly
> include the correct headers.
>
> Signed-off-by: Rob Herring
> ---
> drivers/remoteproc/
Add support for this smartphone based on the MSM8926 SoC, codenamed
"memul".
Supported functionality:
* Power & volume buttons
* ADSP
* Magnetometer
* Accelerometer
* Touchscreen
* Vibrator
* Internal storage
* SD card
* Charger
* USB
Signed-off-by: Luca Weiss
---
arch/arm/boot/dts/qcom/Makefil
Document the compatible for the MSM8926-based HTC One Mini 2 smartphone.
Signed-off-by: Luca Weiss
---
Documentation/devicetree/bindings/arm/qcom.yaml | 1 +
1 file changed, 1 insertion(+)
diff --git a/Documentation/devicetree/bindings/arm/qcom.yaml
b/Documentation/devicetree/bindings/arm/qcom
Add the vendor prefix for HTC (https://www.htc.com/).
Signed-off-by: Luca Weiss
---
Documentation/devicetree/bindings/vendor-prefixes.yaml | 2 ++
1 file changed, 2 insertions(+)
diff --git a/Documentation/devicetree/bindings/vendor-prefixes.yaml
b/Documentation/devicetree/bindings/vendor-pref
Add support for this smartphone from HTC which is based on the MSM8926
SoC and codenamed "memul".
Depends on, runtime-only, bootloader enables watchdog so we need to pet
it to stay alive:
https://lore.kernel.org/linux-arm-msm/20231011-msm8226-msm8974-watchdog-v1-0-2c472818f...@z
From: Matti Lehtimäki
Add compatibles for the MSM8226 and MSM8974 platforms to the Qualcomm
watchdog binding.
Signed-off-by: Matti Lehtimäki
Signed-off-by: Luca Weiss
---
Documentation/devicetree/bindings/watchdog/qcom-wdt.yaml | 2 ++
1 file changed, 2 insertions(+)
diff --git a/Documentati
From: Matti Lehtimäki
Add watchdog for MSM8226 platform.
Signed-off-by: Matti Lehtimäki
Signed-off-by: Luca Weiss
---
arch/arm/boot/dts/qcom/qcom-msm8226.dtsi | 8
1 file changed, 8 insertions(+)
diff --git a/arch/arm/boot/dts/qcom/qcom-msm8226.dtsi
b/arch/arm/boot/dts/qcom/qcom-ms
From: Matti Lehtimäki
Add watchdog for MSM8974 platform.
Signed-off-by: Matti Lehtimäki
Signed-off-by: Luca Weiss
---
arch/arm/boot/dts/qcom/qcom-msm8974.dtsi | 8
1 file changed, 8 insertions(+)
diff --git a/arch/arm/boot/dts/qcom/qcom-msm8974.dtsi
b/arch/arm/boot/dts/qcom/qcom-ms
ase-commit: 2933a1156742d8c47550493a77af8e2d81cf3c84
change-id: 20231011-msm8226-msm8974-watchdog-a88e45f4e2a4
Best regards,
--
Luca Weiss
On 10/10/2023 14:54, Masami Hiramatsu (Google) wrote:
> From: Masami Hiramatsu (Google)
>
> Move the BTF APIs used in tracing to the BTF library code for sharing it
> with others.
> Previously, to avoid complex dependency in a series I made it on the
> tracing tree, but now it is a good time to m
On Tue, 10 Oct 2023 19:31:19 -0500, Huang, Kai wrote:
On Tue, 2023-10-10 at 12:05 -0500, Haitao Huang wrote:
On Mon, 09 Oct 2023 21:12:27 -0500, Huang, Kai
wrote:
>
> > > > >
> > > > Later the hosting process could migrated/reassigned to another
> > cgroup?
> > > > What to do when the new
Greg Kroah-Hartman wrote:
> Now that the driver core allows for struct class to be in read-only
> memory, we should make all 'class' structures declared at build time
> placing them into read-only memory, instead of having to be dynamically
> allocated at runtime.
>
> Cc: Dan Williams
> Cc: Visha
On Tue, 10 Oct 2023 19:01:25 -0500, Sean Christopherson
wrote:
On Tue, Oct 10, 2023, Haitao Huang wrote:
On Mon, 09 Oct 2023 21:23:12 -0500, Huang, Kai
wrote:
> On Mon, 2023-10-09 at 20:42 -0500, Haitao Huang wrote:
> > Hi Sean
> >
> > On Mon, 09 Oct 2023 19:23:04 -0500, Sean Christopher
On 9/26/2023 8:45 PM, Michal Wilczynski wrote:
> In acpi_nfit_init_interleave_set() there is a memory leak + improper use
> of devm_*() family of functions for local memory allocations. This patch
> series provides two commits - one is meant as a bug fix, and could
> potentially be backported, a
On Tue, Oct 10, 2023, at 09:00, Kalle Valo wrote:
> Arnd Bergmann writes:
>
>> From: Arnd Bergmann
>>
>> The ioctl handler has no actual callers in the kernel and is useless.
>> All the functionality should be reachable through the regualar interfaces.
>>
>> Signed-off-by: Arnd Bergmann
>
> In t
On Wed, Oct 11, 2023 at 11:24 AM Guo Ren wrote:
>
> On Mon, Oct 9, 2023 at 8:42 PM Masahiro Yamada wrote:
> > --- a/arch/riscv/Makefile
> > +++ b/arch/riscv/Makefile
> > @@ -131,12 +131,6 @@ endif
> > libs-y += arch/riscv/lib/
> > libs-$(CONFIG_EFI_STUB) += $(objtree)/drivers/firmware/efi/libs
Hi Joey,
kernel test robot noticed the following build warnings:
[auto build test WARNING on mcgrof/modules-next]
[also build test WARNING on linus/master v6.6-rc5 next-20231011]
[If your patch is applied to the wrong git tree, kindly drop us a note.
And when submitting patch, we suggest to use
rnel.org/r/20231009141908.1767241-1-arnd%40kernel.org
patch subject: [PATCH 01/10] appletalk: remove localtalk and ppp support
config: x86_64-randconfig-002-20231011
(https://download.01.org/0day-ci/archive/20231011/202310111736.4mh6cf5c-...@intel.com/config)
compiler: gcc-7 (Ubuntu 7.5.0-6ubuntu2) 7.5.0
repro
In acpi_nfit_ctl() ACPI handle is extracted using to_acpi_dev()
function and accessing handle field in ACPI device. After transformation
from ACPI driver to platform driver this is not optimal anymore. To get
a handle it's enough to just use ACPI_HANDLE() macro to extract the
handle.
Suggested-by:
NFIT driver uses struct acpi_driver incorrectly to register itself.
This is wrong as the instances of the ACPI devices are not meant
to be literal devices, they're supposed to describe ACPI entry of a
particular device.
Use platform_driver instead of acpi_driver. In relevant places call
platform d
Since transformation from ACPI driver to platform driver there are two
devices on which the driver operates - ACPI device and platform device.
For the sake of reader this calls for the distinction in their naming,
to avoid confusion. Rename device to adev, as corresponding
platform device is called
AC driver uses struct acpi_driver incorrectly to register itself. This
is wrong as the instances of the ACPI devices are not meant to
be literal devices, they're supposed to describe ACPI entry of a
particular device.
Use platform_driver instead of acpi_driver. In relevant places call
platform dev
Remove unnecessary checks for NULL for variables that can't be NULL at
the point they're checked for it. Defensive programming is discouraged
in the kernel.
Signed-off-by: Michal Wilczynski
---
drivers/acpi/ac.c | 27 ---
1 file changed, 4 insertions(+), 23 deletions(-)
Use modern string_choices API instead of manually determining the
output using ternary operator.
Suggested-by: Andy Shevchenko
Reviewed-by: Andy Shevchenko
Signed-off-by: Michal Wilczynski
---
drivers/acpi/ac.c | 5 +++--
1 file changed, 3 insertions(+), 2 deletions(-)
diff --git a/drivers/ac
Currently there is a number of drivers that somewhat incorrectly
register themselves as acpi_driver, while they should be registering as
platform_drivers. acpi_device was never meant to represent actual
device, it only represents an entry in the ACPI table and ACPI driver
should be treated as a dri
On Tue, Oct 10, 2023 at 03:22:34PM -0700, Luis Chamberlain wrote:
> On Mon, Oct 02, 2023 at 01:30:35PM +0200, Joel Granados via B4 Relay wrote:
> > V3:
> > * Removed the ia64 patch to avoid conflicts with the ia64 removal
> > * Rebased onto v6.6-rc4
> > * Kept/added the trailing comma for the ctl_t
When modprobe cmds are executed one by one, the final loaded modules
are not in fixed sequence as expected.
Add the option to make sure modules are in fixed sequence across reboot.
Signed-off-by: Joey Jiao
---
kernel/module/Kconfig | 11 +++
kernel/module/main.c | 3 ++-
2 files chang
> Il giorno 10 ott 2023, alle ore 10:15, Arnd Bergmann ha
> scritto:
>
> On Tue, Oct 10, 2023, at 09:10, Rodolfo Zitellini wrote:
>>> Il giorno 9 ott 2023, alle ore 19:29, Arnd Bergmann ha
>>> scritto:
>>> On Mon, Oct 9, 2023, at 18:49, Rodolfo Zitellini wrote:
>>> I can see a few ways this
48 matches
Mail list logo