Re: [PATCH v4 1/2] scsi: fix race between simultaneous decrements of ->host_failed

2016-06-08 Thread Martin K. Petersen
> "Wei" == Wei Fang writes: Wei> sas_ata_strategy_handler() adds the works of the ata error handler Wei> to system_unbound_wq. This workqueue asynchronously runs work Wei> items, so the ata error handler will be performed concurrently on Wei> different CPUs. In this case, ->host_failed will b

[PATCH v3 2/7] leds: documentation: 'ide-disk' to 'disk-activity'

2016-06-08 Thread Stephan Linz
Cc: Joseph Jezak Cc: Nico Macrionitis Cc: Jörg Sommer Signed-off-by: Stephan Linz --- Documentation/devicetree/bindings/leds/common.txt| 2 +- Documentation/devicetree/bindings/leds/leds-gpio.txt | 2 +- Documentation/laptops/asus-laptop.txt| 2 +- Documentation/leds/leds-c

[PATCH v4 08/29] staging: unisys: visorbus: removed unused periodic_test_workqueue

2016-06-08 Thread David Kershner
From: Tim Sell periodic_test_workqueue was an unused relic from the past, and was removed. Signed-off-by: Tim Sell Signed-off-by: David Kershner --- drivers/staging/unisys/visorbus/visorbus_main.c | 15 --- 1 file changed, 15 deletions(-) diff --git a/drivers/staging/unisys/visor

[PATCH v4 03/29] staging: unisys: visorbus: remove unused module parameters

2016-06-08 Thread David Kershner
From: David Binder Removes unused module parameters from visorbus_main.c, in response to findings by SonarQube. Signed-off-by: David Binder Signed-off-by: David Kershner Reviewed-by: Tim Sell --- drivers/staging/unisys/visorbus/visorbus_main.c | 9 + 1 file changed, 1 insertion(+), 8

[PATCH v4 10/29] staging: unisys: visorbus: use kernel timer instead of workqueue

2016-06-08 Thread David Kershner
From: Tim Sell A kernel timer is now used as the vehicle to periodically call the channel_interrupt function of registered visor drivers, instead of a workqueue. This simplifies a lot of things by making periodic_work.c and periodic_work.h no longer necessary. This change also means that the ch

[PATCH v4 23/29] staging: unisys: visorbus: Remove notifier-related code from visorbus

2016-06-08 Thread David Kershner
From: David Binder When this functionality was first implemented, visorchipset and visorbus were separate drivers, which necessitated a registration mechanism for them to communicate. More-recently, visorchipset and visorbus were combined into a single driver, and now exist as separate source fi

[PATCH v4 06/29] staging: unisys: visornic: Correct comment spelling mistake

2016-06-08 Thread David Kershner
From: David Binder Fixes a comment spelling mistake in visornic. Signed-off-by: David Binder Signed-off-by: David Kershner Reviewed-by: Tim Sell --- drivers/staging/unisys/visornic/visornic_main.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/staging/unisys/viso

[PATCH v4 09/29] staging: unisys: visorinput: remove unnecessary locking

2016-06-08 Thread David Kershner
From: Tim Sell Locking in the _interrupt() function is NOT necessary so long as we ensure that interrupts have been stopped whenever we need to pause or resume the device, which we now do. While a device is paused, we ensure that interrupts stay disabled, i.e. that the _interrupt() function will

[PATCH v4 02/29] staging: unisys: visorbus: check parahotplug_request_complete_result

2016-06-08 Thread David Kershner
From: Erik Arfvidson This patch modifies the caller of parahotplug_request_complete() to check the return value and return appropriate result. Signed-off-by: Erik Arfvidson Signed-off-by: David Kershner Reviewed-by: Tim Sell --- drivers/staging/unisys/visorbus/visorchipset.c | 5 - 1 fil

[PATCH v4 13/29] staging: unisys: visorbus: Remove unnecessary EXPORT_SYMBOL statements

2016-06-08 Thread David Kershner
From: Bryan Thompson The driver that is now visorbus started out as multiple separate drivers, and when they were merged the EXPORT_SYMBOL statements that were required for separate drivers were left in the code. This patch removes those now unnecessary exports. Signed-off-by: Bryan Thompson Si

[PATCH v4 20/29] staging: unisys: visorbus: Rectify commenting in visorchipset.c

2016-06-08 Thread David Kershner
From: David Binder Adds kerneldoc formatting to appropriate functions. Other multi-line comments now use proper formatting. Signed-off-by: David Binder Signed-off-by: David Kershner Reviewed-by: Tim Sell --- drivers/staging/unisys/visorbus/visorchipset.c | 292 - 1 fi

[PATCH v4 12/29] staging: unisys: visorbus: Make visordriver_callback_lock a mutex

2016-06-08 Thread David Kershner
From: Bryan Thompson visordriver_callback_lock is just a binary semaphore that logically makes more sense as a mutex. Signed-off-by: Bryan Thompson Signed-off-by: David Kershner Reviewed-by: Tim Sell --- drivers/staging/unisys/include/visorbus.h | 2 +- drivers/staging/unisys/visorbus

[PATCH v4 01/29] staging: unisys: visorbus: remove return values for write_vbus functions

2016-06-08 Thread David Kershner
From: Erik Arfvidson This patch removes the return values from the write_vbus_* channel functions. Nobody was checking the return values and the value stored into the vbus info is not critical to the functioning of the device. Signed-off-by: Erik Arfvidson Signed-off-by: David Kershner Reviewe

[PATCH v4 26/29] staging: unisys: Move vbushelper.h to visorbus directory

2016-06-08 Thread David Kershner
Only visorbus needs this header file so move it to visorbus directory. Signed-off-by: David Kershner Reviewed-by: Tim Sell --- drivers/staging/unisys/{include => visorbus}/vbushelper.h | 0 1 file changed, 0 insertions(+), 0 deletions(-) rename drivers/staging/unisys/{include => visorbus}/vbus

[PATCH v4 19/29] staging: unisys: visorbus: fix visorchannel.c comments

2016-06-08 Thread David Kershner
From: David Binder This patch ONLY touches comment lines, i.e., NO executable code is affected. Comments were fixed in visorchannel.c: * All functions worthy of documenting now use standard kerneldoc formatting. * Multi-line comments were tweaked so as to use appropriate conventions. * Minor t

[PATCH v4 16/29] staging: unisys: visorbus: remove unused parameter from function

2016-06-08 Thread David Kershner
From: Tim Sell The off parameter to visorchannel_create_guts() was never used, so it was removed. Signed-off-by: Tim Sell Signed-off-by: David Kershner --- drivers/staging/unisys/visorbus/visorchannel.c | 7 +++ 1 file changed, 3 insertions(+), 4 deletions(-) diff --git a/drivers/staging

[PATCH v4 25/29] staging: unisys: visorbus: fix visorbus_private.h comments

2016-06-08 Thread David Kershner
From: Tim Sell This patch ONLY touches comment lines, i.e., NO executable code is affected. Comments were fixed in visorbus_private.h: * Minor typos were corrected. * Useless comments were removed. Signed-off-by: Tim Sell Signed-off-by: David Kershner --- drivers/staging/unisys/visorbus/viso

[PATCH v4 21/29] staging: unisys: visorbus: Move visorbus-unique functions to private header

2016-06-08 Thread David Kershner
From: David Binder Moves function prototypes that are unique to visorbus from include/visorbus.h to visorbus/visorbus_private.h. Signed-off-by: David Binder Signed-off-by: David Kershner Reviewed-by: Tim Sell --- drivers/staging/unisys/include/visorbus.h | 25 d

[PATCH v4 28/29] Documentation: Move visorbus documentation from staging to Documentation/

2016-06-08 Thread David Kershner
This patch simple does a git mv of the drivers/staging/unisys/Documentation directory to Documentation. Renames overview.txt to visorbus.txt and renames sysfs-platform-visorchipset to the correct name sysfs-bus-visorbus. Signed-off-by: David Kershner Reviewed-by: Tim Sell --- .../ABI/stable/sys

[PATCH v4 22/29] staging: unisys: visorbus: rectify kerneldoc comment for struct

2016-06-08 Thread David Kershner
From: David Binder Fixes the kerneldoc comment for struct visor_device - the struct members were not listed with the appropriate @ prefix. Signed-off-by: David Binder Signed-off-by: David Kershner --- drivers/staging/unisys/include/visorbus.h | 34 +++ 1 file chang

[PATCH v4 15/29] staging: unisys: Remove reference to unused STANDALONE_CLIENT

2016-06-08 Thread David Kershner
From: Bryan Thompson The STANDALONE_CLIENT define is no longer used by Unisys driver code. Signed-off-by: Bryan Thompson Signed-off-by: David Kershner Reviewed-by: Tim Sell --- drivers/staging/unisys/include/visorbus.h | 2 -- 1 file changed, 2 deletions(-) diff --git a/drivers/staging/unis

[PATCH v4 18/29] staging: unisys: visorbus: fix commenting in visorbus_main.c

2016-06-08 Thread David Kershner
From: David Binder This patch ONLY touches comment lines, i.e., NO executable code is affected. * All functions worthy of documenting now use standard kerneldoc formatting. * Improper uses of kerneldoc formatting were converted to standard multi-line comments. * Multi-line comments were twea

[PATCH v4 29/29] drivers: Add visorbus to the drivers/virt directory

2016-06-08 Thread David Kershner
visorbus is currently located at drivers/staging/visorbus, this patch moves it to drivers/virt. Signed-off-by: David Kershner Reviewed-by: Tim Sell --- drivers/staging/unisys/Kconfig| 3 +-- drivers/staging/unisys/Makefile

[PATCH v4 27/29] include: linux: visorbus: Add visorbus to include/linux directory

2016-06-08 Thread David Kershner
Update include/linux to include the s-Par associated common include header files needed for the s-Par visorbus. Since we have now moved the include directories over to include/linux/visorbus this patch makes all of the visor drivers visorbus, visorinput, visornic, and visorhba use the new include

[PATCH v4 24/29] staging: unisys: visorbus: Rename function to follow existing convention

2016-06-08 Thread David Kershner
From: David Binder Renames visorchipset_device_pause_response to device_pause_response, thereby following the convention that other responder functions follow. Signed-off-by: David Binder Signed-off-by: David Kershner --- drivers/staging/unisys/visorbus/visorbus_main.c| 4 ++-- drivers/st

[PATCH v4 14/29] staging: unisys: visorbus: Remove unused functions

2016-06-08 Thread David Kershner
From: Bryan Thompson Remove visorbus_clear_channel, visorchannel_signalqueue_slots_avail, visorchannel_signalqueue_max_slots, visorchannel_clear, and visorchannel_debug which are no longer called by any driver. Signed-off-by: Bryan Thompson Signed-off-by: David Kershner Reviewed-by: Tim Sell

[PATCH v4 11/29] staging: unisys: visorbus: remove periodic_work.h/.c

2016-06-08 Thread David Kershner
From: Tim Sell These files were made no-longer-necessary by recent commits. Signed-off-by: Tim Sell Signed-off-by: David Kershner --- drivers/staging/unisys/include/periodic_work.h | 40 - drivers/staging/unisys/visorbus/Makefile| 1 - drivers/staging/unisys/visorbus/periodic_

[PATCH v4 17/29] staging: unisys: visorbus: fix commenting in vbusdevinfo.h

2016-06-08 Thread David Kershner
From: David Binder This patch ONLY touches comment lines, i.e., NO executable code is affected. * All functions worthy of documenting now use standard kerneldoc formatting. * Multi-line comments were tweaked so as to use appropriate conventions. * Minor typos were corrected. Signed-off-by: Da

[PATCH v4 04/29] staging: unisys: visorbus: remove unused struct

2016-06-08 Thread David Kershner
From: David Binder Removes unused struct definition, channel_size_info, in response to findings by SonarQube. Signed-off-by: David Binder Signed-off-by: David Kershner Reviewed-by: Tim Sell --- drivers/staging/unisys/visorbus/visorbus_main.c | 6 -- 1 file changed, 6 deletions(-) diff -

[PATCH v4 05/29] staging: unisys: visorbus: modify format string to match argument

2016-06-08 Thread David Kershner
From: David Binder Modifies the format string of snprintf to expect an unsigned int instead of a signed one, per the supplied argument. Signed-off-by: David Binder Signed-off-by: David Kershner Reviewed-by: Tim Sell --- drivers/staging/unisys/visorbus/visorbus_main.c | 2 +- 1 file changed,

[PATCH v4 07/29] staging: unisys: include: Remove thread-related enum members

2016-06-08 Thread David Kershner
From: David Binder Code relating to ktheads was previously removed from s-Par driver code. This patch cleans up lingering remnants of kthreads by removing thread- related enum types. Signed-off-by: David Binder Signed-off-by: David Kershner Reviewed-by: Tim Sell --- drivers/staging/unisys/in

[PATCH v4 00/29] Fixed issues raised by tglx, then move visorbus to drivers/virt

2016-06-08 Thread David Kershner
tglx: The following patchset fixes issues you raised during your code review of visorbus on 5/18. Converts visorbus to use a kernel timer for periodic device-specific callbacks instead of a workqueue, making the implementation in periodic_work.c and periodic_work.h no longer necessary. These file

Re: [PATCH 0/7] add reST/sphinx-doc to linux documentation

2016-06-08 Thread Jonathan Corbet
So I've finally gotten a chance to make another pass over this stuff. Markus, your enthusiasm is great; I'm hoping you'll do great things helping us to improve the kernel's documentation toolchain. But please, at this point, let's build on Jani's work and go from there. Things have waited for lo

Re: [PATCH v2 1/1] hwmon: (tmp401) Add support for TI TMP461

2016-06-08 Thread Guenter Roeck
On Wed, Jun 08, 2016 at 12:00:54PM -0500, Andrew F. Davis wrote: > Signed-off-by: Andrew F. Davis Applied to hwmon-next. Thanks, Guenter -- To unsubscribe from this list: send the line "unsubscribe linux-doc" in the body of a message to majord...@vger.kernel.org More majordomo info at http://vg

Re: [PATCH] hwmon: (tmp401) Add support for TI TMP461

2016-06-08 Thread Guenter Roeck
On Wed, Jun 08, 2016 at 11:56:29AM -0500, Andrew F. Davis wrote: [ ... ] > >> static const u8 TMP432_TEMP_MSB_READ[4][3] = { > >> @@ -149,6 +156,7 @@ static const struct i2c_device_id tmp401_id[] = { > >> { "tmp431", tmp431 }, > >> { "tmp432", tmp432 }, > >> { "tmp435", tmp435

Re: [PATCH 17/23] arm64: ptrace: handle ptrace_request differently for aarch32 and ilp32

2016-06-08 Thread Yury Norov
On Wed, Jun 08, 2016 at 09:34:09AM +0800, zhouchengming wrote: > On 2016/5/24 8:04, Yury Norov wrote: > >Here new aarch32 ptrace syscall handler is introsuced to avoid run-time > >detection of the task type. > > > >Signed-off-by: Yury Norov [...] > Hello, I found ilp32 will use sys_ptrace, not co

[PATCH v2 1/1] hwmon: (tmp401) Add support for TI TMP461

2016-06-08 Thread Andrew F. Davis
Signed-off-by: Andrew F. Davis --- Changes from v1: - Dropped n-factor correction until a generic solution is developed - Removed double empty line Documentation/hwmon/tmp401 | 14 -- drivers/hwmon/Kconfig | 2 +- drivers/hwmon/tmp401.c | 35 +-

Re: [PATCH] hwmon: (tmp401) Add support for TI TMP461

2016-06-08 Thread Andrew F. Davis
On 06/03/2016 11:41 PM, Guenter Roeck wrote: > On 05/31/2016 09:27 AM, Andrew F. Davis wrote: >> Signed-off-by: Andrew F. Davis >> --- >> Documentation/hwmon/tmp401 | 18 +-- >> drivers/hwmon/Kconfig | 2 +- >> drivers/hwmon/tmp401.c | 81 >> ++

Re: [PATCH 2/3] iio: adc: ina3221: Add support for IIO ADC driver for TI INA3221

2016-06-08 Thread Laxman Dewangan
On Wednesday 08 June 2016 08:34 PM, Andrew F. Davis wrote: On 06/07/2016 05:30 PM, Guenter Roeck wrote: On Fri, Jun 03, 2016 at 10:17:55AM -0500, Andrew F. Davis wrote: On 06/03/2016 09:14 AM, Laxman Dewangan wrote: On Friday 03 June 2016 06:59 PM, Guenter Roeck wrote: On 06/03/2016 03:06 AM

Re: [PATCH 2/3] iio: adc: ina3221: Add support for IIO ADC driver for TI INA3221

2016-06-08 Thread Andrew F. Davis
On 06/07/2016 05:30 PM, Guenter Roeck wrote: > On Fri, Jun 03, 2016 at 10:17:55AM -0500, Andrew F. Davis wrote: >> On 06/03/2016 09:14 AM, Laxman Dewangan wrote: >>> >>> On Friday 03 June 2016 06:59 PM, Guenter Roeck wrote: On 06/03/2016 03:06 AM, Jonathan Cameron wrote: > On 01/06/16 13:3

Re: [PATCH v3 04/30] staging: unisys: visorbus: remove unused module parameters

2016-06-08 Thread Neil Horman
On Wed, Jun 08, 2016 at 02:42:08PM +, Binder, David Anthony wrote: > > -Original Message- > > From: Neil Horman [mailto:nhor...@redhat.com] > > Sent: Wednesday, June 08, 2016 9:08 AM > > To: Binder, David Anthony > > Cc: Kershner, David A ; cor...@lwn.net; > > t...@linutronix.de; mi...

RE: [PATCH v3 04/30] staging: unisys: visorbus: remove unused module parameters

2016-06-08 Thread Binder, David Anthony
> -Original Message- > From: Neil Horman [mailto:nhor...@redhat.com] > Sent: Wednesday, June 08, 2016 9:08 AM > To: Binder, David Anthony > Cc: Kershner, David A ; cor...@lwn.net; > t...@linutronix.de; mi...@redhat.com; h...@zytor.com; > gre...@linuxfoundation.org; Arfvidson, Erik ; > Sell

Re: [PATCHv2 2/5] EDAC, altera: ECC Manager IRQ controller support

2016-06-08 Thread Thor Thayer
On 06/08/2016 04:00 AM, Borislav Petkov wrote: On Tue, Jun 07, 2016 at 03:35:57PM -0500, ttha...@opensource.altera.com wrote: From: Thor Thayer To better support child devices, the ECC manager needs to be implemented as an IRQ controller. Signed-off-by: Thor Thayer --- v2 Update with clea

Re: [PATCH v3 04/30] staging: unisys: visorbus: remove unused module parameters

2016-06-08 Thread Neil Horman
On Wed, Jun 08, 2016 at 02:13:47AM +, Binder, David Anthony wrote: > > -Original Message- > > From: Neil Horman [mailto:nhor...@redhat.com] > > Sent: Tuesday, June 07, 2016 9:23 AM > > To: Kershner, David A > > Cc: cor...@lwn.net; t...@linutronix.de; mi...@redhat.com; > > h...@zytor.co

Re: [RFC PATCH v1 10/18] x86/efi: Access EFI related tables in the clear

2016-06-08 Thread Matt Fleming
On Tue, 26 Apr, at 05:57:40PM, Tom Lendacky wrote: > The EFI tables are not encrypted and need to be accessed as such. Be sure > to memmap them without the encryption attribute set. For EFI support that > lives outside of the arch/x86 tree, create a routine that uses the __weak > attribute so that

Re: [RFC PATCH v1 10/18] x86/efi: Access EFI related tables in the clear

2016-06-08 Thread Matt Fleming
(Sorry for the delay) On Thu, 26 May, at 08:45:58AM, Tom Lendacky wrote: > > The patch in question is patch 6/18 where PAGE_KERNEL is changed to > include the _PAGE_ENC attribute (the encryption mask). This now > makes FIXMAP_PAGE_NORMAL contain the encryption mask while > FIXMAP_PAGE_IO does not

Re: [PATCHv2 2/5] EDAC, altera: ECC Manager IRQ controller support

2016-06-08 Thread Borislav Petkov
On Tue, Jun 07, 2016 at 03:35:57PM -0500, ttha...@opensource.altera.com wrote: > From: Thor Thayer > > To better support child devices, the ECC manager needs to be > implemented as an IRQ controller. > > Signed-off-by: Thor Thayer > --- > v2 Update with cleanup/improvements from maintainer. >