Re: Adds glissando stems to Lilypond. (issue4661061)

2011-07-19 Thread hanwenn
hi there, as you see I am really strict here; I hope you understand it is my duty as maintainer to push back on anything invasive, so we can keep lilypond as simple as possible; nothing personal. http://codereview.appspot.com/4661061/diff/29001/lily/glissando-engraver.cc File lily/glissando-en

Re: Adds glissando stems to Lilypond. (issue4661061)

2011-07-19 Thread mtsolo
Most of my comments below are Han-Wen specific, but I do have one request (also echoed below) for anybody. I need to figure out an input syntax for this stuff, which means I'm gonna have to write parser/lexer related code. Ideally, I'd like the syntax to be a4 mikeSolomonIsANinja8 mikeSolomonIs

Re: Adds glissando stems to Lilypond. (issue4661061)

2011-07-19 Thread hanwenn
http://codereview.appspot.com/4661061/diff/29001/lily/glissando-engraver.cc File lily/glissando-engraver.cc (right): http://codereview.appspot.com/4661061/diff/29001/lily/glissando-engraver.cc#newcode83 lily/glissando-engraver.cc:83: if (Glissando_stem::has_interface (stem)) acknowledge_glissand

Re: Adds glissando stems to Lilypond. (issue4661061)

2011-07-19 Thread mtsolo
After a discussion w/ Han-Wen, I've tried to implement this using a new GlissandoStem grob. It is very code-dupey and you'll see that the regtest has one big problem, but other than that it works. I've done a bit of research on why this problem exists. I can already see fishy numbers popping up

RE: Adds glissando stems to Lilypond. (issue4661061)

2011-07-17 Thread James Lowe
...@gmail.com; m...@apollinemike.com; hanw...@gmail.com; bernardobarr...@gmail.com; c_soren...@byu.edu; carl.d.soren...@gmail.com; reinh...@kainhofer.com Cc: re...@codereview.appspotmail.com; lilypond-devel@gnu.org Subject: Re: Adds glissando stems to Lilypond. (issue4661061) I've paired this

Re: Adds glissando stems to Lilypond. (issue4661061)

2011-07-17 Thread mtsolo
I've paired this down to a minimal implementation that only contains: 1) Init file stuff for syntax (this could be made much better...) 2) Modifications to the glissando engraver to ID glissando stems. 3) A function that links them up to glissandi in stem.hh 4) The triggering of this function via

Re: Adds glissando stems to Lilypond. (issue4661061)

2011-07-16 Thread m...@apollinemike.com
On Jul 1, 2011, at 5:50 PM, Han-Wen Nienhuys wrote: > > On a tangent: what is the glissando-index property for? I can't see > it being read anywhere. > > \relative c' { \override Glissando #'style = #(lambda (grob) (if (eq? (ly:grob-property grob 'glissando-index) 1) 'zigzag 'dashed-line)) 1

Re: Adds glissando stems to Lilypond. (issue4661061)

2011-07-16 Thread m...@apollinemike.com
On Jul 1, 2011, at 5:50 PM, Han-Wen Nienhuys wrote: > > On a tangent: what is the glissando-index property for? I can't see > it being read anywhere. > > \relative c' { \override Glissando #'style = #(lambda (grob) (if (eq? (ly:grob-property grob 'glissando-index) 1) 'zigzag 'dashed-line)) 1

Re: Adds glissando stems to Lilypond. (issue4661061)

2011-07-06 Thread m...@apollinemike.com
On Jul 5, 2011, at 12:30 PM, David Kastrup wrote: > "m...@apollinemike.com" writes: > >> On Jul 5, 2011, at 9:58 AM, m...@apollinemike.com wrote: >> >> >> >> >>3) Make the lines_ of a constrained breaker a sparse binary tree >>(see below) of matrices, not a single matrix, that store

Re: Adds glissando stems to Lilypond. (issue4661061)

2011-07-05 Thread Reinhold Kainhofer
Am Dienstag 05 Juli 2011, 06:10:12 schrieb carl.d.soren...@gmail.com: > I'm wondering if it's possible to avoid code dup by making a > base_stem_engraver of which glissando_stem_engraver and stem_engraver > would be children. > > I probably don't have the right terminology for this (in fact I'm su

Re: Adds glissando stems to Lilypond. (issue4661061)

2011-07-05 Thread David Kastrup
"m...@apollinemike.com" writes: > On Jul 5, 2011, at 9:58 AM, m...@apollinemike.com wrote: > > > > > 3)  Make the lines_ of a constrained breaker a sparse binary tree > (see below) of matrices, not a single matrix, that stores the > information above.  Each node of the

Re: Adds glissando stems to Lilypond. (issue4661061)

2011-07-05 Thread m...@apollinemike.com
On Jul 5, 2011, at 9:58 AM, m...@apollinemike.com wrote: > > 3) Make the lines_ of a constrained breaker a sparse binary tree (see below) > of matrices, not a single matrix, that stores the information above. Each > node of the tree would branch off into break/noBreak for a single point in >

Re: Adds glissando stems to Lilypond. (issue4661061)

2011-07-05 Thread m...@apollinemike.com
On Jul 5, 2011, at 6:10 AM, carl.d.soren...@gmail.com wrote: > Looking at the details of the code, it seems fine. > > But I tend to agree with Han-Wen's concerns. > > I'm wondering if it's possible to avoid code dup by making a > base_stem_engraver of which glissando_stem_engraver and stem_engra

Re: Adds glissando stems to Lilypond. (issue4661061)

2011-07-04 Thread Carl . D . Sorensen
Looking at the details of the code, it seems fine. But I tend to agree with Han-Wen's concerns. I'm wondering if it's possible to avoid code dup by making a base_stem_engraver of which glissando_stem_engraver and stem_engraver would be children. I probably don't have the right terminology for t

Re: Adds glissando stems to Lilypond. (issue4661061)

2011-07-03 Thread m...@apollinemike.com
On Jul 1, 2011, at 5:50 PM, Han-Wen Nienhuys wrote: > On Thu, Jun 30, 2011 at 12:46 PM, m...@apollinemike.com > wrote: >>> can you show png examples of what you're trying to do? > > > Can you try a minimal implementation first? For example, > The more I think about this problem, the less trac

Re: Adds glissando stems to Lilypond. (issue4661061)

2011-07-01 Thread Carl Sorensen
On 7/1/11 2:12 PM, "m...@apollinemike.com" wrote: > > I am a proponent of using mixed integer linear programming to solve these > issues. I believe that 100% of LilyPond's spacing could be rewritten as > constraints in a linear program, in which case the vertical and horizontal > spacing would a

Re: Adds glissando stems to Lilypond. (issue4661061)

2011-07-01 Thread m...@apollinemike.com
On Jul 1, 2011, at 7:45 PM, Graham Percival wrote: > On Fri, Jul 01, 2011 at 07:17:08PM +0200, m...@apollinemike.com wrote: >> I'm responding to your e-mail backwards, with answers to the technical >> parts first followed by answers to the broader questions you raise. > > I'll briefly comment

Re: Adds glissando stems to Lilypond. (issue4661061)

2011-07-01 Thread Bernardo Barros
2011/7/1 Han-Wen Nienhuys : > If we add patches like this for every composer's favorite avant-garde > notation, the large parts of the lilypond codebase will shortly become > a tangle of hard to understand dependencies; code for uncommon > notation constructs should only be added if their implement

Re: Adds glissando stems to Lilypond. (issue4661061)

2011-07-01 Thread Graham Percival
On Fri, Jul 01, 2011 at 07:17:08PM +0200, m...@apollinemike.com wrote: >I'm responding to your e-mail backwards, with answers to the technical >parts first followed by answers to the broader questions you raise. I'll briefly comment on those broader questions. > * Have an engraver (b

Re: Adds glissando stems to Lilypond. (issue4661061)

2011-07-01 Thread m...@apollinemike.com
Hey Han Wen, I'm responding to your e-mail backwards, with answers to the technical parts first followed by answers to the broader questions you raise. > Can you try a minimal implementation first? For example, > > * Have a stem property that determines the end of the stem. Currently, we have >

Re: Adds glissando stems to Lilypond. (issue4661061)

2011-07-01 Thread Han-Wen Nienhuys
On Thu, Jun 30, 2011 at 12:46 PM, m...@apollinemike.com wrote: >> can you show png examples of what you're trying to do? Honestly, I cannot allow this patch in its current design. I don't see a reason for an obscure feature to be touching code of note-spacing, stem-tremolo, stem, beam etc. If we

Re: Adds glissando stems to Lilypond. (issue4661061)

2011-07-01 Thread Han-Wen Nienhuys
sorry - disregard; brainfart. On Thu, Jun 30, 2011 at 1:09 PM, m...@apollinemike.com wrote: > Hey Han-Wen, > > I see the to_spanner of which you speak in gdb.cc, but I'm not sure how to > access it.  Should a gdb.hh be put in include/ so that it can be included and > used? -- Han-Wen Nienhuy

Re: Adds glissando stems to Lilypond. (issue4661061)

2011-07-01 Thread m...@apollinemike.com
On Jul 1, 2011, at 12:47 PM, pkx1...@gmail.com wrote: > On 2011/07/01 09:33:50, mike_apollinemike.com wrote: >> Hey all, >> I've uploaded a new patchset that kinda sorta makes tremolos work. > > I'm struggling to get a clean 'make check' I always get an Error 1 > > Looking back it seems I found

Re: Adds glissando stems to Lilypond. (issue4661061)

2011-07-01 Thread pkx166h
On 2011/07/01 09:33:50, mike_apollinemike.com wrote: Hey all, I've uploaded a new patchset that kinda sorta makes tremolos work. I'm struggling to get a clean 'make check' I always get an Error 1 Looking back it seems I found the place.. Processing `/home/james/lilypond-git/build/out/lybook-t

Re: Adds glissando stems to Lilypond. (issue4661061)

2011-06-30 Thread ColinPKCampbell
Added issue 1727 for tracking http://codereview.appspot.com/4661061/ ___ lilypond-devel mailing list lilypond-devel@gnu.org https://lists.gnu.org/mailman/listinfo/lilypond-devel

Re: Adds glissando stems to Lilypond. (issue4661061)

2011-06-30 Thread Colin Campbell
On 11-06-30 03:31 AM, mts...@gmail.com wrote: Long-term, I'll be pushing for a different naming scheme, but I have no objection to \startGlissandoStem for the next few months. Cheers, - Graham New patchset up w/ changed names. Cheers, MS http://codereview.appspot.com/4661061/ Added is

Re: Adds glissando stems to Lilypond. (issue4661061)

2011-06-30 Thread mtsolo
New patch-set uploaded addressing all minor concerns so far. The biggest change is that, as per Han-Wen's suggestion, the glissando-stem stuff no longer happens courtesy of after-line-breaking but rather in response to a callback for glissando-stem. http://codereview.appspot.com/4661061/ __

Re: Adds glissando stems to Lilypond. (issue4661061)

2011-06-30 Thread m...@apollinemike.com
Hey Han-Wen, I see the to_spanner of which you speak in gdb.cc, but I'm not sure how to access it. Should a gdb.hh be put in include/ so that it can be included and used? Cheers, MS On Jun 30, 2011, at 5:29 PM, hanw...@gmail.com wrote: > can you show png examples of what you're trying to do?

Re: Adds glissando stems to Lilypond. (issue4661061)

2011-06-30 Thread m...@apollinemike.com
On Jun 30, 2011, at 5:29 PM, n.putt...@gmail.com wrote: > Hi Mike, > > The interface is an improvement on the patch you originally posted, but > it still leaves a lot to be desired. :) > If it didn't, my patch wouldn't have potential, and who likes a patch without potential? > I don't like th

Re: Adds glissando stems to Lilypond. (issue4661061)

2011-06-30 Thread m...@apollinemike.com
On Jun 30, 2011, at 5:29 PM, hanw...@gmail.com wrote: > can you show png examples of what you're trying to do? > PastedGraphic-1.pdf Description: Adobe PDF document > I think this patch has serious issues. > > > http://codereview.appspot.com/4661061/diff/13/lily/music-sequence.cc > File lil

Re: Adds glissando stems to Lilypond. (issue4661061)

2011-06-30 Thread n . puttock
Hi Mike, The interface is an improvement on the patch you originally posted, but it still leaves a lot to be desired. :) I don't like the way you flag the glissando stems; ideally they'd be a separate grob which doesn't require noteheads and legers to be removed. Cheers, Neil http://coderevie

Re: Adds glissando stems to Lilypond. (issue4661061)

2011-06-30 Thread hanwenn
can you show png examples of what you're trying to do? I think this patch has serious issues. http://codereview.appspot.com/4661061/diff/13/lily/music-sequence.cc File lily/music-sequence.cc (right): http://codereview.appspot.com/4661061/diff/13/lily/music-sequence.cc#newcode118 lily/music-seq

Re: Adds glissando stems to Lilypond. (issue4661061)

2011-06-30 Thread mtsolo
Long-term, I'll be pushing for a different naming scheme, but I have no objection to \startGlissandoStem for the next few months. Cheers, - Graham New patchset up w/ changed names. Cheers, MS http://codereview.appspot.com/4661061/ ___ lilypond-d

Re: Adds glissando stems to Lilypond. (issue4661061)

2011-06-30 Thread Graham Percival
On Thu, Jun 30, 2011 at 09:21:21AM +, pkx1...@gmail.com wrote: > \startGlissandoStem > > while quite long, isn't that long. +1 > I realise this is not GLISS but thought it worth mentioning now. Long-term, I'll be pushing for a different naming scheme, but I have no objection to \startGlissa

Re: Adds glissando stems to Lilypond. (issue4661061)

2011-06-30 Thread pkx166h
hello, I'm in no way qualified to comment on code, but am uncomfortable with the function name: \startGStems It has two caps in the middle and is 'plural'. \startGlissandoStem while quite long, isn't that long. I realise this is not GLISS but thought it worth mentioning now. http://coderev

Adds glissando stems to Lilypond. (issue4661061)

2011-06-30 Thread mtsolo
Reviewers: , Message: I have a functional version of this feature up with a regtest. I think the input syntax works, but it could be cleaner. All suggestions are welcome! Off now to typeset crazy glissandi... Cheers, MS Description: Adds glissando stems to Lilypond. Please review this at htt