Oh, goodness, deary me -- this sounded so familiar I just had to do some
delving and hey presto! I refer you to:
http://marc.info/?l=php-internals&m=124655821522388
(...which, interestingly, even predates Zeev's 2010 claim, and I believe may
have taken inspiration from yet earlier suggestions b
> -Original Message-
> From: yohg...@gmail.com [mailto:yohg...@gmail.com] On Behalf Of
> Yasuo Ohgaki
>
> Hi all,
>
> 2013/7/21 Sherif Ramadan
>
> > The problem is I'm not sure where this type of information should
> be
> > documented. It makes sense to put this on the increment/decreme
I know I'm still somewhat of a beginner with OOP, and not at all into
large-scale OOP frameworks (yet!), but I'm really struggling to understand why
the existing & reference operator doesn't suffice for what you are after?
If you could explain in words of as few syllables as possible what you wo
> -Original Message-
> From: Clint Priest [mailto:cpri...@zerocue.com]
> Sent: 28 October 2012 16:03
>
> So... to be explicit here, you think in this situation:
>
> class a {
>public $b {
> set($x) { $this->b = $x; }
>}
> }
>
> $o = new a();
>
> if(!isset($o->b)) {
>/*
> -Original Message-
> From: Andrew Faulds [mailto:a...@ajf.me]
> Sent: 25 July 2012 18:03
[...]
> Fact: Adding a new name for a special kind of function as a syntax
> construct is going to cost (possibly unnecessary) time and energy,
> because now you have functions, and weird things tha
> -Original Message-
> From: Morgan L. Owens [mailto:pack...@nznet.gen.nz]
> Sent: 25 June 2012 15:41
>
> On 2012-06-25 04:19, Ralph Schindler wrote:
> >> The term 'column' makes a lot of sense for PDO working with
> database
> >> columns, but there is no concept of a 'column' in the array
> -Original Message-
> From: Larry Garfield [mailto:la...@garfieldtech.com]
> Sent: 24 November 2011 22:04
[... BIG SNIP ...]
> If that doesn't change, then I rescind my previous panic attack.
>
> --Larry Garfield
I echo that sentiment. On fuller review, I find a very high FUD
factor i
> -Original Message-
> From: Gustavo Lopes [mailto:glo...@nebm.ist.utl.pt]
> Sent: 23 November 2011 22:31
>
> On Wed, 23 Nov 2011 21:06:09 -, Pierre Joye
>
> wrote:
>
> > The fact that we have reports here showing code not working
> anymore
> > because of this change tells me that it
> -Original Message-
> From: John Crenshaw [mailto:johncrens...@priacta.com]
> Sent: 01 June 2011 23:00
>
> Spot on. It has nothing to do with extra typing (and that sort of
> design is part of what ruined Ruby). My fingers move plenty fast and
> if extra characters make things more safe o
> -Original Message-
> From: Michael Shadle [mailto:mike...@gmail.com]
> Sent: 01 June 2011 21:37
>
> On Wed, Jun 1, 2011 at 1:01 PM, Pierre Joye
> wrote:
>
> > I modified the vote page, pls move your votes to the desired
> syntax
> > (or global -1)
>
> This is a good idea to group thin
> -Original Message-
> From: ekne...@gmail.com [mailto:ekne...@gmail.com] On Behalf Of
> Etienne Kneuss
> Sent: 01 June 2011 01:57
> To: internals@lists.php.net
> Subject: Re: [PHP-DEV] Re: RFC: Short syntax for Arrays (redux)
>
> +1 for a short array syntax.
>
> But only if you keep it c
> -Original Message-
> From: Adam Richardson [mailto:simples...@gmail.com]
> Sent: 08 April 2011 08:02
>
> Indeed.
>
> The '?' character already is special, so using '??' seems like a
> safe,
> practical approach. However, I'd prefer maintaining the form of the
> standard
> ternary oper
> -Original Message-
> From: Jacob Oettinger [mailto:ja...@oettinger.dk]
> Sent: 08 June 2010 14:09
>
> On 08/06/2010, at 12.41, Johannes Schlüter wrote:
>
> > On Tue, 2010-06-08 at 12:23 +0200, Jacob Oettinger wrote:
> >> Would it be equally simple to allow the syntax below?
> >>
> >> $r
> -Original Message-
> From: a...@adamharvey.name [mailto:a...@adamharvey.name] On Behalf
> Of Adam Harvey
> Sent: 04 May 2010 13:15
> The options are:
>
> 1. Apply Tomas's patch to make case-insensitive lookups
> locale-ignorant. Pros: fixes immediate problem. Cons: breaks BC for
> case
> -Original Message-
> From: Richard Quadling [mailto:rquadl...@googlemail.com]
> Sent: 18 September 2009 10:43
>
> Considering we have func_get_args(), maybe func_get_caller() would
> be
> a nice fit.
>
> I don't like the idea of a constant (CALLER) which changes value as
> you move aro
> -Original Message-
> From: Lukas Kahwe Smith [mailto:m...@pooteeweet.org]
> Sent: 02 July 2009 14:05
> To: Ilia Alshanetsky
> Cc: Paul Biggar; PHP Internals; Derick Rethans; Stanislav Malyshev;
> Hannes Magnusson
> Subject: Re: [PHP-DEV] Re: Flexible type hinting
>
>
> On 02.07.2009,
On 28 May 2008 08:20, Derick Rethans advised:
> Right, and I will add immediately to my coding standard that this is
> forbidden to use.
As is, of course, your right -- just as it would be mine to immediately
add to my coding standards that it is compulsory!
+1
(my irrelevant personal opinion
On 19 February 2008 21:03, [EMAIL PROTECTED] advised:
> Hi Marcus,
> Hi Troels,
>
>> The biggest issue I see is finding a syntax everyone likes.
> Well, lets try some variations.
>
> [2a] ! is not readable --> except
> use Trait {
> except foo1, foo2;
> bar => foo1
> }
>
> [2b] ! is not rea
+1 for (b) FWIW
Cheers!
Mike
-
Mike Ford, Electronic Information Services Adviser,
JG125, The Headingley Library,
James Graham Building, Leeds Metropolitan University,
Headingley Campus, LEEDS, LS6 3QS, United Kingdom
Email:
On 07 December 2007 17:36, Gregory Beaver wrote:
> The suggestion to make "namespace __php__;" implicit is very
> interesting, but would defeat its purpose, which is to separate
> declarations from use.
Oh, I missed that little wrinkle -- I did say I was only skimming! I guess it
could still be
On 07 December 2007 01:36, Gregory Beaver wrote:
[...snip...]
> In other words, 1 line of code is needed to take advantage of
> namespace's full protection and ability to import conflicting class
> names into the "global" (in this case unqualified, not
> containing :: in
> the name) scope, while
On 23 October 2007 19:57, Gregory Beaver wrote:
> Giedrius D wrote:
> >
> > Anyway my main question was: is there any reason not to use
> keyword "use"?
> The only reason for me is that "use" implies some kind of autoloading,
> as I suggested in one of my other mails.
H'mm, that's interesting. A
On 09 October 2007 08:18, Antony Dovgal wrote:
> On 09.10.2007 10:57, Alexey Zakhlestin wrote:
> > > How come?
> > > It looks like you're reading $bar[':5'], but forgot the quotes.
> > > On the other side, what could be easier than a function call?
> >
> > operator is definitely easier because it
On 01 October 2007 13:46, Antony Dovgal wrote:
> On 01.10.2007 16:32, Ilia Alshanetsky wrote:
> > This was not on the table and the time of the 5.3 discussion, I for
> > one think its a bit too much magic.
>
> Yeah, too Perl-ish for me.
>
Please stop this.
The minutes of the Paris meeting comm
On 02 October 2007 07:16, Sebastian Nohn wrote:
> Andi Gutmans wrote:
> > Hi Johannes,
> > Our preference would be to stick to "import" because I
> think the perception many will have of "use" is that it also
> includes files (just based on some other languages).
I don't know much about "other la
On 15 February 2007 16:45, Antony Dovgal wrote:
> On 02/15/2007 07:42 PM, Steph Fox wrote:
> > > On 02/15/2007 07:22 PM, Steph Fox wrote:
> > > > Hi Tony,
> > > >
> > > > We've been here before. Last time it got taken off again
> > > > because it led to user confusion. People didn't seem to know
> -Original Message-
> From: Richard Lynch [mailto:[EMAIL PROTECTED]
> Sent: 07 February 2007 02:34
>
> I was specifically thinking of the sheer number of emails to
> PHP-General that would result.
>
> Even if 90% of the newbies "get it" without any research, and
> 5% more figure it ou
> -Original Message-
> From: Robert Cummings [mailto:[EMAIL PROTECTED]
> Sent: 06 February 2007 16:09
>
> I know how much you want to feel special, but here's the
> definition of "read". Your description of how you interpret
> what you see falls into this definition:
Oh, no fair! You'v
On 06 February 2007 14:42, Robert Cummings wrote:
> On Tue, 2007-02-06 at 14:08 +0000, Ford, Mike wrote:
> > On 05 February 2007 17:29, Brian Moon wrote:
> > > That is why you have coding standards. Our doucment states that
> > > this should be written as:
> &g
On 05 February 2007 17:32, Brian Moon wrote:
> Reading the array thread, someone mentioned having several ways of
> doing things. One of their examples was the if: endif; syntax.
> Forgive me if this has been discussed, but has anyone proposed
> removing that for PHP6? Seems like the perfect ti
On 05 February 2007 17:29, Brian Moon wrote:
> Ford, Mike wrote:
> > > I don't find:
> > >
> > > $a = [1 => ['pears', 'apples'], 2 => ['juice', 'oranges']];
> > >
> > > any less reada
On 04 February 2007 21:41, Zeev Suraski wrote:
> At 23:27 04-02-07, Pierre wrote:
> > On 2/4/07, Zeev Suraski <[EMAIL PROTECTED]> wrote:
> > > At 20:14 04-02-07, Pierre wrote:
> > > > Hi,
> > > >
> > > > On 2/4/07, Ilia Alshanetsky <[EMAIL PROTECTED]> wrote:
> > > > > I personally find array extr
On 04 February 2007 18:38, Edin Kadribasic wrote:
> Lukas Kahwe Smith wrote:
> > Yes, you will come across it if its added.
> > I find the Javascript syntax confusing to read as well. However more
> > importantly I do not see the point in adding this sugar to save 5
> > chars.
>
> Nested arrays
On 04 February 2007 07:25, Andi Gutmans wrote:
> Hi,
>
> I thought I may have brought this up a long time ago but
> couldn't find anything in the archives.
> For a long time already I've been thinking about possibly
> adding a new syntax for array(...) which would be shorter. I'd suggest
> [...].
> -Original Message-
> From: Sara Golemon [mailto:[EMAIL PROTECTED]
> Sent: 23 January 2007 19:02
> * - Sidenote: I refuse to call object behavior "reference by
> default",
> I've had too many people notice that it's not actually true
Hear, hear. My favourite terminology here (and I'
On 04 June 2006 17:18, Rasmus Lerdorf wrote:
> I think if we implement a way to get a hash from an object,
> or at least
> a unique identifier that can be used as a hash, then it should be
> implicit just like other things are implicitly converted when the
> context is clear. Of course, you shoul
Ilia Alshanetsky wrote:
> The two topics are:
>
> Inclusion of E_STRICT and E_RECOVERABLE_ERROR into E_ALL
-1/+1
E_RECOVERABLE_ERROR has to be in as it's taken over some previously E_ERROR
situations.
It's probably too soon for E_STRICT right now, although it should be enabled in
some 5.x.0 rel
On 05 April 2006 21:22, crisp at tweakers dot net wrote:
> ID: 36983
> User updated by: crisp at tweakers dot net
> Reported By: crisp at tweakers dot net
> Status: Bogus
>
> That last remark is taking my well-meant criticism to the extreme;
> surely you will kno
On 07 March 2006 09:28, Dmitry Stogov wrote:
> Please reviw and vote.
>
> 1) goto and break label
> 2) goto only (like C)
> 3) break label only (like Java)
> 4) nothing
1) +0.25
2) -1e38
3) +1e38
4) -infinity
Or, in other words, I want labelled break, and I don't want to have to emulate
it wit
On 30 November 2005 01:41, Sara Golemon wrote:
> , I'd like to turn the topic to a completely
> different language
> feature which (might) please enough people to get a rousing consensus.
>
> Actual labeled breaks. Not the break+jump that was proposed
> earlier in the
> guise of a break statemen
On 29 November 2005 15:27, Sara Golemon wrote:
> > Just wondering. There's another thread about goto and labels
> > running as well. If they vote for something like:
> >
> > LABEL:while (cond) {
> >
> > }
> >
> > Wouldn't this add another technical diffuculty with using ':' as a
> > namespace s
On 29 November 2005 09:18, Bart de Boer wrote:
> I feel we're comparing apples with oranges here.
>
> Break; is for breaking out of loops. It shouldn't have anything to do
> with jumping to somewhere else. Let's say *if* PHP supported jumping
> through the code. The following should then be two d
On 28 November 2005 09:50, Stanislav Malyshev wrote:
> > > BUT the discussion is not only about possibility but also about
> > > what you would like. The ":" for example would work if mandatory
> > > whitespace would be introduced for the ternary BUT this is very
> > > very bad.
>
> If my vote i
On 17 November 2005 21:42, Rasmus Lerdorf wrote:
> Andreas Korthaus wrote:
>
> > Can someone tell me the reason for this decision?
>
> Very few people converted to using {} so the argument about
> reading old
> code doesn't really hold. If you go and grep through all the public
> code out there
On 18 November 2005 11:48, Derick Rethans wrote:
> On Fri, 18 Nov 2005, Andreas Korthaus wrote:
>
> > Derick Rethans wrote:
> >
> > > > That's the problem - also grep does not know if [] is used for
> > > > arrays or stings. That's the same for programmers, it's often
> > > > not easy to conclud
On 29 October 2005 22:56, Greg Beaver wrote:
> For an operation as complicated as "use the first variable
> that exists"
> I would be most comfortable with:
>
> $d = first-existing: $a, $b, $c;
That's a horrible syntax, but a fantastic name for a language construct to do
the job. Even better m
On 03 October 2005 15:41, Robert Cummings wrote:
> Amazing how fast the assumption has become that passing
> object values in
> PHP5 is identical to passing the object by reference. It is not the
> same, there are subtle differences. Either way I'm not weighing in on
> the $ref = &$this issue, onl
On 18 August 2005 13:37, Jani Taskinen wrote:
> sniperThu Aug 18 08:37:25 2005 EDT
>
> Modified files:
> /php-src/ext/ftp ftp.c
> - php_error_docref(NULL TSRMLS_CC,
> E_WARNING, "PHP cannot handle files greater then 2147483647
> bytes.\n"); +
To view the terms under which this email is distributed, please go to
http://disclaimer.leedsmet.ac.uk/email.htm
On 30 October 2004 02:03, Andi Gutmans wrote:
> Nah that patch won't do because it'll effect [] also.
> It's more complicated than that. I've tried separating them in the
> past and
On 30 July 2004 18:45, Andi Gutmans wrote:
> At 10:32 AM 7/30/2004 -0700, Sara Golemon wrote:
> > > Secondly, I just don't understand what the sudden necessity for
> > > the goto construct is when over the years we have barely ever had
> > > a PHP developer asking for it.
> > >
> > We clearly tr
On 18 December 2003 23:38, Andi Gutmans wrote:
> At 10:17 PM 12/18/2003 +0100, Christian Schneider wrote:
> I agree wholeheartedly, especially since one can set
> reporting to E_ALL and
> then ignore whatever one likes but with the way it is now
> there is no way
> of not being called for everythi
On 19 November 2003 20:34, Steph wrote:
> > Not to branch the discussion, but again: if we never plan on
> > removing functions, why go to the trouble of deprecating them?
> > Deprecation implies it will be removed.
> >
>
> .. and as Andi said earlier, removal without loud and clear warning
>
On 19 November 2003 06:12, Andi Gutmans contributed these pearls of wisdom:
> Just a warning.
> I commited your patch. Not sure about the naming but it's the
> status quo for now :)
> Andi
>
>> + case E_STRICT:
>> + error_type_str = "Strict
>> S
On 05 November 2003 18:39, Andrei Zmievski wrote:
> On Wed, 05 Nov 2003, Ford, Mike [LSS] wrote:
> >
> > I don't think the number of characters is the main issue here --
> > it's about having a *nicer* set of characters. Personally, I'd be
On 05 November 2003 17:19, Marco Tabini wrote:
> Ford, Mike [LSS] wrote:
> > On 05 November 2003 17:06, Marco Tabini contributed these pearls of
> > wisdom:
> >
> >
> > > Christian Schneider wrote:
> > >
> > > > Marco Tabini wrote:
&g
On 05 November 2003 16:52, Marco Tabini contributed these pearls of wisdom:
>
> $a = [[1,2,3],[1=>[1,3,2,2], "a"=>[[1,2,3,4],4,[1,2]]];
>
> I don't know about you, but I can't even begin to count the
> brackets in there... :-)
At quick glance says it looks unbalanced. A count shows why: 7 [s a
On 05 November 2003 17:06, Marco Tabini contributed these pearls of wisdom:
> Christian Schneider wrote:
>> Marco Tabini wrote:
>>
>>> $a = [[1,2,3],[1=>[1,3,2,2], "a"=>[[1,2,3,4],4,[1,2]]];
>>
>>
>> $a = array(array(1,2,3),array(1=>array(1,3,2,2),
>> "a"=>array(array(1,2,3,4),4,array(1,2)));
>
On 05 November 2003 16:48, Ilia Alshanetsky contributed these pearls of
wisdom:
> I mean c'mon, is 5 characters that much of a problem and is
> absolute code clarity not worth those 5 characters? Character
> efficiency is done in Perl, where you can do things like ~=
> and @_, but that makes Perl
On 05 November 2003 15:57, Ilia Alshanetsky contributed these pearls of
wisdom:
> On November 5, 2003 10:34 am, Christian Schneider wrote:
>> PHP is a mix of C, Perl and other styles anyway, why deny it?
>> It's strength is that it's a pragmatic and simple language
>> but that doesn't mean that no
On 05 November 2003 08:50, Andi Gutmans contributed these pearls of wisdom:
> At 12:33 AM 11/5/2003 +0100, Christian Schneider wrote:
>> I propose to add an alternative (backward compatible) short
>> array creation syntax: $a = [ 1, 2, 3 ]; and $a = [ 'a' =>
>> 42, 'b' => "foo" ];
>
> Personall
> -Original Message-
> From: Rasmus Lerdorf [mailto:[EMAIL PROTECTED]
> Sent: 26 March 2003 16:42
> To: Ford, Mike [LSS]
> > > I'd really not love to see it :) Use an if-else chain of ===
> > > comparisons
> > > instead if that's what yo
> -Original Message-
> From: Zeev Suraski [mailto:[EMAIL PROTECTED]
> Sent: 26 March 2003 01:47
> To: Ford, Mike [LSS]
>
> At 03:27 25/03/2003, Ford, Mike [LSS] wrote:
> >I'd love to see, say, case_identical for requesting an ===
> compar
> -Original Message-
> From: Zeev Suraski [mailto:[EMAIL PROTECTED]
> Sent: 24 March 2003 17:58
> To: Joey Smith
>
> At 05:07 24/03/2003, Joey Smith wrote:
> >I was reminded tonight of the following 'feature' of switch:
> >
> >$a = 0;
> >switch($a) {
> > case 'somestring': echo 'Bu
> -Original Message-
> From: Jani Taskinen [mailto:[EMAIL PROTECTED]
> Sent: 13 March 2003 17:15
>
> This is the first release candidate of the upcoming
> maintenance release of PHP 4.3.2.
>
> Please download and test it as much as possible on real-life
> applications
64 matches
Mail list logo