hi!
On Tue, Aug 21, 2012 at 3:10 PM, Ivan Enderlin @ Hoa
wrote:
> Hello,
>
> Some of my users & contributors have met an issue with files containing
> UTF-8 on certain Windows configurations (but they actually did not found the
> difference). Any idea why?
> The issue does not appear on Linux, BS
Um, Yasuo, have you looked at array_walk implementation and ascertained it is
safe to change array structure while using it?
Because I'm worried you're changing docs without doing so.
--
Sent from Samsung Mobile
Andrew Faulds
http://ajf.me/
Yasuo Ohgaki wrote:
Hi,
2012/8/22 Levi Morrison :
>
On 21/08/12 15:13, Rasmus Lerdorf wrote:
On 08/21/2012 09:10 AM, Ivan Enderlin @ Hoa wrote:
Hello,
Some of my users & contributors have met an issue with files containing
UTF-8 on certain Windows configurations (but they actually did not found
the difference). Any idea why?
The issue does not a
Hi,
2012/8/22 Levi Morrison :
> On Tue, Aug 21, 2012 at 7:45 PM, Yasuo Ohgaki wrote:
>>
>> Hi,
>>
>> 2012/8/16 Rasmus Schultz :
>> > How come there is no straight-foward obvious way to simply remove a given
>> > value from an array?
>> >
>> > Just look at the number of horrible ways people solve
On Tue, Aug 21, 2012 at 7:45 PM, Yasuo Ohgaki wrote:
>
> Hi,
>
> 2012/8/16 Rasmus Schultz :
> > How come there is no straight-foward obvious way to simply remove a given
> > value from an array?
> >
> > Just look at the number of horrible ways people solve this obvious problem:
> >
> > http://stac
Hi,
2012/8/16 Rasmus Schultz :
> How come there is no straight-foward obvious way to simply remove a given
> value from an array?
>
> Just look at the number of horrible ways people solve this obvious problem:
>
> http://stackoverflow.com/questions/7225070/php-array-delete-by-value-not-key
>
> Sho
Oh, yes...
On 2012-08-22 04:35, Lester Caine wrote:
and doesn't seem to
provide any outstanding advantages?
As I wrote in an earlier post:
On 2012-08-09 15:30, Morgan L. Owens wrote:
> I for one am lazy, and would much prefer writing:
> function append_iterator($first, $second)
> {
>f
On 2012-08-22 04:35, Lester Caine wrote:
John LeSueur wrote:
Again, the case you've cited is probably not a case where generators
give much
advantage. But anytime the logic to produce some data becomes more
complicated
(Imagine that you needed to skip some of the lines in the .csv file
based on
2012/8/22 Yasuo Ohgaki :
> Hi,
>
> 2012/8/22 Peter Cowburn :
>> On 21 August 2012 23:26, Yasuo Ohgaki wrote:
>>> array_walk is the best(fast and memory efficient) way
>>> to delete elements.
>>
>> If array_walk() is the best (fast and memory efficient) way to delete
>> elements, why have we had th
2012/8/22 Levi Morrison :
>> Why did you change the equivalent code?
>> array_walk is the best(fast and memory efficient) way
>> to delete elements.
>>
>> This code may be refereed from old PHP users, therefore
>> we should write better code.
>>
>> If you don' t have good reason to do so, please re
Hi,
2012/8/22 Peter Cowburn :
> On 21 August 2012 23:26, Yasuo Ohgaki wrote:
>> array_walk is the best(fast and memory efficient) way
>> to delete elements.
>
> If array_walk() is the best (fast and memory efficient) way to delete
> elements, why have we had the following line in the manual, for
On 21 August 2012 23:26, Yasuo Ohgaki wrote:
> array_walk is the best(fast and memory efficient) way
> to delete elements.
If array_walk() is the best (fast and memory efficient) way to delete
elements, why have we had the following line in the manual, for the
array_walk() callback, for over a de
> Why did you change the equivalent code?
> array_walk is the best(fast and memory efficient) way
> to delete elements.
>
> This code may be refereed from old PHP users, therefore
> we should write better code.
>
> If you don' t have good reason to do so, please revert
> the change.
The implementa
Hi,
2012/8/22 Levi Morrison :
> On Tue, Aug 21, 2012 at 4:13 PM, Yasuo Ohgaki wrote:
>> Hi,
>>
>> I see why with new Criticism section in the wiki page.
>> You've also misunderstood that array_udelete() is
>> array_walk() variant, not array_filter().
>>
>
> Actually, array_udelete is far more sim
Hi,
2012/8/22 Levi Morrison :
> On Tue, Aug 21, 2012 at 4:13 PM, Yasuo Ohgaki wrote:
>> Hi,
>>
>> I see why with new Criticism section in the wiki page.
>> You've also misunderstood that array_udelete() is
>> array_walk() variant, not array_filter().
>>
>
> Actually, array_udelete is far more sim
On Tue, Aug 21, 2012 at 4:13 PM, Yasuo Ohgaki wrote:
> Hi,
>
> I see why with new Criticism section in the wiki page.
> You've also misunderstood that array_udelete() is
> array_walk() variant, not array_filter().
>
Actually, array_udelete is far more similar to array_filter than it is
array_walk
Hi,
I see why with new Criticism section in the wiki page.
You've also misunderstood that array_udelete() is
array_walk() variant, not array_filter().
This may be the good reason why we should have
array_udelete :)
Regards,
--
Yasuo Ohgaki
yohg...@ohgaki.net
2012/8/22 Yasuo Ohgaki :
> 2012/8/
2012/8/22 Levi Morrison :
> On Tue, Aug 21, 2012 at 3:45 PM, Andrew Faulds wrote:
>> On 21/08/12 22:43, Levi Morrison wrote:
>>>
>>> There is a reason to have a callable provided: custom comparison.
>>> Other array functions solve this by providing a `u` alternative:
>>>
>>> `int array_udelete(&$a
On Tue, Aug 21, 2012 at 3:45 PM, Andrew Faulds wrote:
> On 21/08/12 22:43, Levi Morrison wrote:
>>
>> There is a reason to have a callable provided: custom comparison.
>> Other array functions solve this by providing a `u` alternative:
>>
>> `int array_udelete(&$array, $value, bool function($value
Hi,
2012/8/22 Levi Morrison :
> There is a reason to have a callable provided: custom comparison.
> Other array functions solve this by providing a `u` alternative:
>
> `int array_udelete(&$array, $value, bool function($value, $key))`
>
> Let's not deviate from established array naming conventions
On 21/08/12 22:43, Levi Morrison wrote:
There is a reason to have a callable provided: custom comparison.
Other array functions solve this by providing a `u` alternative:
`int array_udelete(&$array, $value, bool function($value, $key))`
Let's not deviate from established array naming convention
There is a reason to have a callable provided: custom comparison.
Other array functions solve this by providing a `u` alternative:
`int array_udelete(&$array, $value, bool function($value, $key))`
Let's not deviate from established array naming conventions. (Yasuo,
I'm looking at you)
Cheers,
On 21/08/12 22:35, Yasuo Ohgaki wrote:
2012/8/22 Andrew Faulds :
On 21/08/12 22:18, Yasuo Ohgaki wrote:
2012/8/22 Andrew Faulds :
Er, so you're advocating adding another method to do the same thing? Why?
Because novices don't know about array_walk().
I think I've written this over and over in
2012/8/22 Andrew Faulds :
> On 21/08/12 22:18, Yasuo Ohgaki wrote:
>>
>> 2012/8/22 Andrew Faulds :
>>>
>>> Er, so you're advocating adding another method to do the same thing? Why?
>>
>> Because novices don't know about array_walk().
>> I think I've written this over and over in this thread.
>
> So
On 21/08/12 22:18, Yasuo Ohgaki wrote:
2012/8/22 Andrew Faulds :
Er, so you're advocating adding another method to do the same thing? Why?
Because novices don't know about array_walk().
I think I've written this over and over in this thread.
So publicise array_walk() then. Don't add a new func
2012/8/21 Andrew Faulds
> On 21/08/12 21:44, Lars Schultz wrote:
>
>> Am 20.08.2012 22:51, schrieb Andrew Faulds:
>>
>>> On 20/08/12 21:43, Lars Schultz wrote:
>>> It's a ridiculous argument, IMO. Nothing you could add to core couldn't
>>> be implemented in userland code somehow. (yes, that's hyp
Lars Schultz wrote:
Am 20.08.2012 23:13, schrieb Lester Caine:
Boilerplates on how to do more complex operations sounds a very good
idea to me. It's exactly the sort of thing I've been asking for ...
I am glad you like the idea!;) although "boilerplate" does seem to leave a
metallic aftertaste
2012/8/22 Andrew Faulds :
> Er, so you're advocating adding another method to do the same thing? Why?
Because novices don't know about array_walk().
I think I've written this over and over in this thread.
> The whole point of this was to allow people to use arrays like sets, or
> easily remove li
On 21/08/12 21:44, Lars Schultz wrote:
Am 20.08.2012 22:51, schrieb Andrew Faulds:
On 20/08/12 21:43, Lars Schultz wrote:
It's a ridiculous argument, IMO. Nothing you could add to core couldn't
be implemented in userland code somehow. (yes, that's hyperbole, but
there is very often a userland so
Am 20.08.2012 22:51, schrieb Andrew Faulds:
On 20/08/12 21:43, Lars Schultz wrote:
It's a ridiculous argument, IMO. Nothing you could add to core couldn't
be implemented in userland code somehow. (yes, that's hyperbole, but
there is very often a userland solution. Most functions are for
convenien
Hi,
Nice to see my name not only in my signature ;)
I've not much to say right now, but what you wrote was slightly in my mind,
when I wrote the other mail.
I'll keep an eye on it (at least ;)).
Regards,
Sebastian
2012/8/20 Lars Schultz
> Am 20.08.2012 19:43, schrieb Sebastian Krebs:
>
>> Wha
On 21/08/12 21:32, Yasuo Ohgaki wrote:
2012/8/22 Andrew Faulds :
On 21/08/12 21:00, Yasuo Ohgaki wrote:
Hi
2012/8/22 Andrew Faulds :
On 21/08/12 10:36, Yasuo Ohgaki wrote:
Int would be better and callable should be accepted like array_walk().
It's better to have array_delete_recursive(), too
2012/8/22 Andrew Faulds :
> On 21/08/12 21:00, Yasuo Ohgaki wrote:
>>
>> Hi
>>
>> 2012/8/22 Andrew Faulds :
>>>
>>> On 21/08/12 10:36, Yasuo Ohgaki wrote:
Int would be better and callable should be accepted like array_walk().
It's better to have array_delete_recursive(), too.
I
Am 20.08.2012 23:13, schrieb Lester Caine:
Boilerplates on how to do more complex operations sounds a very good
idea to me. It's exactly the sort of thing I've been asking for ...
I am glad you like the idea!;) although "boilerplate" does seem to leave
a metallic aftertaste in my mouth.
espec
On 21/08/12 21:00, Yasuo Ohgaki wrote:
Hi
2012/8/22 Andrew Faulds :
On 21/08/12 10:36, Yasuo Ohgaki wrote:
Int would be better and callable should be accepted like array_walk().
It's better to have array_delete_recursive(), too.
I updated the page.
Callable? What? This is to remove a single v
Hi
2012/8/22 Andrew Faulds :
> On 21/08/12 10:36, Yasuo Ohgaki wrote:
>>
>> Int would be better and callable should be accepted like array_walk().
>> It's better to have array_delete_recursive(), too.
>> I updated the page.
>
> Callable? What? This is to remove a single value, like a set. If you w
On 21/08/12 10:36, Yasuo Ohgaki wrote:
Hi
2012/8/21 Tjerk Anne Meesters :
On Tue, Aug 21, 2012 at 10:31 AM, Rasmus Schultz wrote:
Thank you, but this isn't really anything like what I had in mind.
What I had in mind is more like set-semantics for arrays, e.g. designed to
work with sets of d
Hi
2012/8/22 Levi Morrison :
> On Tue, Aug 21, 2012 at 12:53 PM, Yasuo Ohgaki wrote:
>> 2012/8/21 Levi Morrison :
>>>
>>> I'm against this RFC, but if you are going to even try to add
>>> something, please keep it consistent! Don't modify `array_delete` to
>>> take a callable, instead make a diff
On Tue, Aug 21, 2012 at 12:53 PM, Yasuo Ohgaki wrote:
> 2012/8/21 Levi Morrison :
>>
>> I'm against this RFC, but if you are going to even try to add
>> something, please keep it consistent! Don't modify `array_delete` to
>> take a callable, instead make a different function `array_udelete` or
>>
Hi,
2012/8/21 Levi Morrison :
> On Tue, Aug 21, 2012 at 3:36 AM, Yasuo Ohgaki wrote:
>> Hi
>>
>> 2012/8/21 Tjerk Anne Meesters :
>>> On Tue, Aug 21, 2012 at 10:31 AM, Rasmus Schultz wrote:
>>>
Thank you, but this isn't really anything like what I had in mind.
What I had in mind is
Dearest Lester,
I know you don't understand generators. You've posted multiple times
about it. And you know what? It's okay; you don't have to understand
them. I do understand generators and would LOVE to have them
available for some of the things I do in my line of work; that's
perfectly fine
Gustavo Lopes wrote:
I've just tried to compile mysqlnd and mysqli shared and it worked (at least
sapi/cli/php -n -d extension_dir=modules -d extension=mysqlnd.so -d
extension=mysqli.so -i showed no problems).
Correct, it compiles fine, but what setup are you running your mysqlnd.so on?
This m
John LeSueur wrote:
Again, the case you've cited is probably not a case where generators give much
advantage. But anytime the logic to produce some data becomes more complicated
(Imagine that you needed to skip some of the lines in the .csv file based on
some kind of filter), then being able to e
On Tue, Aug 21, 2012 at 3:36 AM, Yasuo Ohgaki wrote:
> Hi
>
> 2012/8/21 Tjerk Anne Meesters :
>> On Tue, Aug 21, 2012 at 10:31 AM, Rasmus Schultz wrote:
>>
>>> Thank you, but this isn't really anything like what I had in mind.
>>>
>>> What I had in mind is more like set-semantics for arrays, e.g.
On Tue, Aug 21, 2012 at 12:31 AM, Lester Caine wrote:
> Morgan L. Owens wrote:
>
>> For the third one ... I'm still waiting for some clarification on how
>>> yield is SUPPOSED to work anyway? If you are using a 'generator' to
>>> return a sequence of data elements, then just what does happen betw
On 08/21/2012 09:10 AM, Ivan Enderlin @ Hoa wrote:
> Hello,
>
> Some of my users & contributors have met an issue with files containing
> UTF-8 on certain Windows configurations (but they actually did not found
> the difference). Any idea why?
> The issue does not appear on Linux, BSD or Mac OS sy
Hello,
Some of my users & contributors have met an issue with files containing
UTF-8 on certain Windows configurations (but they actually did not found
the difference). Any idea why?
The issue does not appear on Linux, BSD or Mac OS system, only for
certain Windows.
What do we need to check?
Em 2012-08-21 14:10, Lester Caine escreveu:
Gustavo Lopes wrote:
So should I be updating that bug to the current state of play? That
this is actually by design? Or create a new bug that states that
'--enable-mysqlnd=shared' should not be allowed? Or is there some
third position in this jigsaw?
Gustavo Lopes wrote:
So should I be updating that bug to the current state of play? That
this is actually by design? Or create a new bug that states that
'--enable-mysqlnd=shared' should not be allowed? Or is there some
third position in this jigsaw?
It usually helps that the extension you comp
Hello there,
Recently we have seen many extremely long discussion threads here on
internals. While discussion is good, much of these threads are filled
with noise, pointless arguing that has little merit.
NikiC calls them pseudo-arguments, I call it a pantomime: Someone will
raise a point, s
Em 2012-08-21 10:41, Lester Caine escreveu:
SO I simply assumed that was the case, it does not give an error
message like other miss configurations do ...
AH - JUST use --enable-mysqlnd=shared and don't add the mysqli shared
module at the same time and the core build happily creates a shared
mod
Hi
2012/8/21 Tjerk Anne Meesters :
> On Tue, Aug 21, 2012 at 10:31 AM, Rasmus Schultz wrote:
>
>> Thank you, but this isn't really anything like what I had in mind.
>>
>> What I had in mind is more like set-semantics for arrays, e.g. designed to
>> work with sets of distinct values/objects.
>>
>>
Rasmus Lerdorf wrote:
mysqlnd is not a standalone extension at all. It is infrastructure code
that needs to be linked into your PHP in order for extensions to use it.
OK that is the key piece of information I was missing. I though we had got over
the 'needs to be built in' and had made it opti
53 matches
Mail list logo