On 21/08/12 22:43, Levi Morrison wrote:
There is a reason to have a callable provided: custom comparison.
Other array functions solve this by providing a `u` alternative:
`int array_udelete(&$array, $value, bool function($value, $key))`
Let's not deviate from established array naming conventions. (Yasuo,
I'm looking at you)
Cheers,
Levi Morrison
Yeah, this looks like a good solution and we have the best of both worlds.
We get int array_delete(&$array, $value, $strict=TRUE); and int
array_udelete(&$array, $value, $callback=bool function ($value $key));
:)
--
Andrew Faulds
http://ajf.me/
--
PHP Internals - PHP Runtime Development Mailing List
To unsubscribe, visit: http://www.php.net/unsub.php