On Jan 12, 2008 1:54 AM, Jeff Griffiths <[EMAIL PROTECTED]> wrote:
> > if (1) {
> > $a = [
> > [
> > ['a' => 1, 3],
> > ($b = 3),
> > ]
> > ];
> > } else {
> > $a = [
> > [
> > ['b' => 1, 3]
> > ]
> > ];
> > }
>
Gregory Beaver wrote:
Jeff Griffiths wrote:
Antony Dovgal wrote:
...
Well, to me it matters whether the author is going to care of the
thing he's proposing or he's going to disappear right after it's
implemented.
I didn't realize there was a section of the code flagged 'syntactic
sugar' and on
Jeff Griffiths wrote:
> Antony Dovgal wrote:
> ...
>> Well, to me it matters whether the author is going to care of the
>> thing he's proposing or he's going to disappear right after it's
>> implemented.
>
> I didn't realize there was a section of the code flagged 'syntactic
> sugar' and only a fe
On 12.01.2008 02:20, Jeff Griffiths wrote:
> Antony Dovgal wrote:
> ...
>> Well, to me it matters whether the author is going to care of the thing he's
>> proposing or he's going to disappear right after it's implemented.
>
> I didn't realize there was a section of the code flagged 'syntactic
>
Antony Dovgal wrote:
...
Well, to me it matters whether the author is going to care of the thing he's
proposing or he's going to disappear right after it's implemented.
I didn't realize there was a section of the code flagged 'syntactic
sugar' and only a few people maintained that part. it als
On 12.01.2008 01:08, Pierre wrote:
>> > If we were voting on implementing a highly advanced technical feature
>> > then yes, people who know what they're talking about should be given
>> > more weight, but in this case I don't think so.
>>
>> You're not going to fix bug reports related to the parse
On Jan 11, 2008 10:52 PM, Antony Dovgal <[EMAIL PROTECTED]> wrote:
> > If we were voting on implementing a highly advanced technical feature
> > then yes, people who know what they're talking about should be given
> > more weight, but in this case I don't think so.
>
> You're not going to fix bug
On 11.01.2008 22:13, Sam Barrow wrote:
>> input from many people is great, moreover - it is necessary. However, it
>> is not the same as deciding by arithmetical majority of votes of whoever
>> cares to vote on technical questions.
>
> Which is a valid point in most cases, but this is not techni
I found the issue that was tripping me with the optimization I was
attempting in #1.
Basically, there seem to be cases where "op_arrays" get destroyed during
middle of program execution (e.g., op_array corresponding to the live
code in a file seems to get destroyed at the end of the "include"
ope
It is better to have input from people with a wide range of experience
levels, it results in a fairer vote that actually represents the
population, rather than putting PHP under the control of a select few.
No, it is not. This has nothing to do with "fairness", as we are not
enacting laws, levy
On Fri, 2008-01-11 at 11:07 -0800, Stanislav Malyshev wrote:
> > It is better to have input from people with a wide range of experience
> > levels, it results in a fairer vote that actually represents the
> > population, rather than putting PHP under the control of a select few.
>
> No, it is not.
On Fri, 2008-01-11 at 14:06 -0500, Olivier Hill wrote:
> On Jan 11, 2008 1:47 PM, Sam Barrow <[EMAIL PROTECTED]> wrote:
> >
> > True. No one's vote is worth more than anyone else's, everybody should
> > have equal say. Some people may know more about the PHP core, but we are
> > all users and devel
It is better to have input from people with a wide range of experience
levels, it results in a fairer vote that actually represents the
population, rather than putting PHP under the control of a select few.
No, it is not. This has nothing to do with "fairness", as we are not
enacting laws, levy
On Jan 11, 2008 1:47 PM, Sam Barrow <[EMAIL PROTECTED]> wrote:
>
> True. No one's vote is worth more than anyone else's, everybody should
> have equal say. Some people may know more about the PHP core, but we are
> all users and developers.
Not when some write anything about everything without kno
On Fri, 2008-01-11 at 19:27 +0100, Pierre wrote:
> On Jan 11, 2008 7:24 PM, Johannes Schlüter <[EMAIL PROTECTED]> wrote:
>
> > But well in my results I have a problem: For Rasmus's vote I've counted
> > a -1 while "as such this syntax is appropriate I think" has to be
> > counted as +1.
>
> There
Johannes Schlüter wrote:
But well in my results I have a problem: For Rasmus's vote I've counted
a -1 while "as such this syntax is appropriate I think" has to be
counted as +1.
I don't understand how you interpreted my view as a -1. I'm somewhat
ambivalent about it, but I don't think it woul
On Jan 11, 2008 7:24 PM, Johannes Schlüter <[EMAIL PROTECTED]> wrote:
> But well in my results I have a problem: For Rasmus's vote I've counted
> a -1 while "as such this syntax is appropriate I think" has to be
> counted as +1.
There is more than that. It is too early to close the poll. I is not
Hi Pierre,
On Fri, 2008-01-11 at 18:37 +0100, Pierre wrote:
> Yes, you forgot me. And restricting the right to vote to php-src only
> is respectless for all the documentation people.
Well, any restriction there is hard. I know hat the php-src karma is not
the best criteria. We have people with ka
I did a short count of the "votes" about the Array Syntax shortcut on
the list. I hope I've got everybody right. The results look like that:
There was no "vote", in fact. For example, I am for it and I'm sure my
"vote" wasn't counted - simply because I already voiced my support for
it last tim
On Jan 11, 2008 6:37 PM, Pierre <[EMAIL PROTECTED]> wrote:
> On Jan 11, 2008 4:47 PM, Johannes Schlüter <[EMAIL PROTECTED]> wrote:
> > Hi,
> >
> > I did a short count of the "votes" about the Array Syntax shortcut on
> > the list. I hope I've got everybody right. The results look like that:
>
> Yes
On Jan 11, 2008 4:47 PM, Johannes Schlüter <[EMAIL PROTECTED]> wrote:
> Hi,
>
> I did a short count of the "votes" about the Array Syntax shortcut on
> the list. I hope I've got everybody right. The results look like that:
Yes, you forgot me. And restricting the right to vote to php-src only
is re
-1
(OK so I'm late...)
- Original Message -
From: "Johannes Schlüter" <[EMAIL PROTECTED]>
To: "PHP Internals List"
Sent: Friday, January 11, 2008 3:47 PM
Subject: [PHP-DEV] SUMMARY: Array syntax
Hi,
I did a short count of the "votes" about the Array Syntax shortcut on
the list. I
Rasmus Lerdorf wrote:
And my stance hasn't changed either:
http://marc.info/?l=php-internals&m=117060700805108&w=2
...
+1
--
PHP Internals - PHP Runtime Development Mailing List
To unsubscribe, visit: http://www.php.net/unsub.php
+1 (option b)
--
Tullio Andreatta
09:f9:11:02:9d:74:e3:5b:d8:41:56:c5:63:56:88:c0
45:5f:e1:04:22:ca:29:c4:93:3f:95:05:2b:79:2a:b2
Disclaimer: "Please treat this email message in a reasonable way, or we
might get angry" ( http://www.goldmark.org/jeff/stupid-disclaimers )
--
PHP Internals - P
To help translating the documentation into danish.
Refered by Kalle Sommer Nielsen (kalle)
--
PHP Internals - PHP Runtime Development Mailing List
To unsubscribe, visit: http://www.php.net/unsub.php
Hi,
I did a short count of the "votes" about the Array Syntax shortcut on
the list. I hope I've got everybody right. The results look like that:
yesno
--
With php-src karma 510
Others16 9
---
On Jan 11, 2008 10:30 AM, Markus Fischer <[EMAIL PROTECTED]> wrote:
> -1
>
> Readability degrades quite a lot.
+1 (b)
Readability will only degrade as much as the coder allows it to.
Besides, I don't get the impression that array() is going to
disappear, only that another option is to be
-1
Readability degrades quite a lot.
--
PHP Internals - PHP Runtime Development Mailing List
To unsubscribe, visit: http://www.php.net/unsub.php
a) Commit square bracket array shortcut patch
keys and values are separated by colons.
( http://www.opendogs.org/pub/php-5.3dev-080109-sbar.patch )
e.g.
$a = [1, 2, 3];
$b = ['foo': 'orange', 'bar': 'apple', 'baz': 'lemon'];
Breaks from PHP's => for no apparent reason (one charact
+1
--
PHP Internals - PHP Runtime Development Mailing List
To unsubscribe, visit: http://www.php.net/unsub.php
+1
--
PHP Internals - PHP Runtime Development Mailing List
To unsubscribe, visit: http://www.php.net/unsub.php
On 11 Jan 2008, at 14:28, Mark Dennehy wrote:
b) Commit square bracket array shortcut patch
keys and values are separated by double arrows.
Breaks backwards compatibility to save typing five characters. See
above. -1.
It doesn't break backwards compatibility; the new syntax is an
alias,
-1
Ilia Alshanetsky
--
PHP Internals - PHP Runtime Development Mailing List
To unsubscribe, visit: http://www.php.net/unsub.php
Guys, there is really no point to argue about aesthetic or taste. Make
your point by using +1/-1 and that's it. As said, the trolls quota has
been used already.
+1
-chuck
--
PHP Internals - PHP Runtime Development Mailing List
To unsubscribe, visit: http://www.php.net/unsub.php
On Jan 11, 2008 2:17 PM, Geoffrey Sneddon <[EMAIL PROTECTED]> wrote:
> I don't think tiredness to type an extra five characters should be an
> excuse to change the syntax.
No, but clarity of expression is a valid reason to do so.
> > a) Commit square bracket array shortcut patch
> >keys an
On 10 Jan 2008, at 10:07, Ryusuke SEKIYAMA wrote:
I'm tired to type "array()" many times. And I want to
declare arrays more easily. So I wrote the patch for
zend_language_parser.y which enables to declare arrays
with square brackets like some other languages.
I don't think tiredness to type a
On Fri, 11 Jan 2008 10:45:25 +0100, Lukas Kahwe Smith <[EMAIL PROTECTED]> wrote:
>
> On Jan 10, 2008, at 8:57 PM, Lukas Kahwe Smith wrote:
>
>>
>> On Jan 10, 2008, at 4:55 PM, Antony Dovgal wrote:
>>
>>> On 10.01.2008 18:33, Derick Rethans wrote:
On Thu, 13 Dec 2007, Gregory Beaver wrote:
>
-1
-Hannes
--
PHP Internals - PHP Runtime Development Mailing List
To unsubscribe, visit: http://www.php.net/unsub.php
+1 (b)
Regards,
--
KUBO Atsuhiro e-mail: [EMAIL PROTECTED]
--
PHP Internals - PHP Runtime Development Mailing List
To unsubscribe, visit: http://www.php.net/unsub.php
On Fri, Jan 11, 2008 at 09:59:46AM +0100, Derick Rethans wrote:
> On Thu, 10 Jan 2008, Joe Orton wrote:
> > On Wed, Jan 09, 2008 at 09:03:02PM +0100, Derick Rethans wrote:
> > > It's not used (anymore). However, there is a PHP function
> > > timezone_identifiers_list that uses the index informatio
+1 (b)
If you think foo([]) is not readable, it's simple... don't use it.
Also, JS defines this since its begining and none until today said it
is not readable.
Regards,
On Jan 11, 2008 11:19 AM, Ford, Mike <[EMAIL PROTECTED]> wrote:
> +1 for (b) FWIW
>
> Cheers!
>
> Mike
>
> -
+1 for (b) FWIW
Cheers!
Mike
-
Mike Ford, Electronic Information Services Adviser,
JG125, The Headingley Library,
James Graham Building, Leeds Metropolitan University,
Headingley Campus, LEEDS, LS6 3QS, United Kingdom
Email:
-1
Tomi Kaistila
PHP Developer
--
PHP Internals - PHP Runtime Development Mailing List
To unsubscribe, visit: http://www.php.net/unsub.php
On Thu, 10 Jan 2008 15:51:51 -0800, "Andi Gutmans" <[EMAIL PROTECTED]> wrote:
> Andi 2003:
> http://www.mail-archive.com/internals@lists.php.net/msg03896.html
>
>
>
> Andi's brain evolves 2007:
> http://marc.info/?l=php-internals&m=117057393530217&w=2
>
>
>
> And today I'm still +1.
>
>
+1
(sorry for the first post)
--
- Peter Brodersen
--
PHP Internals - PHP Runtime Development Mailing List
To unsubscribe, visit: http://www.php.net/unsub.php
On Thu, 10 Jan 2008 15:51:51 -0800, in php.internals [EMAIL PROTECTED]
("Andi Gutmans") wrote:
>Andi 2003:
>http://www.mail-archive.com/internals@lists.php.net/msg03896.html
>
>
>
>Andi's brain evolves 2007:
>http://marc.info/?l=php-internals&m=117057393530217&w=2
>
>
>
>And today I'm still +1.
+1
--
PHP Internals - PHP Runtime Development Mailing List
To unsubscribe, visit: http://www.php.net/unsub.php
On Fri, 2008-01-11 at 10:05 +0200, Lokrain wrote:
> Hello mr. Antonio Touriño,
>
> So as if I understand, you want to change the syntax of array() keyword.
> Will you mind to update the changes in all php scripts in the world too?
>
> PS. You can always have your [] in custom patch, but I do not
On Jan 11, 2008 4:45 AM, Lukas Kahwe Smith <[EMAIL PROTECTED]> wrote:
>
> On Jan 10, 2008, at 8:57 PM, Lukas Kahwe Smith wrote:
>
> >
> > On Jan 10, 2008, at 4:55 PM, Antony Dovgal wrote:
> >
> >> On 10.01.2008 18:33, Derick Rethans wrote:
> >>> On Thu, 13 Dec 2007, Gregory Beaver wrote:
> >>>
> >>
+1
--
Ryusuke SEKIYAMA
--
PHP Internals - PHP Runtime Development Mailing List
To unsubscribe, visit: http://www.php.net/unsub.php
-1
On Fri, 2008-01-11 at 13:18 +0100, Pierre wrote:
> +1 (for the record in this thread :)
>
>
>
> --
> Pierre
> http://blog.thepimp.net | http://www.libgd.org
>
--
Patches/Donations: http://pecl.php.net/~jani/
--
PHP Internals - PHP Runtime Development Mailing List
To unsubscribe, visit:
+1
--
Mark Dennehy
+1
Best regards
Stephan
--
PHP Internals - PHP Runtime Development Mailing List
To unsubscribe, visit: http://www.php.net/unsub.php
-1
Now, back to lurking...
==
Richard Black - Senior Consultant
DataVisibility Ltd
Tel. 020 7917 9570
http://www.datavisibility.com/
Registered Office: 212 Picc
On Jan 11, 2008, at 1:18 PM, Pierre wrote:
+1 (for the record in this thread :)
-1
regards,
Lukas
--
PHP Internals - PHP Runtime Development Mailing List
To unsubscribe, visit: http://www.php.net/unsub.php
+1 (for the record in this thread :)
--
Pierre
http://blog.thepimp.net | http://www.libgd.org
--
PHP Internals - PHP Runtime Development Mailing List
To unsubscribe, visit: http://www.php.net/unsub.php
+1
--
PHP Internals - PHP Runtime Development Mailing List
To unsubscribe, visit: http://www.php.net/unsub.php
-1
--
PHP Internals - PHP Runtime Development Mailing List
To unsubscribe, visit: http://www.php.net/unsub.php
-1
On Jan 11, 2008, at 12:55 PM, "troels knak-nielsen"
<[EMAIL PROTECTED]> wrote:
One problem, I have with this proposal is, that it isn't much like
javascript anyway. In javascript, there is a distinction between array
and hashmap, with different syntaxes. If anything, the syntax should
pro
On Jan 11, 2008 1:19 PM, Pierre <[EMAIL PROTECTED]> wrote:
> Hi,
>
> Guys, there is really no point to argue about aesthetic or taste. Make
> your point by using +1/-1 and that's it. As said, the trolls quota has
> been used already.
>
+1 FWIW :-)
--
Giedrius
--
PHP Internals - PHP Runtime Deve
-1
--
PHP Internals - PHP Runtime Development Mailing List
To unsubscribe, visit: http://www.php.net/unsub.php
One problem, I have with this proposal is, that it isn't much like
javascript anyway. In javascript, there is a distinction between array
and hashmap, with different syntaxes. If anything, the syntax should
probably be {'foo' => 1, 'bar' => 2}.
I don't think the added noise is worth it though, sinc
-1
--
Mikko Koppanen
-1
PHP is not Python.
--Marcelo
On Jan 11, 2008 9:29 AM, Edin Kadribasic <[EMAIL PROTECTED]> wrote:
> +1 on option b.
>
> --
> PHP Internals - PHP Runtime Development Mailing List
> To unsubscribe, visit: http://www.php.net/unsub.php
>
>
--
Marcelo Araujo
Founder & Software Architect
Cell Pho
+1 on option b.
--
PHP Internals - PHP Runtime Development Mailing List
To unsubscribe, visit: http://www.php.net/unsub.php
Hi,
Guys, there is really no point to argue about aesthetic or taste. Make
your point by using +1/-1 and that's it. As said, the trolls quota has
been used already.
Thanks for my bandwidth,
On Jan 11, 2008 12:12 PM, Max Antonov <[EMAIL PROTECTED]> wrote:
> Johannes Schlüter writes:
>
> >
> > The
Johannes Schlüter writes:
The last line is exactly why I won't like such a syntax. Just consider
the a bit worse call like
foo([1, $a[2]]);
I might even construct worse examples,
is this a good-readable code?
foo (array('a'=2,'b'=>array('x'=>5,'c'=>array(1,4,2)),'n'=>$bar[4]));
what diffe
Hi,
On Fri, 2008-01-11 at 12:40 +0300, Max Antonov wrote:
> I use PHP since version 5.0 release
> I'd like use this syntax
> $a = [ 2,6,9 ];
> $b = ['a'=>1 , 'v'=>'string'];
> foo(['bar'=>2, 'test'=null]);
The last line is exactly why I won't like such a syntax. Just consider
the a bit worse call
I don't remember ever seeing this before, but I'm still very strongly
against this kind of useless syntax sugar..
--Jani
On Thu, 2008-01-10 at 11:36 -0800, Andi Gutmans wrote:
> I recommended (b) a few months back and got shot down :)
> I still like it :)
>
> Andi
>
> > -Original Message--
On Jan 10, 2008, at 8:57 PM, Lukas Kahwe Smith wrote:
On Jan 10, 2008, at 4:55 PM, Antony Dovgal wrote:
On 10.01.2008 18:33, Derick Rethans wrote:
On Thu, 13 Dec 2007, Gregory Beaver wrote:
We don't need moderation, we don't need read-only. We need
people to
follow a simple common-sens
I use PHP since version 5.0 release
I'd like use this syntax
$a = [ 2,6,9 ];
$b = ['a'=>1 , 'v'=>'string'];
foo(['bar'=>2, 'test'=null]);
Andi Gutmans пишет:
Andi 2003:
http://www.mail-archive.com/internals@lists.php.net/msg03896.html
Andi's brain evolves 2007:
http://marc.info/?l=php-inter
On Thu, 10 Jan 2008, Joe Orton wrote:
> On Wed, Jan 09, 2008 at 09:03:02PM +0100, Derick Rethans wrote:
> > On Wed, 9 Jan 2008, Joe Orton wrote:
> >
> > > It's a bit of a maintenance headache for distributions when
> > > packages include their own copy of the timezone database, since this
> > >
On 10.01.2008 13:07, Ryusuke SEKIYAMA wrote:
> Hello, lists,
>
> I'm tired to type "array()" many times.
-1
The parser in my head is unable to parse this:
--
Wbr,
Antony Dovgal
--
PHP Internals - PHP Runtime Development Mailing List
To unsubscribe, visit: http://www.php.net/unsub.php
On Thu, 10 Jan 2008, Cristian Rodriguez wrote:
> 2008/1/10, Pierre <[EMAIL PROTECTED]>:
>
> > If distros start to use the
> > system timezone
>
> Distros use system timezonedb for %99 of the other components(some of
> them far more critical than PHP) , why PHP has to be special ?
Because if PHP
On Jan 11, 2008, at 12:43 AM, Stanislav Malyshev wrote:
At the very least, some kind of centralized RFC tracker (like PEAR's
PEPr for package proposals) would be a potential way to track
features
Maybe just for the start create a wiki or something that people
could put their RFCs to and e
On Thu, 10 Jan 2008, Antonio Touriño wrote:
> The array() syntax to me screams function call, something that,
You mean just like if(), for(), while(), foreach(), elseif() and... ?
regards,
Derick
--
Derick Rethans
http://derickrethans.nl | http://ezcomponents.org | http://xdebug.org
--
PHP I
On Thu, 10 Jan 2008, Andi Gutmans wrote:
> I think almost everyone here agreed it'd benefit them and maybe the ones
> who don't would go through the same process I went through once they get
> used to it J
I don't know about that, I for once find it silly to even try to argue
that [] is a good i
It is not about changing, it is about adding a different way to declare
arrays (the function-style way will remain). The current code base will be
unaffected.
+1 vote from me to add ['x'=>'y']
On Jan 11, 2008 10:05 AM, Lokrain <[EMAIL PROTECTED]> wrote:
> Hello mr. Antonio Touriño,
>
> So as if
Hello mr. Antonio Touriño,
So as if I understand, you want to change the syntax of array() keyword.
Will you mind to update the changes in all php scripts in the world too?
PS. You can always have your [] in custom patch, but I do not think
it's useful to want it globally changed.
Hi,
On Thu, 10 Jan 2008 21:02:17 -0300, in php.internals
[EMAIL PROTECTED] ("Cristian Rodriguez") wrote:
>> If distros start to use the
>> system timezone
>
>Distros use system timezonedb for %99 of the other components(some of
>them far more critical than PHP) , why PHP has to be special ?
Beca
80 matches
Mail list logo