Re: [Intel-gfx] [PATCH] drm/i915: fix intel_crtc_get_clock pipe reads after "cleanup"

2011-04-22 Thread Keith Packard
On Fri, 22 Apr 2011 22:22:28 +0100, Chris Wilson wrote: > fp = FP0(pipe); > else > fp = FP1(pipe); > + fp = I915_READ(fp); Please use different variables for the offset vs the value... -- keith.pack...@intel.com pgpaGbAUtaJf4.pgp Description: PGP signat

Re: [Intel-gfx] [PATCH 05/17] drm/i915/tv: Clear state sense detection for Cantiga

2011-04-22 Thread Peter Clifton
On Thu, 2011-04-21 at 16:36 -0700, Eric Anholt wrote: > On Thu, 21 Apr 2011 22:18:20 +0100, Chris Wilson > wrote: > > From: Zhao Yakui > > > > ... otherwise the TV type will be misdetected and cause spurious > > connections. > > > > This was originally applied as fb8b5a39b6310379d7b54c0c711370

Re: [Intel-gfx] [PATCH] drm/i915: fix intel_crtc_get_clock pipe reads after "cleanup"

2011-04-22 Thread Jesse Barnes
On Fri, 22 Apr 2011 22:34:46 +0100 Chris Wilson wrote: > Despite the fixes in 548f245ba6a31 (drm/i915: fix per-pipe reads after > "cleanup"), we missed one neighbouring read that was mistakenly replaced > with the reg value in 9db4a9c (drm/i915: cleanup per-pipe reg usage). > This was preventing

[Intel-gfx] [PATCH] drm/i915: fix intel_crtc_get_clock pipe reads after "cleanup"

2011-04-22 Thread Chris Wilson
Despite the fixes in 548f245ba6a31 (drm/i915: fix per-pipe reads after "cleanup"), we missed one neighbouring read that was mistakenly replaced with the reg value in 9db4a9c (drm/i915: cleanup per-pipe reg usage). This was preventing us from correctly determining the mode the BIOS left the panel in

Re: [Intel-gfx] [PATCH] drm/i915: fix intel_crtc_get_clock pipe reads after "cleanup"

2011-04-22 Thread Jesse Barnes
On Fri, 22 Apr 2011 22:22:28 +0100 Chris Wilson wrote: > Despite the fixes in 548f245ba6a31 (drm/i915: fix per-pipe reads after > "cleanup"), we missed one neighbouring read that was mistakenly replaced > with the reg value in 9db4a9c (drm/i915: cleanup per-pipe reg usage). > This was preventing

[Intel-gfx] [PATCH] drm/i915: fix intel_crtc_get_clock pipe reads after "cleanup"

2011-04-22 Thread Chris Wilson
Despite the fixes in 548f245ba6a31 (drm/i915: fix per-pipe reads after "cleanup"), we missed one neighbouring read that was mistakenly replaced with the reg value in 9db4a9c (drm/i915: cleanup per-pipe reg usage). This was preventing us from correctly determining the mode the BIOS left the panel in

[Intel-gfx] [PATCH] drm/i915: remove unused variables from DP training

2011-04-22 Thread Jesse Barnes
Leftover from the training split, we don't need these guys anymore. Signed-off-by: Jesse Barnes diff --git a/drivers/gpu/drm/i915/intel_dp.c b/drivers/gpu/drm/i915/intel_dp.c index 0daefca..0558e0a 100644 --- a/drivers/gpu/drm/i915/intel_dp.c +++ b/drivers/gpu/drm/i915/intel_dp.c @@ -1275,7 +127

Re: [Intel-gfx] [PATCH 03/17] drm/i915: Release object along create user fb error path

2011-04-22 Thread Ben Widawsky
On Thu, Apr 21, 2011 at 10:18:18PM +0100, Chris Wilson wrote: > Reported-by: Alan Cox > Signed-off-by: Chris Wilson > Cc: sta...@kernel.org > --- > drivers/gpu/drm/i915/intel_display.c |4 +++- > 1 files changed, 3 insertions(+), 1 deletions(-) > > diff --git a/drivers/gpu/drm/i915/intel_di

Re: [Intel-gfx] [PATCH 02/10] drm/i915/lvds: Introduce intel_lvds_connector

2011-04-22 Thread Chris Wilson
On Fri, 22 Apr 2011 10:50:47 -0700, Ben Widawsky wrote: > How about to save some eyestrain, using some macro helpers? > > struct intel_lvds_connector { > struct intel_connector base; > #define drm_base \ > base.base > #define drm_dev \ > drm_base.dev > #define drm_funcs \ >

Re: [Intel-gfx] [PATCH 02/10] drm/i915/lvds: Introduce intel_lvds_connector

2011-04-22 Thread Ben Widawsky
On Fri, Apr 22, 2011 at 10:19:10AM +0100, Chris Wilson wrote: > Introduce a local structure to move LVDS specific information away from > the drm_i915_private and onto the LVDS connector. > > Signed-off-by: Chris Wilson > --- > drivers/gpu/drm/i915/intel_lvds.c | 31 +--

Re: [Intel-gfx] [PATCH 3/5] drm/i915: forcewake struct mutex locking fixes

2011-04-22 Thread Chris Wilson
On Fri, 22 Apr 2011 09:20:17 -0700, Ben Widawsky wrote: > I don't understand what you're asking for. I'm pretty convinced I need > the mutex protected intel_update_fbc, because the call trace could be: > > intel_update_fbc() > intel_enable_fbc() > ironlake_enable_fbc() > sandybridge_blit_fbc_upda

Re: [Intel-gfx] [PATCH 3/5] drm/i915: forcewake struct mutex locking fixes

2011-04-22 Thread Ben Widawsky
On Fri, Apr 22, 2011 at 09:20:17AM -0700, Ben Widawsky wrote: > On Thu, Apr 21, 2011 at 07:18:24AM +0100, Chris Wilson wrote: > > On Wed, 20 Apr 2011 16:53:17 -0700, Ben Widawsky wrote: > > > > > > Signed-off-by: Ben Widawsky > > > > Just to annoy you, this needs to be split up into the various

Re: [Intel-gfx] [PATCH 10/10] drm/i915: Only force a modeset on a lid event if fbcon is active

2011-04-22 Thread Jesse Barnes
On Fri, 22 Apr 2011 10:19:18 +0100 Chris Wilson wrote: > ... otherwise just left userspace handle the notification and change > modes as it desires. > > Signed-off-by: Chris Wilson > --- Problem is that old userspace didn't do anything. The change is a nice one though; maybe a setparam is nee

Re: [Intel-gfx] [PATCH 09/10] drm/i015: Share the EDID caching logic and mode query between LVDS and eDP

2011-04-22 Thread Jesse Barnes
On Fri, 22 Apr 2011 10:19:17 +0100 Chris Wilson wrote: > Signed-off-by: Chris Wilson > --- > drivers/gpu/drm/i915/intel_dp.c| 54 +-- > drivers/gpu/drm/i915/intel_drv.h |3 ++ > drivers/gpu/drm/i915/intel_lvds.c | 33 ++--- > driver

Re: [Intel-gfx] [PATCH 08/10] drm/i915/dp: If the panel has a fixed_mode, it can only be eDP

2011-04-22 Thread Jesse Barnes
On Fri, 22 Apr 2011 10:19:16 +0100 Chris Wilson wrote: > ... and so we can simplify some conditionals. > > Signed-off-by: Chris Wilson > --- > drivers/gpu/drm/i915/intel_dp.c | 17 +++-- > 1 files changed, 7 insertions(+), 10 deletions(-) Only downside of this is that it makes t

Re: [Intel-gfx] [PATCH 07/10] drm/i915: Move the fixed_mode away from drm_i915_private and to the panel

2011-04-22 Thread Jesse Barnes
On Fri, 22 Apr 2011 10:19:15 +0100 Chris Wilson wrote: > ... as matches usage. > > Signed-off-by: Chris Wilson > --- > drivers/gpu/drm/i915/i915_drv.h|1 - > drivers/gpu/drm/i915/intel_dp.c| 43 + > drivers/gpu/drm/i915/intel_drv.h |4 ++- >

Re: [Intel-gfx] [PATCH 05/10] drm/i915: Move the ACPI lid notifier away from LVDS to the generic panel

2011-04-22 Thread Jesse Barnes
On Fri, 22 Apr 2011 10:19:13 +0100 Chris Wilson wrote: > ... in preparation for enabling it from eDP as well. > > Signed-off-by: Chris Wilson > --- > drivers/gpu/drm/i915/intel_drv.h |8 +++ > drivers/gpu/drm/i915/intel_lvds.c | 79 ++- > drivers/gpu/drm/i9

Re: [Intel-gfx] [PATCH 3/5] drm/i915: forcewake struct mutex locking fixes

2011-04-22 Thread Ben Widawsky
On Thu, Apr 21, 2011 at 07:18:24AM +0100, Chris Wilson wrote: > On Wed, 20 Apr 2011 16:53:17 -0700, Ben Widawsky wrote: > > > > Signed-off-by: Ben Widawsky > > Just to annoy you, this needs to be split up into the various categories > of fixes. Because... > > > static void ironlake_crtc_dpms(

Re: [Intel-gfx] [PATCH 04/10] drm/i915/lvds: Move some connector specific info across from the encoder

2011-04-22 Thread Jesse Barnes
On Fri, 22 Apr 2011 10:19:12 +0100 Chris Wilson wrote: > As there is 1:1 mapping between encoder and connector for the LVDS, the > goal is to simply reduce the amount of noise within the connector > functions, i.e. we split the encoder/connector for LVDS as best we can > and try to only operate o

Re: [Intel-gfx] [PATCH 03/10] drm/i915/lvds: Move the acpi_lid_notifier from drm_i915_private to the connector

2011-04-22 Thread Jesse Barnes
On Fri, 22 Apr 2011 10:19:11 +0100 Chris Wilson wrote: > Signed-off-by: Chris Wilson > --- > drivers/gpu/drm/i915/i915_drv.h |3 --- > drivers/gpu/drm/i915/intel_lvds.c | 33 + > 2 files changed, 17 insertions(+), 19 deletions(-) > Yeah, much better. R

Re: [Intel-gfx] [PATCH 02/10] drm/i915/lvds: Introduce intel_lvds_connector

2011-04-22 Thread Jesse Barnes
On Fri, 22 Apr 2011 10:19:10 +0100 Chris Wilson wrote: > Introduce a local structure to move LVDS specific information away from > the drm_i915_private and onto the LVDS connector. > > Signed-off-by: Chris Wilson > --- Nice to split this out. Acked-by: Jesse Barnes -- Jesse Barnes, Intel O

Re: [Intel-gfx] [PATCH 01/10] drm/i915/lvds: Rename intel_lvds to intel_lvds_encoder

2011-04-22 Thread Jesse Barnes
On Fri, 22 Apr 2011 10:19:09 +0100 Chris Wilson wrote: > In preparation for introducing intel_lvds_connector to move some of the > LVDS specific storage away from drm_i915_private, first rename the > encoder to avoid potential confusion. > > Signed-off-by: Chris Wilson > --- > drivers/gpu/drm/

Re: [Intel-gfx] [PATCH 4/5] drm/i915: move gen6 rps handling to workqueue

2011-04-22 Thread Ben Widawsky
On Thu, Apr 21, 2011 at 07:34:08AM +0100, Chris Wilson wrote: > > + /* > > +* Lock not held here, because clearing is non-destructive, and > > +* the interrupt handler is the only other place where it is written. > > +*/ > > + I915_WRITE(GEN6_PMIMR, pm_imr & ~pm_iir); } > > But do

Re: [Intel-gfx] [PATCH] NEWS: fix typo (s/2.14/2.15/) to match corresponding release

2011-04-22 Thread Chris Wilson
Pushed, thanks. -Chris -- Chris Wilson, Intel Open Source Technology Centre ___ Intel-gfx mailing list Intel-gfx@lists.freedesktop.org http://lists.freedesktop.org/mailman/listinfo/intel-gfx

[Intel-gfx] [PATCH] NEWS: fix typo (s/2.14/2.15/) to match corresponding release

2011-04-22 Thread Paul Menzel
Date: Fri, 22 Apr 2011 15:09:12 +0200 Signed-off-by: Paul Menzel --- NEWS |2 +- 1 files changed, 1 insertions(+), 1 deletions(-) diff --git a/NEWS b/NEWS index bf55b4b..61866b0 100644 --- a/NEWS +++ b/NEWS @@ -2,7 +2,7 @@ Release 2.15.0 (2011-04-14) == We are

[Intel-gfx] [PATCH 10/10] drm/i915: Only force a modeset on a lid event if fbcon is active

2011-04-22 Thread Chris Wilson
... otherwise just left userspace handle the notification and change modes as it desires. Signed-off-by: Chris Wilson --- drivers/gpu/drm/i915/intel_panel.c | 21 - 1 files changed, 20 insertions(+), 1 deletions(-) diff --git a/drivers/gpu/drm/i915/intel_panel.c b/drivers

[Intel-gfx] [PATCH 06/10] drm/i915/dp: Enable lid notifier for eDP

2011-04-22 Thread Chris Wilson
Signed-off-by: Chris Wilson --- drivers/gpu/drm/i915/intel_dp.c |6 ++ 1 files changed, 6 insertions(+), 0 deletions(-) diff --git a/drivers/gpu/drm/i915/intel_dp.c b/drivers/gpu/drm/i915/intel_dp.c index 0daefca..3ef944f 100644 --- a/drivers/gpu/drm/i915/intel_dp.c +++ b/drivers/gpu/drm

[Intel-gfx] [PATCH 01/10] drm/i915/lvds: Rename intel_lvds to intel_lvds_encoder

2011-04-22 Thread Chris Wilson
In preparation for introducing intel_lvds_connector to move some of the LVDS specific storage away from drm_i915_private, first rename the encoder to avoid potential confusion. Signed-off-by: Chris Wilson --- drivers/gpu/drm/i915/intel_lvds.c | 227 +++-- 1 files

[Intel-gfx] [PATCH 07/10] drm/i915: Move the fixed_mode away from drm_i915_private and to the panel

2011-04-22 Thread Chris Wilson
... as matches usage. Signed-off-by: Chris Wilson --- drivers/gpu/drm/i915/i915_drv.h|1 - drivers/gpu/drm/i915/intel_dp.c| 43 + drivers/gpu/drm/i915/intel_drv.h |4 ++- drivers/gpu/drm/i915/intel_lvds.c | 45 ---

[Intel-gfx] [PATCH 03/10] drm/i915/lvds: Move the acpi_lid_notifier from drm_i915_private to the connector

2011-04-22 Thread Chris Wilson
Signed-off-by: Chris Wilson --- drivers/gpu/drm/i915/i915_drv.h |3 --- drivers/gpu/drm/i915/intel_lvds.c | 33 + 2 files changed, 17 insertions(+), 19 deletions(-) diff --git a/drivers/gpu/drm/i915/i915_drv.h b/drivers/gpu/drm/i915/i915_drv.h index b21470

[Intel-gfx] [PATCH 09/10] drm/i015: Share the EDID caching logic and mode query between LVDS and eDP

2011-04-22 Thread Chris Wilson
Signed-off-by: Chris Wilson --- drivers/gpu/drm/i915/intel_dp.c| 54 +-- drivers/gpu/drm/i915/intel_drv.h |3 ++ drivers/gpu/drm/i915/intel_lvds.c | 33 ++--- drivers/gpu/drm/i915/intel_panel.c | 19 4 files changed, 58

[Intel-gfx] [PATCH 08/10] drm/i915/dp: If the panel has a fixed_mode, it can only be eDP

2011-04-22 Thread Chris Wilson
... and so we can simplify some conditionals. Signed-off-by: Chris Wilson --- drivers/gpu/drm/i915/intel_dp.c | 17 +++-- 1 files changed, 7 insertions(+), 10 deletions(-) diff --git a/drivers/gpu/drm/i915/intel_dp.c b/drivers/gpu/drm/i915/intel_dp.c index 384017c..4c42f39 100644

[Intel-gfx] [PATCH 04/10] drm/i915/lvds: Move some connector specific info across from the encoder

2011-04-22 Thread Chris Wilson
As there is 1:1 mapping between encoder and connector for the LVDS, the goal is to simply reduce the amount of noise within the connector functions, i.e. we split the encoder/connector for LVDS as best we can and try to only operate on the LVDS connector from the connector funcs and the LVDS encode

[Intel-gfx] [PATCH 05/10] drm/i915: Move the ACPI lid notifier away from LVDS to the generic panel

2011-04-22 Thread Chris Wilson
... in preparation for enabling it from eDP as well. Signed-off-by: Chris Wilson --- drivers/gpu/drm/i915/intel_drv.h |8 +++ drivers/gpu/drm/i915/intel_lvds.c | 79 ++- drivers/gpu/drm/i915/intel_panel.c | 92 3 files c

[Intel-gfx] Share common logic between eDP and LVDS in panel

2011-04-22 Thread Chris Wilson
The eDP panel handling lacked a lot of the finese that we have developed for LVDS, such as handling lid notifications and cacheing EDIDs. Also we had a lot of connector specific data stuffed into the global drm_i915_private which makes for a confusing read. Let's try to reduce that confusion by sh

[Intel-gfx] [PATCH 02/10] drm/i915/lvds: Introduce intel_lvds_connector

2011-04-22 Thread Chris Wilson
Introduce a local structure to move LVDS specific information away from the drm_i915_private and onto the LVDS connector. Signed-off-by: Chris Wilson --- drivers/gpu/drm/i915/intel_lvds.c | 31 +-- 1 files changed, 21 insertions(+), 10 deletions(-) diff --git a/dri