Thanks Viktor,
Ok, I Do understand, thank you very much Viktor.
Best regards.
Xavi
Szakáts Viktor escribió:
Hi Javier,
A question, does it be better to make the change hb_itemPutCPtr() to
hb_itemPutCLPtr() by macro in hbapi.h?
#define hb_itemPutCPtrhb_itemPutCLPtr
Currently there is a
Hi Javier,
A question, does it be better to make the change hb_itemPutCPtr() to
hb_itemPutCLPtr() by macro in hbapi.h?
#define hb_itemPutCPtrhb_itemPutCLPtr
Currently there is a stub with the old name (so
it still works, but it needs two more CPU jumps),
and I did it like this to slightl
Thanks Viktor & Mindaugas,
A question, does it be better to make the change hb_itemPutCPtr() to
hb_itemPutCLPtr() by macro in hbapi.h?
#define hb_itemPutCPtrhb_itemPutCLPtr
I done the change suggested by Mindaugas. Please, could you update the
repository, thank you so much Viktor.
Now ac
Sorry for my error.-
? _SPD( "[%-15s] [%8.1f]", "It's number", 5.5.) // => "[It's number]
[ 5.5]"
For ANSI SQL is only new 't' converter everything others is clone C
sprintf() or error in type data of sprintf(), so we could convert the
Harbour types of data LOGIC and DATES with the '
Thanks Mindaugas, I very much appreciate your views.
Mindaugas Kavaliauskas escribió:
New flags worth to be implemented can be:
1) string and numbers trimming (it would be usefull because .dbf
fields are space PADR'ed);
But this already it does sprintf.-
_SPD("[%15s] [%8.1f]", "It's number",
Thanks Mingaugas, I was expecting exactly this kind
of input. So this is not a clone of sprintf(), but
rather something similar but specially crafted for
SQL expressions.
I'll rename current C_SPRINTF() to SQL_SPRINTF(),
and we can later plug additional implementations
with different names.
Actu
Javier wrote:
I think that the better name for the function would be Sprintf() but I
believe that it is not my decision.
Szakáts Viktor wrote:
> As for a name I'd suggest LIBC_SPRINTF() or C_SPRINTF(),
> maybe HB_SPRINTF() as alternatives.
>
> Votes, suggestions and opinions are welcome.
Hi,
Hi Javier,
Thanks a bunch for your update. I'll commit it ASAP.
As for a name I'd suggest LIBC_SPRINTF() or C_SPRINTF(),
maybe HB_SPRINTF() as alternatives.
Votes, suggestions and opinions are welcome.
Brgds,
Viktor
On 2008.06.11., at 21:05, Javier wrote:
Ok Viktor, I do it.
Now support ind
Ok Viktor, I do it.
Now support index & indirect arguments ANSI C99 .-
Local cName := "Bond", cCity := "Tokyo"
? _SPD( "Hi, I'm %01$s from %02$s.", cName, cCity ) // -> "Hi, I'm Bond
from Tokyo"
? _SPD( "Hi, I'm from %02$s, my name is %01$s.", cName, cCity ) // ->
"Hi, I'm from Tokyo, my name i
> cName := "Bond"; cCity := "Tokyo"
> _SPD( "Hi, I'm %#01s from %#02s.", cName, cCity ) -> "Hi, I'm Bond
from Tokyo"
> _SPD( "Hi, I'm from %#02s, my name is %#01s.", cName, cCity ) ->
"Hi, I'm from Tokyo, my name is Bond"
This is TO DO, do you want do it?
No thanks, I'm doing enough things
That's it, thanks Mindaugas.
Brgds,
Viktor
On 2008.06.08., at 18:43, Mindaugas Kavaliauskas wrote:
... I think it would very
nice if there would be a possibility to specify the
_ordinals_ of those format strings:
cName := "Bond"; cCity := "Tokyo"
_SPD( "Hi, I'm %#01s from %#02s.", cName, cCi
Viktor,
> cName := "Bond"; cCity := "Tokyo"
> _SPD( "Hi, I'm %#01s from %#02s.", cName, cCity ) -> "Hi, I'm Bond
from Tokyo"
> _SPD( "Hi, I'm from %#02s, my name is %#01s.", cName, cCity ) -> "Hi,
I'm from Tokyo, my name is Bond"
This is TO DO, do you want do it?
My problem is that I have lim
... I think it would very
nice if there would be a possibility to specify the
_ordinals_ of those format strings:
cName := "Bond"; cCity := "Tokyo"
_SPD( "Hi, I'm %#01s from %#02s.", cName, cCity ) -> "Hi, I'm Bond from
Tokyo"
_SPD( "Hi, I'm from %#02s, my name is %#01s.", cName, cCity ) -> "H
Hi Javier,
One more thing (well two).
IMO to make this function more universal and even easier
to use and update (and usable for someone needing it for
translated text formatting), I think it would very
nice if there would be a possibility to specify the
_ordinals_ of those format strings:
cNam
Hi Javier,
Could you please apply your changes to the file
on the repository? It's also good if you send a .dif
file for that one. Thanks in advance.
I'd also suggest a more descriptive function name
and maybe even some documentation, so that ppl. can
find out what it does. [ For the doc you can
Tanks Viktor,
Please, change with more complete function.
Incorporate a new converter "%t" to print ANSI SQL's Strings and typing
Dates and Numbers according to FIXED DECIMALS .-
? _Spd( "String's C to %t and Dates %t, Number %t \n", "String's ANSI
SQL", Date(), 3.141516 )
Print NULL always
2008-06-07 13:26 UTC+0100 Viktor Szakats (harbour.01 syenar hu)
* contrib/hbmisc/common.mak
* contrib/hbmisc/Makefile
- contrib/hbmisc/mathx.c
+ contrib/hbmisc/spd.c
- Removed math functions equivalent with CT3 ones.
INCOMPATIBLE: If your code used CEIL() from hbmisc, please
17 matches
Mail list logo