On 2011.10.28 at 07:20 +0200, Markus Trippelsdorf wrote:
> On 2011.10.27 at 17:29 -0700, Andi Kleen wrote:
> > Markus Trippelsdorf writes:
> >
> > > By popular demand, I've prepared a patch that updates the in-tree
> > > libtool to version 2.4.2. It is needed for lto-bootstrap with
> > > -fno-fat
2011/10/27 Georg-Johann Lay :
> This is support of a new option -maccumulate-args that implements
> ACCUMULATE_OUTGOING_ARGS as proposed by Richard.
>
> As 4.7 will be released very soon, I'd like to supply the documentation part
> later and use the remaining stage I time for extension/improvements
On Sat, Oct 29, 2011 at 01:48, Mikael Morin wrote:
> On Tuesday 18 October 2011 17:11:24 Janne Blomqvist wrote:
>> Also, I think I've found a small standards conformance bug. From F2008
>> (N1830) 9.10.2.23 (page 256): "... ASIS if the connection was opened
>> without changing its position." and "
> This broke cross to cris-elf and I guess many other targets
> with TOT binutils, as follows:
>
> mv -f Tlto-wrapper lto-wrapper
Oops. Can you please confirm this patch fixes it?
-Andi
diff --git a/gcc/gcc-ar.c b/gcc/gcc-ar.c
index fc7e4a2..1e86d20 100644
--- a/gcc/gcc-ar.c
+++ b/gcc/gcc-ar.c
> I haven't figured out yet how to use gcc-ar et al. instead of the shell
> wrappers. The plugin path seems to be hardcoded, which is unfortunate.
> Would it be possible to make the wrappers more flexible, so that they
> could be used during bootstrap?
The path can be set with GCC_EXEC_PREFIX curr
On Sat, Oct 29, 2011 at 10:09:48AM +0200, Andi Kleen wrote:
> > This broke cross to cris-elf and I guess many other targets
> > with TOT binutils, as follows:
> >
> > mv -f Tlto-wrapper lto-wrapper
>
> Oops. Can you please confirm this patch fixes it?
I committed the patch with ChangeLog as as
> From: Andi Kleen
> Date: Sat, 29 Oct 2011 10:09:48 +0200
> Oops. Can you please confirm this patch fixes it?
My autotester is still busy after your commit, but has passed
the point of failure. Thanks for fixing.
brgds, H-P
OK.
Jason
On Saturday 29 October 2011 10:09:07 Janne Blomqvist wrote:
> On Sat, Oct 29, 2011 at 01:48, Mikael Morin wrote:
> > On Tuesday 18 October 2011 17:11:24 Janne Blomqvist wrote:
> >> Also, I think I've found a small standards conformance bug. From F2008
> >> (N1830) 9.10.2.23 (page 256): "... ASIS i
As approved on the PR thread,
Iain
Index: gcc/objc/ChangeLog
===
--- gcc/objc/ChangeLog (revision 180650)
+++ gcc/objc/ChangeLog (working copy)
@@ -1,3 +1,10 @@
+2011-10-29 Iain Sandoe
+
+ PR target/47997
+ * objc-ac
On Fri, 2011-10-28 at 07:53 -0500, Aldy Hernandez wrote:
> > diff --git a/gcc/testsuite/gcc.dg/tm/memopt-1.c
> > b/gcc/testsuite/gcc.dg/tm/memopt-1.c
> > index 06d4f64..9a48dcb 100644
> > --- a/gcc/testsuite/gcc.dg/tm/memopt-1.c
> > +++ b/gcc/testsuite/gcc.dg/tm/memopt-1.c
> > @@ -2,8 +2,8 @@
> >
On 10/26/2011 11:56 PM, Jakub Jelinek wrote:
Hi!
This patch implements gather vectorization with -mavx2, if
dr_may_alias (which apparently doesn't use tbaa :(( ) can figure out
there is no overlap with stores in the loop (if any).
The testcases show what is possible to get vectorized.
I chose t
On 10/26/2011 11:56 PM, Jakub Jelinek wrote:
Hi!
This patch implements gather vectorization with -mavx2, if
dr_may_alias (which apparently doesn't use tbaa :(( ) can figure out
there is no overlap with stores in the loop (if any).
The testcases show what is possible to get vectorized.
Hmmm,
On Fri, Oct 28, 2011 at 06:30:35PM +0200, Mikael Morin wrote:
> On Friday 28 October 2011 15:56:36 Jack Howarth wrote:
> > Mikael,
> > The complete patch bootstraps current FSF gcc trunk on
> > x86_64-apple-darwin11 and the resulting gfortran compiler can compile the
> > Polyhedron 2005 benchma
On 10/28/2011 12:07 AM, Richard Henderson wrote:
This exposed a wealth of problems in code that has heretofore never
been tested. The fourth patch makes certain that all expansions of
compare-and-swap go through a single routine.
I've tested the whole series with and without the last patch. So
On Saturday 29 October 2011 14:43:22 Mikael Morin wrote:
> > FWIW, it seems ifort 12.0 uses "UNDEFINED" in this case; I suppose a
> > case could be made for using the same. Comments?
>
> Let's go for UNDEFINED then.
On second thought, UNSPECIFIED is better as UNDEFINED is for another case.
Hello, gentle maintainer.
This is a message from the Translation Project robot.
A revised PO file for textual domain 'gcc' has been submitted
by the Japanese team of translators. The file is available at:
http://translationproject.org/latest/gcc/ja.po
(This file, 'gcc-4.6.1.ja.po', has jus
TLS_MODEL_GLOBAL_DYNAMIC and TLS_MODEL_LOCAL_DYNAMIC symbol references
are not legitimate constants because they may require a function call.
This change fixes a bug exposed by the mpfr-3.1.0 testsuite.
Tested on hppa-unknown-linux, hppa2.0w-hp-hpux11.11 and hppa64-hp-hpux11.11.
Committed to trun
Hello!
2011-10-29 Uros Bizjak
* gcc.target/i386/fma-check.h (main): Use return 0 instead of exit (0).
* gcc.target/i386/fma4-check.h (main): Ditto.
* gcc.target/i386/xop-check.h (main): Ditto.
Committed as trivial change to mainline SVN.
Uros.
Index: fma4-check.h
>Could someone please review this?
+ if (cxx_dialect < cxx0x && !in_system_header)
+ pedwarn (input_location, OPT_pedantic,
+ "comma at end of enumerator list");
Why not use maybe_warn_cpp0x there?
Hello!
lshlv16qi3 is not a generic name for expander, and we have ashlv16qi3
for this. Attached patch adds lshrv16qi3 to generate logical
shift-right XOP instruction.
2011-10-29 Uros Bizjak
* config/i386/i386.md (lshlv16qi3): Remove expander.
(lshrv16qi3): New expander.
When emitting the symbols and cgraph nodes in the symbol table, we were
using the same pointer set to decide whether to emit decls and cgraph
nodes.
So, if a function decl F was sent to rest_of_decl_compilation, we would
later refuse to call cgraph_finalize_function on its node because F had
alre
Hello!
These pattern names are misleading, implying that these are "logical
shift left" and "arithmetic shift left". They are not, they are "shift
logical" and "shift arithmetic". Attached (trivial) patch renames
these patterns to the insn mnemonic they generate.
2011-10-29 Uros Bizjak
...a bit, by disabling the headers for empty sessions.
Committed.
Gerald
Index: changes.html
===
RCS file: /cvs/gcc/wwwdocs/htdocs/gcc-4.6/changes.html,v
retrieving revision 1.134
diff -u -r1.134 changes.html
--- changes.html
Applied.
Gerald
2011-10-29 Gerald Pfeifer
* done.html: Use for the header.
Index: done.html
===
RCS file: /cvs/gcc/wwwdocs/htdocs/java/done.html,v
retrieving revision 1.49
diff -u -r1.49 done.html
--- done.html 12 Sep
Richard,
I have a tentative fix for PR50764.
In the example from the test-case, -fsched2-use-superblocks moves an insn from
block 4 to block 3.
2
bar
|
---+-
/ \
* *
5 * 3
abortbar
2011-10-29 Gerald Pfeifer
* build-snapshot.html: Adjust title to not refer to CVS any more.
Adjust formatting of title.
Change link from CVS instructions to SVN.
Installed.
Gerald
Index: build-snapshot.html
...a bit, by disabling the headers for empty sessions.
Installed.
Gerald
Index: changes.html
===
RCS file: /cvs/gcc/wwwdocs/htdocs/gcc-4.5/changes.html,v
retrieving revision 1.101
diff -u -r1.101 changes.html
--- changes.html
...and has been for a while.
Committed.
Index: snapshots.html
===
RCS file: /cvs/gcc/wwwdocs/htdocs/snapshots.html,v
retrieving revision 1.20
diff -u -r1.20 snapshots.html
--- snapshots.html 21 Sep 2006 14:17:36 - 1.20
On Fri, Oct 28, 2011 at 4:42 PM, Diego Novillo wrote:
> On 11-10-27 01:46 , Richard Guenther wrote:
>>
>> On Wed, 26 Oct 2011, Richard Guenther wrote:
>>
>>>
>>> This completely rewrites LTO option merging. At compile (uselessly
>>> now at WPA?) time we now stream a COLLECT_GCC_OPTIONS like strin
On Fri, Oct 28, 2011 at 5:48 PM, Joseph S. Myers
wrote:
> On Fri, 28 Oct 2011, Richard Guenther wrote:
>
>> + /* Fallthru. */
>> + case OPT_fPIC:
>> + case OPT_fpic:
>> + case OPT_fpie:
>> + case OPT_fcommon:
>> + case OPT_fexceptions:
>> + append_option (decoded_o
On Sat, Oct 29, 2011 at 7:06 AM, Ian Lance Taylor wrote:
> "Joseph S. Myers" writes:
>
>> On Fri, 28 Oct 2011, Ian Lance Taylor wrote:
>>
>>> This patch changes "Linux" to "GNU/Linux" in a comment. Bootstrapped
>>> and ran libiberty testsuite on x86_64-unknown-linux-gnu. Committed to
>>> mainli
> DR 1082 changed the rules for implicitly declared copy constructors and
> assignment operators in the presence of move ctor/op= such that if
> either move operation is present, instead of being suppressed the copy
> operations will still be declared, but as deleted.
We have detected a side effec
On Sat, Oct 29, 2011 at 18:35, Mikael Morin wrote:
> On Saturday 29 October 2011 14:43:22 Mikael Morin wrote:
>> > FWIW, it seems ifort 12.0 uses "UNDEFINED" in this case; I suppose a
>> > case could be made for using the same. Comments?
>>
>> Let's go for UNDEFINED then.
> On second thought, UNSP
On Wed, 6 Jul 2011, Michael Meissner wrote:
> I updated the html documents for my two recent changes:
I made the small follow-up patch below which tweaks markup and
refers to GNU/Linux instead of Linux.
Gerald
Index: changes.html
=
Hi,
today, by chance, I noticed this:
http://gcc.gnu.org/ml/gcc-patches/2011-03/msg01756.html
and it occurred to me that maybe it's time to do this?
Thanks,
Paolo.
//
2011-10-30 Paolo Carlini
* c.opt: Add -std=c++11.
Index: c.opt
=
On 10/30/2011 02:12 AM, Paolo Carlini wrote:
Hi,
today, by chance, I noticed this:
http://gcc.gnu.org/ml/gcc-patches/2011-03/msg01756.html
and it occurred to me that maybe it's time to do this?
... or maybe we want, at the same time, to tweak a bit the description
of c++0x?
Paolo.
37 matches
Mail list logo