Go patch committed: Fix package name as composite literal struct key

2011-09-09 Thread Ian Lance Taylor
This patch to the Go frontend fixes using a package name as a key in a struct composite literal. Bootstrapped and ran Go testsuite on x86_64-unknown-linux-gnu. Committed to mainline. Ian diff -r c266c495ca06 go/expressions.cc --- a/go/expressions.cc Mon Aug 29 15:04:11 2011 -0700 +++ b/go/expre

Re: [PATCH][Cilkplus] Patch to fix Template type inside cilk_for

2011-09-09 Thread H.J. Lu
On Fri, Sep 9, 2011 at 5:02 PM, Iyer, Balaji V wrote: > Hello H.J., >        I think I have fixed all the changes you and Jakub have requested in > the patch. > > Thanks, > I checked it in for you. -- H.J.

RE: [PATCH][Cilkplus] Patch to fix Template type inside cilk_for

2011-09-09 Thread Iyer, Balaji V
Hello H.J., I think I have fixed all the changes you and Jakub have requested in the patch. Thanks, Balaji V. Iyer. -Original Message- From: H.J. Lu [mailto:hjl.to...@gmail.com] Sent: Friday, September 09, 2011 3:10 PM To: Iyer, Balaji V Cc: gcc-patches@gcc.gnu.org Subject: Re:

[pph] Do not read pph files more than once (issue4983055)

2011-09-09 Thread Diego Novillo
This was not causing any failures, but it is pretty wasteful to read the same PPH more than once. We cannot just skip them, however. We need to read the line table to properly modify the line table for the current translation unit. Tested on x86_64. Committed to branch. Diego. * pph

[pph] Fix method lookups (part 1) (issue4997042)

2011-09-09 Thread Diego Novillo
The main problem fixed here is that name lookups for class methods uses a binary search that assumes that the methods in CLASSTYPE_METHOD_VEC are sorted by pointer value. Since the reader typically allocates trees in a different pattern than the writer, it is common for the symbols in the vector t

[cxx-mem-model] C++ wrappers

2011-09-09 Thread Andrew MacLeod
Same as before, only a slight change. __sync_mem_flag_test_and_set() and __sync_mem_flag_clear() have been removed in a different consolidation patch, so this changes those calls to __sync_mem_exchange() and __sync_mem_store() which are subsuming all the behaviour of those routines. Straight

[cxx-mem-model] Some consolidation.

2011-09-09 Thread Andrew MacLeod
I wasn't liking the duplication between the old __sync routines and the new __sync_mem routines. I thought it was going to add confusion to port maintainers at the very least. This patch consolidates everything except the various fetch_op routines, which I will do in a different patch since th

[lra] Fix ppc64 bootstrap failure

2011-09-09 Thread Vladimir Makarov
The following patch fixes compiler crash on stage3 of bootstrap. The patch was successfully bootstrapped on x86/x86-64 and ppc64. 2011-09-09 Vladimir Makarov * lra-constraints.c (equivalence_change_p): Rename to debug_loc_equivalence_change_p. Process subreg of reg whose

Fwd: [cxx-mem-model] Don't over process __sync_mem parameters.

2011-09-09 Thread Andrew MacLeod
This patch implements a reduced type massaging for the new '__sync_mem' built-in functions, as well as verifying the number of parameters are correct. The gory details from the wiki TODO : The parameters are massaged in c-family/c-common.c::resolve_overloaded_builtin, sync_resolve_re

Re: [PATCH][Cilkplus] Patch to fix Template type inside cilk_for

2011-09-09 Thread H.J. Lu
On Fri, Sep 9, 2011 at 11:56 AM, Iyer, Balaji V wrote: > Ok, fixed all the changes you mentioned. Here is the patch. > > Thanks, > Please provide a patch against the current branch since your patch won't apply. - * gimplify.c (gimplify_call_expr): Removed if (SPAWN_CALL_P (*expr)) -

Re: [PATCH][Cilkplus] Patch to fix Template type inside cilk_for

2011-09-09 Thread Jakub Jelinek
On Fri, Sep 09, 2011 at 11:56:29AM -0700, Iyer, Balaji V wrote: > diff --git a/gcc/ChangeLog.cilk b/gcc/ChangeLog.cilk index 8880b0a..299febb > 100644 > --- a/gcc/ChangeLog.cilk > +++ b/gcc/ChangeLog.cilk > @@ -2,6 +2,9 @@ > > * gimplify.c (gimplify_call_expr): Removed if (SPAWN_CALL_P (*ex

Re: [RFC] Cleanup DW_CFA_GNU_args_size handling

2011-09-09 Thread H.J. Lu
On Fri, Sep 9, 2011 at 11:15 AM, Eric Botcazou wrote: >> Binutils CVS from this morning: > > OK, I see.  For some reasons, this build has: > > #define HAVE_GAS_CFI_DIRECTIVE 0 > > and another build with binutils 2.20 succeeds, but it has: > > #define HAVE_GAS_CFI_DIRECTIVE 1 > I have no problems

RE: [PATCH][Cilkplus] Patch to fix Template type inside cilk_for

2011-09-09 Thread Iyer, Balaji V
Ok, fixed all the changes you mentioned. Here is the patch. Thanks, Balaji V. Iyer. -Original Message- From: H.J. Lu [mailto:hjl.to...@gmail.com] Sent: Friday, September 09, 2011 11:54 AM To: Iyer, Balaji V Cc: gcc-patches@gcc.gnu.org Subject: Re: [PATCH][Cilkplus] Patch to fix Template

Re: [RFC] Cleanup DW_CFA_GNU_args_size handling

2011-09-09 Thread Eric Botcazou
> Binutils CVS from this morning: OK, I see. For some reasons, this build has: #define HAVE_GAS_CFI_DIRECTIVE 0 and another build with binutils 2.20 succeeds, but it has: #define HAVE_GAS_CFI_DIRECTIVE 1 So bootstrap is broken without CFI directives. -- Eric Botcazou

[Patch, Fortran, OOP] PR 47978: Invalid INTENT in overriding TBP not detected

2011-09-09 Thread Janus Weil
Hi all, here is another small patch for an accepts-invalid OOP problem: When overriding a type-bound procedure, we need to check that the intents of the formal args agree (or more general: their 'characteristics', as defined in chapter 12.3.2 of the F08 standard). For now I'm only checking type+ra

[testsuite,committed]: Fix gcc.dg/torture/pr49030.c for int < 32 bits

2011-09-09 Thread Georg-Johann Lay
This test cases files with gcc/testsuite/gcc.dg/torture/pr49030.c: In function 'sample_move_d32u24_sS': gcc/testsuite/gcc.dg/torture/pr49030.c:10:2: warning: overflow in implicit constant conversion [-Woverflow] Fixed as obvious, tests pass now for int=16 (tested with avr). http://gcc.gnu.org/v

[patch, arm] Fix PR target/50305 (arm_legitimize_reload_address problem)

2011-09-09 Thread Ulrich Weigand
Hello, the problem in PR 50305 turned out to be caused by the ARM back-end LEGITIMIZE_RELOAD_ADDRESS implementation. One of the arguments to the inline asm ("+Qo" (perf_event_id)) has the form (mem/c/i:DI (plus:SI (reg/f:SI 152) (const_int 1200 [0x4b0])) [5 perf_event_i

Re: [PATCH][Cilkplus] Patch to add GCC Standard header

2011-09-09 Thread H.J. Lu
On Fri, Sep 9, 2011 at 8:47 AM, Iyer, Balaji V wrote: > Hello Everyone, >    This patch is for the Cilk plus branch. This patch will add > the standard GCC header into pragma_simd.c file that I created. > I checked it in for you. -- H.J.

Re: [PATCH][Cilkplus] Patch to fix Template type inside cilk_for

2011-09-09 Thread H.J. Lu
On Fri, Sep 9, 2011 at 8:37 AM, Iyer, Balaji V wrote: > Here is a fixed patch with all the changes you have requested. diff --git a/gcc/ChangeLog.cilk b/gcc/ChangeLog.cilk index 8880b0a..299febb 100644 --- a/gcc/ChangeLog.cilk +++ b/gcc/ChangeLog.cilk @@ -2,6 +2,9 @@ * gimplify.c (gimpli

[PATCH][Cilkplus] Patch to add GCC Standard header

2011-09-09 Thread Iyer, Balaji V
Hello Everyone,    This patch is for the Cilk plus branch. This patch will add the standard GCC header into pragma_simd.c file that I created. Thanks, Balaji V. Iyer. diff --git a/gcc/ChangeLog.cilk b/gcc/ChangeLog.cilk index 299febb..0eaa46e 100644 --- a/gcc/ChangeLog.cilk +++ b/gcc

RE: [PATCH][Cilkplus] Patch to fix Template type inside cilk_for

2011-09-09 Thread Iyer, Balaji V
Here is a fixed patch with all the changes you have requested. Thanks, Balaji V. Iyer. -Original Message- From: H.J. Lu [mailto:hjl.to...@gmail.com] Sent: Friday, September 09, 2011 9:49 AM To: Iyer, Balaji V Cc: gcc-patches@gcc.gnu.org Subject: Re: [PATCH][Cilkplus] Patch to fix Templa

RE: [Patch] Finish function using absolute value not #define value

2011-09-09 Thread Iyer, Balaji V
Patch attached :). -Balaji V. Iyer. -Original Message- From: H.J. Lu [mailto:hjl.to...@gmail.com] Sent: Friday, September 09, 2011 11:14 AM To: Iyer, Balaji V Cc: Tobias Burnus; gcc-patches@gcc.gnu.org Subject: Re: [Patch] Finish function using absolute value not #define value On Fri,

Re: [Patch] Finish function using absolute value not #define value

2011-09-09 Thread H.J. Lu
On Fri, Sep 9, 2011 at 7:48 AM, Iyer, Balaji V wrote: > Hello Everyone, >        Here are the fixes to the patches as mentioned by H. J. . I am not > attaching the patch, just cut and pasting it. Cut/paste may not work if other people have to apply the patch for you. > Thanks, > > Balaji V. Iye

Re: [PATCH] Fix PR50328

2011-09-09 Thread H.J. Lu
On Fri, Sep 9, 2011 at 3:15 AM, Richard Guenther wrote: > > This fixes our inability to handle reductions with a constant > or a parameter. > > Bootstrapped and tested on x86_64-unknown-linux-gnu, the testcase > requires all the previously posted patches from today to not ICE > and pass though. >

RE: [Patch] Finish function using absolute value not #define value

2011-09-09 Thread Iyer, Balaji V
Hello Everyone, Here are the fixes to the patches as mentioned by H. J. . I am not attaching the patch, just cut and pasting it. Thanks, Balaji V. Iyer. Here is the cp/ChangeLog 2011-09-09 Balaji V. Iyer * decl2.c (finish_objects): Replaced finish_function (0) with

Re: [Patch][Master] Finish function using absolute value not #define value

2011-09-09 Thread Tobias Burnus
On 09/09/2011 03:55 PM, H.J. Lu wrote: 1. Remove [Master] in your email subject. 2. Put ChangeLog entries like: > http://gcc.gnu.org/ml/gcc-patches/2011-09/msg00615.html 3. Do not attach patches with Content-Type: application/octet-stream (Email programs usually set the content-type automati

Re: [PATCH][ARM] Generic tuning

2011-09-09 Thread Andrew Stubbs
On 08/09/11 16:32, Richard Earnshaw wrote: OK. Committed, thanks Andrew

Re: [Patch][Master] Finish function using absolute value not #define value

2011-09-09 Thread H.J. Lu
On Thu, Sep 8, 2011 at 9:38 PM, Iyer, Balaji V wrote: > Hello Everyone, >        In several places, I found that finish_function was using an absolute > integer as input parameter instead of these #defines > > #define SF_DEFAULT           0  /* No flags.  */ > #define SF_PRE_PARSED        1  /* T

Re: [PATCH][Cilkplus] Patch to fix Template type inside cilk_for

2011-09-09 Thread H.J. Lu
On Thu, Sep 8, 2011 at 8:30 PM, Iyer, Balaji V wrote: > Hello Everyone, >        This patch is for the Cilk Plus branch GCC C++ compiler. It will fix > the following cases of cilk_for (where 'T' is a template type) > > _Cilk_for ( T ii = ;  ii ;   >  ii <+/->= ) >         > + * cilk.c

Re: [Patch, testsuite, arm] Skip the arch conflict to enable case neon-thumb2-move pass on more targets.

2011-09-09 Thread Richard Earnshaw
On 9 Sep 2011, at 14:03, "Richard Guenther" wrote: > On Fri, Sep 9, 2011 at 2:47 PM, Richard Earnshaw wrote: >> On 09/09/11 11:07, Richard Guenther wrote: >>> On Fri, Sep 9, 2011 at 12:00 PM, Terry Guo wrote: Hello, This patch enables the case pass on targets other than armv7-a

Re: New SPU failures (Re: [PATCH, PR 49923] Check for misaligned accesses before doing SRA)

2011-09-09 Thread Richard Guenther
On Fri, 9 Sep 2011, Richard Guenther wrote: > On Fri, 9 Sep 2011, Martin Jambor wrote: > > > Hi, > > > > On Wed, Aug 10, 2011 at 04:29:40PM +0200, Richard Guenther wrote: > > > On Wed, 10 Aug 2011, Ulrich Weigand wrote: > > > > > > > ... > > > > > > > > > > FAIL: gcc.dg/ipa/ipa-sra-2.c scan-

Re: [Patch, testsuite, arm] Skip the arch conflict to enable case neon-thumb2-move pass on more targets.

2011-09-09 Thread Richard Guenther
On Fri, Sep 9, 2011 at 2:47 PM, Richard Earnshaw wrote: > On 09/09/11 11:07, Richard Guenther wrote: >> On Fri, Sep 9, 2011 at 12:00 PM, Terry Guo wrote: >>> Hello, >>> >>> This patch enables the case pass on targets other than armv7-a by skipping >>> the architecture conflict message. Is it OK t

Ping: Make SMS schedule register moves

2011-09-09 Thread Richard Sandiford
Ping for these four patches: http://gcc.gnu.org/ml/gcc-patches/2011-08/msg02428.html which make SMS schedule the register moves it creates. Richard

PING: [ARM] Model automodified addresses in the Cortex A8 and A9 schedulers -- NEON

2011-09-09 Thread Richard Sandiford
Ping for this patch: http://gcc.gnu.org/ml/gcc-patches/2011-08/msg01488.html which models address register writeback in the Cortex A8 and A9 NEON schedulers. (Ramana has already approved the core equivalent, thanks.) Richard

Re: New SPU failures (Re: [PATCH, PR 49923] Check for misaligned accesses before doing SRA)

2011-09-09 Thread Richard Guenther
On Fri, 9 Sep 2011, Martin Jambor wrote: > Hi, > > On Wed, Aug 10, 2011 at 04:29:40PM +0200, Richard Guenther wrote: > > On Wed, 10 Aug 2011, Ulrich Weigand wrote: > > > > ... > > > > > > > FAIL: gcc.dg/ipa/ipa-sra-2.c scan-tree-dump eipa_sra "About to replace > > > expr cow_.*D.->red with \

[ARM] Loosen MODES_TIEABLE_P

2011-09-09 Thread Richard Sandiford
ARM's MODES_TIEABLE_P only allows classes of the same mode to be tied: #define MODES_TIEABLE_P(MODE1, MODE2) \ (GET_MODE_CLASS (MODE1) == GET_MODE_CLASS (MODE2)) But for NEON, we'd like structure modes to be tied to their vector elements. In particular, a vector subreg of a structure

Re: [Patch, testsuite, arm] Skip the arch conflict to enable case neon-thumb2-move pass on more targets.

2011-09-09 Thread Richard Earnshaw
On 09/09/11 11:07, Richard Guenther wrote: > On Fri, Sep 9, 2011 at 12:00 PM, Terry Guo wrote: >> Hello, >> >> This patch enables the case pass on targets other than armv7-a by skipping >> the architecture conflict message. Is it OK to trunk? > > I don't like these kind of patches. Why do the te

Re: New SPU failures (Re: [PATCH, PR 49923] Check for misaligned accesses before doing SRA)

2011-09-09 Thread Martin Jambor
Hi, On Wed, Aug 10, 2011 at 04:29:40PM +0200, Richard Guenther wrote: > On Wed, 10 Aug 2011, Ulrich Weigand wrote: > ... > > > > FAIL: gcc.dg/ipa/ipa-sra-2.c scan-tree-dump eipa_sra "About to replace expr > > cow_.*D.->red with \\*ISRA" > > FAIL: gcc.dg/ipa/ipa-sra-2.c scan-tree-dump eipa_sra

Re: Add unwind information to mips epilogues

2011-09-09 Thread Bernd Schmidt
On 09/08/11 16:08, Richard Sandiford wrote: > I suppose I still don't get why this is OK but this: > >> @@ -10324,12 +10350,26 @@ mips_expand_epilogue (bool sibcall_p) >>if (!TARGET_MIPS16) >> target = stack_pointer_rtx; >> >> - emit_insn (gen_add3_insn (target, base, adjust));

Re: [PATCH][ARM] -m{cpu,tune,arch}=native

2011-09-09 Thread Richard Earnshaw
On 06/09/11 14:35, Andrew Stubbs wrote: > This update adds many more "magic numbers" for various ARM CPUs, and > also ensures that the implementer is ARM (as opposed to Marvell, etc.). > The list is far from comprehensive, but it should cover many (but by no > means all) of the cores in current

Re: RFA: MN10300: Fix splitting AND insns

2011-09-09 Thread Nick Clifton
Hi Jeff, This is fine, Thanks - committed. after adding a function comment for mn10300_split_and_operand_count; I added this comment: /* This function is used to help split: (set (reg) (and (reg) (int))) into: (set (reg) (shift (reg) (int)) (set (reg) (shift (reg) (in

[PATCH] Fix PR50328

2011-09-09 Thread Richard Guenther
This fixes our inability to handle reductions with a constant or a parameter. Bootstrapped and tested on x86_64-unknown-linux-gnu, the testcase requires all the previously posted patches from today to not ICE and pass though. Richard. 2011-09-09 Richard Guenther PR tree-optimization

[PATCH] Fold PRE inserted statements

2011-09-09 Thread Richard Guenther
This makes us fold (the last) inserted statement from PRE to avoid MEM_REF vs. non-MEM_REF inconsistencies tripping up on un-aware code such as data dependence analysis using operand_equal_p. fold_stmt makes sure to canonicalize either variant but PRE internally uses MEM_REF for all accesses to b

Re: [Patch, testsuite, arm] Skip the arch conflict to enable case neon-thumb2-move pass on more targets.

2011-09-09 Thread Richard Guenther
On Fri, Sep 9, 2011 at 12:00 PM, Terry Guo wrote: > Hello, > > This patch enables the case pass on targets other than armv7-a by skipping > the architecture conflict message. Is it OK to trunk? I don't like these kind of patches. Why do the testcases have -march=armv7-a enabled in the first plac

[PATCH] Adjust fold_stmt_inplace interface

2011-09-09 Thread Richard Guenther
This adjusts fold_stmt_inplace to take a gimple_stmt_iterator argument instead of a gimple. This allows it to operate on statements that are only in a gimple_seq but are not (yet) associated with a basic block. fold_stmt_* shouldn't require a CFG (and yep, I'm going to need that in a followup).

[Patch, testsuite, arm] Skip the arch conflict to enable case neon-thumb2-move pass on more targets.

2011-09-09 Thread Terry Guo
Hello, This patch enables the case pass on targets other than armv7-a by skipping the architecture conflict message. Is it OK to trunk? BR, Terry 2011-09-09 Terry Guo * gcc.target/arm/neon-thumb2-move.c: Skip the architecture conflict to enable the case pass on targ

[PATCH] Fix swap_tree_operands

2011-09-09 Thread Richard Guenther
swap_tree_operands does not handle swapping operands in a_1 = x_2 + 1; very well as it keeps the use operand for x_2 pointing to its old slot and thus 1 after it finished. That's of course bad as no user of swap_tree_operands feels the need to update the statement - swap_tree_operands is after all

Re: [Patch, testsuite] fix target/PR49614

2011-09-09 Thread Andreas Schwab
domi...@lps.ens.fr (Dominique Dhumieres) writes: > If the test case is buggy, why is it not spotted on non ppc platforms? Because it's not run on other platforms. Andreas. -- Andreas Schwab, sch...@redhat.com GPG Key fingerprint = D4E8 DBE3 3813 BB5D FA84 5EC7 45C6 250E 6F00 984E "And now for

Re: [RFC] Cleanup DW_CFA_GNU_args_size handling

2011-09-09 Thread Eric Botcazou
ild/binutils/native32/ld/ld-new --enable-languages=c,c++,ada --enable-checking=yes,rtl --enable-__cxa_atexit --disable-nls --disable-libmudflap --disable-initfini-array Thread model: posix gcc version 4.7.0 20110909 (experimental) [trunk revision 178719] (GCC) eric@atlantis:~/build/gcc/native32>

Re: [Patch, testsuite] fix target/PR49614

2011-09-09 Thread Richard Guenther
On Fri, Sep 9, 2011 at 11:03 AM, Dominique Dhumieres wrote: >> A function not declared inline with an always_inline attribute is a bug. > > If the test case is buggy, why is it not spotted on non ppc platforms? because it's not run on anything besides ppc > Dominique >

Re: [Patch, testsuite] fix target/PR49614

2011-09-09 Thread Dominique Dhumieres
> A function not declared inline with an always_inline attribute is a bug. If the test case is buggy, why is it not spotted on non ppc platforms? Dominique

Re: [PATCH, testsuite] Avoid architecture options conflict for case pr42894.c

2011-09-09 Thread Richard Earnshaw
Ok. R. On 25 Aug 2011, at 12:45, "Terry Guo" wrote: > Hello, > > I think it is useful to run this case for newer arm targets. So the patch > intends to skip the warning of architecture conflicts. Is it ok to commit to > trunk? > > BR, > Terry > > gcc/testsuite/ChangeLog: > > 2011-08-25 T

[PATCH] Fix PR50333

2011-09-09 Thread Richard Guenther
This fixes PR50333, another instance of a extract_ops_from_tree user that doesn't handle ternaries. Bootstrap and testing pending on x86_64-unknown-linux-gnu. Richard. 2011-09-09 Richard Guenther PR middle-end/50333 * tree-data-ref.c (split_constant_offset): Do not try to ha