Pushed.
___
ffmpeg-devel mailing list
ffmpeg-devel@ffmpeg.org
https://ffmpeg.org/mailman/listinfo/ffmpeg-devel
To unsubscribe, visit link above, or email
ffmpeg-devel-requ...@ffmpeg.org with subject "unsubscribe".
On 11/15/24 05:50, Lynne wrote:
This commit implements a standard, compliant, version 3 and version 4
FFv1 encoder, entirely in Vulkan. The encoder is written in standard
GLSL and requires a Vulkan 1.3 supporting GPU with the BDA extension.
The encoder can use any amount of slices, but nominally
Fuzzing has discovered one crash bug so far. It's not related to my
changes.
The crash has some potential to be exploitable so I've emailed
ffmpeg-secur...@ffmpeg.org. Email includes a sample and repro
instructions.
On Sat, 9 Nov 2024 at 01:08, South East <8billion.peo...@gmail.com> wrote:
>
>
On 16.11.2024 19:46, Tom Vaughan wrote:
Any further details you or others could provide to help the x265 dev team
resolve the issue would be appreciated.
Can you share your steps to reproduce this issue? What parameters were changed?
Max CTU size?
Is this documentation inadequate?
https://x2
Hi Anton
On Sat, Nov 16, 2024 at 03:16:16AM +0100, Anton Khirnov wrote:
> Quoting Michael Niedermayer (2024-11-06 15:48:19)
[...]
> > About git access
> > We have a documented and public process since a very long time.
> > people need to be in MAINTAINERS to get git write.
>
> 1) That is not true
This should have been documented long ago and i thought it was
Signed-off-by: Michael Niedermayer
---
doc/developer.texi | 19 +++
1 file changed, 19 insertions(+)
diff --git a/doc/developer.texi b/doc/developer.texi
index ff181abb582..78053a4623a 100644
--- a/doc/developer.texi
Hi,
On Sat, Nov 16, 2024 at 1:00 PM Frank Plowman wrote:
> Remove the MMX versions of these functions and modify the SSE
> implementations to avoid using MMX registers.
>
> Signed-off-by: Frank Plowman
> ---
> libavcodec/x86/videodsp.asm| 61 ++-
> libavcodec/x86/videod
On 11/16/24 01:56, Rémi Denis-Courmont wrote:
Le perjantaina 15. marraskuuta 2024, 22.09.25 EET Scott Theisen a écrit :
On 11/15/24 08:47, Rémi Denis-Courmont wrote:
Le 15 novembre 2024 12:56:23 GMT+02:00, Zhao Zhili
a écrit :
From: Zhao Zhili
_Alignas is portable than compiler's specific
Hello,
to continue vdd meeting ideas here on mailing list where everyone can
comment:
Please comment on what you want documented. and if you think it should
be a public document or just available to devs with git write access
etc.
could someone post the link to the videolan infrastructure docume
I think this would work better than TC or nothing process.
Signed-off-by: Michael Niedermayer
---
doc/developer.texi | 3 +++
1 file changed, 3 insertions(+)
diff --git a/doc/developer.texi b/doc/developer.texi
index 78053a4623a..2af71ed749a 100644
--- a/doc/developer.texi
+++ b/doc/developer.t
On 15/11/2024 20:55, Andreas Rheinhardt wrote:
> Frank Plowman:
>> Remove the MMX versions of these functions and modify the SSE
>> implementations to avoid using MMX registers.
>>
>> Signed-off-by: Frank Plowman
>> ---
>> This wasn't wholly straightforward as the existing SSE implementation did
>
Remove the MMX versions of these functions and modify the SSE
implementations to avoid using MMX registers.
Signed-off-by: Frank Plowman
---
libavcodec/x86/videodsp.asm| 61 ++-
libavcodec/x86/videodsp_init.c | 88 +-
2 files changed, 59 in
Any further details you or others could provide to help the x265 dev team
resolve the issue would be appreciated.
Can you share your steps to reproduce this issue? What parameters were changed?
Max CTU size?
Is this documentation inadequate?
https://x265.readthedocs.io/en/master/api.html#build
On Sat, Nov 16, 2024 at 03:16:16AM +0100, Anton Khirnov wrote:
[...]
> > > Furthermore you object to this being discussed, deny the issue even
> > > exists, and in at least one case you wanted to ban someone for raising
> > > it. Those are all tactics authoritarian governments use to suppress
> > >
On Sat, Nov 16, 2024 at 9:25 AM Pavel Koshevoy wrote:
>
>
> On Sat, Nov 16, 2024 at 9:00 AM James Almer wrote:
>
>> On 11/16/2024 12:57 PM, Pavel Koshevoy wrote:
>> > On Fri, Nov 15, 2024 at 9:25 PM Anton Khirnov
>> wrote:
>> >
>> >> Quoting Pavel Koshevoy (2024-11-15 20:32:21)
>> >>> This avoi
From: Pavel Koshevoy
This avoids unpleasant surprises to av_frame_get_buffer callers
that explicitly specified 64-byte alignment and didn't get
AVFrame.data pointers that are 64-byte aligned.
For example, see https://github.com/sekrit-twc/zimg/issues/212
Although the zscale issue has already be
STRIDE_ALIGN is a lavc define and is not necessarely 32. And align may be <= 0
at the
point plane_padding is being set.
Signed-off-by: James Almer
---
libavutil/frame.c | 9 +
1 file changed, 5 insertions(+), 4 deletions(-)
diff --git a/libavutil/frame.c b/libavutil/frame.c
index f42f3
Signed-off-by: James Almer
---
libavutil/frame.c | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/libavutil/frame.c b/libavutil/frame.c
index f0a0dba018..f42f310023 100644
--- a/libavutil/frame.c
+++ b/libavutil/frame.c
@@ -173,10 +173,10 @@ void av_frame_free(AVFrame **f
On Sat, Nov 16, 2024 at 9:00 AM James Almer wrote:
> On 11/16/2024 12:57 PM, Pavel Koshevoy wrote:
> > On Fri, Nov 15, 2024 at 9:25 PM Anton Khirnov wrote:
> >
> >> Quoting Pavel Koshevoy (2024-11-15 20:32:21)
> >>> This avoids unpleasant surprises to av_frame_get_buffer callers
> >>> that expli
On Thu, Jun 27, 2024 at 08:08:14AM +1000, Peter Ross wrote:
> ---
> libavformat/mm.c | 3 ++-
> 1 file changed, 2 insertions(+), 1 deletion(-)
>
> diff --git a/libavformat/mm.c b/libavformat/mm.c
> index 23c025d852..a40b5c44bb 100644
> --- a/libavformat/mm.c
> +++ b/libavformat/mm.c
> @@ -180,7 +
Le sunnuntaina 10. marraskuuta 2024, 13.34.31 EET u...@foxmail.com a écrit :
> From: sunyuechi
>
> k230
> banana_f3 put_chroma_pixels_8_4x4_c: 63.5 (
> 1.00x)59.2 ( 1.00x) put_chroma_pixels_8_4x4_
On Sat, 16 Nov 2024, Rémi Denis-Courmont wrote:
This should fix PIC builds.
---
libavcodec/riscv/h264dsp_rvv.S | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/libavcodec/riscv/h264dsp_rvv.S b/libavcodec/riscv/h264dsp_rvv.S
index 079896b17b..05d077f44e 100644
--- a/libavcodec/r
On Sat, 16 Nov 2024, Rémi Denis-Courmont wrote:
---
tests/checkasm/checkasm.c | 6 ++
1 file changed, 6 insertions(+)
diff --git a/tests/checkasm/checkasm.c b/tests/checkasm/checkasm.c
index fb307af0ae..f30c53cec2 100644
--- a/tests/checkasm/checkasm.c
+++ b/tests/checkasm/checkasm.c
@@ -96,
On Sat, 16 Nov 2024, Rémi Denis-Courmont wrote:
These values are bytes and need not be aligned.
---
libavcodec/riscv/vp8dsp_rvv.S | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/libavcodec/riscv/vp8dsp_rvv.S b/libavcodec/riscv/vp8dsp_rvv.S
index a8b3e239ba..a0548fbf0a 100644
-
James Almer:
> From: Justine Tunney
>
> Header contents taken from
> https://github.com/jart/jtckdint/commit/62df1fc0966926299253b7af46c23e345545
>
> Signed-off-by: James Almer
> ---
> compat/stdckdint/stdckdint.h | 663 +++
> tests/ref/fate/source|
On Wed, Oct 16, 2024 at 07:36:30PM +0200, Michael Niedermayer wrote:
> Signed-off-by: Michael Niedermayer
> ---
> libavcodec/ffv1.h| 2 +-
> libavcodec/ffv1enc.c | 6 +++---
> 2 files changed, 4 insertions(+), 4 deletions(-)
will apply
[...]
--
Michael GnuPG fingerprint: 9FF2128B147EF6
On 11/16/2024 11:50 AM, Rémi Denis-Courmont wrote:
Le lauantaina 16. marraskuuta 2024, 16.39.29 EET James Almer a écrit :
This a large proportion of values to underflow or overflow out of the int
range. The C version then triggers Undefined Behaviour in that case by
negating INT_MIN, so I don't
Le lauantaina 16. marraskuuta 2024, 16.39.29 EET James Almer a écrit :
> > This a large proportion of values to underflow or overflow out of the int
> > range. The C version then triggers Undefined Behaviour in that case by
> > negating INT_MIN, so I don't suppose that that's correct.
>
> So is th
From: Niklas Haas
Following in the footsteps of the work in the previous commit, it's now
relatively straightforward to expose the options struct publicly as
SwsContext. This is a step towards making this more user friendly, as
well as following API conventions established elsewhere.
Sponsored-b
After the branch, the expected SEW/LMUL ratio is 1 byte/vector.
So we have to set the same ratio before branching (QEMU does not care,
but real hardware does).
---
libavcodec/riscv/h264idct_rvv.S | 8
1 file changed, 4 insertions(+), 4 deletions(-)
diff --git a/libavcodec/riscv/h264idct_
On 11/16/2024 4:50 AM, Rémi Denis-Courmont wrote:
Le perjantaina 15. marraskuuta 2024, 22.41.20 EET James Almer a écrit :
Without this, the tables will be zero and the tests completely useless.
Signed-off-by: James Almer
---
tests/checkasm/aacencdsp.c | 1 +
1 file changed, 1 insertion(+)
On Fri, Nov 15, 2024 at 9:25 PM Anton Khirnov wrote:
> Quoting Pavel Koshevoy (2024-11-15 20:32:21)
> > This avoids unpleasant surprises to av_frame_get_buffer callers
> > that explicitly specified 64-byte alignment and didn't get
> > AVFrame.data pointers that are 64-byte aligned.
> >
> > For ex
On 11/16/2024 12:57 PM, Pavel Koshevoy wrote:
On Fri, Nov 15, 2024 at 9:25 PM Anton Khirnov wrote:
Quoting Pavel Koshevoy (2024-11-15 20:32:21)
This avoids unpleasant surprises to av_frame_get_buffer callers
that explicitly specified 64-byte alignment and didn't get
AVFrame.data pointers that
This avoids unpleasant surprises to av_frame_get_buffer callers
that explicitly specified 64-byte alignment and didn't get
AVFrame.data pointers that are 64-byte aligned.
For example, see https://github.com/sekrit-twc/zimg/issues/212
Although the zscale issue has already been resolved by other me
---
libswscale/riscv/range_rvv.S | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/libswscale/riscv/range_rvv.S b/libswscale/riscv/range_rvv.S
index 24005170af..f2c20627c5 100644
--- a/libswscale/riscv/range_rvv.S
+++ b/libswscale/riscv/range_rvv.S
@@ -110,7 +110,7 @@ func ff_ran
On Fri, 15 Nov 2024 00:49:06 +0100 Michael Niedermayer
wrote:
> On Fri, Nov 15, 2024 at 12:11:34AM +0100, Niklas Haas wrote:
> > On Fri, 15 Nov 2024 00:00:10 +0100 Michael Niedermayer
> > wrote:
> > > On Tue, Nov 12, 2024 at 10:50:46AM +0100, Niklas Haas wrote:
> > > > From: Niklas Haas
> > >
From: Niklas Haas
As part of a larger, ongoing effort to modernize and partially rewrite
libswscale, it was decided and generally agreed upon to introduce a new
public API for libswscale. This API is designed to be less stateful, more
explicitly defined, and considerably easier to use than the ex
From: Niklas Haas
With the ability to set the thread count as well. This benchmark includes
the constant overhead of context initialization.
Sponsored-by: Sovereign Tech Fund
Signed-off-by: Niklas Haas
---
libswscale/tests/swscale.c | 93 --
1 file changed,
From: Niklas Haas
Used by the graph API swscale wrapper, for now.
Sponsored-by: Sovereign Tech Fund
Signed-off-by: Niklas Haas
---
libswscale/swscale_internal.h | 3 +++
libswscale/utils.c| 4 ++--
2 files changed, 5 insertions(+), 2 deletions(-)
diff --git a/libswscale/swscale_in
Changes since v6:
- Rebased on top of current master
- Added backwards compatibility with legacy chroma position API
- Fixed mapping of alphablend and gamma flag options
___
ffmpeg-devel mailing list
ffmpeg-devel@ffmpeg.org
https://ffmpeg.org/mailman/lis
On Thu, 14 Nov 2024 23:47:54 +0100 Michael Niedermayer
wrote:
> On Tue, Nov 12, 2024 at 10:50:46AM +0100, Niklas Haas wrote:
> > From: Niklas Haas
> >
> > Most logic from this filter has been co-opted into swscale itself,
> > allowing the resulting filter to be substantially simpler as it no
> >
From: Niklas Haas
This is a purely cosmetic commit aimed at replacing accesses to
SwsInternal.opts by direct access to SwsContext wherever convenient.
Sponsored-by: Sovereign Tech Fund
Signed-off-by: Niklas Haas
---
libswscale/options.c | 2 +-
libswscale/swscale.c
From: Niklas Haas
This interface has been designed from the ground up to serve as a new
framework for dispatching various scaling operations at a high level. This
will eventually replace the old ad-hoc system of using cascaded contexts,
as well as allowing us to plug in more dynamic scaling passe
From: Niklas Haas
Reorganize the list, fix whitespace, make indentation consistent, and
rename some descriptions for clarity, consistency or informativeness.
Sponsored-by: Sovereign Tech Fund
Signed-off-by: Niklas Haas
---
libswscale/options.c | 86 ++--
From: Niklas Haas
Instead of sprinkling av_assert0 into random init functions.
Sponsored-by: Sovereign Tech Fund
Signed-off-by: Niklas Haas
---
libswscale/swscale_internal.h | 11 +++
libswscale/utils.c| 2 --
libswscale/x86/swscale.c | 4
3 files changed, 11 in
From: Niklas Haas
Most logic from this filter has been co-opted into swscale itself,
allowing the resulting filter to be substantially simpler as it no
longer has to worry about context initialization, interlacing, etc.
Sponsored-by: Sovereign Tech Fund
Signed-off-by: Niklas Haas
---
libavfilt
From: Niklas Haas
Group them into an enum rather than random #defines, and document their
behavior a bit more obviously.
Of particular note, I discovered that SWS_DIRECT_BGR is not referenced
anywhere else in the code base. As such, I have moved it to the deprecated
section, alongside SWS_ERROR_
From: Niklas Haas
This rewrite cleans up the code to use AVFrames and the new swscale API. The
log format has also been simplified and expanded to account for the new
options. (Not yet implemented)
The self testing code path has also been expanded to test the new swscale
implementation against t
---
libavcodec/riscv/h264dsp_rvv.S | 1 -
1 file changed, 1 deletion(-)
diff --git a/libavcodec/riscv/h264dsp_rvv.S b/libavcodec/riscv/h264dsp_rvv.S
index 05d077f44e..44f6202602 100644
--- a/libavcodec/riscv/h264dsp_rvv.S
+++ b/libavcodec/riscv/h264dsp_rvv.S
@@ -288,7 +288,6 @@ func ff_h264_v_loo
Quoting Pavel Koshevoy (2024-11-09 18:46:53)
> AVFrame.data pointers being aligned according to the explicitly specified
> align parameter
> is not going to break any caller. It is a safe change, and I would think
> a welcome change for any users of av_frame_get_buffer.
I agree and am in favor of
On Wed, Sep 25, 2024 at 12:24:09AM +0200, Michael Niedermayer wrote:
> Fixes: Ticket9975
>
> Signed-off-by: Michael Niedermayer
> ---
> libavformat/movenc.c | 1 +
> 1 file changed, 1 insertion(+)
will apply
[...]
--
Michael GnuPG fingerprint: 9FF2128B147EF6730BADF133611EC787040B0FAB
Nat
51 matches
Mail list logo