Quoting James Zern (2023-07-05 21:16:37)
> On Wed, Jul 5, 2023 at 12:15 PM James Zern wrote:
> >
> > Hi,
> >
>
> +ffmpeg-dev. I took the wrong email off the reply.
>
> > On Mon, Jul 3, 2023 at 10:08 PM David Lemler wrote:
> > >
> > > Prevent the fifo used in encoding VPx videos from filling up
Quoting Michael Niedermayer (2023-07-06 00:54:47)
> On Wed, Jul 05, 2023 at 11:22:44AM +0200, Anton Khirnov wrote:
> > Quoting Michael Niedermayer (2023-07-05 01:50:12)
> > > On Tue, Jul 04, 2023 at 07:54:06AM +0200, Anton Khirnov wrote:
> > > > Quoting Michael Niedermayer (2023-07-04 01:50:57)
> >
Quoting James Almer (2023-07-05 15:03:07)
> On 7/5/2023 9:56 AM, Anton Khirnov wrote:
> > Quoting James Almer (2023-07-05 01:26:14)
> >> Signed-off-by: James Almer
> >> ---
> >> configure | 2 +-
> >> libavutil/random_seed.c | 16
> >> 2 files changed, 17 insert
From: Zhao Zhili
It's a fixed value. There is no use case to change that.
---
libavcodec/h264_mp4toannexb_bsf.c | 5 +++--
1 file changed, 3 insertions(+), 2 deletions(-)
diff --git a/libavcodec/h264_mp4toannexb_bsf.c
b/libavcodec/h264_mp4toannexb_bsf.c
index 7dce1ae9b6..846671abb6 100644
---
From: Zhao Zhili
---
tests/fate/ffmpeg.mak | 6 +-
tests/fate/h264.mak | 6 ++
2 files changed, 7 insertions(+), 5 deletions(-)
diff --git a/tests/fate/ffmpeg.mak b/tests/fate/ffmpeg.mak
index 2b3135b6a6..b7ced7d23c 100644
--- a/tests/fate/ffmpeg.mak
+++ b/tests/fate/ffmpeg.mak
@@ -20
From: Zhao Zhili
If there is a single group of SPS/PPS before an IDR frame, but no
SPS/PPS after that, we will miss the chance to reset
idr_sps_seen/idr_pps_seen. No SPS/PPS are inserted afterwards.
This patch saves in-band SPS/PPS and insert them before IDR frames
when necessary.
---
v2: Use a
From: Zhao Zhili
For fate-h264_mp4toannexb_ticket5927 and
fate-h264_mp4toannexb_ticket5927_2, they work by accident
previously. The sample file has two 'avc1' entries, and video
samples use the second one. It means packets should be decoded with
new extradata in side data. Before this patch, only
From: Zhao Zhili
start_code_size depends on whether PS comes from out-of-band or
in-band. Make the code more readable.
---
libavcodec/h264_mp4toannexb_bsf.c | 34 ---
1 file changed, 27 insertions(+), 7 deletions(-)
diff --git a/libavcodec/h264_mp4toannexb_bsf.c
b/l
Am 05.07.23 um 18:08 schrieb Thilo Borgmann:
Hi,
Am 19.05.23 um 18:41 schrieb Zhao Zhili:
From: Zhao Zhili
If there is a single group of SPS/PPS before an IDR frame, but no
SPS/PPS after that, we will miss the chance to reset
idr_sps_seen/idr_pps_seen. No SPS/PPS are inserted afterwards.
Thi
On Thu, 6 Jul 2023 00:19:50 +0300 (EEST), you wrote:
>On Tue, 4 Jul 2023, John Cox wrote:
>
>> Also adds a filter_line3 method which on aarch64 neon yields approx 30%
>> speedup over 2xfilter_line and a memcpy
>>
>> Differences from v3:
>> Remove a few lines of neon in filter_line that should have
On 06/07/2023 14:00, Zhao Zhili wrote:
From: Zhao Zhili
Regression since 99dfdb45. intraRefreshPeriod access cc->gopLength,
which has been overwritten to NVENC_INFINITE_GOPLENGTH before.
Fixes #10445.
---
libavcodec/nvenc.c | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff -
Now includes the demuxer again. Absence of the demuxer caused wrong
framerate detection. We are promised a review of the demuxer code as
well so it shall not rotten again with the remaining patches. Also adds
loop control suggested in v1.
This makes it feasable again to move some definitions into
---
libavcodec/webp.c | 17 +--
libavcodec/webp.h | 55 +++
2 files changed, 56 insertions(+), 16 deletions(-)
create mode 100644 libavcodec/webp.h
diff --git a/libavcodec/webp.c b/libavcodec/webp.c
index d35cb66f8d..15152ec8fb 100644
--- a
From: Josef Zlomek
Fixes: 4907
Adds support for decoding of animated WebP.
The WebP decoder adds the animation related features according to the specs:
https://developers.google.com/speed/webp/docs/riff_container#animation
The frames of the animation may be smaller than the image canvas.
Theref
---
libavcodec/webp.c | 143 +++---
1 file changed, 71 insertions(+), 72 deletions(-)
diff --git a/libavcodec/webp.c b/libavcodec/webp.c
index bee43fcf19..d3e3f85dd3 100644
--- a/libavcodec/webp.c
+++ b/libavcodec/webp.c
@@ -1337,7 +1337,77 @@ static int vp
---
libavcodec/webp_parser.c | 132 ++-
1 file changed, 90 insertions(+), 42 deletions(-)
diff --git a/libavcodec/webp_parser.c b/libavcodec/webp_parser.c
index bd5f94dac5..d10d06bd0e 100644
--- a/libavcodec/webp_parser.c
+++ b/libavcodec/webp_parser.c
@@ -25,1
From: Josef Zlomek
Adds the demuxer of animated WebP files.
It supports non-animated, animated, truncated, and concatenated files.
Reading from a pipe (and other non-seekable inputs) is also supported.
The WebP demuxer splits the input stream into packets containing one frame.
It also marks the
From: Zhao Zhili
When intra_refresh is enabled, gopLength is equal to
NVENC_INFINITE_GOPLENGTH. gopLength should be 1 at least.
Signed-off-by: Zhao Zhili
---
libavcodec/nvenc.c | 18 --
1 file changed, 4 insertions(+), 14 deletions(-)
diff --git a/libavcodec/nvenc.c b/libavcod
> On Jul 6, 2023, at 18:23, Timo Rothenpieler wrote:
>
> On 06/07/2023 14:00, Zhao Zhili wrote:
>> From: Zhao Zhili
>> Regression since 99dfdb45. intraRefreshPeriod access cc->gopLength,
>> which has been overwritten to NVENC_INFINITE_GOPLENGTH before.
>> Fixes #10445.
>> ---
>> libavcodec/nv
On 7/5/2023 11:01 AM, Nuo Mi wrote:
From: frankplow
example clips:
* 12b444vvc1_E_Sony_2
* 12b444Ietsrc_A_Kwai_2
* 10b444P16_D_Sony_2
* 12b444Iepp_A_Sharp_2
* 12b444SPetsrc_B_Kwai_2
Co-authored-by: Nuo Mi
---
libavcodec/cbs_h266.h | 23 +++-
libavcodec/cb
On Thu, Jul 6, 2023 at 9:04 AM James Almer wrote:
> On 7/5/2023 9:41 PM, Nuo Mi wrote:
> >> +if (current->alf_cc_cb_filter_signal_flag)
> >> +ue(alf_cc_cb_filters_signalled_minus1, 0, 3);
> >> +else
> >> +infer(alf_cc_cb_filters_signalled_minus1, 0);
> >>
> > Not right, it
And fix the allowed range for ph_log2_diff_max_bt_min_qt_intra_slice_luma while
at it.
Signed-off-by: James Almer
---
libavcodec/cbs_h266_syntax_template.c | 10 ++
1 file changed, 6 insertions(+), 4 deletions(-)
diff --git a/libavcodec/cbs_h266_syntax_template.c
b/libavcodec/cbs_h266
Fixes warnings about variable set but not used.
Signed-off-by: James Almer
---
libavcodec/cbs_h266_syntax_template.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/libavcodec/cbs_h266_syntax_template.c
b/libavcodec/cbs_h266_syntax_template.c
index f6aae3ac51..97ca6fd32b 100
It's been a while since we've had a release, and we've had
a lot of new features in.
We did say we would make releases more often, and I think
it's about time we have a new release.
Anything anyone wants to have merged or should we branch
off 6.1 in a few days?
Heya,
On Thu, 6 Jul 2023, at 18:04, Lynne wrote:
> It's been a while since we've had a release, and we've had
> a lot of new features in.
> We did say we would make releases more often, and I think
> it's about time we have a new release.
It's a good idea.
> Anything anyone wants to have merged
And fix the allowed range for ph_log2_diff_max_bt_min_qt_intra_slice_luma while
at it.
Signed-off-by: James Almer
---
libavcodec/cbs_h266_syntax_template.c | 7 ++-
1 file changed, 6 insertions(+), 1 deletion(-)
diff --git a/libavcodec/cbs_h266_syntax_template.c
b/libavcodec/cbs_h266_synt
av_random_bytes() can use OS provided strong random functions and does not
depend soley on openssl/gcrypt external libraries.
Fixes ticket #10441.
Signed-off-by: Marton Balint
---
configure| 1 -
libavformat/hlsenc.c | 23 ++-
2 files changed, 2 insertions(+), 2
On 7/6/2023 4:52 AM, Anton Khirnov wrote:
Quoting James Almer (2023-07-05 15:03:07)
On 7/5/2023 9:56 AM, Anton Khirnov wrote:
Quoting James Almer (2023-07-05 01:26:14)
Signed-off-by: James Almer
---
configure | 2 +-
libavutil/random_seed.c | 16
2 files
On Thu, 6 Jul 2023, James Almer wrote:
On 7/6/2023 4:52 AM, Anton Khirnov wrote:
Quoting James Almer (2023-07-05 15:03:07)
On 7/5/2023 9:56 AM, Anton Khirnov wrote:
Quoting James Almer (2023-07-05 01:26:14)
Signed-off-by: James Almer
---
configure | 2 +-
libavu
Signed-off-by: James Almer
---
configure | 2 +-
libavutil/random_seed.c | 6 ++
2 files changed, 7 insertions(+), 1 deletion(-)
diff --git a/configure b/configure
index d6e78297fe..56e2b85f97 100755
--- a/configure
+++ b/configure
@@ -3892,7 +3892,7 @@ avfilter_deps="avutil"
On 7/6/2023 2:56 PM, Marton Balint wrote:
On Thu, 6 Jul 2023, James Almer wrote:
On 7/6/2023 4:52 AM, Anton Khirnov wrote:
Quoting James Almer (2023-07-05 15:03:07)
On 7/5/2023 9:56 AM, Anton Khirnov wrote:
Quoting James Almer (2023-07-05 01:26:14)
Signed-off-by: James Almer
---
On Wed, 5 Jul 2023, QiTong Li wrote:
Not sure if the function naming frame_queue_destory is intended because "destory" is not
really a word. Changing it to "destroy" makes more sense.
Thanks, will apply.
Regards,
Marton
Signed-off-by: QiTong Li
---
fftools/ffplay.c | 8
1 file
On Thu, Jul 6, 2023 at 4:28 AM Thilo Borgmann wrote:
>
> From: Josef Zlomek
>
> Adds the demuxer of animated WebP files.
> It supports non-animated, animated, truncated, and concatenated files.
> Reading from a pipe (and other non-seekable inputs) is also supported.
>
> The WebP demuxer splits th
LGTM
___
ffmpeg-devel mailing list
ffmpeg-devel@ffmpeg.org
https://ffmpeg.org/mailman/listinfo/ffmpeg-devel
To unsubscribe, visit link above, or email
ffmpeg-devel-requ...@ffmpeg.org with subject "unsubscribe".
LGTM
___
ffmpeg-devel mailing list
ffmpeg-devel@ffmpeg.org
https://ffmpeg.org/mailman/listinfo/ffmpeg-devel
To unsubscribe, visit link above, or email
ffmpeg-devel-requ...@ffmpeg.org with subject "unsubscribe".
For uint8_t buf[EVC_NALU_LENGTH_PREFIX_SIZE], &buf still points
to the beginning of buf, but it is of type "pointer to array of
EVC_NALU_LENGTH_PREFIX_SIZE uint8_t" (i.e. pointer arithmetic
would operate on blocks of size EVC_NALU_LENGTH_PREFIX_SIZE).
This is of course a different type than uint8_t
Fixes potential use of uninitialized values
in evc_read_nal_unit_length().
Signed-off-by: Andreas Rheinhardt
---
libavformat/evcdec.c | 2 ++
1 file changed, 2 insertions(+)
diff --git a/libavformat/evcdec.c b/libavformat/evcdec.c
index 9886542311..0f464930f7 100644
--- a/libavformat/evcdec.c
+
Signed-off-by: Andreas Rheinhardt
---
libavformat/evc.h | 17 ++---
1 file changed, 6 insertions(+), 11 deletions(-)
diff --git a/libavformat/evc.h b/libavformat/evc.h
index 46b27f7df7..f30831257d 100644
--- a/libavformat/evc.h
+++ b/libavformat/evc.h
@@ -23,16 +23,17 @@
#define AVF
Am 06.07.23 um 22:24 schrieb James Zern:
On Thu, Jul 6, 2023 at 4:28 AM Thilo Borgmann wrote:
From: Josef Zlomek
Adds the demuxer of animated WebP files.
It supports non-animated, animated, truncated, and concatenated files.
Reading from a pipe (and other non-seekable inputs) is also support
On Thu, 6 Jul 2023, 08:52 Anton Khirnov, wrote:
>
> We are not claiming that. We are claiming that the random numbers
> generated are (to the best of our ability, and that of the underlying
> libraries we rely on) cryptographically secure. This means suitable for
> use in state of the art cryptog
On Thu, Jul 06, 2023 at 09:52:12AM +0200, Anton Khirnov wrote:
> Quoting Michael Niedermayer (2023-07-06 00:54:47)
> > On Wed, Jul 05, 2023 at 11:22:44AM +0200, Anton Khirnov wrote:
> > > Quoting Michael Niedermayer (2023-07-05 01:50:12)
> > > > On Tue, Jul 04, 2023 at 07:54:06AM +0200, Anton Khirn
> -Original Message-
> From: ffmpeg-devel On Behalf Of Dai,
> Jianhui J
> Sent: Monday, July 3, 2023 12:26 PM
> To: ffmpeg-devel@ffmpeg.org
> Subject: [FFmpeg-devel] [PATCH v5] avformat/ivfenc: Set the "number of
> frames" in IVF header
>
> Should set "number of frames" to bytes 24-27
On 7/6/2023 6:08 PM, Andreas Rheinhardt wrote:
Fixes potential use of uninitialized values
in evc_read_nal_unit_length().
Signed-off-by: Andreas Rheinhardt
---
libavformat/evcdec.c | 2 ++
1 file changed, 2 insertions(+)
diff --git a/libavformat/evcdec.c b/libavformat/evcdec.c
index 9886542
On 7/6/2023 6:06 PM, Andreas Rheinhardt wrote:
For uint8_t buf[EVC_NALU_LENGTH_PREFIX_SIZE], &buf still points
to the beginning of buf, but it is of type "pointer to array of
EVC_NALU_LENGTH_PREFIX_SIZE uint8_t" (i.e. pointer arithmetic
would operate on blocks of size EVC_NALU_LENGTH_PREFIX_SIZE)
On 7/6/2023 10:14 PM, James Almer wrote:
On 7/6/2023 6:08 PM, Andreas Rheinhardt wrote:
Fixes potential use of uninitialized values
in evc_read_nal_unit_length().
Signed-off-by: Andreas Rheinhardt
---
libavformat/evcdec.c | 2 ++
1 file changed, 2 insertions(+)
diff --git a/libavformat/evc
James Almer:
> On 7/6/2023 10:14 PM, James Almer wrote:
>> On 7/6/2023 6:08 PM, Andreas Rheinhardt wrote:
>>> Fixes potential use of uninitialized values
>>> in evc_read_nal_unit_length().
>>>
>>> Signed-off-by: Andreas Rheinhardt
>>> ---
>>> libavformat/evcdec.c | 2 ++
>>> 1 file changed, 2 i
On 7/6/2023 10:30 PM, Andreas Rheinhardt wrote:
James Almer:
On 7/6/2023 10:14 PM, James Almer wrote:
On 7/6/2023 6:08 PM, Andreas Rheinhardt wrote:
Fixes potential use of uninitialized values
in evc_read_nal_unit_length().
Signed-off-by: Andreas Rheinhardt
---
libavformat/evcdec.c | 2 ++
James Almer:
> On 7/6/2023 6:08 PM, Andreas Rheinhardt wrote:
>> Fixes potential use of uninitialized values
>> in evc_read_nal_unit_length().
>>
>> Signed-off-by: Andreas Rheinhardt
>> ---
>> libavformat/evcdec.c | 2 ++
>> 1 file changed, 2 insertions(+)
>>
>> diff --git a/libavformat/evcdec.
James Almer:
> On 7/6/2023 10:30 PM, Andreas Rheinhardt wrote:
>> James Almer:
>>> On 7/6/2023 10:14 PM, James Almer wrote:
On 7/6/2023 6:08 PM, Andreas Rheinhardt wrote:
> Fixes potential use of uninitialized values
> in evc_read_nal_unit_length().
>
> Signed-off-by: Andreas R
On 7/6/2023 10:24 PM, Andreas Rheinhardt wrote:
James Almer:
On 7/6/2023 6:08 PM, Andreas Rheinhardt wrote:
Fixes potential use of uninitialized values
in evc_read_nal_unit_length().
Signed-off-by: Andreas Rheinhardt
---
libavformat/evcdec.c | 2 ++
1 file changed, 2 insertions(+)
diff
Jul 6, 2023, 18:19 by j...@videolan.org:
> Heya,
>
> On Thu, 6 Jul 2023, at 18:04, Lynne wrote:
>
>> It's been a while since we've had a release, and we've had
>> a lot of new features in.
>> We did say we would make releases more often, and I think
>> it's about time we have a new release.
>>
>
>
Leavitt
https://en.wikipedia.org/wiki/Henrietta_Swan_Leavitt
> On 7 Jul 2023, at 08:40, Lynne wrote:
>
> Jul 6, 2023, 18:19 by j...@videolan.org:
>
>> Heya,
>>
>> On Thu, 6 Jul 2023, at 18:04, Lynne wrote:
>>
>>> It's been a while since we've had a release, and we've had
>>> a lot of new fea
52 matches
Mail list logo