[FFmpeg-devel] [PATCH 2/2] avformat/hlsenc: deprecate hls_ts_options option

2021-11-17 Thread Steven Liu
From: Steven Liu Because the hls_ts_options will be misunderstand by user, and then user can use hls_segment_options instead of hls_ts_options. Signed-off-by: Steven Liu --- doc/muxers.texi | 2 ++ libavformat/hlsenc.c | 6 -- libavformat/version.h | 4 3 files changed, 10 inse

[FFmpeg-devel] [PATCH 1/2] avformat/hlsenc: add hls_segment_options correct the segment options name

2021-11-17 Thread Steven Liu
From: Steven Liu Because the hls_ts_options will be misunderstand by user that only can be used in mpegts segments option. So add this option for segments. Signed-off-by: Steven Liu --- doc/muxers.texi | 4 libavformat/hlsenc.c | 1 + 2 files changed, 5 insertions(+) diff --git a/do

Re: [FFmpeg-devel] [PATCH 2/2] avfilter: add a vflip_vulkan filter

2021-11-17 Thread Lynne
Nov 17, 2021, 08:51 by jianhua...@intel.com: > The following command is on how to apply vflip_vulkan filter: > > ffmpeg -init_hw_device vulkan -i input.264 -vf > hwupload=extra_hw_frames=16,vflip_vulkan,hwdownload,format=yuv420p output.264 > > Signed-off-by: Wu Jianhua > --- > configure

[FFmpeg-devel] [PATCH 2/2] libRIST: allow setting fifo size and fail on overflow.

2021-11-17 Thread Gijs Peskens
Introduce fifo_size and overrun_nonfatal params to configure fifo buffer behavior. Fifo size is used to left shift 2, since libRIST only accepts powers of 2. Use newly introduced RIST_DATA_FLAGS_OVERFLOW flag to check for overrun and error out in that case. --- libavformat/librist.c | 36

[FFmpeg-devel] [PATCH 1/2] libRIST: Correctly initialize logging_settings

2021-11-17 Thread Gijs Peskens
Correct solution as suggested by Martin Balint on ffmpeg-devel --- libavformat/librist.c | 1 + 1 file changed, 1 insertion(+) diff --git a/libavformat/librist.c b/libavformat/librist.c index 6eae90cc2f..378b635ea7 100644 --- a/libavformat/librist.c +++ b/libavformat/librist.c @@ -130,6 +130,7 @@

Re: [FFmpeg-devel] [PATCH 8/9] ffmpeg: drop a useless assignment

2021-11-17 Thread Michael Niedermayer
On Tue, Nov 16, 2021 at 11:26:26PM +0100, Michael Niedermayer wrote: > On Tue, Nov 16, 2021 at 08:11:41PM +0100, Anton Khirnov wrote: > > Quoting Michael Niedermayer (2021-11-16 14:46:43) > > > On Mon, Nov 15, 2021 at 04:23:59PM +0100, Anton Khirnov wrote: > > > > bits_per_raw_sample is already set

Re: [FFmpeg-devel] [PATCH v3 0/3] Dolby Vision RPU Side Data

2021-11-17 Thread Derek Buitenhuis
On 11/14/2021 2:04 PM, Derek Buitenhuis wrote: > I'll give this a few more days and then apply if there are no > other comments. Pushed. - Derek ___ ffmpeg-devel mailing list ffmpeg-devel@ffmpeg.org https://ffmpeg.org/mailman/listinfo/ffmpeg-devel To u

Re: [FFmpeg-devel] [PATCH v2] avformat/http: Add short_seek_size option

2021-11-17 Thread Derek Buitenhuis
On 11/16/2021 2:57 PM, James Almer wrote: > Micro. > > LGTM otherwise if tested. Double tested and micro bumped. Pushed. - Derek ___ ffmpeg-devel mailing list ffmpeg-devel@ffmpeg.org https://ffmpeg.org/mailman/listinfo/ffmpeg-devel To unsubscribe, vi

Re: [FFmpeg-devel] [PATCH v2] lavfi: add a libplacebo filter

2021-11-17 Thread Dennis Mungai
On Mon, 15 Nov 2021 at 22:26, Timo Rothenpieler wrote: > On 15.11.2021 19:21, Dennis Mungai wrote: > >> > > Hello. > > > > Were you able to build FFmpeg with this filter enabled? > > So far, building this package does not generate any pkgconfig file in the > > configured prefix, and FFmpeg's ./co

Re: [FFmpeg-devel] [PATCH 2/2] avfilter: add a vflip_vulkan filter

2021-11-17 Thread Wu, Jianhua
Lynne wrote: > Nov 17, 2021, 08:51 by jianhua...@intel.com: > > > The following command is on how to apply vflip_vulkan filter: > > > > ffmpeg -init_hw_device vulkan -i input.264 -vf > > > hwupload=extra_hw_frames=16,vflip_vulkan,hwdownload,format=yuv420p > > output.264 > > > > Signed-off-by: Wu J

Re: [FFmpeg-devel] [PATCH] */version.h: define FF_API macros unconditionally

2021-11-17 Thread Andreas Rheinhardt
Anton Khirnov: > Quoting Hendrik Leppkes (2021-11-12 14:59:41) >> On Fri, Nov 12, 2021 at 2:35 PM Anton Khirnov wrote: >>> >>> There is no reason to wrap them in #ifndef guards, they should only be >>> defined here and nowhere else. The define guards just add the >>> possibility to accidentally us

Re: [FFmpeg-devel] [PATCH 1/2] lafi/vf_edgedetect: Move some functions to lavu/imgutils

2021-11-17 Thread Andreas Rheinhardt
Thilo Borgmann: > Hi, > > shared code with vf_blurriness.c in patch 2/2. > RFC: is there a better place to put these? > If you only need this in libavfilter, then why do you put it into libavutil, thereby making it public and adding all sorts of ABI complications? - Andreas

[FFmpeg-devel] [PATCH 1/4] avutils: hwcontext_vaapi, print error if allocated surfaces > pool size

2021-11-17 Thread Xu Guangxin
--- libavutil/hwcontext_vaapi.c | 5 - 1 file changed, 4 insertions(+), 1 deletion(-) diff --git a/libavutil/hwcontext_vaapi.c b/libavutil/hwcontext_vaapi.c index 83e542876d..14a2df38c6 100644 --- a/libavutil/hwcontext_vaapi.c +++ b/libavutil/hwcontext_vaapi.c @@ -475,8 +475,11 @@ static AVBu

[FFmpeg-devel] [PATCH 2/4] avutil: hwcontext_vaapi, add AV_VAAPI_DRIVER_QUIRK_FRAME_POOL_RESIZING

2021-11-17 Thread Xu Guangxin
--- libavutil/hwcontext_vaapi.h | 6 ++ 1 file changed, 6 insertions(+) diff --git a/libavutil/hwcontext_vaapi.h b/libavutil/hwcontext_vaapi.h index 0b2e071cb3..e4c7707861 100644 --- a/libavutil/hwcontext_vaapi.h +++ b/libavutil/hwcontext_vaapi.h @@ -58,6 +58,12 @@ enum { * and the resu

[FFmpeg-devel] [PATCH 3/4] avutil: hwcontext_vaapi, mark i965, VDPAU and ubit driver as AV_VAAPI_DRIVER_QUIRK_FRAME_POOL_RESIZING

2021-11-17 Thread Xu Guangxin
Legacy drivers can't support decode output frame pool resize. --- libavutil/hwcontext_vaapi.c | 15 +-- 1 file changed, 9 insertions(+), 6 deletions(-) diff --git a/libavutil/hwcontext_vaapi.c b/libavutil/hwcontext_vaapi.c index 14a2df38c6..c13c395da2 100644 --- a/libavutil/hwcontext_

[FFmpeg-devel] [PATCH 4/4] avcodec: vaapi_decode, do not set initial_pool_size if driver supports frame pool resizing

2021-11-17 Thread Xu Guangxin
Two benifites of this commit: 1. Save memory. If we play an 8k hevc, previous code we allocate 50M * 20(1 + 16 + 3) = 1G memory. 4 may enough for most of playback usecases. 16 is a waste. 2. Allow downstream cache more frames. A downstream lookahead encoder will cache some frames. 20 may not enou

[FFmpeg-devel] [PATCH v2 1/2] avfilter: add a hflip_vulkan filter

2021-11-17 Thread Wu Jianhua
The following command is on how to apply hflip_vulkan filter: ffmpeg -init_hw_device vulkan -i input.264 -vf hwupload=extra_hw_frames=16,hflip_vulkan,hwdownload,format=yuv420p output.264 Signed-off-by: Wu Jianhua --- configure | 1 + libavfilter/Makefile | 1 +

[FFmpeg-devel] [PATCH v2 2/2] avfilter: add a vflip_vulkan filter

2021-11-17 Thread Wu Jianhua
The following command is on how to apply vflip_vulkan filter: ffmpeg -init_hw_device vulkan -i input.264 -vf hwupload=extra_hw_frames=16,vflip_vulkan,hwdownload,format=yuv420p output.264 Signed-off-by: Wu Jianhua --- configure | 1 + libavfilter/Makefile

[FFmpeg-devel] [PATCH 01/10] avfilter/avgblur_vulkan: check if shader is created with success

2021-11-17 Thread Wu Jianhua
Signed-off-by: Wu Jianhua --- libavfilter/vf_avgblur_vulkan.c | 4 1 file changed, 4 insertions(+) diff --git a/libavfilter/vf_avgblur_vulkan.c b/libavfilter/vf_avgblur_vulkan.c index 4795e482a9..253290663b 100644 --- a/libavfilter/vf_avgblur_vulkan.c +++ b/libavfilter/vf_avgblur_vulkan.c @

[FFmpeg-devel] [PATCH 02/10] avfilter/avgblur_vulkan: use FF_ARRAY_ELEMS instead of magic number

2021-11-17 Thread Wu Jianhua
Signed-off-by: Wu Jianhua --- libavfilter/vf_avgblur_vulkan.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/libavfilter/vf_avgblur_vulkan.c b/libavfilter/vf_avgblur_vulkan.c index 253290663b..243e932f35 100644 --- a/libavfilter/vf_avgblur_vulkan.c +++ b/libavfilter/vf_av

[FFmpeg-devel] [PATCH 03/10] avfilter/chromaber_vulkan: use FF_ARRAY_ELEMS instead of magic number

2021-11-17 Thread Wu Jianhua
Signed-off-by: Wu Jianhua --- libavfilter/vf_chromaber_vulkan.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/libavfilter/vf_chromaber_vulkan.c b/libavfilter/vf_chromaber_vulkan.c index 83ab72f716..b817dd12f7 100644 --- a/libavfilter/vf_chromaber_vulkan.c +++ b/libavfilter/

[FFmpeg-devel] [PATCH 04/10] avfilter/scale_vulkan: use FF_ARRAY_ELEMS instead of magic number

2021-11-17 Thread Wu Jianhua
Signed-off-by: Wu Jianhua --- libavfilter/vf_scale_vulkan.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/libavfilter/vf_scale_vulkan.c b/libavfilter/vf_scale_vulkan.c index 3a2251f8df..7d7120df79 100644 --- a/libavfilter/vf_scale_vulkan.c +++ b/libavfilter/vf_scale_vulkan.c

[FFmpeg-devel] [PATCH 07/10] avfilter/chromaber_vulkan: call av_vkfmt_from_pixfmt only one time

2021-11-17 Thread Wu Jianhua
Signed-off-by: Wu Jianhua --- libavfilter/vf_chromaber_vulkan.c | 6 -- 1 file changed, 4 insertions(+), 2 deletions(-) diff --git a/libavfilter/vf_chromaber_vulkan.c b/libavfilter/vf_chromaber_vulkan.c index b817dd12f7..c4f84d792e 100644 --- a/libavfilter/vf_chromaber_vulkan.c +++ b/libavf

[FFmpeg-devel] [PATCH 05/10] avfilter/overlay_vulkan: use FF_ARRAY_ELEMS instead of magic number

2021-11-17 Thread Wu Jianhua
Signed-off-by: Wu Jianhua --- libavfilter/vf_overlay_vulkan.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/libavfilter/vf_overlay_vulkan.c b/libavfilter/vf_overlay_vulkan.c index b902ad83f5..29eb11c89d 100644 --- a/libavfilter/vf_overlay_vulkan.c +++ b/libavfilter/vf_overla

[FFmpeg-devel] [PATCH 08/10] avfilter/scale_vulkan: call av_pix_fmt_count_planes only one time

2021-11-17 Thread Wu Jianhua
Signed-off-by: Wu Jianhua --- libavfilter/vf_scale_vulkan.c | 10 -- 1 file changed, 4 insertions(+), 6 deletions(-) diff --git a/libavfilter/vf_scale_vulkan.c b/libavfilter/vf_scale_vulkan.c index 7d7120df79..413c2cb294 100644 --- a/libavfilter/vf_scale_vulkan.c +++ b/libavfilter/vf_sca

[FFmpeg-devel] [PATCH 09/10] avfilter/scale_vulkan: call av_vkfmt_from_pixfmt only one time

2021-11-17 Thread Wu Jianhua
Signed-off-by: Wu Jianhua --- libavfilter/vf_scale_vulkan.c | 6 -- 1 file changed, 4 insertions(+), 2 deletions(-) diff --git a/libavfilter/vf_scale_vulkan.c b/libavfilter/vf_scale_vulkan.c index 413c2cb294..77c970473e 100644 --- a/libavfilter/vf_scale_vulkan.c +++ b/libavfilter/vf_scale_vu

[FFmpeg-devel] [PATCH 06/10] avfilter/avgblur_vulkan: call av_vkfmt_from_pixfmt only one time

2021-11-17 Thread Wu Jianhua
There is a loop in av_vkfmt_from_pixfmt. And, even though some compilers will optimize it when the optimization option is on, to consider more situations, just call the function only one time here. Signed-off-by: Wu Jianhua --- libavfilter/vf_avgblur_vulkan.c | 10 +++--- 1 file changed, 7 i

[FFmpeg-devel] [PATCH 10/10] avfilter/overlay_vulkan: call av_vkfmt_from_pixfmt only one time

2021-11-17 Thread Wu Jianhua
Signed-off-by: Wu Jianhua --- libavfilter/vf_overlay_vulkan.c | 12 1 file changed, 8 insertions(+), 4 deletions(-) diff --git a/libavfilter/vf_overlay_vulkan.c b/libavfilter/vf_overlay_vulkan.c index 29eb11c89d..03197ae712 100644 --- a/libavfilter/vf_overlay_vulkan.c +++ b/libavfil

Re: [FFmpeg-devel] [PATCH] avfilter/vf_gblur_vulkan: Fix use of uninitialized value

2021-11-17 Thread Andreas Rheinhardt
lance.lmw...@gmail.com: > From: Limin Wang > > Signed-off-by: Limin Wang > --- > libavfilter/vf_gblur_vulkan.c | 2 +- > 1 file changed, 1 insertion(+), 1 deletion(-) > > diff --git a/libavfilter/vf_gblur_vulkan.c b/libavfilter/vf_gblur_vulkan.c > index d4f391b..16c8bbb 100644 > --- a/libavfil

Re: [FFmpeg-devel] [PATCH 06/10] avfilter/avgblur_vulkan: call av_vkfmt_from_pixfmt only one time

2021-11-17 Thread Andreas Rheinhardt
Wu Jianhua: > There is a loop in av_vkfmt_from_pixfmt. And, even though some > compilers will optimize it when the optimization option is on, to > consider more situations, just call the function only one time here. > > Signed-off-by: Wu Jianhua > --- What compilers optimize this? And how? After

Re: [FFmpeg-devel] [PATCH v2 1/2] avfilter: add a hflip_vulkan filter

2021-11-17 Thread Andreas Rheinhardt
Wu Jianhua: > The following command is on how to apply hflip_vulkan filter: > > ffmpeg -init_hw_device vulkan -i input.264 -vf > hwupload=extra_hw_frames=16,hflip_vulkan,hwdownload,format=yuv420p output.264 > > Signed-off-by: Wu Jianhua > --- > configure | 1 + > libavfil

Re: [FFmpeg-devel] [PATCH 2/2] avformat/hlsenc: deprecate hls_ts_options option

2021-11-17 Thread Andreas Rheinhardt
Steven Liu: > From: Steven Liu > > Because the hls_ts_options will be misunderstand by user, > and then user can use hls_segment_options instead of hls_ts_options. > > Signed-off-by: Steven Liu > --- > doc/muxers.texi | 2 ++ > libavformat/hlsenc.c | 6 -- > libavformat/version.h |

Re: [FFmpeg-devel] [PATCH 06/10] avfilter/avgblur_vulkan: call av_vkfmt_from_pixfmt only one time

2021-11-17 Thread Wu, Jianhua
Andreas Rheinhardt wrote: > > Wu Jianhua: > > There is a loop in av_vkfmt_from_pixfmt. And, even though some > > compilers will optimize it when the optimization option is on, to > > consider more situations, just call the function only one time here. > > > > Signed-off-by: Wu Jianhua > > --- >

Re: [FFmpeg-devel] [PATCH v2 1/2] avfilter: add a hflip_vulkan filter

2021-11-17 Thread Wu, Jianhua
Andreas Rheinhardt wrote: > Wu Jianhua: > > The following command is on how to apply hflip_vulkan filter: > > > > ffmpeg -init_hw_device vulkan -i input.264 -vf > > > hwupload=extra_hw_frames=16,hflip_vulkan,hwdownload,format=yuv420p > > output.264 > > > > Signed-off-by: Wu Jianhua > > --- > > co

Re: [FFmpeg-devel] [PATCH 06/10] avfilter/avgblur_vulkan: call av_vkfmt_from_pixfmt only one time

2021-11-17 Thread Andreas Rheinhardt
Wu, Jianhua: > Andreas Rheinhardt wrote: >> >> Wu Jianhua: >>> There is a loop in av_vkfmt_from_pixfmt. And, even though some >>> compilers will optimize it when the optimization option is on, to >>> consider more situations, just call the function only one time here. >>> >>> Signed-off-by: Wu Jian

Re: [FFmpeg-devel] [PATCH v2 1/2] avfilter: add a hflip_vulkan filter

2021-11-17 Thread Andreas Rheinhardt
Wu, Jianhua: > Andreas Rheinhardt wrote: >> Wu Jianhua: >>> The following command is on how to apply hflip_vulkan filter: >>> >>> ffmpeg -init_hw_device vulkan -i input.264 -vf >>> >> hwupload=extra_hw_frames=16,hflip_vulkan,hwdownload,format=yuv420p >>> output.264 >>> >>> Signed-off-by: Wu Jianhua

Re: [FFmpeg-devel] [PATCH 06/10] avfilter/avgblur_vulkan: call av_vkfmt_from_pixfmt only one time

2021-11-17 Thread Wu, Jianhua
Andreas Rheinhardt: > Sent: Thursday, November 18, 2021 1:24 PM > To: ffmpeg-devel@ffmpeg.org > Subject: Re: [FFmpeg-devel] [PATCH 06/10] avfilter/avgblur_vulkan: call > av_vkfmt_from_pixfmt only one time > > Wu, Jianhua: > > Andreas Rheinhardt wrote: > >> > >> Wu Jianhua: > >>> There is a loop in

Re: [FFmpeg-devel] [PATCH 05/10] avfilter/overlay_vulkan: use FF_ARRAY_ELEMS instead of magic number

2021-11-17 Thread Lynne
Nov 18, 2021, 05:24 by jianhua...@intel.com: > Signed-off-by: Wu Jianhua > --- > libavfilter/vf_overlay_vulkan.c | 2 +- > 1 file changed, 1 insertion(+), 1 deletion(-) > > diff --git a/libavfilter/vf_overlay_vulkan.c b/libavfilter/vf_overlay_vulkan.c > index b902ad83f5..29eb11c89d 100644 > ---

Re: [FFmpeg-devel] [PATCH 05/10] avfilter/overlay_vulkan: use FF_ARRAY_ELEMS instead of magic number

2021-11-17 Thread Wu, Jianhua
> -Original Message- > From: ffmpeg-devel On Behalf Of > Lynne > Sent: Thursday, November 18, 2021 1:48 PM > To: FFmpeg development discussions and patches de...@ffmpeg.org> > Subject: Re: [FFmpeg-devel] [PATCH 05/10] avfilter/overlay_vulkan: use > FF_ARRAY_ELEMS instead of magic numbe

Re: [FFmpeg-devel] [PATCH v2 1/2] avfilter: add a hflip_vulkan filter

2021-11-17 Thread Wu, Jianhua
> Andreas Rheinhardt: > Wu, Jianhua: > > Andreas Rheinhardt wrote: > >> Wu Jianhua: > >>> The following command is on how to apply hflip_vulkan filter: > >>> > >>> ffmpeg -init_hw_device vulkan -i input.264 -vf > >>> > >> > hwupload=extra_hw_frames=16,hflip_vulkan,hwdownload,format=yuv420p > >>> o

Re: [FFmpeg-devel] [PATCH 2/2] avformat/hlsenc: deprecate hls_ts_options option

2021-11-17 Thread Steven Liu
> 2021年11月18日 下午12:57,Andreas Rheinhardt 写道: > > Steven Liu: >> From: Steven Liu >> >> Because the hls_ts_options will be misunderstand by user, >> and then user can use hls_segment_options instead of hls_ts_options. >> >> Signed-off-by: Steven Liu >> --- >> doc/muxers.texi | 2 ++ >>

[FFmpeg-devel] [PATCH v2 1/2] avformat/hlsenc: add hls_segment_options correct the segment options name

2021-11-17 Thread Steven Liu
From: Steven Liu Because the hls_ts_options will be misunderstand by user that only can be used in mpegts segments option. So add this option for segments. Signed-off-by: Steven Liu Signed-off-by: Steven Liu --- doc/muxers.texi | 4 libavformat/hlsenc.c | 1 + 2 files changed, 5 ins

[FFmpeg-devel] [PATCH v2 2/2] avformat/hlsenc: deprecate hls_ts_options option

2021-11-17 Thread Steven Liu
Because the hls_ts_options will be misunderstand by user, and then user can use hls_segment_options instead of hls_ts_options. Signed-off-by: Steven Liu --- doc/muxers.texi | 1 + libavformat/hlsenc.c | 4 +++- libavformat/version.h | 1 + 3 files changed, 5 insertions(+), 1 deletion(-)