Mar 6, 2024, 06:26 by haihao.xiang-at-intel@ffmpeg.org:
> From: Haihao Xiang
>
> Otherwise s->input_format is always yuv420p.
>
> This fixes invalid output format for hwframe download in the command
> below:
> ./ffmpeg -init_hw_device vulkan -f lavfi \
> -i testsrc=duration=1,format=nv12 \
>
Mar 7, 2024, 01:33 by andreas.rheinha...@outlook.com:
> These fields are set for all Vulkan decoding hwaccels;
> they would be useless if it were different.
>
> Signed-off-by: Andreas Rheinhardt
> ---
> libavcodec/vulkan_decode.c | 6 +-
> 1 file changed, 1 insertion(+), 5 deletions(-)
>
> d
> On Mar 7, 2024, at 07:25, Michael Niedermayer via ffmpeg-devel
> wrote:
>
> On Tue, Mar 05, 2024 at 11:27:22AM +0100, Anton Khirnov wrote:
>> Quoting Michael Niedermayer (2024-03-05 03:50:01)
>>> The STF opertunity had a deadline.
>>> Also we can already start discussing what shall be done w
Lynne:
> Mar 3, 2024, 12:35 by andreas.rheinha...@outlook.com:
>
>> Only three of the 226 (== AV_CODEC_ID_AV1) entries
>> have been used. Unsparsing this table is especially
>> important given that this array lives in .data.rel.ro.
>>
>> Signed-off-by: Andreas Rheinhardt
>> ---
>> Instead of para
Signed-off-by: James Almer
---
fftools/ffprobe.c | 157 +++-
tests/fate/iamf.mak | 8 +-
tests/fate/mov.mak | 8 +-
tests/ref/fate/iamf-5_1_4 | 92 ++
tests/ref/fate/iamf-7_1_4
Signed-off-by: James Almer
---
fftools/ffprobe.c | 53 ---
tests/fate/mov.mak| 6 +--
.../ref/fate/mov-heic-demux-still-image-grid | 29 ++
.../ref/fate/mov-heic-demux-still-image-iovl | 19 +++
.../fate/mov-he
Anton Khirnov:
> ---
> libavformat/matroskadec.c | 6 +++---
> 1 file changed, 3 insertions(+), 3 deletions(-)
>
> diff --git a/libavformat/matroskadec.c b/libavformat/matroskadec.c
> index 5d3d18a146..6d6a60c552 100644
> --- a/libavformat/matroskadec.c
> +++ b/libavformat/matroskadec.c
> @@ -203
All the fields of FFVkCodecMap are either decoder-only
or encoder-only (with the latter being unused and unset for now).
Yet there is already a per-decoder struct containing
static information about these decoders, namely
VkExtensionProperties.
This commit merges the decoder-parts of FFVkCodecMap
These fields are set for all Vulkan decoding hwaccels;
they would be useless if it were different.
Signed-off-by: Andreas Rheinhardt
---
libavcodec/vulkan_decode.c | 6 +-
1 file changed, 1 insertion(+), 5 deletions(-)
diff --git a/libavcodec/vulkan_decode.c b/libavcodec/vulkan_decode.c
ind
Only three of the 226 (== AV_CODEC_ID_AV1) entries
have been used. Unsparsing this table is especially
important given that this array lives in .data.rel.ro.
Signed-off-by: Andreas Rheinhardt
---
libavcodec/vulkan_av1.c| 1 +
libavcodec/vulkan_decode.c | 13 +
libavcodec/vulkan_
This commit fixes issues with AMD HEVC encoding.
By default AMD hevc encoder asks for the alignment 64x16, while FFMPEG VAAPI
has 16x16.
Adding support for customzied surface size from VASurfaceAttribAlignmentSize in
VAAPI version 1.21.0.
To: primeadv...@gmail.com
Signed-off-by: Araz Iusubov
The reference file uses BGRA pixel format, so request it here.
---
tests/fate/ffmpeg.mak | 2 ++
1 file changed, 2 insertions(+)
diff --git a/tests/fate/ffmpeg.mak b/tests/fate/ffmpeg.mak
index 669c878c7f..77e93693b9 100644
--- a/tests/fate/ffmpeg.mak
+++ b/tests/fate/ffmpeg.mak
@@ -62,6 +62,7 @@
Signed-off-by: Andreas Rheinhardt
---
libavcodec/vulkan_video.c | 12
1 file changed, 12 deletions(-)
diff --git a/libavcodec/vulkan_video.c b/libavcodec/vulkan_video.c
index a87df52871..dc6652709f 100644
--- a/libavcodec/vulkan_video.c
+++ b/libavcodec/vulkan_video.c
@@ -309,7 +309
On Tue, Mar 05, 2024 at 11:27:22AM +0100, Anton Khirnov wrote:
> Quoting Michael Niedermayer (2024-03-05 03:50:01)
> > The STF opertunity had a deadline.
> > Also we can already start discussing what shall be done when the next grant
> > opertunity comes.
>
> How about some actual transparency
Th
Improves performance by about 30%.
Signed-off-by: Andreas Rheinhardt
---
[1] is a patch that would also move the bitreverse into the LUT;
it didn't make a difference in the benchmarks here, but if it is
an improvement for someone else, it could still be applied.
[1]:
https://github.com/mkver/FFm
Speeds up decoding and also reduces binary size.
Signed-off-by: Andreas Rheinhardt
---
libavcodec/xpmdec.c | 25 -
1 file changed, 16 insertions(+), 9 deletions(-)
diff --git a/libavcodec/xpmdec.c b/libavcodec/xpmdec.c
index 5bc02378c8..804cf8568d 100644
--- a/libavcodec
Signed-off-by: Andreas Rheinhardt
---
libavutil/avstring.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/libavutil/avstring.c b/libavutil/avstring.c
index 8751ce5576..2071dd36a5 100644
--- a/libavutil/avstring.c
+++ b/libavutil/avstring.c
@@ -345,7 +345,7 @@ int av_escape(ch
lör 2024-02-24 klockan 15:13 +0100 skrev Andreas Rheinhardt:
> Tomas Härdin:
> > > > > +static int mxf_check_bitstream(AVFormatContext *s, AVStream
> > > > > *st,
> > > > > const AVPacket *pkt)
> > > > > +{
> > > > > + if (st->codecpar->codec_id == AV_CODEC_ID_H264) {
> > > > > + if (pkt-
On Tue, Mar 05, 2024 at 11:51:45PM +0100, Marton Balint wrote:
> Signed-off-by: Marton Balint
> ---
> libavformat/pcm.c| 38 ++
> libavformat/pcm.h| 1 +
> libavformat/wavdec.c | 11 ++-
> 3 files changed, 29 insertions(+), 21 deletions(-)
bre
Signed-off-by: Andreas Rheinhardt
---
libavcodec/h264_ps.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/libavcodec/h264_ps.c b/libavcodec/h264_ps.c
index dcc51b96db..3c8fc33c7f 100644
--- a/libavcodec/h264_ps.c
+++ b/libavcodec/h264_ps.c
@@ -522,7 +522,7 @@ int ff_h264_deco
Hi all
Today ive received notifications for password reset requests on my facebook
account
ive loged in and tried enabling 2FA but facebook refused. It seems my account
also had access to the FFmpeg facebook page. Which i believe hasnt been used
in the last few years, but maybe iam wrong.
Either
> -Original Message-
> From: ffmpeg-devel On Behalf Of Andreas
> Rheinhardt
> Sent: 2024年3月7日 0:24
> To: ffmpeg-devel@ffmpeg.org
> Subject: Re: [FFmpeg-devel] [PATCH] avcodec/libx264: fix extradata when
> config annexb=0
>
> Zhao Zhili:
> >
> >
> >> -Original Message-
> >> Fro
Thank you Stefano for the review on the whole set. I will take the feedback
and come back with a better organized set in the next 2 or so days.
On Wed, Mar 6, 2024 at 09:42 Stefano Sabatini wrote:
> On date Wednesday 2024-03-06 01:19:12 -0600, Marth64 wrote:
> > Many DVDs have valuable assets in
On Wed, 6 Mar 2024, Ramiro Polla wrote:
ping
Did you miss my response here?
https://ffmpeg.org/pipermail/ffmpeg-devel/2024-February/321448.html
// Martin
___
ffmpeg-devel mailing list
ffmpeg-devel@ffmpeg.org
https://ffmpeg.org/mailman/listinfo/f
Andreas Rheinhardt:
> It is only used by hq_hqa.c, so said header can simply
> be included there.
> Also move the code to initialize the VLCs to hq_hqa.c.
>
> Signed-off-by: Andreas Rheinhardt
> ---
> libavcodec/Makefile | 3 +-
> libavcodec/hq_hqa.c
ping
On Sun, Feb 4, 2024 at 3:42 PM Ramiro Polla wrote:
>
> The code is imported from libjpeg-turbo-3.0.1. The neon registers used
> have been changed to avoid modifying v8-v15.
> ---
> libavcodec/aarch64/Makefile | 2 +
> libavcodec/aarch64/fdct.h | 26 ++
> lib
Zhao Zhili:
>
>
>> -Original Message-
>> From: ffmpeg-devel On Behalf Of Andreas
>> Rheinhardt
>> Sent: 2024年3月6日 22:19
>> To: ffmpeg-devel@ffmpeg.org
>> Subject: Re: [FFmpeg-devel] [PATCH] avcodec/libx264: fix extradata when
>> config annexb=0
>>
>> Zhao Zhili:
>>> From: Zhao Zhili
>
> -Original Message-
> From: ffmpeg-devel On Behalf Of Andreas
> Rheinhardt
> Sent: 2024年3月6日 22:19
> To: ffmpeg-devel@ffmpeg.org
> Subject: Re: [FFmpeg-devel] [PATCH] avcodec/libx264: fix extradata when
> config annexb=0
>
> Zhao Zhili:
> > From: Zhao Zhili
> >
> > ---
> > configur
On date Wednesday 2024-03-06 09:43:26 -0600, Marth64 wrote:
> It is true that this is necessary when muxing to Matroska, but it is also
> the case for MOV - the MOV muxer expects RGB prior to converting to YUV
> again. So this would be needed for MOV also, despite the awkward conversion
> circle. I
On date Wednesday 2024-03-06 09:02:50 +0100, Anton Khirnov wrote:
> ---
> libavformat/matroskadec.c | 6 +++---
> 1 file changed, 3 insertions(+), 3 deletions(-)
>
> diff --git a/libavformat/matroskadec.c b/libavformat/matroskadec.c
> index 5d3d18a146..6d6a60c552 100644
> --- a/libavformat/matros
It is true that this is necessary when muxing to Matroska, but it is also
the case for MOV - the MOV muxer expects RGB prior to converting to YUV
again. So this would be needed for MOV also, despite the awkward conversion
circle. I should update the document to reflect this.
On Wed, Mar 6, 2024 a
On date Wednesday 2024-03-06 01:19:12 -0600, Marth64 wrote:
> Many DVDs have valuable assets in their menu structures, including background
> video or music. Some discs also abuse the menu feature to include actual
> feature footage that needs to change aspect ratio (in order to trick the DVD
> pl
Good morning,
There do exist discs with mono tracks. This was to make the channel
assignment explicit rather than a guess, although if it is not necessary I
am happy to skip it.
Thank you!
On Wed, Mar 6, 2024 at 09:10 Stefano Sabatini wrote:
> On date Wednesday 2024-03-06 01:19:13 -0600, Marth6
Good morning,
DVD subtitle palettes, which are natively YUV, are currently carried as
a hex string in their respective subtitle streams and have
no concept of colorspace tagging (even predating dvd demuxer). The
convention is to convert
them to RGB prior to storage. Common players will only render
On 06/03/2024 16:09, Stefano Sabatini wrote:
On date Wednesday 2024-03-06 01:19:11 -0600, Marth64 wrote:
Since last iteration: removes unused variable in dvdclut.c
Signed-off-by: Marth64
---
doc/demuxers.texi | 5 +++
libavformat/Makefile | 2 +-
libavformat/dvdclut.c |
On date Wednesday 2024-03-06 01:19:13 -0600, Marth64 wrote:
> Signed-off-by: Marth64
> ---
> libavformat/dvdvideodec.c | 4 +++-
> 1 file changed, 3 insertions(+), 1 deletion(-)
>
> diff --git a/libavformat/dvdvideodec.c b/libavformat/dvdvideodec.c
> index 2c7ffdd148..6136060288 100644
> --- a/l
On date Wednesday 2024-03-06 01:19:11 -0600, Marth64 wrote:
> Since last iteration: removes unused variable in dvdclut.c
>
> Signed-off-by: Marth64
> ---
> doc/demuxers.texi | 5 +++
> libavformat/Makefile | 2 +-
> libavformat/dvdclut.c | 75 ++
Signed-off-by: James Almer
---
libavutil/opt.c | 150 ++
libavutil/opt.h | 8 +++
libavutil/tests/opt.c | 7 +-
tests/ref/fate/opt| 48 +++---
4 files changed, 188 insertions(+), 25 deletions(-)
diff --git a/libavutil/opt.c b/l
Zhao Zhili:
> From: Zhao Zhili
>
> ---
> configure| 2 +-
> libavcodec/libx264.c | 148 ---
> 2 files changed, 125 insertions(+), 25 deletions(-)
>
> diff --git a/configure b/configure
> index bbf1a70731..ef58c3fe97 100755
> --- a/configure
On date Tuesday 2024-03-05 23:51:41 +0100, Marton Balint wrote:
> The samples I found all have 2000 sample packets, and by forcing the packet
> size with a bsf we could automagically make muxing work for packets containing
> more than 3640 samples.
>
> Signed-off-by: Marton Balint
> ---
> config
On date Tuesday 2024-03-05 23:51:40 +0100, Marton Balint wrote:
> Signed-off-by: Marton Balint
> ---
> libavcodec/bsf/pcm_rechunk.c | 20 +++-
> 1 file changed, 19 insertions(+), 1 deletion(-)
>
> diff --git a/libavcodec/bsf/pcm_rechunk.c b/libavcodec/bsf/pcm_rechunk.c
> index 9
This and the following commits fix #10857
---
Renamed the option to 'side_data_prefer_packet', as preferred by James
and Derek on IRC.
---
doc/APIchanges | 3 +++
libavcodec/avcodec.h | 31 +++
libavcodec/decode.c| 36 +
On date Tuesday 2024-03-05 23:51:39 +0100, Marton Balint wrote:
> Should be easier to add new codecs by using the same order as in
> av_get_exact_bits_per_sample().
>
> Signed-off-by: Marton Balint
> ---
> libavcodec/bsf/pcm_rechunk.c | 21 +
> 1 file changed, 13 insertions(+
On date Tuesday 2024-03-05 12:50:09 -0300, James Almer wrote:
> On 3/5/2024 12:24 PM, Stefano Sabatini wrote:
> > On date Tuesday 2024-03-05 12:14:53 -0300, James Almer wrote:
> > > On 3/4/2024 9:00 PM, James Almer wrote:
> > > > Signed-off-by: James Almer
> > > > ---
> > > >fftools/ffprobe.c
From: Zhao Zhili
---
configure| 2 +-
libavcodec/libx264.c | 148 ---
2 files changed, 125 insertions(+), 25 deletions(-)
diff --git a/configure b/configure
index bbf1a70731..ef58c3fe97 100755
--- a/configure
+++ b/configure
@@ -3491,7 +3491
Rename dec_open to dec_init(), as it is more descriptive of its new
purpose.
Will be useful in following commits, which will add a new path for
opening decoders.
---
fftools/ffmpeg.h | 2 +-
fftools/ffmpeg_dec.c | 61 ++
fftools/ffmpeg_demux.c | 2
Perform it right after we figure out what the type is.
---
fftools/ffmpeg_filter.c | 15 ---
1 file changed, 8 insertions(+), 7 deletions(-)
diff --git a/fftools/ffmpeg_filter.c b/fftools/ffmpeg_filter.c
index 7425e3d2ed..eb8d0aee78 100644
--- a/fftools/ffmpeg_filter.c
+++ b/fftools/f
These functions used to be much longer, but now they are only a couple
lines each, some of them duplicated between audio and video.
---
fftools/ffmpeg_enc.c | 65 +++-
1 file changed, 22 insertions(+), 43 deletions(-)
diff --git a/fftools/ffmpeg_enc.c b/fft
This allows to send an encoder's output back to decoding and feed the
result into a complex filtergraph.
---
Changelog | 1 +
doc/ffmpeg.texi | 49 ++--
fftools/cmdutils.c | 2 +-
fftools/cmdutils.h | 7 +-
fftools/ffmpeg.c| 26 +++
fftoo
This allows using WRAPPED_AVFRAME encoders with loopback decoders in
order to connect multiple filtergraphs together.
Clear the flag in muxers, since lavf does not need it for anything and
it would change the results of framecrc FATE tests.
---
fftools/ffmpeg_enc.c | 2 ++
fftools/ffmpeg_mux.c |
Will be useful in following commits.
---
fftools/ffmpeg.c | 41 +++--
1 file changed, 31 insertions(+), 10 deletions(-)
diff --git a/fftools/ffmpeg.c b/fftools/ffmpeg.c
index 2f01a01e2d..ffd25f4c5b 100644
--- a/fftools/ffmpeg.c
+++ b/fftools/ffmpeg.c
@@ -402,23
---
fftools/ffmpeg_sched.c | 212 ++---
fftools/ffmpeg_sched.h | 8 +-
2 files changed, 181 insertions(+), 39 deletions(-)
diff --git a/fftools/ffmpeg_sched.c b/fftools/ffmpeg_sched.c
index 5f8ef04680..d1fb942c34 100644
--- a/fftools/ffmpeg_sched.c
+++ b/ffto
These functions used to be passed directly to pthread_create(), which
required them to return void*. This is no longer the case, so they can
return a plain int.
---
fftools/ffmpeg.h| 4 ++--
fftools/ffmpeg_dec.c| 6 +++---
fftools/ffmpeg_demux.c | 4 ++--
fftools/ffmpeg_enc.c| 4 +
Will be useful in following commits.
---
fftools/ffmpeg_sched.c | 151 +
1 file changed, 91 insertions(+), 60 deletions(-)
diff --git a/fftools/ffmpeg_sched.c b/fftools/ffmpeg_sched.c
index e5435dd866..5f8ef04680 100644
--- a/fftools/ffmpeg_sched.c
+++ b/ff
---
fftools/ffmpeg_filter.c | 8
1 file changed, 8 insertions(+)
diff --git a/fftools/ffmpeg_filter.c b/fftools/ffmpeg_filter.c
index eb8d0aee78..7aa9305c88 100644
--- a/fftools/ffmpeg_filter.c
+++ b/fftools/ffmpeg_filter.c
@@ -1142,6 +1142,10 @@ static int fg_complex_bind_input(FilterGr
Will become useful in following commits.
---
fftools/ffmpeg_sched.c | 117 ++---
1 file changed, 98 insertions(+), 19 deletions(-)
diff --git a/fftools/ffmpeg_sched.c b/fftools/ffmpeg_sched.c
index cf9b0c836e..e5435dd866 100644
--- a/fftools/ffmpeg_sched.c
+++
The first of these binds inputs of complex filtergraphs to demuxer
streams (with a misleading comment claiming it *creates* complex
filtergraphs).
The second ensures that all filtergraph outputs are connected to an
encoder.
Merge them into a single function, which simplifies the ffmpeg_filter
API
Treat it analogously to stream parameters like format/dimensions/etc.
This is functionally different from previous code in 2 ways:
* for non-CFR video, the frame timebase (set by the decoder) is used
rather than the demuxer timebase
* for sub2video, AV_TIME_BASE_Q is used, which is hardcoded by t
Current callstack looks like this:
* ifilter_bind_ist() (filter) calls ist_filter_add() (demuxer);
* ist_filter_add() opens the decoder, and then calls
dec_add_filter() (decoder);
* dec_add_filter() calls ifilter_parameters_from_dec() (i.e. back into
the filtering code) in order to give post-av
Encoder timebase is equal to the frame timebase, so does not need to be
passed separately.
Also, rename in_picture to frame, which is shorter and more accurate -
it always contains a frame, never a field.
---
fftools/ffmpeg_enc.c | 12 ++--
1 file changed, 6 insertions(+), 6 deletions(-)
---
fftools/cmdutils.c | 9 +
1 file changed, 5 insertions(+), 4 deletions(-)
diff --git a/fftools/cmdutils.c b/fftools/cmdutils.c
index 008949a39d..8efec942bd 100644
--- a/fftools/cmdutils.c
+++ b/fftools/cmdutils.c
@@ -793,7 +793,7 @@ int split_commandline(OptionParseContext *octx, int
Outside of ifilter_bind_ist(), there are no longer any assumptions about
about filter inputs being fed by an InputStream.
---
fftools/ffmpeg_filter.c | 7 +++
1 file changed, 3 insertions(+), 4 deletions(-)
diff --git a/fftools/ffmpeg_filter.c b/fftools/ffmpeg_filter.c
index 9d9762a599..37705
Will be useful in following commits where we will want to create a
decoder before having enough information to open it.
---
fftools/ffmpeg_dec.c | 51 +++-
1 file changed, 27 insertions(+), 24 deletions(-)
diff --git a/fftools/ffmpeg_dec.c b/fftools/ffmpeg_
> -Original Message-
> From: ffmpeg-devel On Behalf Of
> Andreas Rheinhardt
> Sent: czwartek, 29 lutego 2024 10:37
> To: ffmpeg-devel@ffmpeg.org
> Subject: Re: [FFmpeg-devel] [PATCH 1/9] avcodec/libxevd: Remove
> FF_CODEC_CAP_SETS_PKT_DTS cap
>
> Andreas Rheinhardt:
> > This decoder
> -Original Message-
> From: ffmpeg-devel On Behalf Of
> Andreas Rheinhardt
> Sent: wtorek, 27 lutego 2024 20:59
> To: ffmpeg-devel@ffmpeg.org
> Cc: Andreas Rheinhardt
> Subject: [FFmpeg-devel] [PATCH 7/9] avcodec/libxevd: Use
> CODEC_LONG_NAME()
>
> Brings the length of the line do
> -Original Message-
> From: ffmpeg-devel On Behalf Of
> Andreas Rheinhardt
> Sent: wtorek, 27 lutego 2024 20:59
> To: ffmpeg-devel@ffmpeg.org
> Cc: Andreas Rheinhardt
> Subject: [FFmpeg-devel] [PATCH 6/9] avcodec/libxevd: Remove useless
AVClass
>
> This decoder does not have option
> -Original Message-
> From: ffmpeg-devel On Behalf Of
> Andreas Rheinhardt
> Sent: wtorek, 27 lutego 2024 20:59
> To: ffmpeg-devel@ffmpeg.org
> Cc: Andreas Rheinhardt
> Subject: [FFmpeg-devel] [PATCH 2/9] avcodec/libxevd: Set AV_CODEC_CAP_DR1
>
> This decoder uses av_image_copy() t
> -Original Message-
> From: ffmpeg-devel On Behalf Of
> Andreas Rheinhardt
> Sent: wtorek, 27 lutego 2024 20:48
> To: ffmpeg-devel@ffmpeg.org
> Cc: Andreas Rheinhardt
> Subject: [FFmpeg-devel] [PATCH 1/9] avcodec/libxevd: Remove
> FF_CODEC_CAP_SETS_PKT_DTS cap
>
> This decoder imple
---
libavformat/matroskadec.c | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/libavformat/matroskadec.c b/libavformat/matroskadec.c
index 5d3d18a146..6d6a60c552 100644
--- a/libavformat/matroskadec.c
+++ b/libavformat/matroskadec.c
@@ -2036,7 +2036,7 @@ static int
matros
69 matches
Mail list logo