To comply with checkpatch.
CHECK: Lines should not end with a '('
+u8 rtl_mrate_idx_to_arfr_id(
Signed-off-by: Ricardo Silva
---
drivers/staging/rtlwifi/base.h | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/drivers/staging/rtlwifi/base.h b/drivers/stagi
alue as is
in the code makes it more readable that using a combination of BIT
macros.
Signed-off-by: Ricardo Silva
---
drivers/staging/vme/devices/vme_pio2.h | 80 +-
1 file changed, 40 insertions(+), 40 deletions(-)
diff --git a/drivers/staging/vme/devices/vme_pio2
oubts about doing the
change, as this could break userspace. Will gladly do the change if
it's OK.
Please advise if it's ok to go ahead and fix these remaining checks.
Ricardo Silva (5):
staging: media: lirc: Fix whitespace style checks
staging: media: lirc: Fix NULL comparis
Fix all checkpatch reported issues for "CHECK: Prefer
kzalloc(sizeof(*)...) over kzalloc(sizeof(struct )...)".
Other similar case in the code already using recommended style, so make
it all consistent with the recommended practice.
Signed-off-by: Ricardo Silva
---
drivers/staging/
Fix all checkpatch reported issues for "CHECK: Comparison to NULL could
be written...".
Do these comparisons using the recommended coding style and consistent
with other similar cases in the file, which already used the recommended
way.
Signed-off-by: Ricardo Silva
---
drivers/sta
referred around that ''".
All fixed.
* CHECK: "Alignment should match open parenthesis".
All fixed except one on line 1161, left untouched for readability.
Move towards recommended coding style without compromising readability.
Signed-off-by: Ricardo Silva
---
alanced, so put them all
consistent with the recommended style.
Signed-off-by: Ricardo Silva
---
drivers/staging/media/lirc/lirc_zilog.c | 10 ++
1 file changed, 6 insertions(+), 4 deletions(-)
diff --git a/drivers/staging/media/lirc/lirc_zilog.c
b/drivers/staging/media/lirc/lirc_zilog.
Fix all checkpatch reported issues for "CHECK: Prefer using '"%s...",
__func__' to using '', ..."
Use recommended style. Additionally, __func__ was already used in
similar cases throughout the code, so make it all consistent.
Signed-off-by: Ricard
n.
Fixes the following sparse warnings being raised when the structures'
fields are accessed via 'le16_to_cpu()' and 'le32_to_cpu()' functions:
prism2sta.c:1010:33: warning: cast to restricted __le32
prism2sta.c:1015:33: warning: cast to restricted __le16
Signed-off-by
both the little-endian values and
the converted ones.
With this series, no sparse reported issues are left in the 'wlan-ng' driver.
Ricardo Silva (4):
staging: wlan-ng: prism2sta: Use endian types in 'comm_tallies_{16,32}'
structs fields
staging: wlan-ng: prism2sta: Us
The 'usercnt' field from struct 'hfa384x_ps_user_count' represents a
16-bit little-endian integer, so declare it as such to avoid the
following sparse warning when accessing it through the 'le16_to_cpu()'
function:
prism2sta.c:1727:27: warning: cast to restricted
The 'linkstatus' field from struct 'hfa384x_link_status' represents a
16-bit little-endian integer, so declare it as such to avoid the
following sparse warning when accessing it through the 'le16_to_cpu()'
function:
prism2sta.c:1450:31: warning: cast to restricted
ere are no posterior accesses to the (now already
converted) values, otherwise any posterior accesses must consider that
the conversion was already done.
Signed-off-by: Ricardo Silva
---
drivers/staging/wlan-ng/prism2sta.c | 17 -
1 file changed, 12 insertions(+), 5 delet
n case some change is needed.
Would this be acceptable?
Or, shall I just leave the warnings there?
Regards,
Ricardo Silva
> regards,
> dan carpenter
>
>
___
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel
The 'linkstatus' field from struct 'hfa384x_link_status' represents a
16-bit little-endian integer, so declare it as such to avoid the
following sparse warning when accessing it through the 'le16_to_cpu()'
function:
prism2sta.c:1450:31: warning: cast to restricted
o.linkstatus.linkstatus);
> + hw->link_status_new = inf->info.linkstatus.linkstatus;
Ditto.
If I'm wrong about this being incorrect, then I have a patch submitted for
fixing
the sparse warning here that should be discarded. My patch is:
staging: wlan-ng: hfa384x.h: Use endian type in 'hfa384x_link_status'
and changes the linkstatus field to le16.
Regards,
Ricardo Silva
>
> schedule_work(&hw->link_bh);
> }
>
___
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel
16 matches
Mail list logo