>From 0aa52d88bdf6bc22fed80beb175a6dfe420dfabd Mon Sep 17 00:00:00 2001
From: Cong Wang mailto:amw...@redhat.com>>
Date: Wed, 6 Feb 2013 14:40:36 -0800
Subject: [PATCH] datapath: adjust skb_gso_segment() for calling in rx path
skb_gso_segment() is almost always called in tx path,
except for openvs
Signed-off-by: Ed Maste
---
configure.ac | 5 +++--
1 file changed, 3 insertions(+), 2 deletions(-)
diff --git a/configure.ac b/configure.ac
index 1e23289..91f3835 100644
--- a/configure.ac
+++ b/configure.ac
@@ -63,8 +63,9 @@ AC_CHECK_MEMBERS([struct stat.st_mtim.tv_nsec, struct
stat.st_mtime
Introduced in commit 666afb55e84e9118812de81a75655ec9567b7a5b.
Signed-off-by: Ed Maste
---
lib/netdev-bsd.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/lib/netdev-bsd.c b/lib/netdev-bsd.c
index 1301aad..87ac79f 100644
--- a/lib/netdev-bsd.c
+++ b/lib/netdev-bsd.c
@@ -
On 23 May 2013 00:05, Ben Pfaff wrote:
> I have all of these patches ready to apply, after Ed reviewed my changes
> to patch 2.
Apparently I didn't review them well enough; sorry for letting some
minor nits slip through.
___
dev mailing list
dev@openvsw
On Thu, May 23, 2013 at 10:00:57AM -0400, Ed Maste wrote:
>
> Signed-off-by: Ed Maste
Applied to master, thanks.
___
dev mailing list
dev@openvswitch.org
http://openvswitch.org/mailman/listinfo/dev
On Thu, May 23, 2013 at 10:16:16AM -0400, Ed Maste wrote:
> Introduced in commit 666afb55e84e9118812de81a75655ec9567b7a5b.
>
> Signed-off-by: Ed Maste
Applied to master, thanks.
___
dev mailing list
dev@openvswitch.org
http://openvswitch.org/mailman/li
On Thu, May 23, 2013 at 10:38:11AM -0400, Ed Maste wrote:
> On 23 May 2013 00:05, Ben Pfaff wrote:
> > I have all of these patches ready to apply, after Ed reviewed my changes
> > to patch 2.
>
> Apparently I didn't review them well enough; sorry for letting some
> minor nits slip through.
No pr
On May 22, 2013, at 11:33 PM, Ben Pfaff wrote:
> Signed-off-by: Ben Pfaff
Looks good.
___
dev mailing list
dev@openvswitch.org
http://openvswitch.org/mailman/listinfo/dev
On Wed, May 22, 2013 at 6:38 PM, Simon Horman wrote:
> On Tue, May 21, 2013 at 09:07:06AM -0700, Jesse Gross wrote:
>> On Mon, May 20, 2013 at 5:55 PM, Simon Horman wrote:
>> > On Fri, May 17, 2013 at 04:14:56PM -0700, Jesse Gross wrote:
>> >> On Fri, May 17, 2013 at 12:06 AM, Simon Horman wrote
On Thu, May 23, 2013 at 04:28:08PM +, Kyle Mestery (kmestery) wrote:
> On May 22, 2013, at 11:33 PM, Ben Pfaff wrote:
> > Signed-off-by: Ben Pfaff
>
>
> Looks good.
Thanks, applied to master.
___
dev mailing list
dev@openvswitch.org
http://openvs
On Tue, May 21, 2013 at 11:33:58AM -0700, Alex Wang wrote:
> This commit removes the redundant call to flow_extract in dpif_netdev_execute,
> since in the next line, the call to dpif_netdev_flow_from_nlattrs will reset
> the flow variable.
>
> Signed-off-by: Alex Wang
I think that the flow_extra
On Thu, May 23, 2013 at 4:49 AM, Rajahalme, Jarno (NSN - FI/Espoo)
wrote:
> From 0aa52d88bdf6bc22fed80beb175a6dfe420dfabd Mon Sep 17 00:00:00 2001
> From: Cong Wang
> Date: Wed, 6 Feb 2013 14:40:36 -0800
> Subject: [PATCH] datapath: adjust skb_gso_segment() for calling in rx path
>
> skb_gso_segm
On Thu, May 23, 2013 at 10:10:22AM +0900, Simon Horman wrote:
> On Wed, May 15, 2013 at 05:51:15PM +0900, Simon Horman wrote:
> > On Fri, May 03, 2013 at 08:31:58AM +0900, Simon Horman wrote:
> > > On Thu, May 02, 2013 at 12:56:37PM -0700, Ben Pfaff wrote:
> > > > I made the following comment on v1
On Wed, May 22, 2013 at 04:08:05PM +0900, Simon Horman wrote:
> Signed-off-by: Simon Horman
Applied, thanks.
___
dev mailing list
dev@openvswitch.org
http://openvswitch.org/mailman/listinfo/dev
On Wed, May 22, 2013 at 04:08:06PM +0900, Simon Horman wrote:
> This is in preparation for making dp_netdev_action_userspace()
> more generic and passing dp_netdev_output_userspace() as a callback.
> In this case it makes sense to decode userdata in generic code.
>
> Signed-off-by: Simon Horman
Let's use a better name for the new files, say odp-execute.[ch], and
use an appropriately prefixed name for the function,
e.g. odp_actions_execute(). It would also be acceptable to break
action-related code out of odp-util.[ch] and put all of it in a new
odp-actions.[ch].
Some more comments:
On
On Wed, May 22, 2013 at 04:08:08PM +0900, Simon Horman wrote:
> +set_tunnel_action(const struct nlattr *a, struct flow_tnl *tun_key)
> +{
> +enum odp_key_fitness fitness = tun_key_from_attr(a, tun_key);
> +
> +memset(&tun_key, 0, sizeof tun_key);
> +ovs_assert(fitness != ODP_FIT_ERROR);
On Wed, May 22, 2013 at 04:08:09PM +0900, Simon Horman wrote:
> Recirculation is a technique to allow a frame to re-enter
> frame processing. This is intended to be used after actions
> have been applied to the frame with modify the frame in
> some way that makes it possible for richer processing t
On Wed, May 22, 2013 at 04:08:10PM +0900, Simon Horman wrote:
> diff --git a/lib/execute-actions.c b/lib/execute-actions.c
> index 5e05dc5..1036ede 100644
> --- a/lib/execute-actions.c
> +++ b/lib/execute-actions.c
> @@ -170,7 +170,8 @@ execute_actions(void *dp, struct ofpbuf *packet, struct
> flo
On Thu, May 23, 2013 at 09:41:44AM +0900, Simon Horman wrote:
> For reference I have made it available, applied on top of its dependencies
> at:
>
> git://github.com/horms/openvswitch.git devel/mpls-multi-push-and-pop-v2
Since there are several of them, I think I'd rather wait for the
dependencie
Hey Ben,
Just found, I think there are cases that a whole packet is wanted.
In function "dp_netdev_execute_actions()", there are calls to functions
like "push_mpls()" and "pop__mpls()", which requires the packet header
pointers (e.g. l2_5, l2 ) in "struct ofpbuf *" be initialized. I think the
cal
On Thu, May 23, 2013 at 11:20 AM, Ben Pfaff wrote:
> On Thu, May 23, 2013 at 09:41:44AM +0900, Simon Horman wrote:
>> For reference I have made it available, applied on top of its dependencies
>> at:
>>
>> git://github.com/horms/openvswitch.git devel/mpls-multi-push-and-pop-v2
>
> Since there are
Following patch restructures ovs tunneling and gre vport
implementation to make ovs tunneling more in sync with
upstream kernel tunneling. Doing this tunneling code is
simplified as most of protocol processing on send and
recv is pushed to kernel tunneling. For external ovs
module the code is mov
Signed-off-by: Ben Pfaff
---
vswitchd/ovs-vswitchd.8.in |4 +++-
1 files changed, 3 insertions(+), 1 deletions(-)
diff --git a/vswitchd/ovs-vswitchd.8.in b/vswitchd/ovs-vswitchd.8.in
index 43c5d24..1606b87 100644
--- a/vswitchd/ovs-vswitchd.8.in
+++ b/vswitchd/ovs-vswitchd.8.in
@@ -227,7 +22
Signed-off-by: Ben Pfaff
---
OPENFLOW-1.1+ |2 --
vswitchd/ovs-vswitchd.8.in | 20
2 files changed, 20 insertions(+), 2 deletions(-)
diff --git a/OPENFLOW-1.1+ b/OPENFLOW-1.1+
index b6a4222..975f0d4 100644
--- a/OPENFLOW-1.1+
+++ b/OPENFLOW-1.1+
@@ -70,8 +
OpenFlow 1.2 and later define a value of 65535 (OFPCML_NO_BUFFER) for
the max_len field in an output action to mean that the switch should send
the entire packet without buffering it. Open vSwitch never buffers packets
sent via an output action, so it trivially satisfies this requirement.
Signed-
looks good to me,
On Thu, May 23, 2013 at 3:35 PM, Ben Pfaff wrote:
> Signed-off-by: Ben Pfaff
> ---
> vswitchd/ovs-vswitchd.8.in |4 +++-
> 1 files changed, 3 insertions(+), 1 deletions(-)
>
> diff --git a/vswitchd/ovs-vswitchd.8.in b/vswitchd/ovs-vswitchd.8.in
> index 43c5d24..1606b87 1
There are possibilities when records disappear underneath ovs-xapi-sync.
In this particular case, when VLAN network was deleted, the corresponding
record in bridge's external_ids:xs_network_ids column was not deleted by
xenserver. In situations like that handle the exceptions cleanly.
Bug #17390.
Signed-off-by: Ben Pfaff
---
OPENFLOW-1.1+ |3 ++-
lib/ofp-print.c|6 ++
lib/ofp-util.c | 17 +++--
lib/ofp-util.h |2 ++
ofproto/ofproto-provider.h |1 +
ofproto/ofproto.c | 17 +++--
tests/
On Thu, May 23, 2013 at 04:28:30PM -0700, Gurucharan Shetty wrote:
> There are possibilities when records disappear underneath ovs-xapi-sync.
> In this particular case, when VLAN network was deleted, the corresponding
> record in bridge's external_ids:xs_network_ids column was not deleted by
> xens
Before this patch, datapath keys with ODP_FIT_TO_LITTLE, would be
assigned subfacets and installed in the kernel with a SLOW_MATCH
slow path reason. This is problematic, because these flow keys
can't be reliable converted into a 'struct flow' thus breaking a
fundamental assumption of ofproto-dpif.
Used in future commits.
Signed-off-by: Ethan Jackson
---
lib/ofpbuf.h |6 ++
1 file changed, 6 insertions(+)
diff --git a/lib/ofpbuf.h b/lib/ofpbuf.h
index 8b03c7e..0c12162 100644
--- a/lib/ofpbuf.h
+++ b/lib/ofpbuf.h
@@ -107,6 +107,12 @@ static inline struct ofpbuf *ofpbuf_from_list(co
Before this patch, when in band control was enabled, every DHCP
packet had to be sent to userspace to calculate it's actions.
Those DHCP packets intended for the local port would have a special
action added to ensure they actually make it there. This
unnecessarily complicates the code, so this pat
Upon close inspection, it appears that it's not possible for
actions to differ between subfacets belonging to a given facet.
Given this fact, it makes sense to move datapath actions from
subfacets to their parent facets. It's both conceptually more
straightforward, and necessary for future threadi
This patch changes the name of action_xlate_ctx to xlate_ctx. Aside
from being a bit snappier, it fits more cleanly with structures
added in future patches.
Signed-off-by: Ethan Jackson
---
ofproto/ofproto-dpif.c | 186
1 file changed, 92 inserti
> Would you describe it a little? It's a big patch so the fix isn't
> necessarily obvious (I haven't read on yet). Is it something that we
> should break out separately so that we can backport it?
It was a bug introduced in this patch. Basically facet_create()
didn't set may_learn to true. I r
Invoke the function to reconfigure BFD when a port/interface
is deleted.
Signed-off-by: Pavithra Ramesh
---
lib/bfd.c |2 +-
ofproto/ofproto-dpif.c |2 ++
2 files changed, 3 insertions(+), 1 deletions(-)
diff --git a/lib/bfd.c b/lib/bfd.c
index 95dad2d..48c0e38 100644
---
From: Simon Horman
Date: Wed, 22 May 2013 15:57:15 +0900
> @@ -509,9 +509,9 @@ struct sk_buff {
> __u32 reserved_tailroom;
> };
>
> - sk_buff_data_t inner_transport_header;
> - sk_buff_data_t inner_network_header;
> - sk_buff_data_t
On May 23, 2013, at 5:51 PM, Ben Pfaff wrote:
> Signed-off-by: Ben Pfaff
Looks fine to me Ben, the wording is quite clear here.
___
dev mailing list
dev@openvswitch.org
http://openvswitch.org/mailman/listinfo/dev
On May 23, 2013, at 6:08 PM, Ben Pfaff wrote:
> OpenFlow 1.2 and later define a value of 65535 (OFPCML_NO_BUFFER) for
> the max_len field in an output action to mean that the switch should send
> the entire packet without buffering it. Open vSwitch never buffers packets
> sent via an output actio
Allow datapath to recognize and extract MPLS labels into flow keys
and execute actions which push, pop, and set labels on packets.
Based heavily on work by Leo Alterman and Ravi K.
Cc: Ravi K
Cc: Leo Alterman
Reviewed-by: Isaku Yamahata
Signed-off-by: Simon Horman
---
This is the remaining
On May 23, 2013, at 20:28 , ext Jesse Gross wrote:
> The upstream commit is not really right - the check should depend on
> the origin of the packet, not the location in the networking stack
> processing it. Most of the time these are somewhat the same but
> obviously when bridging, received packe
On May 23, 2013, at 21:21 , ext Alex Wang wrote:
Hey Ben,
Just found, I think there are cases that a whole packet is wanted.
In function "dp_netdev_execute_actions()", there are calls to functions like
"push_mpls()" and "pop__mpls()", which requires the packet header pointers
(e.g. l2_5, l2 )
On Thu, May 23, 2013 at 11:10:37AM -0700, Ben Pfaff wrote:
> On Wed, May 22, 2013 at 04:08:10PM +0900, Simon Horman wrote:
> > diff --git a/lib/execute-actions.c b/lib/execute-actions.c
> > index 5e05dc5..1036ede 100644
> > --- a/lib/execute-actions.c
> > +++ b/lib/execute-actions.c
> > @@ -170,7 +
On Thu, May 23, 2013 at 11:03:50AM -0700, Ben Pfaff wrote:
> On Wed, May 22, 2013 at 04:08:08PM +0900, Simon Horman wrote:
> > +set_tunnel_action(const struct nlattr *a, struct flow_tnl *tun_key)
> > +{
> > +enum odp_key_fitness fitness = tun_key_from_attr(a, tun_key);
> > +
> > +memset(&tu
On Thu, May 23, 2013 at 10:58:46AM -0700, Ben Pfaff wrote:
> Let's use a better name for the new files, say odp-execute.[ch], and
> use an appropriately prefixed name for the function,
> e.g. odp_actions_execute().
Thanks, I have renamed the files as odp-execute.[ch],
and prefixed the functions wi
Pravin,
Please find some review comments below,
Jarno
On May 23, 2013, at 23:01 , ext Pravin B Shelar wrote:
...
> diff --git a/datapath/linux/compat/gre.c b/datapath/linux/compat/gre.c
> new file mode 100644
> index 000..c352ff8
> --- /dev/null
> +++ b/datapath/linux/compat/gre.c
> @@ -0,
Ben,
Tested, works, and looks good. I can now see port duration in "ovs-ofctl -O
OpenFlow13 dump-ports br0" :-)
Jarno
On May 24, 2013, at 2:56 , ext Ben Pfaff wrote:
> Signed-off-by: Ben Pfaff
> ---
> OPENFLOW-1.1+ |3 ++-
> lib/ofp-print.c|6 ++
> lib/ofp
In the case where a non-MPLS packet is received and an MPLS stack is
added it may well be the case that the original skb is GSO but the
NIC used for transmit does not support GSO of MPLS packets.
The aim of this short series is to provide GSO in software for MPLS packets
whose skbs are GSO.
Chang
In order to mitigate ongoing incresase in the size of struct skbuff
use 16 bit integer offsets rather than pointers for inner_*_headers.
This appears to reduce the size of struct skbuff from 0xd0 to 0xc0
bytes on x86_64 with the following all unset.
CONFIG_XFRM
CONFIG_NF_CONNTRACK
In the case where a non-MPLS packet is received and an MPLS stack is
added it may well be the case that the original skb is GSO but the
NIC used for transmit does not support GSO of MPLS packets.
The aim of this code is to provide GSO in software for MPLS packets
whose skbs are GSO.
SKB Usage:
W
51 matches
Mail list logo