Thanks, applied to master.
On 5 June 2014 11:48, Alex Wang wrote:
> Looks good to me,
>
>
> Acked-by: Alex Wang
>
>
> On Wed, Jun 4, 2014 at 3:08 PM, Joe Stringer
> wrote:
>
>> One of the reasons that xlate_cache was introduced was to ensure that
>> statistics were attributed to the correct r
Thanks, applied to master.
On 5 June 2014 06:26, Ethan Jackson wrote:
> Acked
>
>
> On Tuesday, June 3, 2014, Joe Stringer wrote:
>
>> This patch refactors the code around ukey creation and lookup to
>> simplify the code for callers. A new function ukey_acquire() combines
>> these functions an
Thanks, I applied this to master.
On 4 June 2014 15:26, Simon Horman wrote:
> On Wed, Jun 04, 2014 at 02:54:27PM +1200, Joe Stringer wrote:
> > It's unclear why these tests are named "ofproto-if..." unlike all of the
> > other ofproto-dpif tests. Rename them to be more consistent.
> >
> > Signe
I accidentally sent the wrong version with a typo in the subject and small
wording problems below:
> On Jun 4, 2014, at 5:42 PM, Jarno Rajahalme wrote:
>
> When reaching the end
leaf
> of a prefix trie, we checked one bit off the end
> to the
of the
> intended data. However, since the trie
When reaching the end of a prefix trie, we checked one bit off the end
to the intended data. However, since the trie node in that case has
NULLs for both edge links, this did not result in incorrect
functionality.
Signed-off-by: Jarno Rajahalme
---
lib/classifier.c | 28 +-
Signed-off-by: Pravin B Shelar
---
.../linux/compat/include/linux/netdev_features.h | 20
datapath/vport-internal_dev.c| 5 -
2 files changed, 24 insertions(+), 1 deletion(-)
diff --git a/datapath/linux/compat/include/linux/netdev_features.h
The dp_hash and recirc_id fields weren't being initialized.
Found by valgrind.
Signed-off-by: Ben Pfaff
---
ofproto/ofproto-dpif.c | 14 +++---
1 file changed, 7 insertions(+), 7 deletions(-)
diff --git a/ofproto/ofproto-dpif.c b/ofproto/ofproto-dpif.c
index 22ba14e..2984e93 100644
-
Otherwise the indeterminate 'wevent' could frustrate poll_fd_wait_at()'s
attempt to merge "poll_node"s for the same fd.
Signed-off-by: Ben Pfaff
---
lib/stream-ssl.c |2 ++
1 file changed, 2 insertions(+)
diff --git a/lib/stream-ssl.c b/lib/stream-ssl.c
index a130aec..4a63d19 100644
--- a/l
'wevent' isn't actually used on non-Windows systems, but poll_fd_wait_at()
and find_poll_node() treat events with different 'wevent' as different, so
it seems better to make sure that 'wevent' doesn't matter.
Alternatively, one could ovs_assert(!wevent). I guess that would catch
a caller accident
Commit 87400a3d4cc4a (dpif-netdev: Fix use-after-free in port_unref().)
fixed one use-after-free in the common case of port_unref(). However,
there was another, similar case: if port->netdev has no rxqs, then
the netdev_close() causes port->netdev to be destroyed and thus the
following call to net
flow_compose_l4() can cause 'b' to be reallocated, thus the network header
pointer needs to be refreshed afterward.
Found by valgrind in the IPv6 case. I updated the IPv4 case too just in
case, and for consistency.
Signed-off-by: Ben Pfaff
---
lib/flow.c |2 ++
1 file changed, 2 insertions
Thanks for the review. Pushed to master and branch-2.3
On Tue, Jun 3, 2014 at 11:30 PM, YAMAMOTO Takashi
wrote:
>> In case DP_HASH and RECIRC actions need to be executed in slow path,
>> current implementation simply don't handle them -- vswitchd simply
>> crashes. This patch fixes them by supply
Looks good to me,
Acked-by: Alex Wang
On Wed, Jun 4, 2014 at 3:08 PM, Joe Stringer wrote:
> One of the reasons that xlate_cache was introduced was to ensure that
> statistics were attributed to the correct rules and interfaces according
> to the flow that was installed into the datapath, rat
No, I figured that we needed to fix branch-2.3 whether or not master
was correct.
On Wed, Jun 04, 2014 at 04:33:35PM -0700, Jarno Rajahalme wrote:
> I?ll have a look. Did you already check master?
>
> Jarno
>
> On Jun 4, 2014, at 4:15 PM, Ben Pfaff wrote:
>
> > Valgrind reports the following
I’ll have a look. Did you already check master?
Jarno
On Jun 4, 2014, at 4:15 PM, Ben Pfaff wrote:
> Valgrind reports the following, just now, running tests 71, 72, and 73
> on branch-2.3. Can you take a look?
>
> ==16404== Use of uninitialised value of size 4
> ==16404==at 0x8058654: t
Use CRC32 intrinsics for hash computations when building for
X86_64 with SSE4_2.
Signed-off-by: Jarno Rajahalme
---
lib/hash.c| 15 -
lib/hash.h| 167 -
tests/test-hash.c | 11 +++-
3 files changed, 163 insertions(+), 3
Use generic names hash_add() and hash_finish() instead of mhash_*
equivalents. This makes future changes to hash implentations more
localized.
Signed-off-by: Jarno Rajahalme
---
lib/classifier.c | 24
lib/cmap.c|2 +-
lib/flow.c| 24
In some cases an pop MPLS action changes a packet to be a non-mpls packet.
In this case subsequent any L3+ actions require access to portions
of the packet which were not decoded as they were opaque when the
packet was MPLS. Allow such actions to be translated by
first recirculating the packet.
Si
This is in preparation for using the same helper as part of support
for using recirculation in conjunction series of actions including
with MPLS actions that are currently not able to be translated.
In that scenario the idle timeout will be used to expire internal
rules that are added to handle re
The motivation of this series is to allow some sequences of actions
that include MPLS actions to be performed using recirculation.
Sequences of actions that could not previously be handled.
For example pop_mpls:0x0800,dec_ttl.
This uses recirculation after the pop_mpls action to allow access to L
With recirculation in place this should be safe.
Signed-off-by: Simon Horman
---
v2 - v6
* No change
---
lib/ofp-actions.c | 6 --
1 file changed, 6 deletions(-)
diff --git a/lib/ofp-actions.c b/lib/ofp-actions.c
index cc1f9a0..119677e 100644
--- a/lib/ofp-actions.c
+++ b/lib/ofp-actions.c
This is to allow a recirculation id to be associated with a rule
in the case that its actions cause recirculation.
In such a case if the recirc_id field is non-zero then that value should be
used, otherwise a value should be obtained using
ofproto_dpif_alloc_recirc_id and saved in recirc_id field.
This is in preparation for using this value
in ofproto-dpif-xlate.c when composing recirculation
actions added as a result of processing (MPLS) actions.
Signed-off-by: Simon Horman
---
v3 - v6
* No change
v2
* First post
---
ofproto/bond.c | 1 -
ofproto/ofproto-dpif.h | 3 +++
2 files
On Tue, Jun 3, 2014 at 6:01 PM, Simon Horman wrote:
> On Tue, Jun 03, 2014 at 03:40:27PM -0700, Jesse Gross wrote:
>> On Mon, Jun 2, 2014 at 9:04 PM, Simon Horman wrote:
>> > Hi Jesse,
>> >
>> > thanks for your feedback.
>> >
>> > On Mon, Jun 02, 2014 at 05:58:10PM -0700, Jesse Gross wrote:
>> >>
Valgrind reports the following, just now, running tests 71, 72, and 73
on branch-2.3. Can you take a look?
==16404== Use of uninitialised value of size 4
==16404==at 0x8058654: trie_next_node (classifier.c:2124)
==16404==by 0x80586F9: trie_lookup_value (classifier.c:2140)
==16404==by
On Wed, Jun 04, 2014 at 09:37:22AM -0700, Jarno Rajahalme wrote:
> Pushed, thanks for the reminder,
Thanks!
___
dev mailing list
dev@openvswitch.org
http://openvswitch.org/mailman/listinfo/dev
On Wed, Jun 4, 2014 at 1:49 PM, Ryan Wilson wrote:
> When a bridge of datatype type netdev receives a packet, it copies the
> packet from the NIC to a buffer in userspace. Currently, when making
> an upcall, the packet is again copied to the upcall's buffer. However,
> this extra copy is not neces
On Wed, Jun 4, 2014 at 3:05 PM, Daniele Di Proietto
wrote:
> This patch makes sure that the tx and rx queues are allocated on the NUMA
> socket
> chosen at device initalization time, instead of the NUMA socket 0.
>
> Signed-off-by: Daniele Di Proietto
Pushed to master.
Thanks,
Pravin.
___
On Tue, Jun 3, 2014 at 5:10 PM, Daniele Di Proietto
wrote:
> As per netdev-provider interface, netdev_dpdk_rxq_recv should receive at most
> NETDEV_MAX_RX_BATCH.
>
> Signed-off-by: Daniele Di Proietto
Looks good, Pushed to master.
Thanks,
Pravin.
___
This patch makes sure that the tx and rx queues are allocated on the NUMA socket
chosen at device initalization time, instead of the NUMA socket 0.
Signed-off-by: Daniele Di Proietto
---
lib/netdev-dpdk.c | 7 ---
1 file changed, 4 insertions(+), 3 deletions(-)
diff --git a/lib/netdev-dpdk.
One of the reasons that xlate_cache was introduced was to ensure that
statistics were attributed to the correct rules and interfaces according
to the flow that was installed into the datapath, rather than according
to the current state of the flow table.
This patch makes the revalidators use the x
I discussed this change with Alex, and I think there's a flaw with my
reasoning behind whether to re-create the xcache or not.
Consider an openflow pipeline with one rule that has actions A and B.
- We install a datapath flow to do A and B.
- Replace the rule in the pipeline with two rules, one th
udpif->dump_seq already exists in master, and is changed by the leader
revalidator thread.
On 5 June 2014 06:29, Ethan Jackson wrote:
> Maybe I'm missing something. But I'm not seeing where the dump seq is
> incremented
>
>
> On Tuesday, June 3, 2014, Joe Stringer wrote:
>
>> Rather than setti
On Wed, Jun 4, 2014 at 12:00 PM, Jarno Rajahalme wrote:
> Add 2 second sleep before time stop to allow internal ports to
> reconnect in case the initial connection attempt failed.
>
> Bond tests sometimes persistently fail without these delays.
>
> Signed-off-by: Jarno Rajahalme
Adding delay is n
On Wed, Jun 4, 2014 at 2:48 AM, Tahhan, Maryam wrote:
> Hi Pravin
> Are you suggesting adding the dpdk-vhost interface code into netdev-dpdk.c,
> defining a common netdev_class and working from there (similar to
> netdev-linux and tap devices etc.)?
> It does break up modularity somewhat in that
When a bridge of datatype type netdev receives a packet, it copies the
packet from the NIC to a buffer in userspace. Currently, when making
an upcall, the packet is again copied to the upcall's buffer. However,
this extra copy is not necessary when the datapath exists in userspace
as the upcall can
When deleting a mask from the mask array, we always move the last entry
into its current location. Another approach can be NULL in its current
place, and periodically compact it.
The approach taken by this patch is more efficient during run time.
During look up, fast path packet don't have to skip
Signed-off-by: Andy Zhou
---
datapath/flow_table.c | 77 +--
1 file changed, 44 insertions(+), 33 deletions(-)
diff --git a/datapath/flow_table.c b/datapath/flow_table.c
index 58a25c7..97b3283 100644
--- a/datapath/flow_table.c
+++ b/datapath/flow_
Can you make subject shorter?
On Wed, Jun 4, 2014 at 11:00 AM, Ryan Wilson wrote:
> When a bridge of datatype type netdev receives a packet, it copies the
> packet from the NIC to a buffer in userspace. Currently, when making
> an upcall, the packet is again copied to the upcall's buffer. However
Add 2 second sleep before time stop to allow internal ports to
reconnect in case the initial connection attempt failed.
Bond tests sometimes persistently fail without these delays.
Signed-off-by: Jarno Rajahalme
---
tests/ofproto-dpif.at |6 +++---
1 file changed, 3 insertions(+), 3 deletio
No, for the same reason. Tunnel information is metadata so you can't
construct a standalone packet that contains that.
On Tuesday, June 3, 2014, Wenyu Zhang wrote:
> Thanks for your help.
>
> And how about "ovs-appctl ofproto/trace ovs-dummy" command? The manual
> about ovs-vswitchd says that it
Acked
On Tuesday, June 3, 2014, Joe Stringer wrote:
> One of the reasons that xlate_cache was introduced was to ensure that
> statistics were attributed to the correct rules and interfaces according
> to the flow that was installed into the datapath, rather than according
> to the current state
Maybe I'm missing something. But I'm not seeing where the dump seq is
incremented
On Tuesday, June 3, 2014, Joe Stringer wrote:
> Rather than setting and resetting the 'mark' field in the ukey, this
> patch introduces a seq to track whether a flow has been seen during the
> most recent dump. Thi
Acked
On Tuesday, June 3, 2014, Joe Stringer wrote:
> This patch refactors the code around ukey creation and lookup to
> simplify the code for callers. A new function ukey_acquire() combines
> these functions and attempts to acquire a lock on the ukey. Failure to
> acquire a lock on the ukey is
Hey Jarno,
I addressed all the comments in this and your other email (also the
offline discussion about BUILD_ASSERT_DECL) in the following patch v6
(same as v5 but an updated commit message).
Cheers,
Ryan
On 6/3/14 6:41 PM, "Jarno Rajahalme" wrote:
>
>> On Jun 3, 2014, at 6:22 PM, Ryan Wilso
When a bridge of datatype type netdev receives a packet, it copies the
packet from the NIC to a buffer in userspace. Currently, when making
an upcall, the packet is again copied to the upcall's buffer. However,
this extra copy is not necessary when the datapath exists in userspace
as the upcall can
When a bridge of datatype type netdev receives a packet, it copies the
packet from the NIC to a buffer in userspace. Currently, when making
an upcall, the packet is again copied to the upcall's buffer. However,
this extra copy is not necessary when the datapath exists in userspace
as the upcall can
> Thanks Yamamoto! Feel free to push this if you think its ready.
applied. thanks.
YAMAMOTO Takashi
___
dev mailing list
dev@openvswitch.org
http://openvswitch.org/mailman/listinfo/dev
> On Wed, Jun 04, 2014 at 03:22:36PM +0900, YAMAMOTO Takashi wrote:
>> On some platforms including NetBSD,
>> GNU make is usually installed as "gmake".
>>
>> Signed-off-by: YAMAMOTO Takashi
>
> Acked-by: Ben Pfaff
applied. thanks.
YAMAMOTO Takashi
On Wed, Jun 04, 2014 at 03:22:36PM +0900, YAMAMOTO Takashi wrote:
> On some platforms including NetBSD,
> GNU make is usually installed as "gmake".
>
> Signed-off-by: YAMAMOTO Takashi
Acked-by: Ben Pfaff
___
dev mailing list
dev@openvswitch.org
http:/
Pushed, thanks.
Jarno
On Jun 3, 2014, at 11:38 PM, YAMAMOTO Takashi wrote:
>> OVS is slow when compiled with pthreads atomics. Add a generic note
>> in INSTALL, with a reference to lib/ovs-atomic.h, where a new comment
>> provides additional detail.
>>
>> Signed-off-by: Jarno Rajahalme
>
Pushed, thanks for the reminder,
Jarno
On Jun 4, 2014, at 8:37 AM, Jarno Rajahalme wrote:
> Acked-by: Jarno Rajahalme
>
> Will push in a moment.
>
> Jarno
>
>> On Jun 4, 2014, at 1:56 AM, Simon Horman wrote:
>>
>> In the case that an flow for an IP packet has an mpls_push action applie
On Jun 3, 2014, at 6:05 PM, Ethan Jackson wrote:
> Couple of questions.
>
> First, this patch adds a bit of code which extends beyond 79 characters.
>
Sorry, fixed those.
> dp_netdev_input() does this rather interesting stuff with two keys
> that mfk switches between. This is definitely not
Thanks Yamamoto! Feel free to push this if you think its ready.
Ryan
From: YAMAMOTO Takashi
Sent: Tuesday, June 3, 2014 7:20 PM
To: wr...@nicira.com
Cc: dev@openvswitch.org
Subject: Re: [ovs-dev] [PATCH v2] timeval: Add monotonic time functionality for
Ne
Acked-by: Jarno Rajahalme
Will push in a moment.
Jarno
> On Jun 4, 2014, at 1:56 AM, Simon Horman wrote:
>
> In the case that an flow for an IP packet has an mpls_push action applied
> the L3 and L4 portions of the flow will be cleared in flow_push_mpls().
>
> Without this change commit_se
On 06/04/14 at 08:53am, Simon Horman wrote:
> If an MPLS packet requires segmentation then use mpls_features
> to determine if the software implementation should be used.
>
> As no driver advertises MPLS GSO segmentation this will always be
> the case.
>
> I had not noticed that this was necessar
Hi Pravin
Are you suggesting adding the dpdk-vhost interface code into netdev-dpdk.c,
defining a common netdev_class and working from there (similar to netdev-linux
and tap devices etc.)?
It does break up modularity somewhat in that vhost ports are logical and
distinct from dpdk ports, but it ca
In the case that an flow for an IP packet has an mpls_push action applied
the L3 and L4 portions of the flow will be cleared in flow_push_mpls().
Without this change commit_set_port_action() will set the tp_src and tp_dst
mask for the flow to all-ones because the base and flow port values no
longe
58 matches
Mail list logo