On Thu, Jul 11, 2013 at 06:26:32PM -0700, Jesse Gross wrote:
> On Wed, Jul 10, 2013 at 5:16 PM, Simon Horman wrote:
> > On Mon, Jul 08, 2013 at 11:51:18PM -0700, Jesse Gross wrote:
> >> On Tue, Jul 2, 2013 at 6:31 PM, Simon Horman wrote:
> >> > On Tue, Jul 02, 2013 at 02:59:51PM -0700, Jesse Gros
On Wed, Jul 10, 2013 at 5:16 PM, Simon Horman wrote:
> On Mon, Jul 08, 2013 at 11:51:18PM -0700, Jesse Gross wrote:
>> On Tue, Jul 2, 2013 at 6:31 PM, Simon Horman wrote:
>> > On Tue, Jul 02, 2013 at 02:59:51PM -0700, Jesse Gross wrote:
>> >> On Mon, Jul 1, 2013 at 9:16 PM, Simon Horman wrote:
>
When there is no incoming data traffic in the tunnel for a period,
BFD decay allows the bfd session to increase the min_rx. This is
helpful in that usually some tunnels are rarely used. And cpu
consumption can be reduced by processing fewer bfd control packets.
Signed-off-by: Alex Wang
---
lib/b
This commit adds a new boolean option "forwarding_if_rx" to bfd.
When forwarding_if_rx is true and BFD state is down, the forwarding
field in "ovs-appctl bfd/show" output will still be true as long as
there are incoming packets received. This is for indicating the
tunnel liveness when the tunnel i
> We do not have any known usecases from XenServer customers where this is
> needed. We also do not expect a customer to explicitly configure this way.
> However, we want to avoid the case of the customer having configured this
> way with proper connectivity that breaks on upgrade.
I really don't
On Thu, Jul 11, 2013 at 09:40:57AM -0400, Ed Maste wrote:
> On 10 July 2013 19:04, Ben Pfaff wrote:
> > Signed-off-by: Ben Pfaff
>
> > +void
> > +set_subprogram_name(const char *name)
> > +{
> > +free(subprogram_name_set(xstrdup(name)));
> > +}
>
> How about calling (through appropriate abs
On Thu, Jul 11, 2013 at 10:00:21AM -0400, Ed Maste wrote:
> On 10 July 2013 19:03, Ben Pfaff wrote:
> > The worker process implementation isn't thread-safe and, once OVS
> > itself is threaded, it doesn't make much sense to have a worker
> > process anyway.
> >
> > Signed-off-by: Ben Pfaff
>
> A
On Thu, Jul 11, 2013 at 09:28:10AM -0400, Ed Maste wrote:
> On 10 July 2013 19:03, Ben Pfaff wrote:
> > Signed-off-by: Ben Pfaff
>
> Acked-by: Ed Maste
Thanks, applied to master.
___
dev mailing list
dev@openvswitch.org
http://openvswitch.org/mailman
On Thu, Jul 11, 2013 at 09:45:21AM -0400, Ed Maste wrote:
> On 10 July 2013 19:03, Ben Pfaff wrote:
> > Signed-off-by: Ben Pfaff
>
> Acked-by: Ed Maste
Thanks. I applied this to master.
___
dev mailing list
dev@openvswitch.org
http://openvswitch.org
On Thu, Jul 11, 2013 at 09:31:07AM -0400, Ed Maste wrote:
> On 10 July 2013 19:03, Ben Pfaff wrote:
> > The backtrace feature of timeval is useful because it provides a "poor
> > man's profile" view of Open vSwitch. But it is not likely to be useful in
> > a multithreaded process, because signal
On Thu, Jul 11, 2013 at 09:43:44AM -0400, Ed Maste wrote:
> On 10 July 2013 19:03, Ben Pfaff wrote:
> > Signed-off-by: Ben Pfaff
>
> Acked-by: Ed Maste
Thanks, applied to master.
___
dev mailing list
dev@openvswitch.org
http://openvswitch.org/mailman
On Thu, Jul 11, 2013 at 09:13:15AM -0400, Ed Maste wrote:
> On 10 July 2013 19:03, Ben Pfaff wrote:
> > (The usual reason for ppoll() is to ensure atomicity of changing the signal
> > mask and blocking, but time_poll() does not need atomicity. Therefore,
> > even a userspace emulated ppoll() woul
This patch implements an aggregator in the IPFIX exporter, to reduce
the volume of IPFIX messages sent.
There might be issues with multithreading, since the flow caches are
accessed both by upcalls and by the main run loop. I had no problems
in my (very small scale) tests. Should I add locking t
Implement a per-exporter flow cache with active timeout expiration.
Add columns "cache_active_timeout" and "cache_max_flows" into table
"IPFIX" to configure each cache.
Add per-flow elements "octetDeltaSumOfSquares",
"minimumIpTotalLength", and "maximumIpTotalLength" to replace
"ethernetTotalLengt
On Thu, Jul 11, 2013 at 09:17:50AM -0400, Ed Maste wrote:
> On 10 July 2013 19:03, Ben Pfaff wrote:
> > Signed-off-by: Ben Pfaff
> > ---
> > lib/fatal-signal.c |5 -
>
> Acked-by: Ed Maste
Thanks, applied to master.
___
dev mailing list
dev@o
Contact me regarding Aldrich.
Fu.
___
dev mailing list
dev@openvswitch.org
http://openvswitch.org/mailman/listinfo/dev
On Thu, Jul 11, 2013 at 11:42 AM, Pravin Shelar wrote:
> On Tue, Jul 9, 2013 at 2:13 PM, Jesse Gross wrote:
>> Reported-by: Kris zhang
>> Signed-off-by: Jesse Gross
> Acked-by: Pravin B Shelar
Thanks, applied to master and I'll push appropriate versions to the
other affected branches.
X-CudaM
On Thu, Jul 11, 2013 at 12:25 PM, Pravin Shelar wrote:
> On Wed, Jul 10, 2013 at 3:52 PM, Jesse Gross wrote:
>> On Mon, Jul 1, 2013 at 3:28 PM, Pravin B Shelar wrote:
>>> diff --git a/datapath/linux/compat/net_namespace.c
>>> b/datapath/linux/compat/net_namespace.c
>>> index 4e8a891..39b4a28 10
On Wed, Jul 10, 2013 at 3:52 PM, Jesse Gross wrote:
> On Mon, Jul 1, 2013 at 3:28 PM, Pravin B Shelar wrote:
>> diff --git a/datapath/linux/compat/net_namespace.c
>> b/datapath/linux/compat/net_namespace.c
>> index 4e8a891..39b4a28 100644
>> --- a/datapath/linux/compat/net_namespace.c
>> +++ b/d
On Tue, Jul 9, 2013 at 2:13 PM, Jesse Gross wrote:
> Reported-by: Kris zhang
> Signed-off-by: Jesse Gross
Acked-by: Pravin B Shelar
> ---
> FAQ | 3 +++
> 1 file changed, 3 insertions(+)
>
> diff --git a/FAQ b/FAQ
> index 0210477..6b5d8da 100644
> --- a/FAQ
> +++ b/FAQ
> @@ -146,6 +146,9 @@ A
These seem slightly nicer than e.g. htons(UINT16_MAX).
Signed-off-by: Ben Pfaff
---
include/openvswitch/types.h |4
lib/learn.c |2 +-
lib/match.c | 30 +++---
lib/meta-flow.c | 13 ++---
lib/nx-match.c
Signed-off-by: Ben Pfaff
---
lib/classifier.c |3 +-
lib/flow.c | 126 ++
lib/flow.h | 10 +++--
lib/match.c | 31 +-
lib/match.h | 18 +---
5 files changed, 147 insertions(+), 41 deletions(-)
di
We have a controller that puts many rules with different metadata values
into the flow table, where metadata is used (by "resubmit"s) to distinguish
stages in a pipeline. Thus, any given flow only needs to be hashed into
classifier "cls_table"s that contain a match for the flow's metadata value.
T
v1->v2: rebase
v2->v3: rebase
Reposting to get performance numbers. Some review comments from v1
have not yet been addressed and won't be worth addressing unless
the performance numbers are good.
Ben Pfaff (3):
openvswitch/types.h: New macros OVS_BE16_MAX, OVS_BE32_MAX,
OVS_BE64_MAX.
ma
On Thu, Jul 11, 2013 at 10:43 AM, Ben Pfaff wrote:
> On Thu, Jul 11, 2013 at 10:39:38AM -0700, Gurucharan Shetty wrote:
> > On Thu, Jul 11, 2013 at 10:34 AM, Gurucharan Shetty >wrote:
> >
> > > On Thu, Jul 11, 2013 at 10:22 AM, Ben Pfaff wrote:
> > >
> > >> On Thu, Jul 11, 2013 at 09:37:45AM -0
Thanks for the reminder. They all look like good comments to me, but
I'm reposting the series with the goal of getting some performance
measurements. (The 19% in the commit log is obsolete.) If the
performance measurements are good, I'll revise it.
I'm going to repost the series again in a mome
On Thu, Jul 11, 2013 at 12:44:50PM +0900, YAMAMOTO Takashi wrote:
> > On Tue, Jul 09, 2013 at 05:18:34PM +0900, YAMAMOTO Takashi wrote:
> >> hi,
> >>
> >> > @@ -708,9 +711,7 @@ dpif_netdev_flow_from_nlattrs(const struct nlattr
> >> > *key, uint32_t key_len,
> >> > return EINVAL;
> >> >
On Thu, Jul 11, 2013 at 10:39:38AM -0700, Gurucharan Shetty wrote:
> On Thu, Jul 11, 2013 at 10:34 AM, Gurucharan Shetty wrote:
>
> > On Thu, Jul 11, 2013 at 10:22 AM, Ben Pfaff wrote:
> >
> >> On Thu, Jul 11, 2013 at 09:37:45AM -0700, Gurucharan Shetty wrote:
> >> > Signed-off-by: Gurucharan She
On Thu, Jul 11, 2013 at 10:34:06AM -0700, Gurucharan Shetty wrote:
> On Thu, Jul 11, 2013 at 10:22 AM, Ben Pfaff wrote:
>
> > On Thu, Jul 11, 2013 at 09:37:45AM -0700, Gurucharan Shetty wrote:
> > > Signed-off-by: Gurucharan Shetty
> >
> > I'm not sure it's worth mentioning the 65,280 port limit
On Thu, Jul 11, 2013 at 10:34 AM, Gurucharan Shetty wrote:
> On Thu, Jul 11, 2013 at 10:22 AM, Ben Pfaff wrote:
>
>> On Thu, Jul 11, 2013 at 09:37:45AM -0700, Gurucharan Shetty wrote:
>> > Signed-off-by: Gurucharan Shetty
>>
>> I'm not sure it's worth mentioning the 65,280 port limit, because it
On Thu, Jul 11, 2013 at 10:22 AM, Ben Pfaff wrote:
> On Thu, Jul 11, 2013 at 09:37:45AM -0700, Gurucharan Shetty wrote:
> > Signed-off-by: Gurucharan Shetty
>
> I'm not sure it's worth mentioning the 65,280 port limit, because it's
> about the same as the maximum number of file descriptors.
>
>
On Thu, Jul 11, 2013 at 09:37:46AM -0700, Gurucharan Shetty wrote:
> Testing shows that creation of 5000 internal ports and using it
> to do some meaningful tasks works fine on a 12 cpu hardware.
> Since a single port needs one file descriptor and a bridge
> needs 3 file descriptors, we will have t
On Thu, Jul 11, 2013 at 09:37:45AM -0700, Gurucharan Shetty wrote:
> Signed-off-by: Gurucharan Shetty
I'm not sure it's worth mentioning the 65,280 port limit, because it's
about the same as the maximum number of file descriptors.
At first thought, these limits seemed Linux specific, but I think
Testing shows that creation of 5000 internal ports and using it
to do some meaningful tasks works fine on a 12 cpu hardware.
Since a single port needs one file descriptor and a bridge
needs 3 file descriptors, we will have to increase the file
descriptor limit to a higher number from the current li
Signed-off-by: Gurucharan Shetty
---
vswitchd/ovs-vswitchd.8.in | 13 ++---
1 file changed, 6 insertions(+), 7 deletions(-)
diff --git a/vswitchd/ovs-vswitchd.8.in b/vswitchd/ovs-vswitchd.8.in
index 86500c9..da43336 100644
--- a/vswitchd/ovs-vswitchd.8.in
+++ b/vswitchd/ovs-vswitchd.8.
When there is no incoming data traffic in the tunnel for a period,
BFD decay allows the bfd session to increase the min_rx. This isa
helpful in that usually some tunnels are rarely used. And cpu
consumption can be reduced by processing fewer bfd control packets.
Signed-off-by: Alex Wang
---
v1 -
On 10 July 2013 19:04, Ben Pfaff wrote:
> Signed-off-by: Ben Pfaff
Acked-by: Ed Maste
X-CudaMail-Whitelist-To: dev@openvswitch.org
___
dev mailing list
dev@openvswitch.org
http://openvswitch.org/mailman/listinfo/dev
On 10 July 2013 19:03, Ben Pfaff wrote:
> The worker process implementation isn't thread-safe and, once OVS
> itself is threaded, it doesn't make much sense to have a worker
> process anyway.
>
> Signed-off-by: Ben Pfaff
Acked-by: Ed Maste
X-CudaMail-Whitelist-To: dev@openvswitch.org
__
On 10 July 2013 19:04, Ben Pfaff wrote:
> This is harder to implement once threads are introduced.
>
> Signed-off-by: Ben Pfaff
Acked-by: Ed Maste
X-CudaMail-Whitelist-To: dev@openvswitch.org
___
dev mailing list
dev@openvswitch.org
http://openvswitch
On 10 July 2013 19:03, Ben Pfaff wrote:
> Signed-off-by: Ben Pfaff
Acked-by: Ed Maste
X-CudaMail-Whitelist-To: dev@openvswitch.org
___
dev mailing list
dev@openvswitch.org
http://openvswitch.org/mailman/listinfo/dev
On 10 July 2013 19:03, Ben Pfaff wrote:
> Signed-off-by: Ben Pfaff
Acked-by: Ed Maste
X-CudaMail-Whitelist-To: dev@openvswitch.org
___
dev mailing list
dev@openvswitch.org
http://openvswitch.org/mailman/listinfo/dev
On 10 July 2013 19:04, Ben Pfaff wrote:
> Signed-off-by: Ben Pfaff
> +void
> +set_subprogram_name(const char *name)
> +{
> +free(subprogram_name_set(xstrdup(name)));
> +}
How about calling (through appropriate abstraction) pthread_setname_np
(Linux) or pthread_set_name_np (FreeBSD)? The th
On 10 July 2013 19:03, Ben Pfaff wrote:
> The backtrace feature of timeval is useful because it provides a "poor
> man's profile" view of Open vSwitch. But it is not likely to be useful in
> a multithreaded process, because signal delivery doesn't necessarily follow
> the profile when there is mo
On 10 July 2013 19:03, Ben Pfaff wrote:
> Signed-off-by: Ben Pfaff
Acked-by: Ed Maste
X-CudaMail-Whitelist-To: dev@openvswitch.org
___
dev mailing list
dev@openvswitch.org
http://openvswitch.org/mailman/listinfo/dev
On 10 July 2013 19:04, Ben Pfaff wrote:
> Signed-off-by: Ben Pfaff
Acked-by: Ed Maste
X-CudaMail-Whitelist-To: dev@openvswitch.org
___
dev mailing list
dev@openvswitch.org
http://openvswitch.org/mailman/listinfo/dev
On 10 July 2013 19:03, Ben Pfaff wrote:
> Signed-off-by: Ben Pfaff
> ---
> lib/fatal-signal.c |5 -
Acked-by: Ed Maste
X-CudaMail-Whitelist-To: dev@openvswitch.org
___
dev mailing list
dev@openvswitch.org
http://openvswitch.org/mailman/listinf
On 10 July 2013 19:03, Ben Pfaff wrote:
> (The usual reason for ppoll() is to ensure atomicity of changing the signal
> mask and blocking, but time_poll() does not need atomicity. Therefore,
> even a userspace emulated ppoll() would work here in a race-free manner, if
> the kernel does not suppor
On 10 July 2013 19:04, Ben Pfaff wrote:
> static void format_log_message(const struct vlog_module *, enum vlog_level,
> - enum vlog_facility, unsigned int msg_num,
> + enum vlog_facility,
> const char *mes
48 matches
Mail list logo