On 10 July 2013 19:04, Ben Pfaff <b...@nicira.com> wrote:
> Signed-off-by: Ben Pfaff <b...@nicira.com>

> +void
> +set_subprogram_name(const char *name)
> +{
> +    free(subprogram_name_set(xstrdup(name)));
> +}

How about calling (through appropriate abstraction) pthread_setname_np
(Linux) or pthread_set_name_np (FreeBSD)?  The thread names will then
appear in gdb or lldb, and in top(1) (on FreeBSD at least).

Acked-by: Ed Maste <ema...@freebsd.org>
X-CudaMail-Whitelist-To: dev@openvswitch.org
_______________________________________________
dev mailing list
dev@openvswitch.org
http://openvswitch.org/mailman/listinfo/dev

Reply via email to